Subject: [core-parameters] NEW RESOURCE TYPES - oic.r.* and oic.d.*

From: Mark Trayer <[email-masked]>
Date: Mon, 5 Oct 2020 18:06:53 +0000

The Open Connectivity Foundation has specified an additional set of rt values (all beginning with "oic.") to be registered in the
http://www.iana.org/assignments/core-parameters/core-parameters.xhtml#rt-link-target-att-value registry according to the "Specification Required" policy.
The references for all of them are in the ZIP file at https://openconnectivity.org/specs/OCF_v2.2.0%20Specification.zip

Since registering a prefix is not currently allowed, here is a list of the separate rt values requested to register.

Resource Type (rt=) Link Target Attribute Value

Attribute Value

Description

Reference

oic.d.afci

Arc Fault Circuit Interrupter

OCF_Device_Specification_v2.2.0 clause A.2

oic.d.airer

Airer

OCF_Device_Specification_v2.2.0 clause A.2

oic.d.gfci

Ground Fault Circuit Interrupter

OCF_Device_Specification_v2.2.0 clause A.2

oic.r.sdi

Security Domain Information

OCF_Security_Specification_v2.2.0 clause C.10

oic.r.settings.accessibility

Device Settings - Accessibility

OCF_Resource_Type_Specification_v2.2.0 clause 6.164

oic.r.settings.broadcasting

Device Settings - Broadcasting

OCF_Resource_Type_Specification_v2.2.0 clause 6.165

oic.r.settings.picture

Device Settings - Picture

OCF_Resource_Type_Specification_v2.2.0 clause 6.166

oic.r.settings.sound

Devcie Settings - Sound

OCF_Resource_Type_Specification_v2.2.0 clause 6.167

oic.r.settings.support

Device Settings - Support

OCF_Resource_Type_Specification_v2.2.0 clause 6.168

oic.r.settings.system

Device Settings - System

OCF_Resource_Type_Specification_v2.2.0 clause 6.169

Please let me know if there are any questions or clarifications required in this regard.

Best,
Mark Trayer
OCF Core Technology Working Group Chair

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 6 Oct 2020 14:55:56 +0200

Hi Mark,

these look good to me; please go ahead as Klaus suggested and ask IANA for registration.

I note that the description of the “priv” flag for oic.r.sdi in Table 55 of the OCF Security Specification (»Flag to indicate whether the Security Domain Information is copied to “/oic/res”«) and on the OpenAPI definition in C.10.4 is the wrong way around (the rest of the text around Table 55 makes that clear, but it is still very confusing, in particular if only looking at the OpenAPI description).

Grüße, Carsten

> On 2020-10-05, at 20:06, Mark Trayer <[email-masked]> wrote:
> 
> The Open Connectivity Foundation has specified an additional set of rt values (all beginning with “oic.”) to be registered in the
> http://www.iana.org/assignments/core-parameters/core-parameters.xhtml#rt-link-target-att-value registry according to the “Specification Required” policy.
> _______________________________________________
> core-parameters mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core-parameters

---

From: Jaime Jiménez <[email-masked]>
Date: Tue, 6 Oct 2020 17:42:05 +0300

Hi Carsten and Mark,

Just FYI. I also had a look at the OCF spec and the new attributes look OK to me. 

Ciao!
-- Jaime