Subject: [core-parameters] NEW RESOURCE TYPES - oic.r.* and oic.d.*

From: Mark Trayer <[email-masked]>
Date: Mon, 1 Nov 2021 15:57:22 +0000

The Open Connectivity Foundation has specified an additional set of rt values (all beginning with "oic.") to be registered in the
http://www.iana.org/assignments/core-parameters/core-parameters.xhtml#rt-link-target-att-value registry according to the "Specification Required" policy.
The references for all of them are in the ZIP file at https://openconnectivity.org/specs/OCF_v2.2.4%20Specification.zip; or to go to the referenced specifications directly:
https://openconnectivity.org/specs/OCF_Device_Specification_v2.2.4.pdf
https://openconnectivity.org/specs/OCF_Resource_Type_Specification_v2.2.4.pdf

Since registering a prefix is not currently allowed, here is a list of the separate rt values requested to register.

Resource Type (rt=) Link Target Attribute Value

Attribute Value

Description

Reference

oic.d.acassistant

A/C Assistant

OCF_Device_Specification_v2.2.0 clause A.2

oic.d.dali

Light (DALI) Device

OCF_Device_Specification_v2.2.0 clause A.2

oic.d.dali.ac

Light (DALI) Application Controller

OCF_Device_Specification_v2.2.0 clause A.2

oic.d.dali.bus

Light (DALI) Bus

OCF_Device_Specification_v2.2.0 clause A.2

oic.d.light.smart

Smart Light

OCF_Device_Specification_v2.2.0 clause A.2

oic.d.wallpad

Wallpad

OCF_Device_Specification_v2.2.0 clause A.2

oic.r.remotecontrol

Remote Control

OCF_Resource_Type_Specification_v2.2.2 clause 6.177

oic.r.tv.apps

TV Apps

OCF_Resource_Type_Specification_v2.2.2 clause 6.178

oic.r.vendorlist

Vendor List

OCF_Resource_Type_Specification_v2.2.2 clause 6.179

oic.r.dali

DALI

OCF_Resource_Type_Specification_v2.2.2 clause 6.180

oic.r.dali.conf

DALI Configuration

OCF_Resource_Type_Specification_v2.2.2 clause 6.181

Please let me know if there are any questions or clarifications required in this regard.

Best,
Mark Trayer
OCF Core Technology Working Group Chair

---

From: Esko Dijk <[email-masked]>
Date: Thu, 4 Nov 2021 10:38:59 +0000

Hello,

It looks good to me with only these minor comments:

  *   If the reference files (as provided) are v2.2.4, then the Reference column text should also refer to this version and not v2.2.0 / v2.2.2 as now.
  *   The “clause 6.x” references are in fact “clause 7.x” when looking into the PDF version 2.2.4.
  *   A/C is more clear in the OCF spec itself, it is listed there as “Air Conditioner” which removes the ambiguity (e.g. A/C power, Application Controller, Atmospheric Cleaner, etc). Maybe expand the acronym?

Best regards
Esko

IoTconsultancy.nl  |  Email/Teams: [email-masked]

From: core-parameters <[email-masked]> On Behalf Of Mark Trayer
Sent: Monday, November 1, 2021 16:57
To: [email-masked]' <[email-masked]>; [email-masked]
Subject: [core-parameters] NEW RESOURCE TYPES - oic.r.* and oic.d.*

The Open Connectivity Foundation has specified an additional set of rt values (all beginning with “oic.”) to be registered in the
http://www.iana.org/assignments/core-parameters/core-parameters.xhtml#rt-link-target-att-value registry according to the “Specification Required” policy.
The references for all of them are in the ZIP file at https://openconnectivity.org/specs/OCF_v2.2.4%20Specification.zip; or to go to the referenced specifications directly:
https://openconnectivity.org/specs/OCF_Device_Specification_v2.2.4.pdf
https://openconnectivity.org/specs/OCF_Resource_Type_Specification_v2.2.4.pdf

Best,
Mark Trayer

---

From: Mark Trayer <[email-masked]>
Date: Thu, 4 Nov 2021 19:16:59 +0000

Greetings,

Thanks for the rapid review, and appreciate the comments.  Please fine below an updated table that hopefully reflects all of the comments that were provided.

Best,
mark.

Attribute Value

Description

Reference

oic.d.acassistant

Air Conditioner Assistant

OCF_Device_Specification_v2.2.4 clause A.2

oic.d.dali

Light (DALI) Device

OCF_Device_Specification_v2.2.4 clause A.2

oic.d.dali.ac

OCF_Device_Specification_v2.2.4 clause A.2

oic.d.dali.bus

Light (DALI) Bus

OCF_Device_Specification_v2.2.4 clause A.2

oic.d.light.smart

Smart Light

OCF_Device_Specification_v2.2.4 clause A.2

oic.d.wallpad

Wallpad

OCF_Device_Specification_v2.2.4 clause A.2

oic.r.remotecontrol

Remote Control

OCF_Resource_Type_Specification_v2.2.4 clause 7.177

oic.r.tv.apps

TV Apps

OCF_Resource_Type_Specification_v2.2.4 clause 7.178

oic.r.vendorlist

Vendor List

OCF_Resource_Type_Specification_v2.2.4 clause 7.179

oic.r.dali

DALI

OCF_Resource_Type_Specification_v2.2.4 clause 7.180

oic.r.dali.conf

DALI Configuration

OCF_Resource_Type_Specification_v2.2.4 clause 7.181

From: core-parameters <[email-masked]> On Behalf Of Esko Dijk
Sent: Thursday, November 4, 2021 5:39 AM
To: Mark Trayer <[email-masked]>; [email-masked]' <[email-masked]>; [email-masked]
Subject: Re: [core-parameters] NEW RESOURCE TYPES - oic.r.* and oic.d.*

Hello,

Best regards
Esko

IoTconsultancy.nl  |  Email/Teams: [email-masked]<mailto:[email-masked]>

From: core-parameters <[email-masked]<mailto:[email-masked]>> On Behalf Of Mark Trayer
Sent: Monday, November 1, 2021 16:57
To: [email-masked]' <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: [core-parameters] NEW RESOURCE TYPES - oic.r.* and oic.d.*

The Open Connectivity Foundation has specified an additional set of rt values (all beginning with “oic.”) to be registered in the
http://www.iana.org/assignments/core-parameters/core-parameters.xhtml#rt-link-target-att-value registry according to the “Specification Required” policy.
The references for all of them are in the ZIP file at https://openconnectivity.org/specs/OCF_v2.2.4%20Specification.zip<https://protect2.fireeye.com/v1/url?k=61fb1d60-0119803d-61fa962f-000babd9f1ba-981de285101040f5&q=1&e=45e45574-d4e1-4eba-9867-c5f17d828018&u=https%3A%2F%2Fopenconnectivity.org%2Fspecs%2FOCF_v2.2.4%2520Specification.zip>; or to go to the referenced specifications directly:
https://openconnectivity.org/specs/OCF_Device_Specification_v2.2.4.pdf<https://protect2.fireeye.com/v1/url?k=ba942561-da76b83c-ba95ae2e-000babd9f1ba-1c14bac8cfaafe6c&q=1&e=45e45574-d4e1-4eba-9867-c5f17d828018&u=https%3A%2F%2Fopenconnectivity.org%2Fspecs%2FOCF_Device_Specification_v2.2.4.pdf>
https://openconnectivity.org/specs/OCF_Resource_Type_Specification_v2.2.4.pdf<https://protect2.fireeye.com/v1/url?k=f261dea1-928343fc-f26055ee-000babd9f1ba-8bb6a9587ae91b5f&q=1&e=45e45574-d4e1-4eba-9867-c5f17d828018&u=https%3A%2F%2Fopenconnectivity.org%2Fspecs%2FOCF_Resource_Type_Specification_v2.2.4.pdf>

Attribute Value

Description

Reference

oic.d.acassistant

A/C Assistant

oic.d.dali

Light (DALI) Device

oic.d.dali.ac

oic.d.dali.bus

Light (DALI) Bus

oic.d.light.smart

Smart Light

oic.d.wallpad

Wallpad

oic.r.remotecontrol

Remote Control

oic.r.tv.apps

TV Apps

oic.r.vendorlist

Vendor List

oic.r.dali

DALI

oic.r.dali.conf

DALI Configuration

Best,
Mark Trayer

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 4 Nov 2021 21:09:14 +0100

Indeed, this looks good now.

Grüße, Carsten

> On 2021-11-04, at 20:16, Mark Trayer <[email-masked]> wrote:
> 
> Greetings,
>  
> 	• If the reference files (as provided) are v2.2.4, then the Reference column text should also refer to this version and not v2.2.0 / v2.2.2 as now.
> 	• The “clause 6.x” references are in fact “clause 7.x” when looking into the PDF version 2.2.4.
> 	• A/C is more clear in the OCF spec itself, it is listed there as “Air Conditioner” which removes the ambiguity (e.g. A/C power, Application Controller, Atmospheric Cleaner, etc). Maybe expand the acronym?
>  
> Best regards
> Esko
>  
> _______________________________________________
> core-parameters mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core-parameters

---

From: Jaime Jiménez <[email-masked]>
Date: Wed, 10 Nov 2021 09:37:12 +0200

Hi,

@Iana I just had a look and it also seems OK to me. 

@Mark A side question. On the spec the field "Vendor List" refers to an air conditioner assistant (oic.d.acassistant). Could you clarify what is this about? It seems somewhat unrelated to devices properties.

Ciao!
-- 
Jaime Jiménez

---

From: Mark Trayer <[email-masked]>
Date: Wed, 10 Nov 2021 14:49:45 +0000

Greetings,

So an a/c assistant is a device common in China and other Asian markets.  These are connected devices that "talk" to legacy a/c units via whatever protocol they support (typically an IR style connection).  Thus making your legacy a/c an IoT device.  

The "vendorlist" is the set of a/c vendors that the a/c assistant provides support for (i.e. the IR code sets it understands).  So a client can select the vendor of their a/c unit from the provided list.

Does this help?

Best,
mark.

-----Original Message-----
From: core-parameters <[email-masked]> On Behalf Of Jaime Jiménez
Sent: Wednesday, November 10, 2021 1:37 AM
To: Carsten Bormann <[email-masked]>; Mark Trayer <[email-masked]>
Cc: [email-masked]; Esko Dijk <[email-masked]>; [email-masked]
Subject: Re: [core-parameters] NEW RESOURCE TYPES - oic.r.* and oic.d.*

Hi,

Ciao!
--
Jaime Jiménez

On Thu, Nov 4, 2021, at 10:09 PM, Carsten Bormann wrote:
>> Resource Type (rt=) Link Target Attribute Value Attribute Value 
>> Description Reference oic.d.acassistant Air Conditioner Assistant
>> OCF_Device_Specification_v2.2.4 clause A.2 oic.d.dali Light (DALI) 
>> Device
>> OCF_Device_Specification_v2.2.4 clause A.2 oic.d.dali.ac Light (DALI) 
>> Application Controller
>> OCF_Device_Specification_v2.2.4 clause A.2 oic.d.dali.bus Light 
>> (DALI) Bus
>> OCF_Device_Specification_v2.2.4 clause A.2 oic.d.light.smart Smart 
>> Light
>> OCF_Device_Specification_v2.2.4 clause A.2 oic.d.wallpad Wallpad
>> OCF_Device_Specification_v2.2.4 clause A.2 oic.r.remotecontrol Remote 
>> Control
>> OCF_Resource_Type_Specification_v2.2.4 clause 7.177 oic.r.tv.apps TV 
>> Apps
>> OCF_Resource_Type_Specification_v2.2.4 clause 7.178 oic.r.vendorlist 
>> Vendor List
>> OCF_Resource_Type_Specification_v2.2.4 clause 7.179 oic.r.dali DALI
>> OCF_Resource_Type_Specification_v2.2.4 clause 7.180 oic.r.dali.conf 
>> DALI Configuration
>> To: Mark Trayer <[email-masked]>; [email-masked]' 
>> <[email-masked]>; [email-masked]
>> The Open Connectivity Foundation has specified an additional set of 
>> rt values (all beginning with “oic.”) to be registered in the http://www.iana.org/assignments/core-parameters/core-parameters.xhtml#rt-link-target-att-value registry according to the “Specification Required” policy.
>> The references for all of them are in the ZIP file at https://protect2.fireeye.com/v1/url?k=b7ecbca0-e87785a2-b7ed37ef-0cc47a312ab0-963b820d5fa4d22d&q=1&e=58c56798-0b9d-4ae4-8d40-59b02f4dfcfc&u=https%3A%2F%2Fopenconnectivity.org%2Fspecs%2FOCF_v2.2.4%2520Specification.zip; or to go to the referenced specifications directly:
>> https://protect2.fireeye.com/v1/url?k=9dc6eb89-c25dd28b-9dc760c6-0cc4
>> 7a312ab0-33f0c3456dae6277&q=1&e=58c56798-0b9d-4ae4-8d40-59b02f4dfcfc&
>> u=https%3A%2F%2Fopenconnectivity.org%2Fspecs%2FOCF_Device_Specificati
>> on_v2.2.4.pdf 
>> https://protect2.fireeye.com/v1/url?k=7e47905a-21dca958-7e461b15-0cc4
>> 7a312ab0-0c34b501dcdd2828&q=1&e=58c56798-0b9d-4ae4-8d40-59b02f4dfcfc&
>> u=https%3A%2F%2Fopenconnectivity.org%2Fspecs%2FOCF_Resource_Type_Spec
>> ification_v2.2.4.pdf
>>  
>> Resource Type (rt=) Link Target Attribute Value Attribute Value 
>> Description Reference oic.d.acassistant A/C Assistant
>> OCF_Device_Specification_v2.2.0 clause A.2 oic.d.dali Light (DALI) 
>> Device
>> OCF_Device_Specification_v2.2.0 clause A.2 oic.d.dali.ac Light (DALI) 
>> Application Controller
>> OCF_Device_Specification_v2.2.0 clause A.2 oic.d.dali.bus Light 
>> (DALI) Bus
>> OCF_Device_Specification_v2.2.0 clause A.2 oic.d.light.smart Smart 
>> Light
>> OCF_Device_Specification_v2.2.0 clause A.2 oic.d.wallpad Wallpad
>> OCF_Device_Specification_v2.2.0 clause A.2 oic.r.remotecontrol Remote 
>> Control
>> OCF_Resource_Type_Specification_v2.2.2 clause 6.177 oic.r.tv.apps TV 
>> Apps
>> OCF_Resource_Type_Specification_v2.2.2 clause 6.178 oic.r.vendorlist 
>> Vendor List
>> OCF_Resource_Type_Specification_v2.2.2 clause 6.179 oic.r.dali DALI
>> OCF_Resource_Type_Specification_v2.2.2 clause 6.180 oic.r.dali.conf 
>> DALI Configuration