Subject: [core-parameters] [IANA #1229125] expert review for draft-ietf-anima-constrained-join-proxy (core-parameters)

From: "Sabrina Tanamal via RT" <[email-masked]>
Date: Tue, 05 Apr 2022 16:43:15 +0000

Carsten and Jaime (cc: anima WG), 

As the designated experts for the Resource Type (rt=) Link Target Attribute Values registry, can you review the proposed registrations in draft-ietf-anima-constrained-join-proxy for us? Please see

https://datatracker.ietf.org/doc/draft-ietf-anima-constrained-join-proxy/

If this is OK, when the IESG approves the document for publication, we'll make the registration at

https://www.iana.org/assignments/core-parameters

If you're the first expert to submit a review, please let us know whether you want us to wait for both reviewers to respond before we mark the document "IANA OK" (or send your comments to the authors, if the registrations aren't OK).

The IESG has asked us to set a two-week deadline for registration reviews. The due date for this request is 19 April 2022. 

thanks,

Sabrina Tanamal
Lead IANA Services Specialist

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 5 Apr 2022 22:29:37 +0200

Hi Sabrina,

I looked at the registration requests in the draft.
They use somewhat unusual language about discovering ports - resource discovery is understood to discover resources.  For brski.jp, this appears to be about discovering a CoAP or CoAPs entry point (without describing how exactly that is then used, e.g., what happens if that has a different IP address in the authority than the request address).  For brski.rjp, this appears to be about discovering an entry point for a protocol that I don’t seem to fully understand the description for.

I didn’t try to obtain a deep understanding of the protocol before writing this, but I would prefer if the language used for the description were understandable for other registrants in this registry, i.e., discussing resources, not ports (port numbers?).

All the other criteria for a registration appear to be fulfilled.

I don’t think we need to reach a consensus between the designated experts before proceeding.

Grüße, Carsten

> On 2022-04-05, at 18:43, Sabrina Tanamal via RT <[email-masked]> wrote:
>