Subject: [core] Minor nit in Figure 12

From: "Thomas Pötsch" <[email-masked]>
Date: Mon, 28 Feb 2011 11:44:13 +0100 (CET)

Hello,

I think I have discovered a small nit in figure 12 in coap-04. Here the field "Option Count" is set to 2 for the request and 1 for the response. Since the request contains only one option(Uri-Path), the OC should be set to 1 and for the response to 0. Am I right?

Best regards

Thomas

___________________________________________________________
WEB.DE DSL Doppel-Flat ab 19,99 &euro;/mtl.! Jetzt mit 
gratis Handy-Flat! http://produkte.web.de/go/DSL_Doppel_Flatrate/2

---

From: Klaus Hartke <[email-masked]>
Date: Mon, 28 Feb 2011 12:11:13 +0100

> I think I have discovered a small nit in figure 12 in coap-04. Here the field "Option Count" is set to 2 for the request and 1 for the response. Since the request contains only one option(Uri-Path)…

Yep, that's right. I'll fix it.

Klaus

---

From: Likepeng <[email-masked]>
Date: Tue, 01 Mar 2011 01:31:38 +0000

Previously I have the same confusion. If we take the Token option into account, the original number is correct. 

In Figure 12, the "Option Count" should be 2, because Token is another option, and it is left to empty. Also it is the same in the response. The Token is implicit both in request and response.

That is what I understand from the explanation paragraph on top of the figure: the Token is left at its default value (empty).

I think it is reasonable that we don't count Token as an Option if it is implicit, that means, not occurred in the message. So I agree that we should reduce the OC to 1 (in the request) and 0 (in the response).

Kind Regards
Kepeng
-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]] 代表 Klaus Hartke
发送时间: 2011年2月28日 19:11
收件人: [email-masked]
主题: Re: [core] Minor nit in Figure 12

Klaus
_______________________________________________
core mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/core