Subject: [core] draft-ietf-core-coap-06 What messages needs a Token

From: Cullen Jennings <[email-masked]>
Date: Wed, 4 May 2011 20:46:07 -0600

As far as I can tell, all request and response need a token as that is the only way to match them or suppress duplicates. Is this correct? I could not find the text in the draft that really told me when a Token was needed. The thread on the list did not enlighten me. 

Cullen <in my role as an individual contributor>

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 5 May 2011 07:11:50 +0200

On May 5, 2011, at 04:46, Cullen Jennings wrote:

> 
> As far as I can tell, all request and response need a token

Yes.  

Note that the Token Option has a default value (empty string), so all requests and responses do have a Token, regardless of whether the option is in a message or not.

> as that is the only way to match them

The match rules are defined in 5.3.  They use more information than the Token.

> or suppress duplicates. Is this correct?

No. Duplicate suppression is done using message IDs.

> I could not find the text in the draft that really told me when a Token was needed.

Since there always is a Token, there is no such text.
The text in 5.3 and 5.10.1 is meant to describe what the rules are for choosing a value for the Token (where choosing a value different from the empty string happens to mean that a Token Option needs to be in the message).

> The thread on the list did not enlighten me. 

Clearly, we have an editorial issue here.  I have created ticket #147.

Gruesse, Carsten

---

From: Cullen Jennings <[email-masked]>
Date: Thu, 5 May 2011 12:18:51 -0600

I went back and reread section 5.3 after reading your email and I see what you are saying. Draft looks like it has the right normative statements in it.