Subject: [core] Client / server requirements for separate messaging

From: Paul Duffy <[email-masked]>
Date: Wed, 04 May 2011 19:09:20 -0400

This is going to sound confusing given the usage of client and server in 
core-coap.

Do I assume correctly that a device MUST implement both a COAP client 
and server?

Meaning not only MUST a device implement a client to send requests, but 
MUST also implement a server to process COAP requests?

This to support the separate messaging pattern

Cheers

---

From: Cullen Jennings <[email-masked]>
Date: Wed, 4 May 2011 21:10:06 -0600

I don't think this it has to do both. The confusing comes from it has to be able to both send and receive CON messages and deal with the ACKS for them. This is the same as an HTTP server needs to be able to deal with sending data both ways on the TCP connection and ACKs both ways at the TCP level. My understanding of the draft is that a node could act as a CoAP server and only receive Requests and only send Responses. Just like a HTTP server. But again, just like a HTTP server, at the transport level it deals with receiving and sending ACKs. Similarly an end point could only act as a client and only send Requests and get Responses. I think some end points, particular ones doing pub/sub type stuff will want to act as both a client and server. 

On May 4, 2011, at 5:09 PM, Paul Duffy wrote:

> This is going to sound confusing given the usage of client and server in core-coap.
> 
> Do I assume correctly that a device MUST implement both a COAP client and server?
> 
> Meaning not only MUST a device implement a client to send requests, but MUST also implement a server to process COAP requests?
> 
> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core