Subject: [core] draft-bormann-coap-misc-08 - Payload-Length options

From: Cullen Jennings <[email-masked]>
Date: Tue, 10 May 2011 07:12:54 -0700

I'd like to propose that we take the text from section 6 of this draft defining an option to use Payload-Length options and move it to CoAP. The main reasons I think it needs to be in the base draft is it is hard to add later and easy to implement. Having this makes it much easier for us to be future proof for use on non datagram transports or have aggregation of multiple CoAP messages into a single IP datagram. 

It also makes it easy to figure out to use CoAP in a situation where you have a serial line between the host and proxy that is IP connected. 

Cullen <in my individual contributor role>

---

From: Likepeng <[email-masked]>
Date: Wed, 11 May 2011 01:10:31 +0000

I agree that it is quite useful for some cases, but I prefer it to be a separate draft. 

(1) Because it is not needed (or at least optional) if we use UDP as transport, which is the major transport under consideration now. The information will be redundant if we can get the information from the Payload-Length Option and from the UDP layer. And it may cause problem if they are inconsistent.

(2) I don't think it is good to pack more than one CoAP message into one UDP payload. It will add the complexity and I can't see too much benefit. 

(3) I remember it was in the base draft before, but it was removed for some reasons.

FYI, this is the justification from the misc-08 for the Payload-Length:
   Not all transport mappings may provide an unambiguous length of the
   CoAP message.  For UDP, it may also be desirable to pack more than
   one CoAP message into one UDP payload (aggregation); in that case,
   for all but the last message there needs to be a way to delimit the
   payload of that message.

Kind Regards
Kepeng
-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Cullen Jennings
Sent: Tuesday, May 10, 2011 10:13 PM
To: core WG
Subject: [core] draft-bormann-coap-misc-08 - Payload-Length options

_______________________________________________
core mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/core