Subject: [core] new bc draft

From: "Stok, Peter van der" <[email-masked]>
Date: Mon, 31 Oct 2011 08:08:20 +0000

A new version of I-D, draft-vanderstok-core-bc-05.txt has been successfully submitted by Peter Stok and posted to the IETF repository.

Filename:   draft-vanderstok-core-bc

Revision:   05

Title:            CoAP Utilization for Building Control

Creation date:    2011-10-30

WG ID:            Individual Submission

Number of pages: 32

url: draft-vanderstok-core-bc-05<https://datatracker.ietf.org/doc/draft-vanderstok-core-bc/>

Changes from bc-04 to bc-05
- extended and corrected examples for multi-function devices
- syntax more compatible with other resource discovery I-Ds
- abstract adapted
- more stringent use of the words server, end point, service and

devices

Abstract:

   This draft describes an example use of the RESTful CoAP protocol for

   building automation and control (BAC) applications such as HVAC and

   lighting.  A few basic design assumptions are stated first, then URI

   structure is utilized to define group as well as unicast scope for

   RESTful operations.

   This proposal supports the view that 1) service discovery is

   complementary to resource discovery and facilitates control network

   scaling, and 2) building control is likely to move in steps toward

   all-IP control networks based on the legacy efforts provided by DALI,

   LON, BACnet, ZigBee, and other standards.

   The authority portion of the URI is used to identify a device (group)

   and the resulting DNS name is bound to a unicast (multicast) address.

   Group addressing has consequence for the naming convention of the

   resources of a device.  Naming of URI is building or organization

   dependent, must be flexible, and SHOULD conform to some local

   convention.  Naming of resources MUST be standardized preferably by

   a building control related organization.

   It is shown that DNS-based service discovery can be used to locate

   URIs on the scale necessary in large commercial BAC deployments.  The

   relation of DNS-SD and a Resource Directory is discussed.  Finally, a

   method is proposed for mapping URIs onto legacy BAC resources, e.g.,

   to discover application-layer gateways, proxies, and their dependent

   services.

Peter van der Stok
Philips Research Laboratories Eindhoven
High Tech Campus                                                          HTC 34 (WB) 1-067
5656 AA Eindhoven                                                      The Netherlands
phone +31 40 2749657                                                Fax: + 31 40 2746321
mailto: [email-masked]

________________________________
The information contained in this message may be confidential and legally protected under applicable law. The message is intended solely for the addressee(s). If you are not the intended recipient, you are hereby notified that any use, forwarding, dissemination, or reproduction of this message is strictly prohibited and may be unlawful. If you are not the intended recipient, please contact the sender by return e-mail and destroy all copies of the original message.

---

From: "Keoh, Sye Loong" <[email-masked]>
Date: Mon, 31 Oct 2011 14:56:09 +0100

A new version of I-D, draft-garcia-core-security-03.txt has been successfully submitted by Sye Loong Keoh and posted to the IETF repository.

Filename:   draft-garcia-core-security

Revision:   03

Title:            Security Considerations in the IP-based Internet of Things

Creation date:    2011-10-31

Number of pages: 44

Changes:

Added section 3.1 to discuss various security threats and potential vulnerabilities in the context of IoTs.

URL: draft-garcia-core-security-03<https://datatracker.ietf.org/doc/draft-garcia-core-security/>

Abstract:

   A direct interpretation of the Internet of Things concept refers to

   the usage of standard Internet protocols to allow for human-to-thing

   or thing-to-thing communication.  Although the security needs are

   well-recognized, it is still not fully clear how existing IP-based

   security protocols can be applied to this new setting.  This

   Internet-Draft first provides an overview of security architecture,

   its deployment model and general security needs in the context of the

   lifecycle of a thing.  Then, it presents challenges and requirements

   for the successful roll-out of new applications and usage of standard

   IP-based security protocols when applied to get a functional Internet

   of Things.

Cheers

Sye Loong