Subject: Re: [core] Figure 2: Simple blockwise GET

From: cyril auburtin <[email-masked]>
Date: Fri, 30 Sep 2011 19:32:28 +0200

Hello

in  http://tools.ietf.org/html/draft-ietf-core-block-04 Figure 2: Simple
blockwise GET

Why does the server retuns the response in a blockwise way if the client did
not send any Block2 option?

Thanks , sincerely

---

From: Carsten Bormann <[email-masked]>
Date: Sat, 1 Oct 2011 23:35:43 +0200

> in  http://tools.ietf.org/html/draft-ietf-core-block-04 Figure 2: Simple blockwise GET
> 
> Why does the server retuns the response in a blockwise way if the client did not send any Block2 option?

Hi Cyril,

in this example, while the server could send the response in one UDP datagram, it is configured to send a response of the given size in multiple blocks.  One reason for configuring a server that way might be that it is on a constrained network that has a bad datagram delivery rate for datagrams that need to be excessively L2-fragmented.

Maybe your question was "how does the server dare to use Block if the client hasn't indicated Block capability".  When we designed -block, we had a choice between avoiding a potential surprise of this kind, but then requiring a Block2 option in just about any request that might possibly elicit a blockwise answer, and just assuming the majority of the clients will be able to handle block options.  We opted for the latter.  It's not like we have any backward compatibility issues here that would more or less force the first choice.

Grüße, Carsten