Subject: [core] I-D:core-interfaces

From: "Stok, Peter van der" <[email-masked]>
Date: Mon, 23 Jan 2012 08:27:50 +0000

Hi Zach,

Your concept of sub resource is quite central .
Could you define it in the terminology section 2?

I looked up RFC 5988 and found the following terms

o Relation Name: chapter
o Description: Refers to a chapter in a collection of resources.
o Reference: [W3C.REC-html401-19991224]

o Relation Name: section
o Description: Refers to a section in a collection of resources.
o Reference: [W3C.REC-html401-19991224

o Relation Name: subsection
o Description: Refers to a resource serving as a subsection in a
collection of resources.
o Reference: [W3C.REC-html401-19991224]

o Relation Name: start
o Description: Refers to the first resource in a collection of
resources.
o Reference: [W3C.REC-html401-19991224]

Are these related to your sub resource?

Peter

Peter van der Stok
Philips Research Laboratories Eindhoven
High Tech Campus                                                          HTC 34 (WB) 1-067
5656 AA Eindhoven                                                      The Netherlands
phone +31 40 2749657                                                Fax: + 31 40 2746321
mailto: [email-masked]

________________________________
The information contained in this message may be confidential and legally protected under applicable law. The message is intended solely for the addressee(s). If you are not the intended recipient, you are hereby notified that any use, forwarding, dissemination, or reproduction of this message is strictly prohibited and may be unlawful. If you are not the intended recipient, please contact the sender by return e-mail and destroy all copies of the original message.

---

From: Zach Shelby <[email-masked]>
Date: Mon, 23 Jan 2012 10:42:25 +0200

Hi Peter,

> Could you define it in the terminology section 2?

Sure, but this is by no means "my" concept :-) A resource collection is pretty central to REST. For example the POST method is designed to create a resource to a collection, and DELETE to remove it. I actually find the "RESTful Web Services" section on Wikipedia [http://en.wikipedia.org/wiki/Representational_state_transfer] to give a nice (or at least short) summary of the base resource, collection and element concepts used in REST APIs.

What my core-interfaces draft does is just to formalize a simple collection definition useful for constrained devices. The batch definition that is there right now is a pretty limited use case. I can foresee that we would need at least 2 other collection definitions to cover most use cases. 

> Are these related to your sub resource?

Those do refer to parts of a collection, but something pretty specific to HTML documents that have chapters and sections. 

Zach

-- 
Zach Shelby, Chief Nerd, Sensinode Ltd.
http://www.sensinode.com
http://zachshelby.org  - My blog "On the Internet of Things"
http://6lowpan.net - My book "6LoWPAN: The Wireless Embedded Internet"
Mobile: +358 40 7796297