Subject: Re: [core] Moving Observe forward

From: Klaus Hartke <[email-masked]>
Date: Mon, 13 Feb 2012 20:50:44 +0100

Zach Shelby wrote:
> Observe otherwise is in really good shape, and the WG seemed to think in Taipei that it would be ready for WGLC if this Max-OFE problem would be taken care of.

Max-OFE was the wrong solution to the problem and needs to be disposed
of. The question is: Is there is a problem that needs to be taken care
of or not?

If there is a problem, I believe the solution outlined by Carsten in
ticket #174 is the right one.

I'll submit a new revision of -observe soon with Max-OFE removed.
Maybe we can gather some deployment experience in Paris that helps us
answer the question.

Klaus

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 13 Feb 2012 20:58:42 +0100

> of. The question is: Is there is a problem that needs to be taken care

That question is easy to answer: Of course there is.
The more interesting question is whether that problem and it solutions are well-understood enough to build a solution in the base spec.
Observe works fine for many applications without such a solution, and an elective option that provides more efficiency for additional cases can be added later.

> ticket #174 is the right one.

I think so, too :-)

> I'll submit a new revision of -observe soon with Max-OFE removed.

I completely agree that this is the right way forward.

> Maybe we can gather some deployment experience in Paris that helps us

I could add #174 to coap-misc, so people who want to try it have some spec to work from.

Grüße, Carsten

---

From: Peter Saint-Andre <[email-masked]>
Date: Mon, 13 Feb 2012 13:04:30 -0700

<hat type='individual'/>

> I could add #174 to coap-misc, so people who want to try it have some spec to work from.

I agree that removing it from the base spec is the right path forward.
Putting a proposed solution in coap-misc or a standalone spec seems like
a good approach.

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: Zach Shelby <[email-masked]>
Date: Mon, 13 Feb 2012 22:40:29 +0200

> Putting a proposed solution in coap-misc or a standalone spec seems like

+1

-- 
Zach Shelby, Chief Nerd, Sensinode Ltd.
http://www.sensinode.com
http://zachshelby.org  - My blog "On the Internet of Things"
http://6lowpan.net - My book "6LoWPAN: The Wireless Embedded Internet"
Mobile: +358 40 7796297

---

From: Likepeng <[email-masked]>
Date: Tue, 14 Feb 2012 00:53:57 +0000

Hi,

> Putting a proposed solution in coap-misc or a standalone spec seems like a good approach.

A separate draft will be submitted soon (a few days).

Salvatore, Esko and me are working on a Patience option draft. 

It covers this issue (ticket 174).

Thanks,
Kind Regards
Kepeng
-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]] 代表 Peter Saint-Andre
发送时间: 2012年2月14日 4:05
收件人: Carsten Bormann
抄送: [email-masked] WG; Klaus Hartke
主题: Re: [core] Moving Observe forward

<hat type='individual'/>

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

_______________________________________________
core mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/core

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 14 Feb 2012 20:43:28 +0100

> It covers this issue (ticket 174).

Great!

While we are waiting for that, section 6 of draft-ietf-coap-misc-11 contains a more detailed write-up of my own simplistic view of the interaction timings:

	6.  Patience, Leisure, and Pledge

I'm optimistic it can be made as simple as that, but I'm looking forward to your more detailed considerations.

Grüße, Carsten

---

From: Salvatore Loreto <[email-masked]>
Date: Wed, 15 Feb 2012 10:13:27 +0200

>> Putting a proposed solution in coap-misc or a standalone spec seems like
+1 on removing Max-OFE from the Observe draft