Subject: Re: [core] Combined 4.13 response with Block Option?

From: Carsten Bormann <[email-masked]>
Date: Wed, 15 Feb 2012 16:43:51 +0100

On Apr 20, 2011, at 13:20, Dijk, Esko wrote:

> If a server receiving a (first) block finds that the message in its receive buffer is truncated (truncation case I took from coap-05), the problem is it can’t acknowledge the block because part of the data is missing. Hence, it cannot send a Block Option to indicate a smaller block size is necessary. It can only respond with error 4.13 in this case? 

Hmm, it might send a 4.13 with a Block1 to indicate the desired size.
Would that solve #170?

I'm about to add this text to the penultimate paragraph of Section 2 in -block, to solve #170:

(Note that a 4.13 response to a request that does not employ Block1 is
a hint for the client to try sending Block1, and a 4.13 response with
a smaller SZX in the Block1 than requested is a hint to try a smaller SZX.)

Grüße, Carsten

---

From: "Dijk, Esko" <[email-masked]>
Date: Wed, 15 Feb 2012 16:52:21 +0000

Yes, that would solve #170 I believe. Also my preferred solution.

thanks,
Esko

-----Original Message-----
From: Carsten Bormann [mailto:[email-masked]]
Sent: Wednesday 15 February 2012 16:44
To: Dijk, Esko
Cc: Likepeng; [email-masked]
Subject: Re: [core] Combined 4.13 response with Block Option?

On Apr 20, 2011, at 13:20, Dijk, Esko wrote:

> If a server receiving a (first) block finds that the message in its receive buffer is truncated (truncation case I took from coap-05), the problem is it can't acknowledge the block because part of the data is missing. Hence, it cannot send a Block Option to indicate a smaller block size is necessary. It can only respond with error 4.13 in this case?

Grüße, Carsten

________________________________
The information contained in this message may be confidential and legally protected under applicable law. The message is intended solely for the addressee(s). If you are not the intended recipient, you are hereby notified that any use, forwarding, dissemination, or reproduction of this message is strictly prohibited and may be unlawful. If you are not the intended recipient, please contact the sender by return e-mail and destroy all copies of the original message.