Subject: Re: [core] [Gen-art] Review: draft-ietf-core-link-format-11

From: Cullen Jennings <[email-masked]>
Date: Wed, 18 Apr 2012 12:40:43 -0600

On Mar 8, 2012, at 5:55 AM, Zach Shelby wrote:

>> 
>> Major issues:
>>   What is the registration / collision avoidance strategy for resource type (rt) and interface description (if) values?  They are both defined as opaque strings which can happen to be URIs.  So there seems to be potential for collision.
> 
> There is definitely a possibility for collision for those two attributes, especially as there will be a mix of specifications that define specific values to be used, and developers using their own values. Currently while those are being defined in CoRE drafts we can avoid collisions, but when other WGs or SDOs start defining them...
> 
> We have deliberated on the idea of defining registries for rt= and if= values, but it has not been clear if that should be done in this document. Recently several CoRE drafts have been written that do specify well-known values for those fields, so it starts to become obvious that those registries would be useful. If I understand right, your recommendation would be that we define those registries in the IANA section of this document? I would be in favor of doing that.

Where are we on resolving topic? This is closely linked with the registry proposed in senml.

---

From: Zach Shelby <[email-masked]>
Date: Wed, 18 Apr 2012 23:06:23 +0300

> Where are we on resolving topic? This is closely linked with the registry proposed in senml. 

Yes, it is being resolved in Ticket #195. I am adding both registries following the same style as the relation registry in RFC5988. 

http://trac.tools.ietf.org/wg/core/trac/ticket/195

The only action point right now is for me to update the draft closing this and the other tickets.

Zach

-- 
Zach Shelby, Chief Nerd, Sensinode Ltd.
http://www.sensinode.com
http://zachshelby.org  - My blog "On the Internet of Things"
http://6lowpan.net - My book "6LoWPAN: The Wireless Embedded Internet"
Mobile: +358 40 7796297