Subject: [core] WGLC draft-ietf-core-block-08: Disentangle Block and Token (#210)

From: Carsten Bormann <[email-masked]>
Date: Mon, 16 Apr 2012 11:11:04 +0200

I have written up my current thinking on how to simplify the -block mechanism.
Please see #210 (http://trac.tools.ietf.org/wg/core/trac/ticket/210).

This proposal is based on what we have seen during the interop testing in Paris.
I have no doubt that what we have now in -block-08 can be made to work, but with the simplifications outlined in #210 we have practically the same functionality with a lot less complexity.

(Most of that complexity comes from coupling in the implementation that is suddenly required in surprising places, so the few text deletions are not quite indicative of how much the implementation complexity goes down.)

I'd love to hear from implementers who experienced difficulties with -block in Paris whether this is the right direction.

Grüße, Carsten

---

From: "Kovatsch Matthias" <[email-masked]>
Date: Mon, 16 Apr 2012 16:21:33 +0000

+1

(Also see my comment about block ordering, as I think we should have monotonically increasing block numbers always starting with zero to keep it simple.)

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Carsten Bormann
> Sent: Montag, 16. April 2012 11:11
> To: [email-masked] WG
> Subject: [core] WGLC draft-ietf-core-block-08: Disentangle Block and Token
> (#210)
> 
> I have no doubt that what we have now in -block-08 can be made to work,
> but with the simplifications outlined in #210 we have practically the same
> functionality with a lot less complexity.
> 
> (Most of that complexity comes from coupling in the implementation that is
> suddenly required in surprising places, so the few text deletions are not
> quite indicative of how much the implementation complexity goes down.)
> 
> I'd love to hear from implementers who experienced difficulties with -block
> in Paris whether this is the right direction.
> 
> Grüße, Carsten
> 
> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core