Subject: Re: [core] Disentangle Block and Token

From: Klaus Hartke <[email-masked]>
Date: Tue, 17 Apr 2012 00:14:00 +0200

On 16 April 2012 11:01, core issue tracker
<[email-masked]> wrote:
>  3. similarly, for the state for atomic POST/PUT ("context"):
>   select this per end-point (and URI), too.
>
>     * note that this means a new upload to the same URI (before an old
>     one from the same endpoint was finished) simply overwrites the
>     context.  This is probably exactly what one wants.

Who wins if two clients perform a block-wise atomic POST/PUT with the
same URI through the same proxy at the same time?

Klaus

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 17 Apr 2012 00:37:08 +0200

> same URI through the same proxy at the same time?

Who wins if two clients perform a POST/PUT with the
same URI through the same proxy at the same time?

I think the more interesting question is how the intermediary can avoid the two concurrent operations to get confused with each other.  Right now, it would need to run its own buffering, or if it wants to "write through", use some form of locking and allocate separate port numbers in case of a lock conflict.  Not very nice, but is that an important enough use case to optimize that we want to incur the complexity everywhere that we have experienced?

Grüße, Carsten

---

From: Klaus Hartke <[email-masked]>
Date: Tue, 17 Apr 2012 00:46:15 +0200

> I think the more interesting question is how the intermediary can avoid the two concurrent operations to get confused with each other.  Right now, it would need to run its own buffering, or if it w…

I'd just add a sentence or two to make sure that the result is not
accidentally a resource where some parts come from one client and some
parts from the other.

Klaus