Subject: [core] roadmap draft

From: "Stok, Peter van der" <[email-masked]>
Date: Mon, 2 Apr 2012 09:04:30 +0000

Dear wg and chairs,

The roadmap draft is a very welcome document that tries to put some order in the possibly inconsistent set of documents produced by the wg members. A danger exists that this document will be the means by which the members will learn the probability that a document will go to wg or rfc status. A possibly good guard is to give the draft writers fair access to the contents of the roadmap draft.
One of the things that makes it difficult to judge the validity of a draft is the large number of application areas and network architectures that coap addresses. Just to name a few obvious ones:

*         Stand alone lowpan without edge router

*         Stand alone lowpan without edge router

*         Connected lowpan with edge router
Within these three possible network architectures there is the distinction between managed network (e.g. office infra structure) and unmanaged network (e.g. residential). I think it would be good to characterize drafts to see which architecture they aim at.  These categories are also necessary in my opinion to come to security solutions which are lean but adequate for the environment for which they are intended.
My suggestion is to make the roadmap draft a document that describes attributes of each draft with a table that can be provided by the authors of the draft, and that authors also have access to the text describing their drafts but within well defined space limits. One of the topics of this description should be a description how the draft extends other core drafts or proposes a different solution to the same problem without discussion of the why and how.

Peter van der Stok
mailto: [email-masked]

________________________________
The information contained in this message may be confidential and legally protected under applicable law. The message is intended solely for the addressee(s). If you are not the intended recipient, you are hereby notified that any use, forwarding, dissemination, or reproduction of this message is strictly prohibited and may be unlawful. If you are not the intended recipient, please contact the sender by return e-mail and destroy all copies of the original message.

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 6 Apr 2012 02:49:58 +0200

Hi Peter,

thank you for having a look at the first version of the draft.

I'm very well aware of the dangers of such a draft, but I thought the upsides are greater.

> A possibly good guard is to give the draft writers fair access to the contents of the roadmap draft.

This is certainly what I have in mind.

I have to qualify this a bit however:

There would have been two ways to do this:
-- aim for a WG draft, and use the WG consensus process to move it forward;
-- run this as a personal draft, and be quicker and possibly more candid in places.

(E.g., it is easier for me to say "draft-yegin-coap-security-options-00 was more of a trial balloon to
explore one approach that is not actively pursued." than for the WG chairs to state WG consensus on this.)

This works best if authors are also candid in telling me where to improve the document...

> ·         Stand alone lowpan without edge router
> ·         Stand alone lowpan without edge router
> ·         Connected lowpan with edge router
> 
> Within these three possible network architectures there is the distinction between managed network (e.g. office infra structure) and unmanaged network (e.g. residential). 

Indeed.  If you have text that could shed some light on this, I would love to include this in the roadmap draft.
(Or point to it.)

> I think it would be good to characterize drafts to see which architecture they aim at.  These categories are also necessary in my opinion to come to security solutions which are lean but adequate for the environment for which they are intended.
> My suggestion is to make the roadmap draft a document that describes attributes of each draft with a table that can be provided by the authors of the draft,

Developing such a table/taxonomy would be a worthwhile goal in evolving this draft.
I don't think we have such a taxonomy ready to use right now.
(Once we have it, that might spin off as a useful WG document of its own.  But let's try to collect some input first.)

> and that authors also have access to the text describing their drafts but within well defined space limits. One of the topics of this description should be a description how the draft extends other core drafts or proposes a different solution to the same problem without discussion of the why and how.

I've tried to capture this for some of the documents, but obviously ran out of time during the meeting.

Draft authors: If you want to help this document along, please do send a paragraph or two in the spirit of what Peter described!
I have submitted a -01 today -- not much changed (http://tools.ietf.org/rfcdiff?url2=draft-bormann-core-roadmap-01.txt); please do send me material for a better -02.

Grüße, Carsten