Subject: [core] any Agenda for Virtual Interim - May 16?

From: Salvatore Loreto <[email-masked]>
Date: Fri, 11 May 2012 11:00:20 +0300

Hi Cullen and Carsten,

sorry if I have missed it,
but I haven't seen any Agenda for the Core Virtual Interim ?

IMO it would be good to know in advance which issues/tickets (and 
eventually also  the relative order)
are going to be discussed in the Virtual Interim,
so people can be prepared (and eventually know if the can join later or 
leave earlier )

best regards
Sal

-- 
Salvatore Loreto, PhD
www.sloreto.com

---

From: Cullen Jennings <[email-masked]>
Date: Fri, 11 May 2012 04:44:11 -0600

Sorry Salvatore,

We should have had that out by now. I think that Carsten is selecting the set of tickets for the draft of the agenda but I will coordinate with Carsten and we will get that out soon.

Cullen

On May 11, 2012, at 2:00 AM, Salvatore Loreto wrote:

> IMO it would be good to know in advance which issues/tickets (and eventually also  the relative order)
> so people can be prepared (and eventually know if the can join later or leave earlier )
> 
> 
> best regards
> Sal
> 
> -- 
> Salvatore Loreto, PhD
> www.sloreto.com
>

---

From: Thomas Fossati <[email-masked]>
Date: Tue, 15 May 2012 10:32:53 +0200

Hi Cullen,

> We should have had that out by now. I think that Carsten is selecting the set of tickets for the draft of the agenda but I will coordinate with Carsten and we will get that out soon.

any news ?

Thanks, Thomas.

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 15 May 2012 13:29:48 +0200

>> We should have had that out by now. I think that Carsten is selecting the set of tickets for the draft of the agenda but I will coordinate with Carsten and we will get that out soon.

Unfortunately, other commitments meant that I'm only starting just now.  More in the course of the day.

Grüße, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 15 May 2012 17:59:10 +0200

Here is a draft agenda.
Please suggest adjustments.

Note that, numerically speaking, we have turned about 1/3 of the WGLC comment items into tickets.
I'd expect the remaining ones to be a bit less work per item, but there is still a lot of work ahead that is not in this agenda.

Grüße, Carsten

2012-05-16 14:30Z..17:30Z

CoRE Virtual Interim 2012-05-16

Below, find a rough agenda for disposing of 39 tickets.
The guesses for the times are probably somewhat optimistic, so we may
not even get to the end of all tickets.
Still:

Per draft, we distinguish:

-- check defined resolution and go ahead (~ 2 min per)
   The ticket has a defined resolution with non-trivial impact.
   We should check that this is what we want to do.

-- discuss (~ 10 min per)
   The ticket is still in need of a defined resolution.

-- tickets with a clear way forward (optional) (~ 1 min per)
   There is some relatively straightforward work to do, but not
   necessarily here -- speak up if you think discussion is needed.

-- tickets that need more work on the mailing list (~ 1 min per)
   Next interim.

In reverse alphabetical order:

* Call to order (10 min) 14:30Z..14:40Z

-- Notetakers etc.
-- Technical issues
-- Agenda bashing

* Observe (49 min) 14:40Z..15:29Z

-- check defined resolution and go ahead (2 min)

#225  Explain why it is not always possible to react to a RST that is in reply to a NON   new      editorial   minor

-- discuss (40 min)

#204  Introduce a minimal version of Pledge   new      protocol enhancement   major
#217  how fast must the observe clock be able to go?   new      protocol enhancement   major
#220  Should observe support time series data?   new      protocol enhancement   minor
#227  Make aborting the previous transaction optional   new      protocol enhancement   minor

-- tickets with a clear way forward (optional) (7 min)

#219  Clarify that observe is about eventual consistency   new      editorial   minor
#221  Occasionally sending CON is not just a security consideration   new      protocol defect   minor
#223  Fix reordering detection condition description   new      editorial   minor
#234  Editorial updates to -observe examples   new   [email-masked]   editorial   minor
#235  Avoid extending the base standard retransmission rules   new      other technical   minor
#236  Clarify the semantics of the "obs" link target attribute   new      other technical   minor
#237  Multicast -> reference groupcomm draft   new      editorial   minor

-- tickets that need more work on the mailing list

(none)

* CoAP (59 min) 15:29Z..16:28Z

-- check defined resolution and go ahead (22 min)

#202  Remove the 270 byte artificial limit   new      protocol defect   minor
#213  Path/Query options minimum length   new      protocol defect   minor
#214  Adopt vendor-defined option into core-coap   new      protocol enhancement   minor
#218  Mostly obvious section 5.10.8 fixes   new   [email-masked]   other technical   minor
#222  RawPublicKey identifier   new   [email-masked]   protocol enhancement   minor
#228  Proxying of multicast requests   new      protocol enhancement   minor
#229  Move sections 10-10.2. out of the "Security Considerations"   new      editorial   minor
#232  Clarify inclusion of Location options in a 2.01 (Created)
#response   new      editorial   minor
#233  Response codes with payload inconsistency   new      editorial   trivial
#239  Always reserve option delta 15   new      other technical   minor

-- discuss (30 min)

#201  Clarify use of retransmission window for duplicate detection   new      editorial   minor
#215  editorial issues around Congestion Control   new      editorial   major
#230  Multiple Location options need to be processed as a unit   new      protocol defect   minor

-- tickets with a clear way forward (optional) (5 min)

#207  Add advice on default values for critical options   new      editorial   minor
#212  Option numbers 14, 28, 42, ... reserved but usable   new      editorial   minor
#224  Clarify the concept of end-point   new      editorial   major
#216  IANA: get Multicast addresses   new      other technical   major
#226  Clarify which language addresses intermediaries in general vs. forward proxies specifically   new      other technical   major

-- tickets that need more work on the mailing list (2 min)

#231  Splitting/combining Location options   new      other technical   minor
#238  Proxy terminology   new      editorial   minor

* Block (9 min) 16:28Z..16:37Z

-- check defined resolution and go ahead (6)

#203  Restrict the potential combinations of Block1 and Block2   new      protocol defect   major
#210  Disentangle Block and Token   new      protocol defect   major
#211  Signal provisional responses (atomic Block1) in the response code   new      protocol defect   major

-- discuss (0)

-- tickets with a clear way forward (optional) (3)

#206  Clarify that atomic Block1 transfers match per token *and* endpoint   new      editorial   major
#205  Clarify that Size does not modify the request semantics beyond adding the size information   new      editorial   minor
#209  Add potential attacks to security considerations   new      editorial   minor

-- tickets that need more work on the mailing list

* Non-tickets (38 min) 16:37Z..17:15Z

What do we want to do here, *if* we really have that time?

Link-Format?

* Wrap-up, planning (15 min) 17:15Z..17:30Z

---

From: Salvatore Loreto <[email-masked]>
Date: Wed, 16 May 2012 11:51:51 +0300

my suggestion is to start the interim talking of CoAP tickets/issues

/Sal

On 5/15/12 6:59 PM, Carsten Bormann wrote:
> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 16 May 2012 11:04:31 +0200

> my suggestion is to start the interim talking of CoAP tickets/issues

That was our first thought.

We are not going to get done today with the core document in any case, there are still quite a few items that haven't been turned into tickets yet.
Observe happens to have all items covered in tickets, and I like to have a well-prepared discussion and to finish that one off.  We do need to time-box that, though.

You didn't give a reason for your suggestion -- is there maybe any specific ticket on -coap that you think should be discussed before the -observe ones?

Grüße, Carsten

---

From: Salvatore Loreto <[email-masked]>
Date: Wed, 16 May 2012 14:19:50 +0300

> You didn't give a reason for your suggestion -- is there maybe any specific ticket on -coap that you think should be discussed before the -observe ones?
the reason of my suggestion was: "first things first"
i.e IMO it would be better try to finalize/fix first the core protocol
but it was just a suggestion

/Sal

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 16 May 2012 13:34:46 +0200

> i.e IMO it would be better try to finalize/fix first the core protocol

I sure agree with the principle, but I think most of the -observe tickets actually do contribute to that.
#204 and #217 are the ones that are somewhat specific to observe -- it is high time that we nail down this part (of the ones where we have tickets, it is the largest piece of unfinished business that actually impacts implementations significantly).

Grüße, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 16 May 2012 14:31:55 +0200

... just to make sure we have no confusion about the time zones.

BTW, I don't have the webex data yet.

For resolving any webex problems, it is probably best if you all are in the jabber channel:

	xmpp:[email-masked]?join

Grüße, Carsten