Subject: [core] Fwd: New Version Notification for draft-shelby-core-resource-directory-03.txt

From: Zach Shelby <[email-masked]>
Date: Thu, 17 May 2012 16:25:54 +0300

http://www.ietf.org/id/draft-shelby-core-resource-directory-03.txt

An improved version of the Resource Directory specification is now available, and we'd like to thank Matthieu, Sampo and everyone involved with IPSO interop for the useful comments and ideas included in this new release. 

   Changes from -02 to -03:

      o Changed the end-point name back to a single registration
      parameter ep= and removed the h= and ins= parameters.

      o Updated REST interface descriptions to use RFC6570 URI Template
      format.

      o Introduced an improved RD Lookup design as its own function set.

      o Improved the security considerations section.

      o Made the POST registration interface idempotent by requiring the
      ep= paramter to be present.

Now let's have a little competition who upgrades their implementation first :-) Soon as my test RD is available on-line I will post a link.

Regards,
Zach

Begin forwarded message:

> From: [email-masked]
> Date: May 17, 2012 4:20:50 PM GMT+03:00
> To: [email-masked]
> Cc: [email-masked]
> Subject: New Version Notification for draft-shelby-core-resource-directory-03.txt
> 
> A new version of I-D, draft-shelby-core-resource-directory-03.txt has been successfully submitted by Zach Shelby and posted to the IETF repository.
> 
> Filename:	 draft-shelby-core-resource-directory
> Revision:	 03
> Title:		 CoRE Resource Directory
> Creation date:	 2012-05-17
> WG ID:		 Individual Submission
> Number of pages: 19
> 
> Abstract:
>   In many M2M applications, direct discovery of resources is not
>   practical due to sleeping nodes, disperse networks, or networks where
>   multicast traffic is inefficient.  These problems can be solved by
>   employing an entity called a Resource Directory (RD), which hosts
>   descriptions of resources held on other servers, allowing lookups to
>   be performed for those resources.  This document specifies the web
>   interfaces that a Resource Directory supports in order for web
>   servers to discover the RD and to register, maintain, lookup and
>   remove resources descriptions.  Furthermore, new link attributes
>   useful in conjunction with an RD are defined.
> 
> 
> 
> 
> The IETF Secretariat

-- 
Zach Shelby, Chief Nerd, Sensinode Ltd.
http://www.sensinode.com
http://zachshelby.org  - My blog "On the Internet of Things"
http://6lowpan.net - My book "6LoWPAN: The Wireless Embedded Internet"
Mobile: +358 40 7796297

---

From: Zach Shelby <[email-masked]>
Date: Mon, 21 May 2012 15:20:46 +0300

I have an updated resource directory interface test implementation on-line (IPv4 and IPv6 enabled), now upgraded to almost all features of -03:

Registration Interface:

coap://interop.ams.sensinode.com:5683/rd

Lookup interface:

coap://interop.ams.sensinode.com:5683/rd-lookup

HTTP Browser

http://interop.ams.sensinode.com/

There is a single IPSO Profile node running on that server on port 8000 and registered with this RD. Feel free to register your own end-points to this RD, it is meant to be running continuously.

Example resource lookups that you can make:

coap://interop.ams.sensinode.com:5683/rd-lookup/ep   (lookup all end-points)
coap://interop.ams.sensinode.com:5683/rd-lookup/res   (lookup all resources)
coap://interop.ams.sensinode.com:5683/rd-lookup/res?rt=ucum:Cel   (lookup temperature resources)
coap://interop.ams.sensinode.com:5683/rd-lookup/res?rt=ipso:dev*    (lookup all IPSO Device function set resources using a wildcard)

Zach

On May 17, 2012, at 4:25 PM, Zach Shelby wrote:

> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core