Subject: Re: [core] #220: Should observer support time series data?

From: Carsten Bormann <[email-masked]>
Date: Fri, 4 May 2012 10:51:54 +0200

> Observe currently is about 2 (eventual consistency).  What kinds of
> mechanisms would we need to add to support time series data as in 1?  Is
> the resulting set of changes a desirable addition?

So far the feedback has been negative.
We also don't have a detailed design.
Should we mark this "wontfix" for -observe and wait for a separate extension proposal later?

Grüße, Carsten

---

From: Jeroen Hoebeke <[email-masked]>
Date: Fri, 4 May 2012 15:23:29 +0200

> Should we mark this "wontfix" for -observe and wait for a separate extension proposal later?

The way I see it is the following:

time series data as in case 1 = case 2 minus the obligation to send a notification whenever max-age expires and the resource did not change during that period

So, case 1 will always result in less messages, because of the absence of this obligation. 

To support case 1, a solution to indicate the duration of the relationship independent of max-age is needed (since case 1 should work for non-cacheable resources as well). 
Most importantly, what is also lacking is a way for the client/server to indicate which kind of relation it wants to establish, 1 or 2?. It would be good then to make this part of a separate extension proposal. My aim is to make a suggestion on how to do that as part of the conditional observe draft.

Kind regards,
Jeroen

---

From: "core issue tracker" <[email-masked]>
Date: Wed, 16 May 2012 18:14:23 -0000

#220: Should observe support time series data?

Changes (by hartke@…):

 * status:  new => closed
 * resolution:   => wontfix

Comment:

 In the interim meeting, Jeroen clarified that this ticket is
 misinterpreting his comment and that the item raised is really about
 notifications with a Max-Age of zero which will be resolved in ticket
 #204.

-- 
----------------------------------+----------------------------------------
 Reporter:  cabo@…                |       Owner:  draft-ietf-core-observe@…
     Type:  protocol enhancement  |      Status:  closed
 Priority:  minor                 |   Milestone:  post-WGLC-1
Component:  observe               |     Version:  observe-05
 Severity:  In WG Last Call       |  Resolution:  wontfix
 Keywords:                        |
----------------------------------+----------------------------------------

Ticket URL: <http://trac.tools.ietf.org/wg/core/trac/ticket/220#comment:2>
core <http://tools.ietf.org/core/>