Subject: [core] Fwd: Last Call: <draft-farrell-decade-ni-07.txt> (Naming Things with Hashes) to Proposed Standard

From: Zach Shelby <[email-masked]>
Date: Mon, 4 Jun 2012 18:08:17 +0300

FYI - this is a draft that we have a dependency on in CoAP for our public key identity hash. Great to see it making progress. 

Zach

Begin forwarded message:

> From: The IESG <[email-masked]>
> Date: June 4, 2012 5:18:04 PM GMT+03:00
> To: IETF-Announce <[email-masked]>
> Subject: Last Call: <draft-farrell-decade-ni-07.txt> (Naming Things with Hashes) to Proposed Standard
> Reply-To: [email-masked]
> 
> 
> The IESG has received a request from an individual submitter to consider
> the following document:
> - 'Naming Things with Hashes'
>  <draft-farrell-decade-ni-07.txt> as Proposed Standard
> 
> The IESG plans to make a decision in the next few weeks, and solicits
> final comments on this action. Please send substantive comments to the
> [email-masked] mailing lists by 2012-07-02. Exceptionally, comments may be
> sent to [email-masked] instead. In either case, please retain the
> beginning of the Subject line to allow automated sorting.
> 
> Abstract
> 
> 
>   This document defines a set of ways to identify a thing using the
>   output from a hash function, specifying URI, URL, binary and human
>   "speakable" formats for these names.  The various formats are
>   designed to support, but not require, a strong link to the referenced
>   object such that the referenced object may be authenticated to the
>   same degree as the reference to it.
> 
> 
> 
> 
> The file can be obtained via
> http://datatracker.ietf.org/doc/draft-farrell-decade-ni/
> 
> IESG discussion can be tracked via
> http://datatracker.ietf.org/doc/draft-farrell-decade-ni/ballot/
> 
> 
> The following IPR Declarations may be related to this I-D:
> 
>   http://datatracker.ietf.org/ipr/1773/
>   http://datatracker.ietf.org/ipr/1775/
> 
> 
> 

-- 
Zach Shelby, Chief Nerd, Sensinode Ltd.
http://www.sensinode.com
http://zachshelby.org  - My blog "On the Internet of Things"
http://6lowpan.net - My book "6LoWPAN: The Wireless Embedded Internet"
Mobile: +358 40 7796297

---

From: Stephen Farrell <[email-masked]>
Date: Mon, 04 Jun 2012 16:13:20 +0100

> FYI - this is a draft that we have a dependency on in CoAP for our public key identity hash. Great to see it making progress. 

It is:-)

We've also updated the code for it [1] if that's useful
for anyone. Ultimately that code is intended for other
things, but its apache licensed so folks can grab what
they find useful from the c, python, ruby or clojure
libraries that are up to date wrt -07. Other bits of
the code are more work in progress, but the stuff you
guys care about should be usable.

Cheers,
S.

[1] http://sourceforge.net/projects/netinf/