Subject: Re: [core] #238: Proxy terminology

From: "core issue tracker" <[email-masked]>
Date: Mon, 04 Jun 2012 09:16:13 -0000

#238: Proxy terminology

Comment (by zach@…):

 I would propose "translating proxy"

-- 
-----------------------------+-------------------------------------
 Reporter:  cabo@…           |       Owner:  draft-ietf-core-coap@…
     Type:  editorial        |      Status:  new
 Priority:  minor            |   Milestone:  post-WGLC-1
Component:  coap             |     Version:  coap-09
 Severity:  In WG Last Call  |  Resolution:
 Keywords:                   |
-----------------------------+-------------------------------------

Ticket URL: <http://trac.tools.ietf.org/wg/core/trac/ticket/238#comment:1>
core <http://tools.ietf.org/core/>

---

From: "core issue tracker" <[email-masked]>
Date: Mon, 04 Jun 2012 14:14:52 -0000

#238: Proxy terminology

Comment (by angelo@…):

 from core-http-mapping-04:

 2.  Terminology

    A device providing cross-protocol HTTP-CoAP mapping is called an
    HTTP-CoAP cross-protocol proxy (HC proxy).

Ticket URL: <http://trac.tools.ietf.org/wg/core/trac/ticket/238#comment:2>
core <http://tools.ietf.org/core/>

---

From: "core issue tracker" <[email-masked]>
Date: Mon, 11 Jun 2012 09:22:10 -0000

#238: Proxy terminology

#choose ticket.new
  #when True
 Cullen Jennings notes (msg03072e):

 Section 1.2

 We have two very different types of proxies - one only speaks COAP and the
 other type translates between CoAP and HTTP. I would prefer a different
 terms for the translating type. Perhaps "translator" or "translator
 proxy". I understand people don't want to use gateway but it is what many
 people would call a gateway.

 -> Agree on terminology and go through the 113 occurrences of "proxy"
  #end
  #otherwise
    #if changes_body
Changes (by zach@…):

    #end
    #if changes_descr
      #if not changes_body and not change.comment and change.author
Description changed by zach@…:
      #end

--
    #end
    #if change.comment

Comment(by zach@…):

 In the June 4th interim meeting we settled on "Cross Proxy".
    #end
  #end
#end

Ticket URL: <http://trac.tools.ietf.org/wg/core/trac/ticket/238#comment:3>
core <http://tools.ietf.org/core/>

---

From: "core issue tracker" <[email-masked]>
Date: Mon, 11 Jun 2012 09:23:39 -0000

#238: Proxy terminology

#choose ticket.new
  #when True

 Section 1.2

 * owner:  draft-ietf-core-coap@… => hartke@…

    #end
    #if changes_descr

--
    #end
    #if change.comment

Comment:

    #end
  #end
#end

-- 
-----------------------------+--------------------------
 Reporter:  cabo@…           |       Owner:  hartke@…
     Type:  editorial        |      Status:  new
 Priority:  minor            |   Milestone:  post-WGLC-1
Component:  coap             |     Version:  coap-09
 Severity:  In WG Last Call  |  Resolution:
 Keywords:                   |
-----------------------------+--------------------------

Ticket URL: <http://trac.tools.ietf.org/wg/core/trac/ticket/238#comment:4>
core <http://tools.ietf.org/core/>

---

From: "core issue tracker" <[email-masked]>
Date: Mon, 25 Jun 2012 17:14:14 -0000

#238: Proxy terminology

Comment (by cabo@…):

 Section 10 now (coap-10) has a single instance pf "cross-protocol
 proxying" (plus one in the heading).
 Hence, the abbreviation is not introduced.  Fine?

Ticket URL: <http://tools.ietf.org/wg/core/trac/ticket/238#comment:5>
core <http://tools.ietf.org/core/>