Subject: Re: [core] #202: Remove the 270 byte artificial limit

From: Zach Shelby <[email-masked]>
Date: Mon, 4 Jun 2012 11:48:44 +0300

Thanks Carsten. This is in alignment with what we agreed in the last interop PhC. You also have a chance to comments on the list, but otherwise I plan on integrating this change as proposed  in misc-17 Section 2.1. 

Zach

On May 26, 2012, at 3:38 PM, core issue tracker wrote:

> #202: Remove the 270 byte artificial limit
> 
> 
> Comment (by cabo@…):
> 
> Some more detailed considerations are now in section 2.1 of
> http://tools.ietf.org/html/draft-bormann-coap-misc-17#section-2.1 -- these
> are the result of the discussions in the interim.  Actual text can be
> generated when we have agreed (by review of this on the list, not just on
> the phone) on the principles.
> 
> -- 
> -----------------------------+-------------------------------------
> Reporter:  cabo@…           |       Owner:  draft-ietf-core-coap@…
>     Type:  protocol defect  |      Status:  new
> Priority:  minor            |   Milestone:
> Component:  coap             |     Version:
> Severity:  In WG Last Call  |  Resolution:
> Keywords:                   |
> -----------------------------+-------------------------------------
> 
> Ticket URL: <http://trac.tools.ietf.org/wg/core/trac/ticket/202#comment:1>
> core <http://tools.ietf.org/core/>
> 
> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core

-- 
Zach Shelby, Chief Nerd, Sensinode Ltd.
http://www.sensinode.com
http://zachshelby.org  - My blog "On the Internet of Things"
http://6lowpan.net - My book "6LoWPAN: The Wireless Embedded Internet"
Mobile: +358 40 7796297

---

From: "core issue tracker" <[email-masked]>
Date: Mon, 11 Jun 2012 13:49:05 -0000

#choose ticket.new
  #when True
 For a while, it seemed we had consensus to leave in the artificial limit
 of 270 bytes for the option length.  However, this left a scar on Uri-
 Proxy, which needed special handling for the rare case where this creates
 a problem.

 Matthias Kovatsch has now proposed a simple way to remove the artificial
 limitation, which is documented in section 2.1 of

        http://tools.ietf.org/html/draft-bormann-coap-misc-14#section-2.1

 This change will also enable the reverting of Uri-Proxy to its natural
 state of a  non-repeatable option.
  #end
  #otherwise
    #if changes_body
Changes (by zach@…):

 * owner:  draft-ietf-core-coap@… => cabo@…

    #end
    #if changes_descr
      #if not changes_body and not change.comment and change.author
Description changed by zach@…:
      #end

--
    #end
    #if change.comment

Comment:

    #end
  #end
#end

-- 
-----------------------------+---------------------
 Reporter:  cabo@…           |       Owner:  cabo@…
     Type:  protocol defect  |      Status:  new
 Priority:  minor            |   Milestone:
Component:  coap             |     Version:
 Severity:  In WG Last Call  |  Resolution:
 Keywords:                   |
-----------------------------+---------------------

Ticket URL: <http://trac.tools.ietf.org/wg/core/trac/ticket/202#comment:2>
core <http://tools.ietf.org/core/>

---

From: "core issue tracker" <[email-masked]>
Date: Mon, 25 Jun 2012 17:10:09 -0000

Comment (by cabo@…):

 Text in section 2.1 of coap-misc-18, to be moved over to core-coap.

Ticket URL: <http://tools.ietf.org/wg/core/trac/ticket/202#comment:3>
core <http://tools.ietf.org/core/>

---

From: "core issue tracker" <[email-masked]>
Date: Mon, 25 Jun 2012 20:11:16 -0000

Changes (by hartke@…):

 * version:   => coap-09
 * milestone:   => post-WGLC-1

-- 
-----------------------------+--------------------------
 Reporter:  cabo@…           |       Owner:  cabo@…
     Type:  protocol defect  |      Status:  new
 Priority:  minor            |   Milestone:  post-WGLC-1
Component:  coap             |     Version:  coap-09
 Severity:  In WG Last Call  |  Resolution:
 Keywords:                   |
-----------------------------+--------------------------

Ticket URL: <http://tools.ietf.org/wg/core/trac/ticket/202#comment:4>
core <http://tools.ietf.org/core/>