Subject: Re: [core] #233: Response codes with payload inconsistency

From: "core issue tracker" <[email-masked]>
Date: Mon, 11 Jun 2012 14:53:43 -0000

#233: Response codes with payload inconsistency

#choose ticket.new
  #when True
 Section 5.5, first paragraph:

   The response codes with payload are 2.05 (Content) and the error codes.

 But a few paragraphs later:

   2.01 (Created), 2.02 (Deleted), 2.04 (Changed) MAY include payload

 ->

 The first paragraph needs to be fixed.

 ----

 Ari Keränen notes:

   2.01 (Created), 2.02 (Deleted), 2.04 (Changed) MAY include payload

 Change to "Responses with code [...]"
  #end
  #otherwise
    #if changes_body
Changes (by zach@…):

 * status:  new => closed
 * resolution:   => fixed

    #end
    #if changes_descr
      #if not changes_body and not change.comment and change.author
Description changed by zach@…:
      #end

--
    #end
    #if change.comment

Comment:

 Done in r693.
    #end
  #end
#end

-- 
-----------------------------+-------------------------------------
 Reporter:  hartke@…         |       Owner:  draft-ietf-core-coap@…
     Type:  editorial        |      Status:  closed
 Priority:  trivial          |   Milestone:  post-WGLC-1
Component:  coap             |     Version:  coap-09
 Severity:  In WG Last Call  |  Resolution:  fixed
 Keywords:                   |
-----------------------------+-------------------------------------

Ticket URL: <http://trac.tools.ietf.org/wg/core/trac/ticket/233#comment:1>
core <http://tools.ietf.org/core/>

---

From: Klaus Hartke <[email-masked]>
Date: Mon, 11 Jun 2012 17:07:05 +0200

> - POST, and the response codes with payload are 2.05 (Content) and the error
> - codes.</t>
> + POST, and the response codes with payload are 2.01 (Created), 2.02
> + (Deleted), 2.04 (Changed) and the error codes.</t>

2.05 (Content) can have payload as well.

Klaus