Subject: Re: [core] #212: Option numbers 14, 28, 42, ... reserved but usable

From: "core issue tracker" <[email-masked]>
Date: Mon, 11 Jun 2012 11:08:49 -0000

#212: Option numbers 14, 28, 42, ... reserved but usable

#choose ticket.new
  #when True
 Section 5.4.5. (Option Numbers) states that "the numbers 14, 28, 42, ...
 are reserved for 'fenceposting'". It is actually not necessary to reserve
 them for this; options with those numbers just need to have a default
 value that is encoded with zero bytes. The Vendor option in -misc already
 takes advantage of this.

 ->

 Clarify that while the positive option numbers divisible by 14 are indeed
 reserved, they still are available for allocation as long as a zero-length
 option with each of these numbers remains available as a no-operation
 option for fenceposting.

 (msg03034a, also covers msg03072cc)
  #end
  #otherwise
    #if changes_body
Changes (by zach@…):

 * status:  new => closed
 * resolution:   => fixed

    #end
    #if changes_descr
      #if not changes_body and not change.comment and change.author
Description changed by zach@…:
      #end

--
    #end
    #if change.comment

Comment:

    #end
  #end
#end

-- 
-----------------------------+-------------------------------------
 Reporter:  cabo@…           |       Owner:  draft-ietf-core-coap@…
     Type:  editorial        |      Status:  closed
 Priority:  minor            |   Milestone:  post-WGLC-1
Component:  coap             |     Version:  coap-09
 Severity:  In WG Last Call  |  Resolution:  fixed
 Keywords:                   |
-----------------------------+-------------------------------------

Ticket URL: <http://trac.tools.ietf.org/wg/core/trac/ticket/212#comment:2>
core <http://tools.ietf.org/core/>

---

From: "core issue tracker" <[email-masked]>
Date: Mon, 11 Jun 2012 11:08:42 -0000

#choose ticket.new
  #when True

 ->

    #end
    #if changes_descr

--
    #end
    #if change.comment

Comment(by zach@…):

 Done in r687.
    #end
  #end
#end

-- 
-----------------------------+-------------------------------------
 Reporter:  cabo@…           |       Owner:  draft-ietf-core-coap@…
     Type:  editorial        |      Status:  new
 Priority:  minor            |   Milestone:  post-WGLC-1
Component:  coap             |     Version:  coap-09
 Severity:  In WG Last Call  |  Resolution:
 Keywords:                   |
-----------------------------+-------------------------------------

Ticket URL: <http://trac.tools.ietf.org/wg/core/trac/ticket/212#comment:1>
core <http://tools.ietf.org/core/>

---

From: Klaus Hartke <[email-masked]>
Date: Mon, 11 Jun 2012 17:07:52 +0200

> - Option Numbers 14, 28, 42, ... are reserved for no-op options
> - when they are sent with an empty value (they are ignored)
> - and can be used as "fenceposts" if
> + Option Numbers 14, 28, 42, ... are reserved
> + for no-op options when they are sent with an empty value
> + (they are ignored) and can be used as "fenceposts" if

The point is that these options are not reserved at all. There are
just some constraints in their definition.

Klaus