Subject: Re: [core] #239: Always reserve option delta 15

From: "core issue tracker" <[email-masked]>
Date: Mon, 11 Jun 2012 14:47:51 -0000

#239: Always reserve option delta 15

#choose ticket.new
  #when True
 Cullen Jennings notes (msg03072j):

 Section 3.1

 Having the a option delta of 15 mean different things based on if the
 Option Count Field is 0 or not just seems it adds complexity and bugs not
 worth the small compression gain.

 ->

 (substitute 15 for 0 in the above)

 For simplicity, we should always only use option deltas from 0 to 14,
 independent of whether we need the option terminator or not.
  #end
  #otherwise
    #if changes_body
Changes (by zach@…):

 * owner:  draft-ietf-core-coap@… => cabo@…

    #end
    #if changes_descr
      #if not changes_body and not change.comment and change.author
Description changed by zach@…:
      #end

--
    #end
    #if change.comment

Comment:

    #end
  #end
#end

-- 
-----------------------------+--------------------------
 Reporter:  cabo@…           |       Owner:  cabo@…
     Type:  other technical  |      Status:  new
 Priority:  minor            |   Milestone:  post-WGLC-1
Component:  coap             |     Version:  coap-09
 Severity:  In WG Last Call  |  Resolution:
 Keywords:                   |
-----------------------------+--------------------------

Ticket URL: <http://trac.tools.ietf.org/wg/core/trac/ticket/239#comment:1>
core <http://tools.ietf.org/core/>

---

From: "core issue tracker" <[email-masked]>
Date: Mon, 25 Jun 2012 17:27:25 -0000

Changes (by cabo@…):

 * status:  new => closed
 * resolution:   => fixed

Comment:

 Fixed in [814]:

 Fix #239

-- 
-----------------------------+--------------------------
 Reporter:  cabo@…           |       Owner:  cabo@…
     Type:  other technical  |      Status:  closed
 Priority:  minor            |   Milestone:  post-WGLC-1
Component:  coap             |     Version:  coap-09
 Severity:  In WG Last Call  |  Resolution:  fixed
 Keywords:                   |
-----------------------------+--------------------------

Ticket URL: </ticket/239#comment:2>
core <http://tools.ietf.org/core/>