Subject: [core] I-D Action: draft-ietf-core-coap-11.txt

From: [email-masked]
Date: Mon, 16 Jul 2012 14:53:13 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Constrained RESTful Environments Working Group of the IETF.

	Title           : Constrained Application Protocol (CoAP)
	Author(s)       : Zach Shelby
                          Klaus Hartke
                          Carsten Bormann
                          Brian Frank
	Filename        : draft-ietf-core-coap-11.txt
	Pages           : 100
	Date            : 2012-07-16

Abstract:
   The Constrained Application Protocol (CoAP) is a specialized web
   transfer protocol for use with constrained nodes and constrained
   (e.g., low-power, lossy) networks.  The nodes often have 8-bit
   microcontrollers with small amounts of ROM and RAM, while constrained
   networks such as 6LoWPAN often have high packet error rates and a
   typical throughput of 10s of kbit/s.  The protocol is designed for
   machine-to-machine (M2M) applications such as smart energy and
   building automation.

   CoAP provides a request/response interaction model between
   application end-points, supports built-in discovery of services and
   resources, and includes key concepts of the Web such as URIs and
   Internet media types.  CoAP easily interfaces with HTTP for
   integration with the Web while meeting specialized requirements such
   as multicast support, very low overhead and simplicity for
   constrained environments.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-core-coap

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-core-coap-11

A diff from previous version is available at:
http://tools.ietf.org/rfcdiff?url2=draft-ietf-core-coap-11

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 17 Jul 2012 00:23:56 +0200

After core-coap-10 made some major rearrangements, core-coap-11 mainly has the changes to close ticket #201, by moving material from coap-misc to section 4.8 (Transmission Parameters) and editing it in shape for the spec.
Please read the new text again carefully, as it has a little bit of math in it that is easy to get wrong.

Htmlized:        http://tools.ietf.org/html/draft-ietf-core-coap-11
Diff:            http://tools.ietf.org/rfcdiff?url2=draft-ietf-core-coap-11

Most of the other major proposals for ticket resolutions are still in coap-misc, which also was renewed today:

Htmlized:        http://tools.ietf.org/html/draft-bormann-coap-misc-19
Diff:            http://tools.ietf.org/rfcdiff?url2=draft-bormann-coap-misc-19

There is a new section 3.2 that proposes an alternative resolution for #214 based on the discussion at the virtual interim.
Section 5 provides text for resolving -observe tickets #204, #221 IIRC.

Finally, a resolution for #215 is being prepared in core-congestion-control.
 	
Htmlized:        http://tools.ietf.org/html/draft-bormann-core-congestion-control-01
Diff:            http://tools.ietf.org/rfcdiff?url2=draft-bormann-core-congestion-control-01

The main change from -00 is the addition of a section 6 detailing the changes planned for Base Specifications	

While there is a lot of boring detail work remaining, I believe we have the bulk of the necessary new material now out there.
Please read and prepare for IETF84 in Vancouver.  
Pending major disagreements on the list, the material pointed out should move into coap-12 and observe-06 by Vancouver.

Grüße, Carsten