Subject: [core] Comments on draft-bormann-core-links-json-01

From: Zach Shelby <[email-masked]>
Date: Sun, 29 Jul 2012 21:37:47 -0400

Carsten,

I reviewed this draft, and definitely find it useful. In addition to some detailed comments (will send directly to Carsten), I think there is one meta-issue here. Do we want this JSON format to be a generic representation of RFC5988 Web Links, or is this something really only specific to the CoRE Link Format use of Web Linking? I think deciding on that scope would help close some of the open questions in the draft. Personally I find the later purpose really nice, but looking at the bigger picture this should probably be as generic as possible.

Definitely think this is something the WG should continue working on. When communicating these CoRE Links from the constrained world to other web applications, JSON provides a handy representation that is easy to work with in high-level programming languages.

Zach

-- 
Zach Shelby, Chief Nerd, Sensinode Ltd.
http://www.sensinode.com
http://zachshelby.org  - My blog "On the Internet of Things"
http://6lowpan.net - My book "6LoWPAN: The Wireless Embedded Internet"
Mobile: +358 40 7796297

---

From: Carsten Bormann <[email-masked]>
Date: Sun, 29 Jul 2012 22:57:42 -0700

On Jul 29, 2012, at 18:37, Zach Shelby <[email-masked]> wrote:

> Do we want this JSON format to be a generic representation of RFC5988 Web Links, or is this something really only specific to the CoRE Link Format use of Web Linking? I think deciding on that scope would help close some of the open questions in the draft. Personally I find the later purpose really nice, but looking at the bigger picture this should probably be as generic as possible.

I think the guiding principle should (as in most protocol design be):

Generality is great if it costs nothing (or very, very little).
When generality starts to make things complex or lose some of the focused goodness of a proposal and it's not quite clear the the important use cases require this complexity, you are almost always better off doing the less general thing.

http://en.wikipedia.org/wiki/You_ain't_gonna_need_it

So, my questions would be:
-- Do we know about any complexity that would come from making this a general RFC5988 representation?
   (Such complexity may include the need for interfacing with other groups, which can slow us down unless we know how to do it efficiently.)
-- Do we lose something in the process?

If we can be reasonably sure both are not the case, we should go for the whole thing.

Grüße, Carsten