Subject: [core] Light switch authentication issue

From: Behcet Sarikaya <[email-masked]>
Date: Wed, 1 Aug 2012 20:16:28 -0500

Dear all,

Today in the session someone asked about why a light switch needs to
be authenticated after my presentation of
draft-sarikaya-core-sbootstrapping-05.

I would like ask if the light switch would have an IP stack? If not of
course no issue. Then CoAP would also be not applicable.

So it is fair to assume an IPv6 stack then the first step in getting
into IP network is secure bootstrapping which  involves
authentication.

This is what we address in the draft.

I hope that the person who asked this question can clarify his point.

Behcet

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 1 Aug 2012 18:29:20 -0700

In Paris, we held a workshop that addressed some of the relevant issues.
You can find papers and slides at:

http://www.lix.polytechnique.fr/hipercom/SmartObjectSecurity/#h.th5igs8wmy9s

E.g., position papers 21 or 27 may be a good source of ideas about different kinds of bootstrapping.

Here, generally the idea is to do bootstrapping even before secure network access is established (because that requires bootstrapping -- that is the reason for using this term...).

There is also a nice overview of the issues in:

http://tools.ietf.org/html/draft-garcia-core-security-04

(cf. also the workshop's position paper 6).

These are only highlights, there's more.

Grüße, Carsten

---

From: Behcet Sarikaya <[email-masked]>
Date: Wed, 1 Aug 2012 20:33:47 -0500

> These are only highlights, there's more.

Yes, they are referenced in draft-sarikaya-core-sbootstrapping-05 :-)

 Grüße, Behcet

---

From: "Keoh, Sye Loong" <[email-masked]>
Date: Thu, 2 Aug 2012 16:37:57 +0000

Dear all,

My impression of the workshop in Paris was that there are various security issues that need to be addressed. Bootstrapping is definitely one of them, and it was concluded that it's a difficult problem to solve.
Another highlights of the workshop was whether existing security mechanisms such as DTLS, public-key cryptography can fit on Class 1 devices, and what sort of optimization is needed. It was 'sort of concluded' that some of these implementation issues discussed in the LWIG.

However, what I am missing here still is that, now we have all these security issues related to smart objects, where is the right place to address/discuss them if not in CoRE? Maybe in ROLL?

Cheers
Sye Loong

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Carsten Bormann
Sent: donderdag 2 augustus 2012 3:29
To: [email-masked]
Cc: core WG
Subject: Re: [core] Light switch authentication issue

Grüße, Carsten

_______________________________________________
core mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/core

________________________________
The information contained in this message may be confidential and legally protected under applicable law. The message is intended solely for the addressee(s). If you are not the intended recipient, you are hereby notified that any use, forwarding, dissemination, or reproduction of this message is strictly prohibited and may be unlawful. If you are not the intended recipient, please contact the sender by return e-mail and destroy all copies of the original message.

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 2 Aug 2012 09:51:33 -0700

Hi Sye,

indeed, what *is* the right place!
We will have a discussion of this at the end of Friday's ROLL meeting.
ROLL is another group that really needs a security environment to base their security on.
The working groups in this space have spent about half of a decade pointing at each other and either saying "you have to solve our problem" or saying "you have to swallow what we think is the right solution to your problem".
Neither works, and we need an actual architecture to put the required elements in.

Sye, as a co-author of draft-garcia-core-security-04.txt (and I think the only one present here), can you say a few words about Figure 1 in the ROLL meeting?
We won't have much time, but I think this figure is important as a lead-in to that discussion.

Grüße, Carsten

---

From: "Keoh, Sye Loong" <[email-masked]>
Date: Thu, 2 Aug 2012 16:59:29 +0000

Hi Carsten,

Yes, I would be happy to say a few words about the figure: "The lifecycle of a thing in the Internet of Things" to kick-start the discussion in ROLL security.

Cheers
Sye Loong

-----Original Message-----
From: Carsten Bormann [mailto:[email-masked]] 
Sent: donderdag 2 augustus 2012 18:52
To: Keoh, Sye Loong
Cc: core WG; [email-masked]
Subject: Re: [core] Light switch authentication issue

Hi Sye,

Grüße, Carsten

---

From: Behcet Sarikaya <[email-masked]>
Date: Thu, 2 Aug 2012 12:46:15 -0500

Carsten, Sye,

Well, we can discuss where to do this work, OK. But my presentation
yesterday in Core has shown how illiterate people are in Core on this
topic.

I got the impression that most people are thinking that CoAP runs in
some other world where nothing else (IPv6 stack, transport layer,
etc.) is needed. People are so happy dealing with the details of CoAP
features and completely forget what is going on underneath.

IMHO this would be avoided if Core accepted our secure bootstrapping
draft in November 2010 Beijing meeting. In that meeting we had a very
informed set of attendees, they were interested on the subject and had
given so many good feedback.

Sigh :-).

Behcet