Subject: Re: [core] FW: New Version Notification for draft-ietf-core-groupcomm-02.txt

From: Shoichi Sakane <[email-masked]>
Date: Sat, 04 Aug 2012 02:55:33 +0900

I don't know whether there was same discussion before.
If you allow DELETE method, you should allow POST method.
why don't you allow to use POST method in the current draft ?

Shoichi

---

From: "Dijk, Esko" <[email-masked]>
Date: Wed, 15 Aug 2012 13:17:32 +0000

Hello Shoichi,

The reason indicated in the draft is that POST is non-idempotent. (DELETE is idempotent.)
However the reason why non-idempotent requests are not allowed, is not mentioned. It has to do with the fact that not all group members
are guaranteed to receive the multicast request; and the client (sender) can not readily find out which group members did get it and
which not.

Any discussion input is welcome here. I think that under certain conditions, use of POST in CoAP multicast can be allowed.
E.g. if it's ok that only a part of the group receive the request.

Esko

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Shoichi Sakane
Sent: Friday 3 August 2012 19:56
To: Rahman, Akbar; [email-masked]
Subject: Re: [core] FW: New Version Notification for draft-ietf-core-groupcomm-02.txt

Shoichi
_______________________________________________
core mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/core

________________________________
The information contained in this message may be confidential and legally protected under applicable law. The message is intended solely for the addressee(s). If you are not the intended recipient, you are hereby notified that any use, forwarding, dissemination, or reproduction of this message is strictly prohibited and may be unlawful. If you are not the intended recipient, please contact the sender by return e-mail and destroy all copies of the original message.