Subject: Re: [core] draft-shelby-core-resource-directory-04: unclear 'rt' parameter in Update

From: Zach Shelby <[email-masked]>
Date: Fri, 7 Sep 2012 12:38:32 +0300

Esko,

The rt= query string parameter in a Registration or Update sets the "Endpoint Type", which gives some meaning to an endpoint semantically in a backend system. That can be used e.g. to set the correct icon for an endpoint on a map. That has no effect on the Resource Type parameter of individual resources, which you are correct wouldn't make sense.

Probably using rt= for that query string parameter is confusing. Could be better to change that to et= or type= in the query string?

Thanks,
Zach

On Aug 30, 2012, at 1:28 PM, Dijk, Esko wrote:

> Hello Zach, all,
>  
> in section 5.3 (Update) the ‘rt’ parameter can be specified when doing a PUT update of registration to Resource Directory. To me it’s not clear what this parameter would do. The resource types of each resource that is updated, would be already included in the payload as “rt=.....” link-format parameters. I assume it should be removed from the allowed query parameters in section 5.3?
>  
> regards,
> Esko
> 
> The information contained in this message may be confidential and legally protected under applicable law. The message is intended solely for the addressee(s). If you are not the intended recipient, you are hereby notified that any use, forwarding, dissemination, or reproduction of this message is strictly prohibited and may be unlawful. If you are not the intended recipient, please contact the sender by return e-mail and destroy all copies of the original message.

-- 
Zach Shelby, Chief Nerd, Sensinode Ltd.
http://www.sensinode.com
http://zachshelby.org  - My blog "On the Internet of Things"
http://6lowpan.net - My book "6LoWPAN: The Wireless Embedded Internet"
Mobile: +358 40 7796297

---

From: peter van der Stok <[email-masked]>
Date: Mon, 10 Sep 2012 10:03:49 +0200

Zach,

In my opinion the same overloading of resource and end-type happens at 
several places in the document and the core -interfaces document.
The grouping concept adds to the confusion. Making the distinction up 
front in the document would be helpful.
You may consider resource-type, endpoint-type, and group-type. In 
core-interfaces you do a first attempt and talk about resource-type for 
resources and for Function-sets. Althoug you keep the same parameter 
name rt, you seem to distinguish in the name space
What to do with batches, which are heterogeneous, is another question.

It would be nice if this is solved homogeneously over all documents. 
May be it is, and I just combine the wrong pieces of text.

peter

Zach Shelby schreef op 2012-09-07 11:38:
> Esko,
>
> The rt= query string parameter in a Registration or Update sets the
> "Endpoint Type", which gives some meaning to an endpoint semantically
> in a backend system. That can be used e.g. to set the correct icon 
> for
> an endpoint on a map. That has no effect on the Resource Type
> parameter of individual resources, which you are correct wouldn't 
> make
> sense.
>
> Probably using rt= for that query string parameter is confusing.
> Could be better to change that to et= or type= in the query string?
>
> Thanks,
> Zach
>
>> in section 5.3 (Update) the ‘rt’ parameter can be specified when 
>> doing a PUT update of registration to Resource Directory. To me it’s 
>> not clear what this parameter would do. The resource types of each 
>> resource that is updated, would be already included in the payload as 
>> “rt=.....” link-format parameters. I assume it should be removed from 
>> the allowed query parameters in section 5.3?
>>
>> regards,
>> Esko
>>
>> The information contained in this message may be confidential and 
>> legally protected under applicable law. The message is intended solely 
>> for the addressee(s). If you are not the intended recipient, you are 
>> hereby notified that any use, forwarding, dissemination, or 
>> reproduction of this message is strictly prohibited and may be 
>> unlawful. If you are not the intended recipient, please contact the 
>> sender by return e-mail and destroy all copies of the original 
>> message.

---

From: Zach Shelby <[email-masked]>
Date: Mon, 10 Sep 2012 11:20:46 +0300

Hi Peter,

On Sep 10, 2012, at 11:03 AM, peter van der Stok wrote:

> Zach,
> 
> In my opinion the same overloading of resource and end-type happens at several places in the document and the core -interfaces document.
> The grouping concept adds to the confusion. Making the distinction up front in the document would be helpful.
> You may consider resource-type, endpoint-type, and group-type. In core-interfaces you do a first attempt and talk about resource-type for resources and for Function-sets. Althoug you keep the same parameter name rt, you seem to distinguish in the name space
> It would be nice if this is solved homogeneously over all documents. May be it is, and I just combine the wrong pieces of text.

I definitely agree some better uniformity and explanation would help. Matthieu and I can take a shot at that in the next update in both core-interfaces, and then in resource-directory as well. 

Group type, interesting idea we haven't been using yet. Not sure if we have a real need for it or not, but let's keep it in mind when we see a need. It might be that the group name is already a good enough descriptor. 

Zach

>> in a backend system. That can be used e.g. to set the correct icon for
>> parameter of individual resources, which you are correct wouldn't make
>> sense.
>> 
> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core