Subject: [core] Scalability of multicast use for discovery (ticket #247)

From: "Dijk, Esko" <[email-masked]>
Date: Thu, 18 Oct 2012 06:07:56 +0000

Dear all,

to explore possible solutions to ticket #247 (http://trac.tools.ietf.org/wg/core/trac/ticket/247) in the WG here are some initial ideas.

To enable safe use of multicast for CoAP discovery; we could include in core-coap stricter requirements on multicast responding e.g.:

- for site-local scope or any smaller scope, a discovery multicast request (/.well-known/core) by an unauthenticated client MAY be responded to by a server

- for organization-local and global scope, a discovery multicast request by an unauthenticated client SHOULD NOT be responsed to

- for global scope, a discovery multicast request SHOULD NOT be responded to. Exception case is a server known to be deployed in an isolated network i.e. multicast not propagating onto the internet or to multicast backbones. In that case the server MUST be explicitly configured to do so.

This would allow local multicast discovery (of servers previously unknown to the client) use cases without the side effects that the IANA appointed expert mentions.

regards,
Esko

Esko Dijk

Philips Group Innovation, Research
High Tech Campus 34, Eindhoven, The Netherlands
[email-masked]

________________________________
The information contained in this message may be confidential and legally protected under applicable law. The message is intended solely for the addressee(s). If you are not the intended recipient, you are hereby notified that any use, forwarding, dissemination, or reproduction of this message is strictly prohibited and may be unlawful. If you are not the intended recipient, please contact the sender by return e-mail and destroy all copies of the original message.

---

From: Zach Shelby <[email-masked]>
Date: Thu, 18 Oct 2012 10:04:46 +0300

Esko,

> - for global scope, a discovery multicast request SHOULD NOT be responded to. Exception case is a server known to be deployed in an isolated network i.e. multicast not propagating onto the internet…

This is not just about discovery, but for responding to any multicast CoAP request. 

I start to be doubtful about the actual utility of the CoAP multicast address with global scope (the risks are much greater than the benefit). To be safer, and deal with the IANA comments completely, we could just limit the default CoAP multicast address to local and site-local scope only. For specialized applications where global scope could be useful, it would be better for that application to use a dedicated multicast address for that purpose. 

Zach

> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core

-- 
Zach Shelby, Chief Nerd, Sensinode Ltd.
http://www.sensinode.com
http://zachshelby.org  - My blog "On the Internet of Things"
http://6lowpan.net - My book "6LoWPAN: The Wireless Embedded Internet"
Mobile: +358 40 7796297

---

From: "Dijk, Esko" <[email-masked]>
Date: Thu, 18 Oct 2012 07:27:00 +0000

I agree, since the CoRE discovery use cases seem to be all for link-local or site-local scope multicast.

For the IPv4 address assignment, there's no site-local IPv4 but looking at the IANA registry (http://www.iana.org/assignments/multicast-addresses/multicast-addresses.xml#multicast-addresses-3 ) it looks somewhat like the ad-hoc block I (224.0.2.0 - 224.0.255.255) has taken on this function? Since there are some recent additions of single addresses in there.
Alternatively we only register link-local for IPv4.

Esko

-----Original Message-----
From: Zach Shelby [mailto:[email-masked]] 
Sent: Thursday 18 October 2012 9:05
To: Dijk, Esko
Cc: [email-masked]
Subject: Re: [core] Scalability of multicast use for discovery (ticket #247)

Esko,

Zach