Subject: [core] Maximum number of nodes served by a single access point

From: Mazhelis Oleksiy <[email-masked]>
Date: Tue, 9 Oct 2012 07:09:37 +0000

Dear all,

As a part of CoAP cost-efficiency analysis, we need to estimate the maximum number of nodes served by a single access point (AP) in a simple network consisting of 802.15.4 constrained nodes connected directly to the AP and communicating either via CoAP or HTTP. Could you, please, direct to the studies on this, or give some estimates based on your first-hand experience?

In general, is the maximum largely determined by:
- the application protocol (HTTP vs CoAP)
- the transport (UDP as opposite to TCP) - related to the above
- the radio used
- the frequency and pattern of communication (e.g., pull vs. push)
Or something else?

Thank you in advance!
Regards,
Oleksiy Mazhelis
--
Post-doctoral researcher
Department of Comp.Sci & IS
Agora, P.O.Box 35, FI-40014
Univ. of Jyväskylä, Finland
Office: +358 40 805 4293
Mobile: +358 40 515 0641
Fax:    +358 14 260 2544
Email:   [email-masked]<mailto:[email-masked]>

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 9 Oct 2012 09:42:25 +0200

Hi Oleksiy,

> maximum number of nodes served by a single access point (AP) in a simple network consisting of 802.15.4 constrained nodes connected directly to the AP

A star network is certainly one way to configure a 802.15.4 network, but maybe not the one you would come up with under cost efficiency considerations.

> - the transport (UDP as opposite to TCP) - related to the above

These choices are essentially translating the offered load at the application layer to one at the network layer.
How much of a difference these choices make depends a lot on the application, which you haven't told us anything about.
Depending on the application, the choices may be pretty much inconsequential (e.g., for a web cam), or may cause a load difference that is an order of magnitude.
Whether that load difference translates into a performance difference is another question.
(If the resulting load is much smaller than your capacity, and you have enough energy, there is no influence at all on the maximum number of devices.)

> - the radio used

You said 802.15.4, but of course there are different variants and different quality implementations of each of these.
Another important input is what the radio propagation properties of the environment are going to be (including interference).
(E.g., the maximum number may be entirely limited by the density you need times the area that can be covered.)

> - the frequency and pattern of communication (e.g., pull vs. push)

That is indeed the input you need to be able to assess the differences in the choices above.
(Your application will also tell you how close you can drive the network to its limits.
And don't work with averages, work with the peaks that still need to work.)
If you want to derive a useful answer, you probably have to be very specific about the scenario you are looking at and make a number of reasonable assumptions.

> Or something else?

How about the cost of the devices themselves?

Grüße, Carsten