Subject: [core] Tr : New Version Notification for draft-vial-core-mirror-server-01.txt

From: [email-masked]
Date: Wed, 10 Apr 2013 10:51:15 +0200

Dear working group,

I have posted a minor change to mirror server draft thanks to Esko and
Carsten.

Best regards,
Matthieu

----- Transféré par Matthieu Vial/FR/Non/Schneider le 10/04/2013 10:45
-----

De :	[email-masked]
A :	Matthieu Vial/FR/Non/Schneider@Europe,
Date :	10/04/2013 10:18
Objet :	New Version Notification for
            draft-vial-core-mirror-server-01.txt

A new version of I-D, draft-vial-core-mirror-server-01.txt
has been successfully submitted by Matthieu Vial and posted to the
IETF repository.

Filename:		  draft-vial-core-mirror-server
Revision:		  01
Title:		 		  CoRE Mirror Server
Creation date:		  2013-04-10
Group:		 		  Individual Submission
Number of pages: 20
URL:
http://www.ietf.org/internet-drafts/draft-vial-core-mirror-server-01.txt
Status:
http://datatracker.ietf.org/doc/draft-vial-core-mirror-server
Htmlized:
http://tools.ietf.org/html/draft-vial-core-mirror-server-01
Diff:
http://www.ietf.org/rfcdiff?url2=draft-vial-core-mirror-server-01

Abstract:
   The Constrained RESTful Environments (CoRE) working group aims at
   realizing the REpresentational State Transfer (REST) architecture in
   a suitable form for the most constrained nodes.  Thanks to the
   Constrained Application Protocol (CoAP), REST is now applicable to
   constrained networks.  However the most energy-constrained devices
   may enter sleep mode and disconnect their network link during several
   minutes to save energy, hence preventing them from acting as
   traditional web servers.  This document describes how a sleeping
   device can store resource representations in an entity called Mirror
   Server and participate in a constrained RESTful environment.

The IETF Secretariat

______________________________________________________________________
This email has been scanned by the Symantec Email Security.cloud service.
______________________________________________________________________

---

From: "Dijk, Esko" <[email-masked]>
Date: Thu, 11 Apr 2013 12:17:51 +0000

Thanks Matthieu,

I wondered about the phrasing:
"it is a list of web links to resources that have been modified by
       clients since either the last PUT request or the last call to the
       modification check interface.  "

That sounds ambiguous, as if the Mirror Server (MS) implementation could *choose* one out of two point in time as the last-modified-time.

Maybe something like this is more accurate?
"it is a list that contains web links to all resources that have been modified by
       clients since either 1) the last PUT request from the SEP was received by the Mirror Server, or 2) the last call to the
       modification check interface made by the SEP was received by the Mirror Server, whichever one was most recent. "

Esko

PS glad to see that my earlier comments have been promoted from 'fruitful' to 'useful' ;)

From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, April 10, 2013 10:51
To: [email-masked]
Subject: [core] Tr : New Version Notification for draft-vial-core-mirror-server-01.txt

Dear working group,

I have posted a minor change to mirror server draft thanks to Esko and Carsten.

Best regards,
Matthieu

----- Transféré par Matthieu Vial/FR/Non/Schneider le 10/04/2013 10:45 -----

De : [email-masked]<mailto:[email-masked]>
A : Matthieu Vial/FR/Non/Schneider@Europe,
Date : 10/04/2013 10:18
Objet : New Version Notification for draft-vial-core-mirror-server-01.txt

________________________________

Filename:  draft-vial-core-mirror-server
Revision:  01
Title:  CoRE Mirror Server
Creation date:  2013-04-10
Group:  Individual Submission
Number of pages: 20
URL:             http://www.ietf.org/internet-drafts/draft-vial-core-mirror-server-01.txt
Status:          http://datatracker.ietf.org/doc/draft-vial-core-mirror-server
Htmlized:        http://tools.ietf.org/html/draft-vial-core-mirror-server-01
Diff:            http://www.ietf.org/rfcdiff?url2=draft-vial-core-mirror-server-01

Abstract:

The IETF Secretariat

________________________________
The information contained in this message may be confidential and legally protected under applicable law. The message is intended solely for the addressee(s). If you are not the intended recipient, you are hereby notified that any use, forwarding, dissemination, or reproduction of this message is strictly prohibited and may be unlawful. If you are not the intended recipient, please contact the sender by return e-mail and destroy all copies of the original message.

---

From: [email-masked]
Date: Thu, 11 Apr 2013 16:55:20 +0200

Thanks Esko for your comment,

> That sounds ambiguous, as if the Mirror Server (MS) implementation could
*choose* one out of two point in time as the last-modified-time.

Agreed

What do you think of:
Instead, it is a list of web links to all resources that have been modified
by clients since the last check be it with the Modification check interface
or the SEP operation interface.

Matthieu