Subject: [core] #293: Add description of DoS attack on congestion control

From: "core issue tracker" <[email-masked]>
Date: Sun, 07 Apr 2013 12:30:55 -0000

#293: Add description of DoS attack on congestion control

 Michael Scharf (tsv-dir reviewer) notes (msg04191-tsvdir-5):

 Section 11

 (b) A subtle attack with spoofed addresses could possibly exploit the lack
 of congestion control in CoAP. Due to NSTART=1, a tricky attacker could
 prevent a server to communicate with a legitime client, because only one
 transaction is allowed to one destination address. The attacker could try
 to always occupy this "slot".

-- 
-------------------------+-------------------------------------------------
 Reporter:               |      Owner:  [email-masked]
  [email-masked]           |     Status:  new
     Type:  other        |  Milestone:  post-IESG-1
  technical              |    Version:  coap-14
 Priority:  minor        |   Keywords:
Component:  coap         |
 Severity:  Submitted    |
  WG Document            |
-------------------------+-------------------------------------------------

Ticket URL: <http://trac.tools.ietf.org/wg/core/trac/ticket/293>
core <http://tools.ietf.org/core/>

---

From: "core issue tracker" <[email-masked]>
Date: Fri, 12 Apr 2013 19:24:59 -0000

Changes (by [email-masked]):

 * status:  new => closed
 * resolution:   => fixed

Comment:

 Fixed in [1289]:

 Add a paragraph about resource depletion attacks, fix #292 and fix #293

-- 
-------------------------+-------------------------------------------------
 Reporter:               |       Owner:  draft-ietf-core-
  [email-masked]           |  [email-masked]
     Type:  other        |      Status:  closed
  technical              |   Milestone:  post-IESG-1
 Priority:  minor        |     Version:  coap-14
Component:  coap         |  Resolution:  fixed
 Severity:  Submitted    |
  WG Document            |
 Keywords:               |
-------------------------+-------------------------------------------------

Ticket URL: </ticket/293#comment:1>
core <http://tools.ietf.org/core/>