Subject: [core] Small discrepancy about 2.02 Delete

From: "Kovatsch Matthias" <[email-masked]>
Date: Tue, 16 Apr 2013 15:36:23 +0000

Hi

There is a small discrepancy in the definition of 2.02 Deleted:

In 5.8.2. POST it says:
"If the POST succeeds and results in the target resource being deleted, the response SHOULD have a 2.02 (Deleted) response code."

However, in 5.9.1.2. 2.02 Deleted it says:
"Like HTTP 204 "No Content", but only used in response to DELETE requests."

Should this be fixed to "in response to POST and DELETE requests"?

Ciao
Matthias

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 17 Apr 2013 17:52:48 +0200

> "Like HTTP 204 "No Content", but only used in response to DELETE requests."

Obvious bug.  Clearly, 5.9.1.2 needs to be fixed, because the language in 5.8.2 is there intentionally (#105, listed in the changes from -04 to -05).

> Should this be fixed to "in response to POST and DELETE requests"?

That would be the simplest fix.

Maybe more future proof: "in response to requests that cause the resource to cease being available, such as DELETE and in certain circumstances POST".

Since we are in IESG processing now, I'll do this by the book and open a ticket.

Grüße, Carsten