Subject: Re: [core] Handling tokens for No-response

From: "weigengyu" <[email-masked]>
Date: Wed, 23 Apr 2014 21:46:04 +0800

>> As the sematics of Zero length token is defined in CoAP -18,
>Zero length tokens do not have any special semantics as defined in the CoAP 
>specification.

CoAP -18 defines the Zero length token the same as other tokens,
so Zero length token has sematics already.
No words say "any special semantics".

One alternative of No-Response trys to give Zero length token one "special 
semantics".
By current CoAP -18, using Zero length token as No-response option will not 
get effect.

Regards,

Gengyu
Network Techonology Center
School of Computer
Beijing University of Posts and Telecommunications.

-----原始邮件----- 
From: weigengyu
Sent: Wednesday, April 23, 2014 9:19 PM
To: Carsten Bormann
Cc: Dijk, Esko ; Likepeng ; Abhijan Bhattacharyya ; [email-masked]
Subject: Re: [core] Handling tokens for No-response

Hi,

I think the following sentence need being clarified:

In CoAP -18 page 34,
"The client SHOULD generate tokens in such a way that tokens currently
in use for a given source/destination endpoint pair are unique.
(Note that a client implementation can use the same token for any
request if it uses a different endpoint each time, e.g. a different
source port number.) An empty token value is appropriate e.g. when
no other tokens are in use to a destination, or when requests are
made serially per destination and receive piggy-backed responses.
There are however multiple possible implementation strategies to
fulfill this. "

By this, zero length token is a token, it can be used the same way as other
tokens.
If the request is with zero token, the response should adopt the zero token
too.

Angthing wrong?

Regards,

Network Technology Center
School of Computer
Beijing University of Posts and Telecommunications.

-----原始邮件----- 
From: Carsten Bormann
Sent: Wednesday, April 23, 2014 4:22 PM
To: weigengyu
Cc: Dijk, Esko ; Likepeng ; Abhijan Bhattacharyya ; [email-masked]
Subject: Re: [core] Handling tokens for No-response

A number of clarifications about “empty tokens":

> If the token length is ZERO, then there is no token. So the token is 
> empty.

If the token length is zero, there still is a token, it is just of length
zero.
There is nothing special about this token value; I have no idea why this is
discussed as if it were.

> If the token length is one, for example, the value of the token could be 
> from 0 to 255.

The token is an opaque byte string (for a one-byte token, the value of the
first and only byte would indeed be between 0 and 255).

>  In this case, when the value of token is 0, the token is not empty.

Indeed, what you mean seems to be just another token value, a byte string of
length 1 with a zero byte.

> As the sematics of Zero length token is defined in CoAP -18,

Zero length tokens do not have any special semantics as defined in the CoAP
specification.

> when No-Response is identified by Zeron length token, it can not get an 
> effect.

Non sequitur.

The discussion of how to choose token values, including when a previously
used token can be used again, is quite relevant for a client implementation
(and I would expect the LWIG document to gain some substance here in the
next revision), but there is nothing special about the zero-length token
value in this discussion.

Grüße, Carsten

---

From: Abhijan Bhattacharyya <[email-masked]>
Date: Thu, 24 Apr 2014 00:56:55 +0530

Hi Gengyu,
>One alternative of No-Response trys to give Zero length token one

Your comment is not really clear to me. I am not sure if I understand what you mean by 'one alternative of No-response'.  
The present draft on No-response does not mention anything about token and that is why we are carrying out this discussion to bridge the gap. Use of zero length token came up as part of the discussion. However, the confusions have already been cleared by Carsten and Esko. No-response is not at all trying to give any special semantics to anything. 

Regards
Abhijan Bhattacharyya
Associate Consultant
Scientist, Innovation Lab, Kolkata, India
Tata Consultancy Services Limited
Mailto: [email-masked]
Website: http://www.tcs.com
____________________________________________
Experience certainty.	IT Services
Business Solutions
Consulting
____________________________________________

-----"weigengyu" <[email-masked]> wrote: -----

>To: "Carsten Bormann" <[email-masked]>
>From: "weigengyu" <[email-masked]>
>Date: 04/23/2014 07:16PM
>Cc: "Dijk, Esko" <[email-masked]>, "Likepeng"
><[email-masked]>, "Abhijan Bhattacharyya"
><[email-masked]>, <[email-masked]>
>-----&#21407;&#22987;&#37038;&#20214;----- 
>From: weigengyu
>-----&#21407;&#22987;&#37038;&#20214;----- 
>From: Carsten Bormann
>A number of clarifications about &#8220;empty tokens":
>
=====-----=====-----=====
Notice: The information contained in this e-mail
message and/or attachments to it may contain 
confidential or privileged information. If you are 
not the intended recipient, any dissemination, use, 
review, distribution, printing or copying of the 
information contained in this e-mail message 
and/or attachments to it are strictly prohibited. If 
you have received this communication in error, 
please notify us by reply e-mail or telephone and 
immediately and permanently delete the message 
and any attachments. Thank you

---

From: "weigengyu" <[email-masked]>
Date: Thu, 24 Apr 2014 09:46:39 +0800

Hi Abhijan，

I know your draft proposed No-Respose, and did not say anything about Zero Length Token. 
My comments are about the following email in which Zero length token may be adviced for No-response. 

{
From: Rahman, Akbar 
Sent: Thursday, April 17, 2014 2:57 AM
To: Dijk, Esko 
Cc: Abhijan Bhattacharyya ; [email-masked] 
Subject: Re: [core] Handling tokens for No-response

Hi Esko,

> 1. When sending a unicast CON request and no response is given or the client asks for No-Response, I would think that the Token can be re-used after EXCHANGE_LIFETIME. Is that right?

Yes, that would be my interpretation as well.

> Suppose we would advise to use a zero-length (default) Token for such requests – wouldn’t there be the same problem of Token re-use? I.e. I can only re-use the 0 Token after EXCHANGE_LIFETIME time has passed.

Yes, good point!

/Akbar

}

Regards, 

From: Abhijan Bhattacharyya 
Sent: Thursday, April 24, 2014 3:26 AM
To: weigengyu 
Cc: Carsten Bormann ; [email-masked] ; Dijk, Esko ; Likepeng 
Subject: Re: Re: [core] Handling tokens for No-response

Hi Gengyu,

Regards
Abhijan Bhattacharyya
Associate Consultant

>source port number) An empty token value is appropriate e.g. when
>zero

---

From: "weigengyu" <[email-masked]>
Date: Thu, 24 Apr 2014 09:49:10 +0800

Hi Abhijan，

{
From: Rahman, Akbar 

Hi Esko,

Yes, good point!

/Akbar

}

Regards, 

Gengyu 

Network Technology Center
School of Computer
Beijing Univerisity of Posts and Telecommunications. 

Hi Gengyu,

Regards
Abhijan Bhattacharyya
Associate Consultant

--------------------------------------------------------------------------------
_______________________________________________
core mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/core