Subject: [core] CoAP implementation for TCP?

From: Abhijan Bhattacharyya <[email-masked]>
Date: Thu, 21 Jan 2016 16:35:59 +0530

Dear List,
Is there any available CoAP implementation that supports CoAP over TCP as 
suggested in "draft-ietf-core-coap-tcp-tls-01"? 

Regards
Abhijan Bhattacharyya
Associate Consultant
Scientist, Innovation Lab, Kolkata, India
Tata Consultancy Services
Mailto: [email-masked]
Website: http://www.tcs.com
____________________________________________
Experience certainty.   IT Services
                        Business Solutions
                        Consulting
____________________________________________
=====-----=====-----=====
Notice: The information contained in this e-mail
message and/or attachments to it may contain 
confidential or privileged information. If you are 
not the intended recipient, any dissemination, use, 
review, distribution, printing or copying of the 
information contained in this e-mail message 
and/or attachments to it are strictly prohibited. If 
you have received this communication in error, 
please notify us by reply e-mail or telephone and 
immediately and permanently delete the message 
and any attachments. Thank you

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 21 Jan 2016 13:08:50 +0100

Last time I looked at the libcoap variant employed by IoTivity, their
CoAP over TCP implementation was based on the L3 proposal -- the CoRE WG
chose L1 instead.
But changing that detail that is probably just a very small matter of
coding (and might have been done already, you may want to check).

Grüße, Carsten

Abhijan Bhattacharyya wrote:
> Dear List,
> Is there any available CoAP implementation that supports CoAP over TCP
> as suggested in "draft-ietf-core-coap-tcp-tls-01"?
> 
> Regards
> Abhijan Bhattacharyya
> Associate Consultant
> Website: http://www.tcs.com <http://www.tcs.com/>
> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core

---

From: Michael Koster <[email-masked]>
Date: Thu, 21 Jan 2016 07:36:35 -0800

Hi Crsten,

I am participating in the OIC core and smarthome task groups now. 

I have noted the WG choice of L1 to the OIC core tg mailing list and could follow up in Bangkok next week.

Michael

> On Jan 21, 2016, at 4:08 AM, Carsten Bormann <[email-masked]> wrote:
> 
>> Mailto: [email-masked] <mailto:[email-masked]>
>> Website: http://www.tcs.com <http://www.tcs.com/> <http://www.tcs.com/ <http://www.tcs.com/>>
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/core <https://www.ietf.org/mailman/listinfo/core>