Subject: [core] 🔔 WG adoption of draft-vanderstok-core-etch-00

From: Jaime Jiménez <[email-masked]>
Date: Thu, 28 Apr 2016 14:05:10 +0000

Hi all,

going through the item list, in Buenos Aires we discussed the adoption of draft-vanderstok-core-etch-00 as WG item. Back then there was room consensus with 12 people in favor (+ 4 more on the jabber) and noone against. 

This work is needed in order to keep using PATCH link updates on the RD and also for the COMI work that has already been adopted as of this week. 

This is a one-week call for confirmation on that decision, so if there are objections please voice them on the mailing list by 2016-05-06.

Ciao,
- - Jaime Jimenez

---

From: Alexander Pelov <[email-masked]>
Date: Thu, 28 Apr 2016 16:52:10 +0200

Dear all,

I am in favor for adopting the document as a WG item.

Both FETCH and PATCH are adding missing functionality to the set of standard CoAP verbs. They provide semantics which are already present in standard HTTP, or that will be standardized soon.

For non-constrained networks and/or devices their lack may be a matter of personal feelings or slight inconveniences. For constrained networks or constrained devices, their addition provides powerful methods to significantly limit the data sent on the air + simplify the APIs. The functionality provided by FETCH and PATCH could be to some extent emulated with POSTs, but many of the benefits we have from RESTful applications are lost. 

Through the design of the function set of the latest COMI/COOL proposal, we’ve passed through several iterations and we’ve investigated FETCH+PATCH approach VS no-FETCH and no-PATCH solution. The latter required introducing new CoAP option and was generally more complex. Some things were simply impossible without the use of POST.

My personal take on this is: we need FETCH and PATCH. The work on the document advances very well and there are several key people actively contributing to it. 

+1

Best,
Alexander

> Le 28 avr. 2016 à 16:05, Jaime Jiménez <[email-masked]> a écrit :
> 
> Hi all,
> 
> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core

---

From: Michel Veillette <[email-masked]>
Date: Thu, 28 Apr 2016 15:53:15 +0000

+1

Useful methods to access resource subset.
Use in CoMI/CoOL to implement an atomic update and a partial retrieval of a datastore.

Regards,
Michel

-----Original Message-----
From: core [mailto:[email-masked]] On Behalf Of Alexander Pelov
Sent: April-28-16 10:52 AM
To: Jaime Jiménez <[email-masked]>
Cc: [email-masked]
Subject: Re: [core] 🔔 WG adoption of draft-vanderstok-core-etch-00

Dear all,

+1

Best,
Alexander

---

From: Somaraju Abhinav <[email-masked]>
Date: Thu, 28 Apr 2016 18:11:36 +0000

+1 for the same reasons Michel has.

Sent from my Windows Phone
________________________________
From: Alexander Pelov<mailto:[email-masked]>
Sent: ‎28/‎04/‎2016 16:51
To: Jaime Jiménez<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [core] 🔔 WG adoption of draft-vanderstok-core-etch-00

Dear all,

+1

Best,
Alexander

_______________________________________________
core mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/core
________________________________________________________ The contents of this e-mail and any attachments are confidential to the intended recipient. They may not be disclosed to or used by or copied in any way by anyone other than the intended recipient. If this e-mail is received in error, please immediately notify the sender and delete the e-mail and attached documents. Please note that neither the sender nor the sender's company accept any responsibility for viruses and it is your responsibility to scan or otherwise check this e-mail and any attachments.