Subject: [core] #406 (resource-directory): Consider URI ranking, Privacy Model, etc. as part of RD

From: "core issue tracker" <[email-masked]>
Date: Thu, 28 Apr 2016 01:56:17 -0000

#406: Consider URI ranking, Privacy Model, etc. as part of RD

 In IETF-95, there was a discussion regarding various enhancements to the
 RD that should be considered as outlined in

 https://tools.ietf.org/html/draft-rahman-core-advanced-rd-features-02

 Examples of the enhancements included ranking of URI results from the RD
 lookup interface, and a clear privacy model for the RD lookup interface.

 The conclusion of the discussion in IETF-95 was summarized by Carsten as
 follows:

   "For the resource directory (RD) and related documents, we are aiming
   at WGLC before July 1st so we can discuss the outcome in Berlin and
   ship soon after.  There are quite a few things to do, many of which
   are on the editorial level (see slides, but also Akbar's "advanced
   RD" document; we will not try to put mirror server/pubsub support in
   the RD document now, though). The issues will managed on the WG
   tracker."

 https://www.ietf.org/mail-archive/web/core/current/msg07032.html

-- 
-------------------------------------+-------------------------------------
 Reporter:                           |      Owner:  draft-ietf-core-
  [email-masked]      |  [email-masked]
     Type:  protocol enhancement     |     Status:  new
 Priority:  major                    |  Milestone:
Component:  resource-directory       |    Version:
 Severity:  -                        |   Keywords:
-------------------------------------+-------------------------------------

Ticket URL: <https://tools.ietf.org/wg/core/trac/ticket/406>
core <https://tools.ietf.org/core/>

---

From: "Rahman, Akbar" <[email-masked]>
Date: Thu, 28 Apr 2016 02:03:48 +0000

Hi Mike,

I had an outstanding action from IETF-95 to create this ticket so we could have further discussion on which of the features out of draft-rahman-core-advanced-rd-features that we need for the first release of the RD:

Any feedback would be appreciated.

/Akbar

-----Original Message-----
From: core issue tracker [mailto:[email-masked]]
Sent: Wednesday, April 27, 2016 9:56 PM
To: [email-masked]; Rahman, Akbar <[email-masked]>
Cc: [email-masked]
Subject: [core] #406 (resource-directory): Consider URI ranking, Privacy Model, etc. as part of RD

In IETF-95, there was a discussion regarding various enhancements to the  RD that should be considered as outlined in

Examples of the enhancements included ranking of URI results from the RD  lookup interface, and a clear privacy model for the RD lookup interface.

--
-------------------------------------+----------------------------------
-------------------------------------+---
Reporter:                           |      Owner:  draft-ietf-core-
 [email-masked]      |  [email-masked]
    Type:  protocol enhancement     |     Status:  new
Priority:  major                    |  Milestone:
Component:  resource-directory       |    Version:
Severity:  -                        |   Keywords:
-------------------------------------+----------------------------------
-------------------------------------+---