Subject: [core] additional approach to RD discovery

From: peter van der Stok <[email-masked]>
Date: Wed, 29 Jun 2016 09:57:36 +0200

Hi all,

While discussing the RD discovery with some other people an addition to 
RD discovery was suggested.

It was pointed out that in many situations, there will be a border 
router between the discovering nodes and the Resource Directory.
Therefore:
Discovering the the RD via a link-local broadcast, or site-local does 
not apply.
Using the RDNSS Neighbour Discovery (ND) option does not apply during 
start-up, when the discovery is needed.
Using ABRO option is too limited.

It is therefore suggested that a new ND option is defined that includes 
the distribution of the RD address (name).
I should like to specify that new option in the RD version to be 
published shortly.

Greetings,

Peter

-- 
Peter van der Stok
mailto: [email-masked]

---

From: "Dijk, Esko" <[email-masked]>
Date: Wed, 29 Jun 2016 14:39:50 +0000

Hi Peter,

although site-local CoAP discovery should in theory find you the RD (even if it is e.g. beyond a Border Router, so not on the same mesh) ; in practice the scope of IPv6 multicast may be limited in various ways. E.g. a Border Router could block larger-than-Realm-Local multicasts, or the IPv6 stack on a constrained node may be limited for security reasons to send at most Realm-Local scoped multicasts. For these reasons I think an ND Option to find the RD address or name is very useful.
So +1

regards
Esko

-----Original Message-----
From: core [mailto:[email-masked]] On Behalf Of peter van der Stok
Sent: Wednesday, June 29, 2016 9:58
To: Core <[email-masked]>
Subject: [core] additional approach to RD discovery

Hi all,

While discussing the RD discovery with some other people an addition to RD discovery was suggested.

It was pointed out that in many situations, there will be a border router between the discovering nodes and the Resource Directory.
Therefore:
Discovering the the RD via a link-local broadcast, or site-local does not apply.
Using the RDNSS Neighbour Discovery (ND) option does not apply during start-up, when the discovery is needed.
Using ABRO option is too limited.

It is therefore suggested that a new ND option is defined that includes the distribution of the RD address (name).
I should like to specify that new option in the RD version to be published shortly.

Greetings,

Peter

_______________________________________________
core mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/core

________________________________
The information contained in this message may be confidential and legally protected under applicable law. The message is intended solely for the addressee(s). If you are not the intended recipient, you are hereby notified that any use, forwarding, dissemination, or reproduction of this message is strictly prohibited and may be unlawful. If you are not the intended recipient, please contact the sender by return e-mail and destroy all copies of the original message.