Subject: [core] LWM2M spec now available for public download ... was Re: Using Yang to describe LWM2M

From: Hannes Tschofenig <[email-masked]>
Date: Wed, 22 Jun 2016 13:46:11 +0200

I just wanted to follow-up on this discussion in April.

A few of us have worked with OMA to change the access to the LWM2M
specification and it can now be downloaded without having to enter any
personal data or to accept some legal terms prior to the download:

Here is the link:
http://technical.openmobilealliance.org/Technical/Release_Program/docs/LightweightM2M/V1_0-20160407-C/OMA-TS-LightweightM2M-V1_0-20160407-C.pdf

I hope that this will make it easier for others to review the work.

Ciao
Hannes

On 04/27/2016 09:07 AM, Juergen Schoenwaelder wrote:
> On Mon, Apr 25, 2016 at 01:03:34PM +0200, Hannes Tschofenig wrote:
>> Hi Juergen,
>>
>> On 04/25/2016 12:33 PM, Juergen Schoenwaelder wrote:
>>> Hannes,
>>>
>>> whether this YANG fragment makes sense or not I simply do not know
>>> without knowing LWM2M and since there are no open specs there is
>>> little help you can expect. I have no clue about the interaction model
>>> of OMA LWM2M nor do I know what LWM2M_Device is etc.
>>
>> The specs are publically available for download at no cost.
>>
>> Here is the link:
>> http://technical.openmobilealliance.org/Technical/technical-information/release-program/current-releases/oma-lightweightm2m-v1-0
>>
>> You want to look at the 'Technical Specification'.
> 
> They are not open, I have to accept certain legal terms to get
> access. In particular:
> 
>   use all or any part of a Document as part of a specification or
>   standard not emanating from the Licensor without the prior written
>   consent of the Licensor
> 
> I might already need a written consent if I post an example here since
> everything posted to an IETF list may be considered a contribution.
>  
>> The registry for the objects are also public and available in a nicely
>> written page (similar to what IANA provides for the IETF):
>> http://technical.openmobilealliance.org/Technical/technical-information/omna/lightweight-m2m-lwm2m-object-registry
>>
> 
> Looking at examples to infer what the semantics of the schema are is
> not what I am going to spend my time on.
> 
>> There is no permission that needs to be obtained IMHO, if I understand
>> the OMA copyright policy correctly.
> 
> See above.
> 
> /js
>

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 22 Jun 2016 13:56:44 +0200

On 22 June 2016 at 13:46:26, Hannes Tschofenig ([email-masked]) wrote:
I hope that this will make it easier for others to review the work. 
This is great news — getting those little obstacles out of the way can make a big difference in the impact a specification has.

Looking forward to further expanding the cooperation between IETF and OMA.

Grüße, Carsten