Subject: [core] CoRE agenda @ietf96

From: Carsten Bormann <[email-masked]>
Date: Wed, 06 Jul 2016 13:55:41 +0200

Jaime and I have started preparing a draft agenda for the CoRE meetings
in Berlin.

https://github.com/core-wg/ietf96/wiki

(Please ignore for now the weird formatting issues github creates...)

Those of you who put in a slot request:
Please check that it is covered by this draft agenda.

We haven't written down the slot leaders ("presenters") everywhere, so
if you think you will be holding the microphone, please let Jaime and me
know ([email-masked]).

Please also check the objectives: Is this a reasonable summary of what
we are trying to achieve?

Anything else we are missing?

Grüße, Carsten

---

From: Pascal Urien <[email-masked]>
Date: Wed, 6 Jul 2016 19:16:12 +0200

Dear Chair

According to https://github.com/core-wg/ietf96/wiki the document
"draft-urien-core-identity-module-coap-00" is "apparently out of scope"

The document "draft-urien-core-identity-module-coap-00" is a draft proposal
for the (optional) support of an identity module by the CoAP protocol.

According to rfc7252 "The work on Constrained RESTful Environments (CoRE)
aims at realizing the REST architecture in a suitable form for the most
constrained nodes (e.g., 8-bit microcontrollers with limited RAM and ROM)
and networks"

In the draft-urien-core-identity-module-coap-00 we suggest to use ISO7816
compatible devices, based on secure microcontrollers. One advantage of this
approach is to design an interface with well defined encoding rules

According to the rfc 7252 " Just as HTTP is secured using Transport Layer
Security (TLS) over TCP, CoAP is secured using Datagram TLS (DTLS)
[RFC6347] over UDP"

Although not mandatory (DTLS may be disabled), DTLS may use PreSharedKey,
RawPublicKey or Certificate.

So the rfc 7252, in a way or another, suggests that DTLS is used as
identity stack.

The draft draft-urien-core-identity-module-coap-00 proposes the definition
of an ISO7816 interface to DTLS/TLS stacks running in secure
microcontrollers.

If CoAP targets billion devices in M2M networks, then trust could be part
of the WG scope, at least as recommendation.

The WikiLeaks documents demonstrated that trust in networks can be an issue.

Rgs

2016-07-06 13:55 GMT+02:00 Carsten Bormann <[email-masked]>:

> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core
>

---

From: "William" <[email-masked]>
Date: Thu, 7 Jul 2016 11:24:02 +0900

I agree with Dr. Bormann that trust could be taken into consideration for scope the WG. 

It is quite important when we have a large and global M2M networks.

Looking forward to see our WG discussion on trust and identity module.

Many thanks,

William

PhD of Research

IoT based Smart Furniture for Smart Home <http://cuddlyhomeadvisors.com/smart-home-smart-furniture/iot-based-smart-furniture-for-your-smart-home/>  Research Group

From: core [mailto:[email-masked]] On Behalf Of Pascal Urien
Sent: Thursday, July 07, 2016 2:16 AM
To: Carsten Bormann
Cc: [email-masked]; [email-masked] WG
Subject: Re: [core] CoRE agenda @ietf96

Dear Chair

According to https://github.com/core-wg/ietf96/wiki the document "draft-urien-core-identity-module-coap-00" is "apparently out of scope"

The document "draft-urien-core-identity-module-coap-00" is a draft proposal for the (optional) support of an identity module by the CoAP protocol.

According to rfc7252 "The work on Constrained RESTful Environments (CoRE) aims at realizing the REST architecture in a suitable form for the most constrained nodes (e.g., 8-bit microcontrollers with limited RAM and ROM) and networks"

In the draft-urien-core-identity-module-coap-00 we suggest to use ISO7816 compatible devices, based on secure microcontrollers. One advantage of this approach is to design an interface with well defined encoding rules

According to the rfc 7252 " Just as HTTP is secured using Transport Layer Security (TLS) over TCP, CoAP is secured using Datagram TLS (DTLS) [RFC6347] over UDP"

Although not mandatory (DTLS may be disabled), DTLS may use PreSharedKey, RawPublicKey or Certificate. 

So the rfc 7252, in a way or another, suggests that DTLS is used as identity stack.

The draft draft-urien-core-identity-module-coap-00 proposes the definition of an ISO7816 interface to DTLS/TLS stacks running in secure microcontrollers.

If CoAP targets billion devices in M2M networks, then trust could be part of the WG scope, at least as recommendation. 

Rgs

2016-07-06 13:55 GMT+02:00 Carsten Bormann <[email-masked] <mailto:[email-masked]> >:

We haven't written down the slot leaders ("presenters") everywhere, so
if you think you will be holding the microphone, please let Jaime and me
know ([email-masked] <mailto:[email-masked]> ).

Grüße, Carsten

_______________________________________________
core mailing list
[email-masked] <mailto:[email-masked]> 
https://www.ietf.org/mailman/listinfo/core

---

From: Carsten Bormann <[email-masked]>
Date: Sat, 09 Jul 2016 09:54:48 +0200

The agenda draft is now updated with what was actually submitted and at
the official site:

https://www.ietf.org/proceedings/96/agenda/agenda-96-core

It is getting pretty compressed in the Thursday meeting.
Much of the discussion, in particular in the last half hour, is about
assessing documents with respect to readiness for last-call or WG
adoption -- maybe we can have some discussion of these on the mailing
list already so this compressed f2f form works in the time we have.

Again, slot leaders, please check your time allocation and objectives,
and send any updates to the list or to the chairs.

Now, everybody, please use the time up to the meeting to read the drafts
-- for your convenience, they are all properly linked from the agenda.

Grüße, Carsten