Subject: Re: [core] Resource directory evolution

From: Michael Koster <[email-masked]>
Date: Thu, 7 Jul 2016 14:16:17 -0700

Hi Carsten,

> On Jun 11, 2016, at 9:22 AM, Carsten Bormann <[email-masked]> wrote:
> 
> * We need to link the resources implicitly included in the current
>  function sets (can be done in .well-known/core)
> * We need to annotate how to formulate the requests to these resources
>  (can be done with rt= for now, backed by the textual descriptions we
>  have in the RD specification)
> * We need to allow for additional lookup interfaces (can be done
>  through additional rt= registrations, backed by the specifications
>  referenced)
> * The registration interface would not change much, just support
>  additional media types (containing collections of links, which
>  need to be made available in link-format style to those consumers
>  not familiar with the media type)

What we have now is similar to your description

--------------------
   Req: GET coap://[ff02::1]/.well-known/core?rt=core.rd*

   Res: 2.05 Content
   </rd>;rt="core.rd";ct=40; ct=21225
   </rd-lookup>;rt="core.rd-lookup";ct=40; ct=21225
   </rd-group>;rt="core.rd-group";ct=40; ct=21225
----------------------

We have links to function sets in .well-known/core that use rt= to identify the function sets using IANA registered resource types

We also have content-format hints in the links  (I added a second ct to illustrate)

I will add something requiring ct=40 as a mandatory format, and noting that any other format registered must have an equivalent link-format representation

Is there anything you can think of to add at this point?

Best regards,

Michael

---

From: Michael Koster <[email-masked]>
Date: Thu, 7 Jul 2016 14:20:44 -0700

I think the representation should look more like:

   Res: 2.05 Content
   </rd>;rt="core.rd";ct="40 60",
   </rd-lookup>;rt="core.rd-lookup";ct="40 50",
   </rd-group>;rt="core.rd-group";ct="40 50"

which is in the document. I'll change the second format to something different.

MIchael

> On Jul 7, 2016, at 2:16 PM, Michael Koster <[email-masked]> wrote:
> 
> Hi Carsten,
> 
>> On Jun 11, 2016, at 9:22 AM, Carsten Bormann <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>    Req: GET coap://[ff02::1]/.well-known/core?rt=core.rd* <coap://[ff02::1]/.well-known/core?rt=core.rd*>
> 
>    Res: 2.05 Content