Subject: [core] SenML values and extensions in SenML Records

From: Ari Keränen <[email-masked]>
Date: Wed, 20 Jul 2016 12:14:27 +0000

Hi,

We are considering small changes to SenML draft to clarify use of values in SenML Records and to facilitate value extensions.

Currently the draft says that there must be exactly one of the defined value labels {v, vb, vd, vs} in each SenML record unless there's a sum value. However, if in future we define a new value label, currently it would mean you could not have that alone in a Record.

Therefore, we are suggesting to relax that rule to say that exactly one value label (defined in the SenML document or in some future document) must be in each record. The proposed text change can be seen in pull request #22:
https://github.com/core-wg/senml-spec/pull/22/files

Is anyone against doing this change? Other comments welcome too.

Cheers,
Ari

---

From: Christian Amsüss <[email-masked]>
Date: Wed, 20 Jul 2016 14:42:17 +0200

> Is anyone against doing this change? Other comments welcome too.

I'm in favor of this change for your reasons but also due to a
suggestion I'm currently writing up -- but to make it short: To
accomodate streaming parsing, the current draft is much better than what
we had last year, but parsers still need to seek around a little because
a bn/bt can be after a n/t. If we made them mutually exclusive (either
bn or n, either bt or t), the 30-byte-state-parser (which includes
relative URI resolution) becomes doable again.

Best regards
Christian

-- 
Christian Amsüss                      | Energy Harvesting Solutions GmbH
founder, system architect             | headquarter:
mailto:[email-masked]  | Arbeitergasse 15, A-4400 Steyr
tel:+43-664-97-90-6-39                | http://www.energyharvesting.at/
                                      | ATU68476614

---

From: Christian Groves <[email-masked]>
Date: Thu, 21 Jul 2016 05:53:45 +1000

Hello Ari,

I support the change.

Regards, Christian

On 20/07/2016 10:14 PM, Ari Keränen wrote:
> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core
>

---

From: Lennart Dührsen <[email-masked]>
Date: Wed, 20 Jul 2016 22:13:07 +0200

Hi,

> I support the change.

so do I.

Cheers,
Lennart

---

From: Michael Koster <[email-masked]>
Date: Wed, 20 Jul 2016 22:54:40 +0200

So to be clear, does this mean that a base value or a regular value is still required in every record?

Meaning I can't have a simple collection representation like this?

[
  {
    "bn": "/collection/"
  },
  {
    "n": "resource1",
    "vs": "foo",
  },
  {
    "n": "resource2",
    "vs" "bar",
  },
  {
    "n": "resource3",
    "vs": "baz"
  }
]

Best regards,

Michael

> On Jul 20, 2016, at 2:42 PM, Christian Amsüss <[email-masked]> wrote:
>