Subject: [core] FYI - Resource Directory article in The Internet Protocol Journal

From: "Rahman, Akbar" <[email-masked]>
Date: Tue, 19 Jul 2016 14:43:32 +0000

FYI - Some people suggested I send this info to the list for background reading on the RD (especially as the RD draft is now nearing for WGLC).

We wrote a tutorial style article on "Resource Discovery for the IoT" that was published in the June Internet Protocol Journal.  Since it describes the work done in CORE WG related to the RD it will hopefully be interesting to the members of this list.

http://ipj.dreamhosters.com/wp-content/uploads/issues/2016/ipj19-2.pdf

Best Regards,

Akbar

---

From: Badis Djamaa <[email-masked]>
Date: Sun, 24 Jul 2016 01:04:55 +0200

Thank you Akbar for the reminder.

Hi Akbar, members,

Thank you for posting this informative article.

The RD draft employs reactive resource discovery to detect the presence of
an RD, which might be inefficient when the number of providers/clients
increases. We have proposed Proactive RD Discovery (PRD) allowing an RD to
advertise its presence to the network. I thought it maybe useful to share a
first version of this work-in-progress with list members for eventual
discussions.

http://www.sciencedirect.com/science/article/pii/S1877050916301296

Best, badis

On Thursday, 21 July 2016, Rahman, Akbar <[email-masked]>
wrote:

> Hi Badis,
>
>
>
> Thanks for the nice link and I will look at it.  But you didn’t copy the
> CORE lis so if you want other people to read your article please resend the
> email to the whole list!
>
>
>
> Akbar
>
>
>
> *From:* Badis Djamaa [mailto:[email-masked]
> <javascript:_e(%7B%7D,'cvml',[email-masked]');>]
> *Sent:* Thursday, July 21, 2016 11:05 AM
> *To:* Rahman, Akbar <[email-masked]>
> *Subject:* Re: [core] FYI - Resource Directory article in The Internet
> Protocol Journal
>
>
>
> Hi Akbar, members,
>
> Thank you for posting this informative article.
>
> The RD draft employs reactive resource discovery to detect the presence of
> an RD, which might be inefficient when the number of providers/clients
> increases. We have proposed Proactive RD Discovery (PRD) allowing an RD to
> advertise its presence to the network. I thought it maybe useful to share a
> first version of this work-in-progress with list members for eventual
> discussions.
>
> http://www.sciencedirect.com/science/article/pii/S1877050916301296
>
> Best, badis
>
>
>
>
>
>
> <http://idcc.me/1W0351X>
>
> This e-mail is intended only for the use of the individual or entity to
> which it is addressed, and may contain information that is privileged,
> confidential and/or otherwise protected from disclosure to anyone other
> than its intended recipient. Unintended transmission shall not constitute
> waiver of any privilege or confidentiality obligation. If you received this
> communication in error, please do not review, copy or distribute it, notify
> me immediately by email, and delete the original message and any
> attachments. Unless expressly stated in this e-mail, nothing in this
> message or any attachment should be construed as a digital or electronic
> signature.
>
> On 19 July 2016 at 16:43, Rahman, Akbar <[email-masked]
> <javascript:_e(%7B%7D,'cvml',[email-masked]');>> wrote:
>
> FYI – Some people suggested I send this info to the list for background
> reading on the RD (especially as the RD draft is now nearing for WGLC).
>
>
>
> We wrote a tutorial style article on “Resource Discovery for the IoT” that
> was published in the June Internet Protocol Journal.  Since it describes
> the work done in CORE WG related to the RD it will hopefully be interesting
> to the members of this list.
>
>
>
>
>
> _______________________________________________
> core mailing list
> [email-masked] <javascript:_e(%7B%7D,'cvml',[email-masked]');>
> https://www.ietf.org/mailman/listinfo/core
>
>
>
>