Subject: [core] Correct behavior of observe, blockwise etc. if access rights expire

From: Ludwig Seitz <[email-masked]>
Date: Tue, 24 Jan 2017 11:10:43 +0100

Hello CoRE,

I'm currently considering a question that has arisen in the context of 
ACE, for which I'd like some input from CoRE:

If a client has a long-running request such as an observe, a blockwise 
transmission, or a subscription in a pubSub scenario ongoing and the 
access rights for that request expire or are revoked. What would be the 
desirable behavior of the RS:

a.) Send a final 4.01 Unauthorized and then drop the long-running request

b.) Silently drop the long-running request

Regards,

Ludwig

-- 
Ludwig Seitz, PhD   RISE ICT/SICS
Ideon Science Park, Building Beta 2
Scheelevägen 17, SE-223 70 Lund
Phone +46(0)70-349 92 51

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 24 Jan 2017 12:23:05 +0100

On 24 Jan 2017, at 11:10, Ludwig Seitz <[email-masked]> wrote:
> 
> What would be the desirable behavior of the RS:
> 

This.

> b.) Silently drop the long-running request

The client always has to be prepared that this may happen (server rebooting and forgetting its state), but it may take longer until the client finally goes re-establishing the observation then.

Grüße, Carsten