Subject: [core] [Technical Errata Reported] RFC7252 (4902)

From: RFC Errata System <[email-masked]>
Date: Wed, 11 Jan 2017 15:26:18 -0800 (PST)

The following errata report has been submitted for RFC7252,
"The Constrained Application Protocol (CoAP)".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=7252&eid=4902

--------------------------------------
Type: Technical
Reported by: Neil Kolban <[email-masked]>

Section: 3.0

Original Text
-------------
This is followed by a variable-length Token value, which can be
between 0 and 8 bytes long.

Corrected Text
--------------
This is followed by a variable-length Token value, which can be
between 0 and 7 bytes long.

Notes
-----
This is a nit-pick but we enter into the ambiguity of the semantics of "between" and whether it means inclusive or exclusive.  In this context, since we can obviously have no token which would mean a token of length 0, then we are using between in its "inclusive" semantics ... which would then imply that "7" is the maximum (inclusive) length of a token which is constrained to 3 bits with a maximum value of 0b111 = decimal 7.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC7252 (draft-ietf-core-coap-18)
--------------------------------------
Title               : The Constrained Application Protocol (CoAP)
Publication Date    : June 2014
Author(s)           : Z. Shelby, K. Hartke, C. Bormann
Category            : PROPOSED STANDARD
Source              : Constrained RESTful Environments APP
Area                : Applications
Stream              : IETF
Verifying Party     : IESG

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 12 Jan 2017 08:29:21 +0100

Hi Neil,

no problem, thanks for reading attentively.

Your report reminded me that sometimes we write things in specifications that probably should be marked with a “(really!)” or “(!)”.  I’m not sure we have a good convention for that (“(!)” has all these other connotations), but something like Knuth’s “dangerous bend" might prevent the occasional double take when a spec violates the POLS (principle of least surprise).

(CCing rfc-i not because this is something that must be handled immediately, but to start the creative processes in the back of their collective minds.)

Grüße, Carsten

> On 12 Jan 2017, at 00:30, Neil Kolban <[email-masked]> wrote:
> 
> Please ignore this report ... just realized that the TKL is 4 bits and not 3 bits and hence 8 is a valid length for a token.
> 
> 
> Apologies.
> 
> 
> Neil
> 
> 
> On 1/11/2017 5:26 PM, RFC Errata System wrote: