Subject: [core] Confirmable message

From: Ana Minaburo <[email-masked]>
Date: Tue, 24 Jan 2017 09:42:08 +0100

Hi Peter

In the draft, draft-vanderstok-core-comi-11.txt,  you mention that a
confirmable message is mandatory for carry CoMi requests. We understand
that for setting a value it is necessary to be sure that the information
has been correctly received. In LPWAN WG we are studying the way to
compress header and reduce traffic on very constraint links. Do you think,
it could be possible to suppress this constraint and allow the use of NON
confirmable messages ?

Thanks

Ana

---

From: peter van der Stok <[email-masked]>
Date: Tue, 24 Jan 2017 10:08:51 +0100

Hi Ana,

thanks for the motivated suggestion.
We can change the text such that every implementation MUST support the 
confirmable requests, and MAY support non-confirmable requests.

would that do the trick? It is then possible that a client that accesses 
unknowingly a LPWAN server uses confirmable requests and cannot use 
non-confirmable requests.

Other variations are possible. But I like to restrict the number of 
request possibilities.

Peter

Ana Minaburo schreef op 2017-01-24 09:42:
> confirmable message is mandatory for carry CoMi requests. We
> understand that for setting a value it is necessary to be sure that
> the information has been correctly received. In LPWAN WG we are
> studying the way to compress header and reduce traffic on very
> constraint links. Do you think, it could be possible to suppress this
> constraint and allow the use of NON confirmable messages ?
> 
> Thanks
> 
> Ana
> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core

---

From: Michel Veillette <[email-masked]>
Date: Mon, 30 Jan 2017 14:41:21 +0000

Hi Ana

In CoMI, "NON confirmable messages" are supported though notifications.
In section https://tools.ietf.org/html/draft-ietf-core-comi-00#section-5.5.1, the sentence
"To check that the client is still alive, the server MUST send confirmable notifications once in a while."
implicitly confirm this option.

Regards,
Michel

From: core [mailto:[email-masked]] On Behalf Of Ana Minaburo
Sent: Tuesday, January 24, 2017 3:42 AM
To: Core <[email-masked]>; peter van der Stok <[email-masked]>
Subject: [core] Confirmable message

Hi Peter
In the draft, draft-vanderstok-core-comi-11.txt,  you mention that a confirmable message is mandatory for carry CoMi requests. We understand that for setting a value it is necessary to be sure that the information has been correctly received. In LPWAN WG we are studying the way to compress header and reduce traffic on very constraint links. Do you think, it could be possible to suppress this constraint and allow the use of NON confirmable messages ?

Thanks

Ana

---

From: peter van der Stok <[email-masked]>
Date: Tue, 31 Jan 2017 08:54:55 +0100

Hi Ana,

Why not solve this in the gateway and elide the Con flag?
Removes the problem of not LPWAN aware clients contacting LPWAN servers.

Peter

Michel Veillette schreef op 2017-01-30 15:41:
> In section
> https://tools.ietf.org/html/draft-ietf-core-comi-00#section-5.5.1 [1],
> the sentence
> 
> "To check that the client is still alive, the server MUST send
> confirmable notifications once in a while."
> 
> FROM: core [mailto:[email-masked]] ON BEHALF OF Ana Minaburo
> SENT: Tuesday, January 24, 2017 3:42 AM
> TO: Core <[email-masked]>; peter van der Stok <[email-masked]>
> SUBJECT: [core] Confirmable message
> 
> Hi Peter
> 
> Links:
> ------
> [1] https://tools.ietf.org/html/draft-ietf-core-comi-00#section-5.5.1