Subject: [core] Fwd: New Version Notification for draft-vanderstok-core-comi-11.txt

From: peter van der Stok <[email-masked]>
Date: Wed, 18 Jan 2017 12:46:10 +0100

Hi all,

A new version of I-D, draft-vanderstok-core-comi-11.txt
has been successfully submitted by Peter van der Stok and posted to the
IETF repository.

@chairs, this is the version to confirm the adoption over the mailing 
list.
Greetings,

Peter

Name:		draft-vanderstok-core-comi
Revision:	11
Title:		CoAP Management Interface
Document date:	2017-01-18
Group:		Individual Submission
Pages:		46
URL:            
https://www.ietf.org/internet-drafts/draft-vanderstok-core-comi-11.txt
Status:         
https://datatracker.ietf.org/doc/draft-vanderstok-core-comi/
Htmlized:       
https://tools.ietf.org/html/draft-vanderstok-core-comi-11
Diff:           
https://www.ietf.org/rfcdiff?url2=draft-vanderstok-core-comi-11

Abstract:
    This document describes a network management interface for
    constrained devices and networks, called CoAP Management Interface
    (CoMI).  The Constrained Application Protocol (CoAP) is used to
    access data resources specified in YANG, or SMIv2 converted to YANG.
    CoMI uses the YANG to CBOR mapping and converts YANG identifier
    strings to numeric identifiers for payload size reduction.  CoMI
    extends the set of YANG based protocols, NETCONF and RESTCONF, with
    the capability to manage constrained devices and networks.

Please note that it may take a couple of minutes from the time of 
submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 18 Jan 2017 12:52:48 +0100

> On 18 Jan 2017, at 12:46, peter van der Stok <[email-masked]> wrote:
> 
> Hi all,
> 
> @chairs, this is the version to confirm the adoption over the mailing list.

Indeed.

In Seoul, we had in-room consensus to adopt this draft as a WG document, filling in the remaining gap of the COMI/COOL series of documents.  We said we needed to confirm that consensus on the mailing list, but didn’t do that immediately, and then there was a new version impending.

That new version is now available.  So if you do not agree with the in-room consensus that we had in Seoul to adopt this as a WG document, please speak up until the end of 2017-01-25.  (If you weren’t in the room but do agree with adopting this document, you can also tell us.)

Grüße, Carsten

> URL:            https://www.ietf.org/internet-drafts/draft-vanderstok-core-comi-11.txt
> Status:         https://datatracker.ietf.org/doc/draft-vanderstok-core-comi/
> Htmlized:       https://tools.ietf.org/html/draft-vanderstok-core-comi-11
> Diff:           https://www.ietf.org/rfcdiff?url2=draft-vanderstok-core-comi-11
> 
> Abstract:

---

From: James Nguyen <[email-masked]>
Date: Wed, 18 Jan 2017 12:33:21 -0500

Hi WG,

I strongly support this document.

James

> On Jan 18, 2017, at 6:52 AM, Carsten Bormann <[email-masked]> wrote:
> 
> 
> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core

---

From: Ana Minaburo <[email-masked]>
Date: Wed, 18 Jan 2017 19:41:31 +0100

Hello,

I also supports this document.

Ana

On Wed, Jan 18, 2017 at 12:52 PM, Carsten Bormann <[email-masked]> wrote:

> In Seoul, we had in-room consensus to adopt this draft as a WG document,
> filling in the remaining gap of the COMI/COOL series of documents.  We said
> we needed to confirm that consensus on the mailing list, but didn’t do that
> immediately, and then there was a new version impending.
>
> That new version is now available.  So if you do not agree with the
> in-room consensus that we had in Seoul to adopt this as a WG document,
> please speak up until the end of 2017-01-25.  (If you weren’t in the room
> but do agree with adopting this document, you can also tell us.)
>
> Grüße, Carsten
>

---

From: Michel Veillette <[email-masked]>
Date: Wed, 18 Jan 2017 19:51:55 +0000

Hi Carsten

I'm also supporting the call for adoption of draft-vanderstok-core-comi-11.

Some minor details still need to be resolved, but most of the work required to merge the original CoMI with the alternate approach proposed by https://tools.ietf.org/html/draft-veillette-core-cool-02 have been resolved. The end product combines the data resource access level of CoMI and the datastore access level as proposed by CoOL. All this based on a common naming model (https://tools.ietf.org/html/draft-ietf-core-sid-00) and encoding model (https://tools.ietf.org/html/draft-ietf-core-yang-cbor-03). 

The adoption of CoMI will enable a change of focus toward the development of YANG modules to be used by this protocol https://datatracker.ietf.org/doc/draft-veillette-core-cool-library/, logger access and control, OTA upgrade, datastore management, ...

Regards,
Michel Veillette
(System architect, Trilliant Network)

-----Original Message-----
From: core [mailto:[email-masked]] On Behalf Of Carsten Bormann
Sent: Wednesday, January 18, 2017 6:53 AM
Cc: Core <[email-masked]>
Subject: [core] 🔔 Confirmation call for WG adoption of draft-vanderstok-core-comi-11.txt

> A new version of I-D, draft-vanderstok-core-comi-11.txt has been 
> successfully submitted by Peter van der Stok and posted to the IETF 
> repository.
> 

Indeed.

Grüße, Carsten

---

From: "Carles Gomez Montenegro" <[email-masked]>
Date: Thu, 19 Jan 2017 09:07:01 +0100

+1

Carles

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 26 Jan 2017 13:40:08 +0100

2017-01-25 has ended even on Baker Island, and we have mailing list confirmation of this WG adoption.

Authors: please resubmit as draft-ietf-core-comi-00.

Grüße, Carsten

> On 18 Jan 2017, at 12:52, Carsten Bormann <[email-masked]> wrote:
>