Subject: [core] Binding Attributes in draft-groves-core-dynlink-02

From: "Carey, Timothy (Nokia - US)" <[email-masked]>
Date: Sat, 25 Feb 2017 16:34:12 +0000

Hi,

I noticed in the latest draft the binding attributes were changed.
The LWM2M uses the binding attributes in their specification that was recently published.
In LWM2M Greater than is gt; Less than is lt and Step is stp.
In the latest dynlink draft Greater than is gth; Less than is lth and Step is st

Do we know the reason for the change?
Is it possible to use lt; gt; stp as is specificed in LWM2M?

BR,
Tim

---

From: Carsten Bormann <[email-masked]>
Date: Sat, 25 Feb 2017 19:08:54 +0100

(No chair hat.)

> On 25 Feb 2017, at 17:34, Carey, Timothy (Nokia - US) <[email-masked]> wrote:
> 
> Hi,
>  

There was a naming issue with “lt” being used for both lifetime and less than.
This is not a problem now, but could become one.
Since lifetime was in use, attempts have been made to rename less than (and greater than analogously), but discussion took some time (maybe because lt and gt are the obvious names for anyone who has heard of FORTRAN).

> Is it possible to use lt; gt; stp as is specificed in LWM2M?

Maybe we have missed a window in which this change (avoiding the name collision) could have been net positive.

Grüße, Carsten

---

From: Michael Koster <[email-masked]>
Date: Sat, 25 Feb 2017 11:33:27 -0800

Hi Tim,

Is there a name collision with "st" that required OMA LWM2M to use "stp" instead? I used "st" in the mbed reference implementation in early 2015.

Best regards,

Michael

> On Feb 25, 2017, at 10:08 AM, Carsten Bormann <[email-masked]> wrote:
> 
> (No chair hat.)
> 
> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core

---

From: "Carey, Timothy (Nokia - US)" <[email-masked]>
Date: Sun, 26 Feb 2017 19:17:06 +0000

Michael,

Well the IETF interfaces draft has been consistent - the step attribute is "st".
I went back and traced the change in LWM2M from "st" to "stp".
It occurred between: 
The February 2015 (OMA-TS-LightweightM2M-V1_0-20150228-D) has "stp" and the February 2015 version (OMA-TS-LightweightM2M-V1_0-20150225-D) has "st".
The agreed to cr that brought that change was OMA-DM-LightweightM2M-2015-0008R01-CR_Attributes_

I added Thierry into this email - maybe he can answer your question better since he brought the original CR but it looks to me to be an editorial problem when he restructured that part of the document and clarified the rules for use within LWM2M... Probably just a typo that needs corrected in the OMA spec...

BR,
Tim

-----Original Message-----
From: Michael Koster [mailto:[email-masked]] 
Sent: Saturday, February 25, 2017 1:33 PM
To: Carsten Bormann <[email-masked]>
Cc: Carey, Timothy (Nokia - US) <[email-masked]>; [email-masked] WG <[email-masked]>
Subject: Re: [core] Binding Attributes in draft-groves-core-dynlink-02

Hi Tim,

Best regards,

Michael

---

From: "Carey, Timothy (Nokia - US)" <[email-masked]>
Date: Sun, 26 Feb 2017 19:18:59 +0000

Carsten, 
Probably for gt and lt; they have been used in LWM2M since it looks like around 2013.
Changing the values to gth and lth will probably affect implementations.

BR,
Tim

-----Original Message-----
From: Carsten Bormann [mailto:[email-masked]] 
Sent: Saturday, February 25, 2017 12:09 PM
To: Carey, Timothy (Nokia - US) <[email-masked]>
Cc: [email-masked] WG <[email-masked]>
Subject: Re: [core] Binding Attributes in draft-groves-core-dynlink-02

(No chair hat.)

Grüße, Carsten

---

From: Christian Groves <[email-masked]>
Date: Mon, 27 Feb 2017 14:36:21 +1100

Hello Tim,

Given the overlap in "lt" it was either people's resource directory 
implementations or binding attribute implementations that would be 
impacted. It seemed that there were more resource directory 
implementations and draft-ietf-core-resource-directory was further along 
so it seemed the preference of the list was to change 
draft-ietf-core-dynlink.

As editor i'll leave it up to the Chairs to determine which should 
change. We could leave gt as it is and only change lt if it helps.

Regards, Christian

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 27 Feb 2017 07:03:58 +0100

On 27 Feb 2017, at 04:36, Christian Groves <[email-masked]> wrote:
> 
> As editor i'll leave it up to the Chairs to determine which should change.

The chairs can only channel the consensus of the WG, so please keep the comments on this (bikesheddy, but icky) issue coming.

> We could leave gt as it is and only change lt if it helps.

(Chair hat off:)  It seems to me personally that a change here hurts more than it helps, both with respect to requiring a change from the released LWM2M spec and with respect to permanently installing a POLS*) violation in the spec.

Grüße, Carsten

*) POLS: Principle of least surprise, which shouts loudly for less than to be abbreviated lt.