Subject: [core] draft-becker-core-coap-sms-gprs-06: Identifying CoAP PDUs

From: "Carey, Timothy (Nokia - US)" <[email-masked]>
Date: Fri, 17 Mar 2017 14:26:06 +0000

Hello,

How does a device determine from the received SMS PDU that this PDU is a CoAP message and to which CoAP endpoint
the CoAP message should be sent?

Looking at the draft -
I can decode the SMS using the TP-DATA-Coding-Scheme but how do I know it's a CoAP message vs some other PDU.
Likewise once I know it's a CoAP message how do I determine the CoAP endpoint if the device supports multiple CoAP endpoints (maybe that is out of scope).

Thanks in advance,
Tim

---

From: Lauri Piikivi <[email-masked]>
Date: Mon, 20 Mar 2017 07:21:05 +0000

The SMS bearer was supported by WAP, way back — hesitate to admit that I worked on it :)  There the assumption was to use the User-Data-Header for ports information, and the assumption was that 8-bit SMS is commonplace.

Could the spec refer to WAP directly? http://www.openmobilealliance.org/tech/affiliates/wap/wap-259-wdp-20010614-a.pdf

- Lauri

On 17 Mar 2017, at 16:26, Carey, Timothy (Nokia - US) <[email-masked]<mailto:[email-masked]>> wrote:

Hello,

Looking at the draft –
I can decode the SMS using the TP-DATA-Coding-Scheme but how do I know it’s a CoAP message vs some other PDU.
Likewise once I know it’s a CoAP message how do I determine the CoAP endpoint if the device supports multiple CoAP endpoints (maybe that is out of scope).

Thanks in advance,
Tim
_______________________________________________
core mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/core

IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 20 Mar 2017 09:01:55 +0100

> The SMS bearer was supported by WAP, way back — hesitate to admit that I worked on it :)  There the assumption was to use the User-Data-Header for ports information, and the assumption was that 8-b…

One of the things that came up during development of this draft is that 8-bit SMS actually is slightly less common than we assumed.  Hence the discussion of 7-bit mappings.

> Could the spec refer to WAP directly? http://www.openmobilealliance.org/tech/affiliates/wap/wap-259-wdp-20010614-a.pdf

If we can avoid that…

I don’t think implementations right now have a multiplexing point here.
That would be nice to have to make CoAP over SMS usable with devices such as smartphones.
I’m just not sure how to do this in a way that accommodates existing implementations.

Grüße, Carsten

---

From: Becker Markus <[email-masked]>
Date: Tue, 21 Mar 2017 19:41:47 +0000

Hi.

> > The SMS bearer was supported by WAP, way back — hesitate to admit that
> I worked on it :)  There the assumption was to use the User-Data-Header for
> ports information, and the assumption was that 8-bit SMS is commonplace.
>
> One of the things that came up during development of this draft is that 8-bit
> SMS actually is slightly less common than we assumed.  Hence the discussion
> of 7-bit mappings.

At least back in 2014/15 we had troubles doing 8bit SMS with Android. It seems nowadays it should be possible:

http://codetheory.in/android-sms/

https://developer.android.com/reference/android/telephony/SmsManager.html#sendDataMessage(java.lang.String, java.lang.String, short, byte[], android.app.PendingIntent, android.app.PendingIntent)

The Android API seems to give access to the port (==protocol identifier?):
void sendDataMessage (String destinationAddress,
                String scAddress,
                short destinationPort,
                byte[] data,
                PendingIntent sentIntent,
                PendingIntent deliveryIntent)

> > Could the spec refer to WAP directly?
> http://www.openmobilealliance.org/tech/affiliates/wap/wap-259-wdp-
> 20010614-a.pdf
>
> If we can avoid that…
>
> [email-masked]
________________________________________________________ The contents of this e-mail and any attachments are confidential to the intended recipient. They may not be disclosed to or used by or copied in any way by anyone other than the intended recipient. If this e-mail is received in error, please immediately notify the sender and delete the e-mail and attached documents. Please note that neither the sender nor the sender's company accept any responsibility for viruses and it is your responsibility to scan or otherwise check this e-mail and any attachments.

---

From: Becker Markus <[email-masked]>
Date: Tue, 21 Mar 2017 19:46:13 +0000

Hi Timothy.

From: core [mailto:[email-masked]] On Behalf Of Carey, Timothy (Nokia - US)
Sent: Freitag, 17. März 2017 15:26
To: core <[email-masked]>
Subject: [core] draft-becker-core-coap-sms-gprs-06: Identifying CoAP PDUs

Hello,

How about using TP-PID (TP-Protocol-Identifier) for that?

Looking at the draft -

Thanks in advance,
Tim

---

From: "Carey, Timothy (Nokia - US)" <[email-masked]>
Date: Fri, 24 Mar 2017 13:11:57 +0000

Markus,

I know that the WAP (UDH) is being used for SMS in various applications. I think it's the same as what that is in RFC7925/A.3.
If possible we would like to see this option in the draft to handle existing applications.

BR,
Tim

-----Original Message-----
From: Becker Markus [mailto:[email-masked]] 
Sent: Tuesday, March 21, 2017 2:42 PM
To: Carsten Bormann <[email-masked]>; Lauri Piikivi <[email-masked]>
Cc: core <[email-masked]>
Subject: Re: [core] draft-becker-core-coap-sms-gprs-06: Identifying CoAP PDUs

Hi.

> I worked on it :)  There the assumption was to use the 
> User-Data-Header for ports information, and the assumption was that 8-bit SMS is commonplace.
>
> One of the things that came up during development of this draft is 
> that 8-bit SMS actually is slightly less common than we assumed.  
> Hence the discussion of 7-bit mappings.