Subject: [core] Interop event for coap over tcp/tls/websockets?

From: Carsten Bormann <[email-masked]>
Date: Wed, 15 Mar 2017 10:59:45 +0100

In the process of producing the writeup for the submission of coap-tcp-tls to IESG, we noticed that we never asked about implementations.

It is well known that IoTivity has one (needing to be updated to a newer version).

Who else has an implementation that we could report in the writeup?

Apart from the writeup, should we stage an interop event?
The first opportunity would be at the Hackathon in Chicago.
But maybe we should do a more widely announced one in April.
In any case, this would be open to remote participation, just like the recent OSCOAP interop.

Who wants to join?

Grüße, Carsten

---

From: Hannes Tschofenig <[email-masked]>
Date: Fri, 17 Mar 2017 16:20:22 +0100

Hi Carsten,

this is a great idea. For the IETF meeting Chicago it is a bit too short
notice for me since I have committed myself to do other things at the
Hackathon already. I think we should prepare ourselves to a have such an
interop event for the Prague IETF meeting. Maybe it is possible to
combine it with other CORE related specifications.

Ciao
Hannes

On 03/15/2017 10:59 AM, Carsten Bormann wrote:
> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core
>

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 21 Mar 2017 09:41:51 +0100

> combine it with other CORE related specifications.

Right.  We are already planning to have a OSCOAP interop there, so coap-tcp-tls, as well as fetch-patch, could be added to that.  I’m wondering whether we should try to get ETSI’s help.

Grüße, Carsten