Subject: [core] CoRE@IETF98

From: Carsten Bormann <[email-masked]>
Date: Wed, 15 Mar 2017 20:50:20 +0100

We have uploaded a 0.1 draft of the CoRE agenda for Chicago at:

https://datatracker.ietf.org/meeting/98/agenda/core/

As usual, this is based on the documents we have on the plate.

If you have a document, please check the above agenda that you have adequate time at this meeting to drive your work forward.  Please tell us who will be managing the slot.
(And start making slides…  We’ll want them on Saturday, March 25.)

Anything else that should be on the agenda?

(Note that we are a bit constrained with allocating time, as we asked for 180 minutes total only for CoRE.  So there is no flextime this time, just a little bit of buffer on Friday for spillover from Tuesday.)

Grüße, Carsten

---

From: Christian Groves <[email-masked]>
Date: Thu, 16 Mar 2017 10:13:53 +1100

Hello Carsten,

Given that draft-ietf-core-interfaces, draft-ietf-core-dynlink, 
draft-groves-core-obsattr and draft-groves-core-bas are all related it 
may be more efficient to present them as a block?

I was also going to propose to discuss about the renaming of the "lt" 
parameter so I don't know if we should do that in conjunction with 
draft-ietf-core-resource-directory? It might take some time. There's 
also the proposal on the list regarding updating RD to make the IANA 
registration of query attributes more generic.

With respect to draft-groves-core-rfc6690up I haven't done anything more 
on this so if you need more time it would be OK to drop it. However I'm 
happy to discuss it with people in Chicago.

Yes draft-groves-coap-webrtcdc is not dead. My understanding from Seoul 
was that we'd hold off on it until draft-ietf-core-coap-tcp-tls was out 
of the way.

Regards, Christian

On 16/03/2017 6:50 AM, Carsten Bormann wrote:
> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core

---

From: peter van der Stok <[email-masked]>
Date: Thu, 16 Mar 2017 09:03:46 +0100

Hi  Carsten,

I will be happy to present ietf-comi-00 draft; It needs some discussion 
on the content-format for the PATCH and FETCH methods. I like to hear 
the opinion of the WG

For the hartke-core-pending draft I should like a 2 min elevator pitch 
at the start of the Friday meeting, followed by a 2 minute request for 
interest.

Greetings,

peter

Carsten Bormann schreef op 2017-03-15 20:50:
> If you have a document, please check the above agenda that you have
> adequate time at this meeting to drive your work forward.  Please tell
> us who will be managing the slot.
> (Note that we are a bit constrained with allocating time, as we asked
> for 180 minutes total only for CoRE.  So there is no flextime this
> time, just a little bit of buffer on Friday for spillover from
> Tuesday.)
> 
> Grüße, Carsten
>

---

From: Jaime Jiménez <[email-masked]>
Date: Tue, 21 Mar 2017 14:16:06 +0000

Hi all,

just a gentle reminder to the document authors about the IETF 98 agenda.

If you have not already, please let the chairs know if you can present the draft updates in the allocated slot or not, so that we can reschedule.

Those still missing, will receive an individual reminder before the end of the week   :)

Thanks!

---------------  8< ------------------
PRELIMINARY AGENDA IETF 98

TUESDAY, March 28, 2017
1300–1430 Afternoon Session I: Zurich C

Intro (10)

  *   Agenda bashing, WG status
  *   Mention RFC 8075, draft-ietf-core-etch<https://tools.ietf.org/html/draft-ietf-core-etch>

Post-WGLC (15)

  *   (brief update) draft-ietf-core-coap-tcp-tls<https://tools.ietf.org/html/draft-ietf-core-coap-tcp-tls> –07 2017–03–06
  *   (results of 2nd WGLC) draft-ietf-core-links-json<https://tools.ietf.org/html/draft-ietf-core-links-json> –07 2017–03–13

Maybe WGLC (15)

  *   (new appendix, WGLC now?) draft-ietf-core-cocoa<https://tools.ietf.org/html/draft-ietf-core-cocoa> –01 2017–03–13
  *   (call for review) draft-ietf-core-resource-directory<https://tools.ietf.org/html/draft-ietf-core-resource-directory> –10 2017–03–13

comi (20)

  *   Discuss results from Monday’s 15:20 to 16:50 semi-formal COMI meeting

Objective: Which of these can we WGLC now? Where are we with installing a SID process with IANA and other actors needed? [SID] Check status of IANA processes (register SIDs, lookup SIDs).

  *   draft-ietf-core-yang-cbor<https://tools.ietf.org/html/draft-ietf-core-yang-cbor> –04 2017–02–07
  *   draft-ietf-core-comi<https://tools.ietf.org/html/draft-ietf-core-comi> –00 2017–01–26
  *   draft-ietf-core-sid<https://tools.ietf.org/html/draft-ietf-core-sid> –00 2016–10–26

Objective: what are the next steps? (Based on results from Monday:)

  *   draft-veillette-core-yang-library<https://tools.ietf.org/html/draft-veillette-core-yang-library> –00 2017–01–31

object security (30)

  *   Report of the Interop (Summary)
  *   Updates on the bigger changes on v –02
  *   Confirm results of inner-blockwise discussion, cf. http-encryption
  *   Objective: ➔ more interops + WGLC before or right after Prague.
  *   draft-ietf-core-object-security<https://tools.ietf.org/html/draft-ietf-core-object-security> –02 2017–03–13

What does the WG want to do with (the subjects of) these documents:

  *   draft-hartke-core-e2e-security-reqs<https://tools.ietf.org/html/draft-hartke-core-e2e-security-reqs> –02 2017–01–06
  *   draft-mattsson-core-security-overhead<https://tools.ietf.org/html/draft-mattsson-core-security-overhead> –00 2017–03–13
  *   draft-tiloca-core-multicast-oscoap<https://tools.ietf.org/html/draft-tiloca-core-multicast-oscoap> –01 2017–03–13

Σ 90

FRIDAY, March 31, 2017
1150–1320 Afternoon Session I: Zurich C
Intro (5)
spillover from Tuesday (20)
data formats (20)
Objective: is this now finally ready for WGLC?

  *   draft-ietf-core-senml<https://tools.ietf.org/html/draft-ietf-core-senml> –05 2017–03–13

Objective: Should these be worked on by the CoRE WG?

  *   draft-groves-core-senml-bto<https://tools.ietf.org/html/draft-groves-core-senml-bto> –00 2016–10–17
  *   draft-groves-core-senml-options<https://tools.ietf.org/html/draft-groves-core-senml-options> –00 2017–03–10

Working on it (15)

  *   (just call for review) draft-ietf-core-coap-pubsub<https://tools.ietf.org/html/draft-ietf-core-coap-pubsub> –01 2017–03–13
  *   draft-ietf-core-interfaces<https://tools.ietf.org/html/draft-ietf-core-interfaces> –09 2017–03–13
  *   draft-ietf-core-dynlink<https://tools.ietf.org/html/draft-ietf-core-dynlink> –03 2017–03–13

Transports: candidates for WG work (10)

  *   (get reviews) draft-becker-core-coap-sms-gprs<https://tools.ietf.org/html/draft-becker-core-coap-sms-gprs> –06 2017–02–20

Objective: discuss this in the context of the now completed coap-tcp

  *   draft-silverajan-core-coap-protocol-negotiation<https://tools.ietf.org/html/draft-silverajan-core-coap-protocol-negotiation> –04 2016–10–31

More open discussion: (20)
(Gong show)

  *   draft-cao-core-delegated-observe<https://tools.ietf.org/html/draft-cao-core-delegated-observe> –00 2016–10–27
  *   draft-groves-core-obsattr<https://tools.ietf.org/html/draft-groves-core-obsattr> –00 2017–02–21
  *   draft-groves-core-bas<https://tools.ietf.org/html/draft-groves-core-bas> –01 2017–03–13
  *   draft-groves-core-rfc6690up<https://tools.ietf.org/html/draft-groves-core-rfc6690up> –00 2016–10–17
  *   draft-hartke-core-pending<https://tools.ietf.org/html/draft-hartke-core-pending> –00 2017–02–27

Σ 90

Ciao!
- - Jaime Jiménez

On 15 Mar 2017, at 21.50, Carsten Bormann <[email-masked]<mailto:[email-masked]>> wrote:

Grüße, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 28 Mar 2017 11:08:41 -0500

A consolidated slide deck is now available at

https://datatracker.ietf.org/doc/slides-98-core-consolidated-slide-set/

Slot leaders: Please check your slides are in (in the newest version you sent me).

See you 6600 seconds...

Grüße, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 31 Mar 2017 09:43:28 -0500

> https://datatracker.ietf.org/doc/slides-98-core-consolidated-slide-set/

Updated now for today’s meeting.
(Slot leaders: Please check.)

(We're still waiting for the SID/IANA slides.)

Grüße, Carsten