Subject: [core] Fwd: New Version Notification for draft-groves-core-senml-options-00.txt

From: Christian Groves <[email-masked]>
Date: Fri, 10 Mar 2017 16:55:04 +1100

Hello all,

FYI I've submitted a draft to discuss the problem of the behaviour of 
endpoints if they encounter an unknown SenML attribute such as BTO. This 
was raised at the Seoul meeting.

Regards, Christian

-------- Forwarded Message --------
Subject: 	New Version Notification for 
draft-groves-core-senml-options-00.txt
Date: 	Thu, 9 Mar 2017 21:19:06 -0800
From: 	[email-masked]
To: 	Weiwei Yang <[email-masked]>, Christian Groves 
<[email-masked]>, Christian Groves 
<[email-masked]>

A new version of I-D, draft-groves-core-senml-options-00.txt
has been successfully submitted by Christian Groves and posted to the
IETF repository.

Name:		draft-groves-core-senml-options
Revision:	00
Title:		SenML Options
Document date:	2017-03-10
Group:		Individual Submission
Pages:		13
URL:            https://www.ietf.org/internet-drafts/draft-groves-core-senml-options-00.txt
Status:         https://datatracker.ietf.org/doc/draft-groves-core-senml-options/
Htmlized:       https://tools.ietf.org/html/draft-groves-core-senml-options-00

Abstract:
    SenML [I-D.ietf-core-senml] defines an initial set of base and
    regular attributes which are tied to a particular version of SenML.
    SenML also allows the definition of additional attributes by
    extending the syntax with a new label.  Allowing the extension of
    attributes brings the problem of how do endpoints negotiate whether
    the new attribute can be used or not?  This document discusses the
    issue and proposes some potential solutions to this issue.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

.

---

From: Ari Keränen <[email-masked]>
Date: Thu, 30 Mar 2017 21:14:32 +0000

Hi all,

I've been discussing this issue with mandatory to understand extensions (new attributes) for SenML at the IETF meeting with bunch of people, and seems that the preference would be to not use media-type parameters for this, but indicate in the SenML Pack, in attribute names, if there are extensions that can't be ignored (i.e., second option discussed in the draft [1]).

Apparently the media type parameters are in generally currently ignored so they would not actually provide this capability reliably. Also, media type extension would only help in cases where the media types are available, but not in cases where a SenML is distributed in a file or dumped to database (without the media-type information).

Therefore, we'd suggest to pick a character that is safe for attribute names (e.g., "z") and use that in the beginning of the name, or after "b" for base attributes, to indicate an attribute is mandatory to understand. Alternatively we could pick special character like "+" or "_" but some concerns were raised that e.g., some database systems may not like using these in keys.

We're planning to discuss this tomorrow at the CoRE session, but please comment already here on the list if you have any concerns / questions on this.

Thanks,
Ari

[1] https://tools.ietf.org/html/draft-groves-core-senml-options-00#section-3.2

> On 09 Mar 2017, at 23:55, Christian Groves <[email-masked]> wrote:
> 
> Hello all,
> 
> FYI I've submitted a draft to discuss the problem of the behaviour of endpoints if they encounter an unknown SenML attribute such as BTO. This was raised at the Seoul meeting.
> 
> Regards, Christian
> 
> 
> 
> Subject: 	New Version Notification for draft-groves-core-senml-options-00.txt
> To: 	Weiwei Yang <[email-masked]>, Christian Groves <[email-masked]>, Christian Groves <[email-masked]>
> 
> 
> 
> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core