Subject: [core] AD review of draft-ietf-core-links-json-07.txt

From: Alexey Melnikov <[email-masked]>
Date: Fri, 7 Apr 2017 17:59:47 +0100

Hi,

I have requested an extra review to check that use of Link relations is 
correct.

I also found a small cut & paste error:

In 3.2:

                  +------------------------------+-------+
                  | Media type                   | ID    |
                  +------------------------------+-------+
                  | application/link-format+cbor | TBD64 |
                  | application/link-format+cbor | TBD54 |
                  +------------------------------+-------+

I think one of these should be +json.

As I have no other comments, I've initiated IETF LC for this document.

Thank you,

Alexey

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 7 Apr 2017 21:01:43 +0200

>                 | application/link-format+cbor | TBD54 |

Indeed, this registration should be

                 | application/link-format+cbor | TBD64 |
                 | application/link-format+json | TBD54 |

(Listed in alphabetical, not the suggested numerical order.
Note that 60 is application/cbor and 50 is application/json, and then 40 is application/link-format, so there is some mnemonic value to using 64 and 54 as suggested numbers — at least to my twisted mind :-)

Grüße, Carsten

---

From: Michael Koster <[email-masked]>
Date: Fri, 7 Apr 2017 12:46:58 -0700

60 is application/cbor and 
50 is application/json, and then 
40 is application/link-format 

therefore:

                | application/link-format+cbor | TBD100 |
                | application/link-format+json | TBD90 |

;-)

> On Apr 7, 2017, at 12:01 PM, Carsten Bormann <[email-masked]> wrote:
> 
> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core