Subject: [core] Is this a typo in -08

From: Jim Schaad <[email-masked]>
Date: Wed, 26 Apr 2017 01:43:14 -0700

In section 6 the following text occurs:

In descriptive usage, a BERT Option is interpreted in the same way as
   the equivalent Option with SZX == 6, except that the payload is also
   allowed to contain a multiple of 1024 bytes (non-final BERT block) or
   more than 1024 bytes (final BERT block).

However I think that the last sentence should read "less than 1024 bytes".

Jim

---

From: Christian Amsüss <[email-masked]>
Date: Wed, 26 Apr 2017 11:07:37 +0200

> However I think that the last sentence should read "less than 1024 bytes".

Sounds right to me: It extends what is already permitted for SZX=6, and
<=1024 is already allowed for final SZX=6 blocks. (In effect, the last
BERT block can have any length, only limited by Max-Message-Size).

Best regards
Christian

-- 
To use raw power is to make yourself infinitely vulnerable to greater powers.
  -- Bene Gesserit axiom

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 26 Apr 2017 11:10:51 +0200

> On Apr 26, 2017, at 11:07, Christian Amsüss <[email-masked]> wrote:
> 

Yes.

This seems to be the second time that someone stumbles about that wording; maybe we can find a better way to say this.

Grüße, Carsten

---

From: 'Christian Amsüss' <[email-masked]>
Date: Wed, 26 Apr 2017 13:05:19 +0200

On Wed, Apr 26, 2017 at 03:21:03AM -0700, Jim Schaad wrote:
> where in RC 7959 does it say this?

To be honest, I don't find it explicitly either; 7959 2.3 only says "The
block size implied by SZX MUST match the size of the payload in bytes,
if the M bit is set." -- I'd be a bit strange to send a final payload
longer then the block size, but maybe it's even allowed?

Christian

---

From: Jim Schaad <[email-masked]>
Date: Wed, 26 Apr 2017 04:41:00 -0700

-----Original Message-----
From: Carsten Bormann [mailto:[email-masked]] 
Sent: Wednesday, April 26, 2017 2:11 AM
To: Christian Amsüss <[email-masked]>
Cc: Jim Schaad <[email-masked]>; [email-masked]; core <[email-masked]>
Subject: Re: [core] Is this a typo in -08

Yes.

[JLS] I think I now understand what this text is supposed to be saying.

"except that the payload is also allowed to contain multiple blocks.  For non-final BERT blocks, the payload is always a multiple of 1024 bytes. 
For final BERT blocks, the payload is a multiple (possibly 0) of 1024 bytes plus a  partial block of less than 1024 bytes."

Jim

Grüße, Carsten

---

From: Brian Raymor <[email-masked]>
Date: Wed, 26 Apr 2017 20:40:55 +0000

Tracking in https://github.com/core-wg/coap-tcp-tls/issues/143 for coap-tcp-tls-09.

-----Original Message-----
From: Jim Schaad [mailto:[email-masked]] 
Sent: Wednesday, April 26, 2017 4:41 AM
To: 'Carsten Bormann' <[email-masked]>; 'Christian Amsüss' <[email-masked]>
Cc: [email-masked]; 'core' <[email-masked]>
Subject: RE: [core] Is this a typo in -08

-----Original Message-----
From: Carsten Bormann [mailto:[email-masked]] 
Sent: Wednesday, April 26, 2017 2:11 AM
To: Christian Amsüss <[email-masked]>
Cc: Jim Schaad <[email-masked]>; [email-masked]; core <[email-masked]>
Subject: Re: [core] Is this a typo in -08

Yes.

Jim

Grüße, Carsten