Subject: [core] draft-ietf-core-coap-tcp-tls

From: Jim Schaad <[email-masked]>
Date: Thu, 18 May 2017 08:51:28 -0700

This document is missing any statements about making sure that the same
session (TLS, TCP, WebSockets,...) is used when matching requests and
replys.  While this may seem to be obvious, the statement does exist for
DTLS and thus should be echoed here.

Jim

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 18 May 2017 18:34:39 +0200

> DTLS and thus should be echoed here.

Hi Jim,

3.3 (for the TCP and TLS/TCP cases) says:

   Responses MUST be returned over the same connection as
   the originating request.  

and goes on:

   Concurrent requests are differentiated by
   their Token, which is scoped locally to the connection.

4.3 (for the WebSockets cases) redundantly(*) says:

   Responses MUST be returned over the same
   connection as the originating request.

and also goes on:

   Concurrent requests are
   differentiated by their Token, which is scoped locally to the
   connection.

Is there more we need to say?

Grüße, Carsten

(*) Para 1 of Section 4 says "this section only specifies the differences between the
   transports.”.  But I think it does not hurt to state this important point again.

---

From: Jim Schaad <[email-masked]>
Date: Fri, 19 May 2017 10:11:33 -0700

I was looking for something stronger - such as the language from the CoAP draft

The following rules are added for matching a response to a request:
   The DTLS session MUST be the same, and the epoch MUST be the same.

I could not find the language as I was searching for similar language dealing with matching.   The language is adequate, but something that matches the other draft would still have been my preference.   

Jim

-----Original Message-----
From: Carsten Bormann [mailto:[email-masked]] 
Sent: Thursday, May 18, 2017 9:35 AM
To: Jim Schaad <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: Re: [core] draft-ietf-core-coap-tcp-tls

On May 18, 2017, at 17:51, Jim Schaad <[email-masked]> wrote:
> 
> This document is missing any statements about making sure that the 
> same session (TLS, TCP, WebSockets,...) is used when matching requests 
> and replys.  While this may seem to be obvious, the statement does 
> exist for DTLS and thus should be echoed here.

Hi Jim,

and goes on:

and also goes on:

   Concurrent requests are

Grüße, Carsten