Subject: [core] CoAP compression is now ready to review

From: Alexander Pelov <[email-masked]>
Date: Tue, 30 May 2017 22:04:38 +0200

Dear CORE,

The Static Context Header Compression (SCHC) for CoAP, a WG item at the LPWAN WG, is now ready to receive your reviews. The draft is available here: https://tools.ietf.org/html/draft-ietf-lpwan-coap-static-context-hc-01 <https://tools.ietf.org/html/draft-ietf-lpwan-coap-static-context-hc-01>

We have done some great progress on the whole SCHC framework (the founding document is on IP/UDP) and we have seen that the CoAP SCHC is pretty stable compared to these changes. There are people that are starting to implement.. so things are moving in the right direction.

Now is the time to look at the draft and provide your feedback - especially if you spot any potential compatibility issues or possibilities for improvement. Things can (still) be modified following your input.

Also, we will soon start to ask more touchy subjects, such as adjusting timer behavior, which *COULD* adapt RFC 7252 to LPWAN characteristics. 

The next Interim meeting will be in a little bit more than a week (June 7th, 7-8am US Pacific, 4pm CEST) and we’ll continue our discussions on the topic. 

Best,
The chairs of LPWAN WG

---

From: Martin Thomson <[email-masked]>
Date: Thu, 1 Jun 2017 11:54:28 +1000

This document doesn't include a Security Considerations section.

I'd expect something on the interaction between compression and
traffic analysis.  Though I see that there might be an assumption that
encryption is not in use.

On 31 May 2017 at 06:04, Alexander Pelov <[email-masked]> wrote:
> Dear CORE,
>
> The Static Context Header Compression (SCHC) for CoAP, a WG item at the
> LPWAN WG, is now ready to receive your reviews. The draft is available here:
> https://tools.ietf.org/html/draft-ietf-lpwan-coap-static-context-hc-01
>
> We have done some great progress on the whole SCHC framework (the founding
> document is on IP/UDP) and we have seen that the CoAP SCHC is pretty stable
> compared to these changes. There are people that are starting to implement..
> so things are moving in the right direction.
>
> Now is the time to look at the draft and provide your feedback - especially
> if you spot any potential compatibility issues or possibilities for
> improvement. Things can (still) be modified following your input.
>
> Also, we will soon start to ask more touchy subjects, such as adjusting
> timer behavior, which *COULD* adapt RFC 7252 to LPWAN characteristics.
>
> The next Interim meeting will be in a little bit more than a week (June 7th,
> 7-8am US Pacific, 4pm CEST) and we’ll continue our discussions on the topic.
>
> Best,
> The chairs of LPWAN WG
>
>
> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core
>