Subject: [core] Official (de facto/de jure) API for CoAP?

From: Riccardo Bernardini <[email-masked]>
Date: Fri, 4 Aug 2017 16:56:25 +0200

Dear all,
I am planning to write a CoAP library in Ada/SPARK [1] (why? Partly because
it is fun, partly as a tough exercise in SPARK, partly for a future project
of mine).

My question is: does it exist  an official API (or a preferred one) for
CoAP?

So far

  (1)    I went to the "Implementation" page (
http://coap.technology/impls.html) where I saw several implementations, but
no reference to a common API.  I could take inspiration from an
implementation, but which one?

  (2)    I searched the mail archive for "API" (
https://mailarchive.ietf.org/arch/search/?email_list=core&gbt=1&q=API ),
but browsing the "Subject" of the resulting 139 messages, I did not see
anything promising (with the exception of "Common request/response API,"
but as I understand it is related to defining a set of exceptions)

Thank you in advance for your help

Riccardo

[1] https://en.wikipedia.org/wiki/SPARK_(programming_language)

---

From: Jim Schaad <[email-masked]>
Date: Fri, 4 Aug 2017 08:32:21 -0700

The IETF does not generally decide what APIs look like.  I am not aware of any standardized API although the one from Californium may be the closest you might get for a flavor.

Jim

From: core [mailto:[email-masked]] On Behalf Of Riccardo Bernardini
Sent: Friday, August 4, 2017 7:56 AM
To: [email-masked]
Subject: [core] Official (de facto/de jure) API for CoAP?

Dear all,

I am planning to write a CoAP library in Ada/SPARK [1] (why? Partly because it is fun, partly as a tough exercise in SPARK, partly for a future project of mine).  

My question is: does it exist  an official API (or a preferred one) for CoAP? 

So far 

  (1)    I went to the "Implementation" page (http://coap.technology/impls.html) where I saw several implementations, but no reference to a common API.  I could take inspiration from an implementation, but which one?

  (2)    I searched the mail archive for "API" ( https://mailarchive.ietf.org/arch/search/?email_list=core <https://mailarchive.ietf.org/arch/search/?email_list=core&gbt=1&q=API> &gbt=1&q=API ), but browsing the "Subject" of the resulting 139 messages, I did not see anything promising (with the exception of "Common request/response API," but as I understand it is related to defining a set of exceptions)

Riccardo

---

From: Riccardo Bernardini <[email-masked]>
Date: Fri, 4 Aug 2017 18:10:34 +0200

Thank you Jim.

On Fri, Aug 4, 2017 at 5:32 PM, Jim Schaad <[email-masked]> wrote:

> The IETF does not generally decide what APIs look like.
>

Yes, I know, and I also know that every now and then there is some
discussion if it should (but I do not want to re-ignite this discussion
here).  However, sometimes "de facto" standard APIs emerge (e.g., BSD
socket), although CoAP is maybe too young for that.

> I am not aware of any standardized API although the one from Californium
> may be the closest you might get for a flavor.
>

I'll check.  Thank you again.

Riccardo

>
>
> Jim
>
>
>
>
>
> *From:* core [mailto:[email-masked]] *On Behalf Of *Riccardo
> Bernardini
> *Sent:* Friday, August 4, 2017 7:56 AM
> *To:* [email-masked]
> *Subject:* [core] Official (de facto/de jure) API for CoAP?
>
>
>
> Dear all,
>
> I am planning to write a CoAP library in Ada/SPARK [1] (why? Partly
> because it is fun, partly as a tough exercise in SPARK, partly for a future
> project of mine).
>
> http://coap.technology/impls.html) where I saw several implementations,
> but no reference to a common API.  I could take inspiration from an