Subject: [core] draft-ietf-core-resource-directory is update atomic

From: Jim Schaad <[email-masked]>
Date: Fri, 11 Aug 2017 09:34:03 -0700

I am going through and figuring out how to implement this specification and
I came up with a questions on how things work.

1.  The document says that PATCH is supported.  What about iPATCH?

2. Are PATCH and POST update operations atomic?  Is a partial update
permitted or is that not allowed?

Jim

---

From: peter van der Stok <[email-masked]>
Date: Mon, 14 Aug 2017 09:56:23 +0200

Thanks Jim,

I try to answer below. I hope I understand the meaning correctly.

> 1.  The document says that PATCH is supported.  What about iPATCH?
Good remark. The document should probably state that both are allowed 
but iPATCH is preferred.
> 
> 2. Are PATCH and POST update operations atomic?
The spec says that registrations need to be idempotent, that is not 
repeated for the other operations (but implied?).
The update changes the lt; you might argue that this is not an 
idempotent operation as the effects at a given time changes after a 
second invocation of the same update. Nevertheless, I would call it 
idempotent.
Idempotency => atomic? (as meaning: all or nothing)
> Is a partial update
Partial updates are permitted for PATCH and also for POST under the 
conditions specified in section 5.4.1
Or is your argument that POST should not be used for partial updates.
> Jim

Hope this helps.

peter
> 
> 
> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core

---

From: Jim Schaad <[email-masked]>
Date: Mon, 14 Aug 2017 07:41:54 -0700

What I was looking at with atomic is along the lines of.

Half way through the update I find that an error will result.  Do I throw
away all the of the updates that I have done so far?

Jim

> -----Original Message-----
> From: peter van der Stok [mailto:[email-masked]]
> Sent: Monday, August 14, 2017 12:56 AM
> To: Jim Schaad <[email-masked]>
> Cc: [email-masked]; [email-masked]
> Subject: Re: [core] draft-ietf-core-resource-directory is update atomic
> 
> Thanks Jim,
> 
> > I am going through and figuring out how to implement this
> > specification and I came up with a questions on how things work.
> >
> Good remark. The document should probably state that both are allowed but
> iPATCH is preferred.
> >
repeated
> for the other operations (but implied?).
> The update changes the lt; you might argue that this is not an idempotent
> operation as the effects at a given time changes after a second invocation
of
> the same update. Nevertheless, I would call it idempotent.
> conditions specified in section 5.4.1 Or is your argument that POST should
not
> be used for partial updates.
> >
> > Jim
> 
> Hope this helps.
> 
> peter
> >
> >