Subject: Re: [core] 🔔 WGLC on draft-ietf-core-coap-senml

From: Gonzalo Camarillo <[email-masked]>
Date: Fri, 22 Sep 2017 10:29:06 +0300

Hi,

I was just having a quick look at the draft and have a couple of questions:

At the bottom of page 11:

https://tools.ietf.org/html/draft-ietf-core-senml-10#page-11

> SenML defines a
> separate media type to indicate Sensor Streaming Measurement Lists
> (SensML) for this usage (see Section 12.3.1). 

Wouldn't it be better to reference Section 12.3.2 instead?

On pages 5 and 8 positive t values are described as carrying absolute
times while negative values are described as carrying relative times:

https://tools.ietf.org/html/draft-ietf-core-senml-10#page-5

> Time is represented in floating point
> as seconds and values greater than zero represent an absolute time
> relative to the Unix epoch while values of 0 or less represent a
> relative time in the past from the current time.

https://tools.ietf.org/html/draft-ietf-core-senml-10#page-8

> A time of zero
> indicates that the sensor does not know the absolute time and the
> measurement was made roughly "now".  A negative value is used to
> indicate seconds in the past from roughly "now".  A positive value is
> used to indicate the number of seconds, excluding leap seconds, since
> the start of the year 1970 in UTC.

Nevertheless, Sections 5.1.2, 5.1.3, and 5.1.7 seem to contain positive
t times that are relative times. For example, on Section 5.1.2 (top of
page 12):

https://tools.ietf.org/html/draft-ietf-core-senml-10#page-12

> {"bn":"urn:dev:ow:10e2073a01080063","bt":1.320067464e+09,
>       "bu":"%RH","v":21.2},
>      {"t":10,"v":21.3},
>      {"t":20,"v":21.4}

Am I missing something?

Cheers,

Gonzalo

On 05/07/2017 2:23 PM, Jaime Jiménez wrote:
> 
> Dear CoRE WG,
> 
> The core-senml draft has gotten to a state that the authors feel is in
> good shape for WGLC. 
> We will do a 2 week WGLC before next IETF. 
> 
> _https://tools.ietf.org/html/draft-ietf-core-senml-10_
> 
> Best Regards,
> - - Jaime Jiménez

---

From: Jim Schaad <[email-masked]>
Date: Fri, 22 Sep 2017 22:58:19 -0700

> -----Original Message-----
> From: core [mailto:[email-masked]] On Behalf Of Gonzalo Camarillo
> Sent: Friday, September 22, 2017 12:29 AM
> To: Jaime Jiménez <[email-masked]>; [email-masked] WG
> <[email-masked]>
> Cc: [email-masked]
> Subject: Re: [core] 🔔 WGLC on draft-ietf-core-coap-senml
> 
> Hi,
> 
> On pages 5 and 8 positive t values are described as carrying absolute times
> while negative values are described as carrying relative times:
> 
> Nevertheless, Sections 5.1.2, 5.1.3, and 5.1.7 seem to contain positive t times
> that are relative times. For example, on Section 5.1.2 (top of page 12):
> 

You are missing the behavior that occurs when the "bt" time field is present.

Jim

> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core

---

From: Gonzalo Camarillo <[email-masked]>
Date: Sat, 23 Sep 2017 09:06:54 +0300

Hi Jim,

> You are missing the behavior that occurs when the "bt" time field is present.

where exactly is it defined in the draft how the presence of the bt
field modifies the meaning of the time field?

Thanks,

Gonzalo

---

From: Ari Keränen <[email-masked]>
Date: Mon, 25 Sep 2017 14:41:13 +0000

Hi Gonzalo,

> On 23 Sep 2017, at 9.06, Gonzalo Camarillo <[email-masked]> wrote:
> 
> Hi Jim,
> 

That's defined in section 4.3 (https://tools.ietf.org/html/draft-ietf-core-senml-10#page-8):

>    If either the Base Time or Time value is missing, the missing field
>    is considered to have a value of zero.  The Base Time and Time values
>    are added together to get the time of measurement.  A time of zero

And good catch with the SensML section cross-reference; I'll fix that for the next revision.

Cheers,
Ari