Subject: [core] draft-ietf-core-resource-directory-11

From: "Turner, Randy" <[email-masked]>
Date: Thu, 7 Sep 2017 14:42:57 +0000

Hi All,

There is text in section 3.1 "Principles" of the RD draft that says...

   ...snip..."it follows that no information should be stored in the
   resource directory that cannot be discovered from querying the
   described device's /.well-known/core resource directly."

This seems counter to the text in section 1 "Introduction", which says...

...snip..."These problems can be solved by employing an
   entity called a Resource Directory (RD), which hosts descriptions of
   resources held on other servers, allowing lookups to be performed for
   those resources."

Could the text in 3.1 be re-stated differently?

Randy

---

From: Jaime Jiménez <[email-masked]>
Date: Thu, 7 Sep 2017 15:39:49 +0000

Hi Randy,

Resource descriptions are links to the endpoints actually hosting the resources and providing the data. 
So the text is correct, the RD is not providing data directly.  Maybe that text can be clarified in the next version. 
I’ll added to the issue tracker for discussion: https://github.com/core-wg/resource-directory/issues <https://github.com/core-wg/resource-directory/issues> 

Ciao!
- - Jaime Jiménez

> On 7 Sep 2017, at 17.42, Turner, Randy <[email-masked]> wrote:
> 
> Hi All,
>  
> There is text in section 3.1 “Principles” of the RD draft that says…
>  
>    …snip…”it follows that no information should be stored in the
>    described device's /.well-known/core resource directly.”
>  
> This seems counter to the text in section 1 “Introduction”, which says…
>  
> …snip…”These problems can be solved by employing an
>    those resources.”
> _______________________________________________
> core mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/core <https://www.ietf.org/mailman/listinfo/core>

---

From: peter van der Stok <[email-masked]>
Date: Fri, 08 Sep 2017 09:12:54 +0200

Hi Randy,

You are right, there are some hidden assumptions in 3.1.
Rephrasing seems the best way forward.

tanks,

Peter

Turner, Randy schreef op 2017-09-07 16:42:
> Hi All,
> 
> There is text in section 3.1 "Principles" of the RD draft that says…
> 
> 
>    …snip…"it follows that no information should be stored in the
> 
> This seems counter to the text in section 1 "Introduction", which
> says…
> 
> …snip…"These problems can be solved by employing an
> 
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core