Subject: [core] Testing CoAP/TCP at the IETF100 Hackathon?

From: Carsten Bormann <[email-masked]>
Date: Sun, 5 Nov 2017 23:03:32 +0100

Maybe hidden in the Internet-Draft deadline frenzy, we have submitted -10 of the TCP/TLS draft.
This should cover the remaining IESG comments (there is still some work outstanding on coap-at://, but that will not be done in this document):

	https://tools.ietf.org/html/draft-ietf-core-coap-tcp-tls-10

In other news, the CoAP-over-TCP patch has landed for libcoap:

	https://github.com/obgm/libcoap/pull/113

I’m not entirely sure about the status of CoAP/TCP in Californium, but finding out the answer is exactly what hackathons are really good at.  And of course for aiocoap, coap.me, etc.

So who would be up to a CoAP-over-TCP session at the IETF100 hackathon?
(Local and remote participation are both fine.)
We would probably want to reserve a two-hour slot sometime during the Saturday where remote participants are sure they can find someone in the hackathon room who is also working on this.  We could meet at

	https://jitsi.tools.ietf.org/coap-tcp

Any preferences for the time on Saturday?

Grüße, Carsten

---

From: Olaf Bergmann <[email-masked]>
Date: Mon, 06 Nov 2017 16:38:22 +0100

Carsten Bormann <[email-masked]> writes:

> We would probably want to reserve a two-hour slot sometime during the
> Saturday where remote participants are sure they can find someone in
> the hackathon room who is also working on this.  We could meet at
>

I will be in UTC+1, i.e., the later the better.

Grüße
Olaf

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 10 Nov 2017 16:26:50 +0800

So we’ll meet at 15:00 Singapore time (0700Z, 08:00 CET, 09:00 EET, …) at the Hackathon room.

Grüße, Carsten

> On Nov 6, 2017, at 23:38, Olaf Bergmann <[email-masked]> wrote:
>

---

From: Christian Amsüss <[email-masked]>
Date: Sat, 11 Nov 2017 07:57:49 +0100

> I’m not entirely sure about the status of CoAP/TCP in Californium, but finding out the answer is exactly what hackathons are really good at.  And of course for aiocoap, coap.me, etc.

I've read through it (with some later notes to the issue tracker), but
didn't get around to adding TCP support to my implementation; but if any
interop testing is happening over jitsi (ie. if anyone else than libcoap
supports it yet), I'd like to listen in and maybe save myself some
detours when finally implementing it.

Best regards
Christian

-- 
To use raw power is to make yourself infinitely vulnerable to greater powers.
  -- Bene Gesserit axiom