Subject: [core] dev-urn draft update

From: Jari Arkko <[email-masked]>
Date: Fri, 3 Nov 2017 09:25:28 +0200

We updated this draft last month.

Current version: https://tools.ietf.org/html/draft-arkko-core-dev-urn-05 <https://tools.ietf.org/html/draft-arkko-core-dev-urn-05>
Changes: https://tools.ietf.org/rfcdiff?url2=draft-arkko-core-dev-urn-05.txt <https://tools.ietf.org/rfcdiff?url2=draft-arkko-core-dev-urn-05.txt>

And below is a copy of the writeup on what got changed. Discussion
on these changes would be welcome. We’ve changed the ‘;’ syntax
for instance to avoid issues with SenML. And added a way to do
local/organisation specific identifiers. Thoughts?

(And can I ask for the document to be formally posted as draft-ietf-core draft
soon?)

> Version -05 made a change to the delimiter for parameters within a
> DEV URN.  Given discussions on allowed character sets in SenML
> [I-D.ietf-core-senml <https://tools.ietf.org/html/draft-arkko-core-dev-urn-05#ref-I-D.ietf-core-senml>], we would like to suggest that the "_"
> character be used instead of ";", to avoid the need to translate DEV
> URNs in SenML-formatted communications or files.  However, this
> reverses the earlier decision to not use unreserved characters.  This
> also means that device IDs cannot use "_" characters, and have to
> employ other characters instead.  Feedback on this decision is
> sought.
> 
> Version -05 also introduced local or organisation-specific device
> identifiers.  Organisations are identified by their PEN number
> (although we considered FQDNs as a potential alternative.  The
> authors belive an organisation-specific device identifier type will
> make experiments and local use easier, but feedback on this point and
> the choice of PEN numbers vs. other possible organisation identifiers
> would be very welcome.
> 
> Version -05 also added some discussion of privacy concerns around
> long-term stable identifiers.
> 
> Finally, version -05 clarified the situations when new allocations
> within the registry of possible device identifier subtypes is
> appropriate.

---

From: Peter Saint-Andre <[email-masked]>
Date: Mon, 6 Nov 2017 15:24:06 -0700

On 11/3/17 1:25 AM, Jari Arkko wrote:
> Current version: https://tools.ietf.org/html/draft-arkko-core-dev-urn-05

RFC 8141 has obsoleted RFC 2141. As a result, the registration template
and process have changed. Please refer to RFC 8141 for instructions.
This will require modifications to Section 3.

The syntactic structure definition says "The identifier is expressed in
ASCII (UTF-8) characters", but it's not clear why UTF-8 is cited here.
It's all just ASCII, no?

The changes between -04 and -05 look reasonable to me.

Peter

---

From: Jari Arkko <[email-masked]>
Date: Tue, 7 Nov 2017 01:06:25 +0200

Thanks for your comments, Peter!

RFC 8141 reference was already updated in my private copy (thanks for the PR, Ari).

I see your point Peter about the UTF-8 reference. Have edited my copy again.

Jari

---

From: Peter Saint-Andre <[email-masked]>
Date: Mon, 6 Nov 2017 16:09:30 -0700

> RFC 8141 reference was already updated in my private copy (thanks for the PR, Ari).

It's not just the reference - the registration template changed, too.

Peter

---

From: Christian Amsüss <[email-masked]>
Date: Mon, 13 Nov 2017 19:27:43 +0100

Hello Jari,

> local/organisation specific identifiers. Thoughts?

I'd like to propose the slash ('/') for the separator. It is in the
allowed set for SenML, and since RFC8141 is legal for URNs.

If the slash was allowed to be used, urn:dev: addresses could be used
together with protocol-negotiation similar to ocf:// addresses, where a
resource directory can be used to turn a URN about a resource on a
device into a URL that can be used, depending on the protocol.

Best regards
Christian

-- 
To use raw power is to make yourself infinitely vulnerable to greater powers.
  -- Bene Gesserit axiom

---

From: Jari Arkko <[email-masked]>
Date: Tue, 14 Nov 2017 12:45:03 +0800

In today’s meeting I have a brief slot to discuss the DEV URN draft. I’ve previously posted about the changes in -05, and gotten on- and off-list feedback. Thanks! 

My slides for today list the following topics for discussion:

• Thoughts on the delimiter change? Breaks any existing usage?

• Thoughts on local device identifiers?

• Adding device IDs specified in OneM2M and LWM2M (urn:dev:os and urn:dev:ops)? And would BBF USP protocol identifiers be useful to add as well?

• Peter: Needs to use the new URN registration template

• Fix a mistake in ABNF (org: vs. dn:)

• Draft adoption? Was briefly discussed last time, but we haven’t actually done it, either as AD sponsored or as WG draft… I think the latter would be the way to go, personally.

Jari

---

From: Peter Saint-Andre <[email-masked]>
Date: Mon, 20 Nov 2017 10:09:51 -0700

> • Draft adoption? Was briefly discussed last time, but we haven’t actually done it, either as AD sponsored or as WG draft… I think the latter would be the way to go, personally.

Agreed on making it a WG document (not that it's strictly necessary).

Peter