Subject: Re: [Crypto-panel] [Cfrg] I-D Action: draft-irtf-cfrg-re-keying-08.txt

From: "Paterson, Kenny" <[email-masked]>
Date: Sun, 29 Oct 2017 16:08:02 +0000

Dear CFRG panel members,

draft-irtf-cfrg-re-keying-08
(https://tools.ietf.org/html/draft-irtf-cfrg-re-keying-08) is ready for
panel review. 

Any volunteers to look at this one?

(We don't expect too many more review requests for a while after this and
draft-mcgrew-hash-sigs.)

Regards,

Kenny  

On 09/10/2017 16:14, "Stanislav V. Smyshlyaev" <[email-masked]> wrote:

>Dear colleagues,
>
>
>In Prague, we listed several todo's about our Re-keying draft; thanks to
>the efforts of the persons listed in the contributors and "thanks to"
>lists now we have a new version, addressing the comments and concerns
>that have been
> discussed earlier.
>There have been several updates of the draft, major changes from the July
>version (discussed at IETF 99 CFRG meeting) are the following:
>
>
>1) New test examples have been added: external re-keying with a parallel
>construction based on AES-256, external re-keying with a serial
>construction based on SHA-256, OMAC-ACPKM-Master mode with AES-256,
> as agreed.
>2) CCM-ACPKM and CCM-ACPKM-Master, OFB-ACPKM-Master modes have been
>removed from the document, as agreed.
>3) “Key Hierarchy Construction” section has been added.
>4) The more restrictive terminology for different types of keys has been
>introduced: "initial key", "section key" (data processing key in internal
>re-keying), "master key", "section key material", "subkey",
> "frame key" (data processing key in external re-keying).
>5) The additional hash calculation for ICB value (if c!=32) has been
>removed from GCM-ACPKM and GCM-ACPKM-Master modes.
>
>
>The current version
>(https://tools.ietf.org/html/draft-irtf-cfrg-re-keying-08) seems to take
>all concerns and considerations we've discussed (in Chicago, in Prague
> and in e-mails) into account – please let me know if we've missed
>something. If there won't be any objections, I think we should start
>thinking about moving to the review phase.
>
>
>Kindest regards,
>Stanislav
>
>
>
>
>
>
>
>
>2017-10-09 17:36 GMT+03:00 <[email-masked]>:
>
>
>A New Internet-Draft is available from the on-line Internet-Drafts
>directories.
>This draft is a work item of the Crypto Forum RG of the IRTF.
>
>        Title           : Re-keying Mechanisms for Symmetric Keys
>        Author          : Stanislav Smyshlyaev
>        Filename        : draft-irtf-cfrg-re-keying-08.txt
>        Pages           : 49
>        Date            : 2017-10-09
>
>Abstract:
>   A certain maximum amount of data can be safely encrypted when
>   encryption is performed under a single key.  This amount is called
>   "key lifetime".  This specification describes a variety of methods to
>   increase the lifetime of symmetric keys.  It provides external and
>   internal re-keying mechanisms based on hash functions and on block
>   ciphers, that can be used with modes of operations such as CTR, GCM,
>   CBC, CFB and OMAC.
>
>
>The IETF datatracker status page for this draft is:
>https://datatracker.ietf.org/doc/draft-irtf-cfrg-re-keying/
>
>There are also htmlized versions available at:
>https://tools.ietf.org/html/draft-irtf-cfrg-re-keying-08
>https://datatracker.ietf.org/doc/html/draft-irtf-cfrg-re-keying-08
>
>A diff from the previous version is available at:
>https://www.ietf.org/rfcdiff?url2=draft-irtf-cfrg-re-keying-08
>
>
>Please note that it may take a couple of minutes from the time of
>submission
>until the htmlized version and diff are available at
>tools.ietf.org <http://tools.ietf.org>.
>
>Internet-Drafts are also available by anonymous FTP at:
>ftp://ftp.ietf.org/internet-drafts/
>
>_______________________________________________
>Cfrg mailing list
>[email-masked]
>https://www.irtf.org/mailman/listinfo/cfrg
>
>
>
>
>
>

---

From: Yaron Sheffer <[email-masked]>
Date: Sun, 29 Oct 2017 18:16:41 +0200

Hi Kenny,

I can take this one, but it will be more than a few days. What is the 
time expectation?

Thanks,
	Yaron

On 29/10/17 18:08, Paterson, Kenny wrote:
> Crypto-panel mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/crypto-panel
>

---

From: "Paterson, Kenny" <[email-masked]>
Date: Sun, 29 Oct 2017 16:43:12 +0000

Hi Yaron,

Thanks.

A couple of weeks would be fine I think - the authors can't make any
changes now before IETF 100 anyway, because of the cutoff for new drafts.

Cheers,

Kenny

---

From: Yaron Sheffer <[email-masked]>
Date: Sun, 29 Oct 2017 18:52:17 +0200

Sounds good, count me in.

---

From: Russ Housley <[email-masked]>
Date: Sun, 29 Oct 2017 14:59:31 -0400

I have already read it and provided comments.  My name was on an earlier version.  It deserves another set of eyes.

Russ

> On Oct 29, 2017, at 12:08 PM, Paterson, Kenny <[email-masked]> wrote:
> 
> Dear CFRG panel members,
>