Subject: [dane] Let's all take a deep breath and SLOW DOWN (was Re: WG Last Call item: PKIX validation)

From: Zack Weinberg <[email-masked]>
Date: Thu, 23 Feb 2012 11:25:28 -0800

On Thu, Feb 23, 2012 at 9:05 AM, Paul Hoffman <[email-masked]> wrote:
>> It is clear to me that I
>> did not make an adequate case for the change I want, but due to
>> deadlines on an unrelated project, I have not had time to do any
>> research with which to make a better case.
>
> If the WG does not support you now, you can still make this argument in IETF Last Call.

You are effectively saying that you believe this document to be *done*
and you do not want to hear different from anyone.  This is consistent
with the responses that other people (notably John Gilmore) are
getting, but it is exceedingly demotivating.

It has already been made abundantly clear that presentation
improvements are unwelcome, even where desperately needed; and it has
also become apparent that the group is uninterested in "minor"
technical problems.  But I am trying to convince you that there is a
*showstopper* bug here, and apparently you don't want to hear about
that, either.

I realize that there's been a lot of filibustering and attempted
mission creep in this WG and perhaps everyone is tired of thinking
about this document and *wants* it to be done, but that doesn't make
it done.  It seems far more important to me that this document be
*completely correct* when first published than that it get out the
door soon.  Is there a publication deadline I am unaware of?  What,
precisely, is the hurry?

If what you are really trying to communicate is that I have no
credibility whatsoever with this WG and I should stop wasting my time,
I'd be grateful if you would just say so.  I do have plenty of other
things I could be working on.  But if not, please, everyone, let's not
rush this through WGLC.  Let's slow down, calm down, and get it right.

zw

---

From: Paul Hoffman <[email-masked]>
Date: Thu, 23 Feb 2012 11:39:44 -0800

On Feb 23, 2012, at 11:25 AM, Zack Weinberg wrote:

> and you do not want to hear different from anyone.  

Don't put words in my mouth. I am definitely (not effectively) saying that WG Last Call is an appropriate time to discuss open issues before sending a document to the IETF. The document is clearly *not done* because we have gotten many good comments during WG LC that have gotten consensus. Jakob and I will make those changes.

> This is consistent

The fact that you, or John, make requests for changes that are not supported by others in the WG should not be demotivating. That's part of the process.

> improvements are unwelcome, even where desperately needed;

That's bullshit. Presentation improvements suggested by the WG have been added almost every other draft.

> and it has

Truth be told, I don't want to hear it the third time when the WG has shown no interest earlier.

> door soon.  Is there a publication deadline I am unaware of?  

No.

> What,

There is none. The fact that people disagree with you and don't want to hear your same arguments again doesn't mean that there is a hurry, does it?

> I'd be grateful if you would just say so.

I wouldn't try to communicate that to you because it isn't true.

>  I do have plenty of other

There has bee a *lot* of good discussion in WG LC on lots of issues. Your insinuation that, because we aren't waiting for you to re-explain this one point we must be rushing, is kind of insulting to the rest of the people who have been on top of the discussion.

--Paul Hoffman

---

From: Ondřej Surý <[email-masked]>
Date: Thu, 23 Feb 2012 21:05:48 +0100

Hi all,

<chair hat>
it looks like we are on the verge of a very nice flamewar, which I would personally like to prevent.  So I am asking anybody to stick to the technical views and if feel a great urge to respond, please don't send the email immediately, but wait a hour, re-read the mail and rethink if you really need to send it.

Chairs would also like to ask anybody to contact them directly ([email-masked]) if you think that the working group opinion has been ignored or we made any other error in handling the consensus in the working group.
</chair hat>

Ondrej&Warren
--
 Ondřej Surý
 vedoucí výzkumu/Head of R&D department
 -------------------------------------------
 CZ.NIC, z.s.p.o.    --    Laboratoře CZ.NIC
 Americka 23, 120 00 Praha 2, Czech Republic
 mailto:[email-masked]    http://nic.cz/
 tel:+420.222745110       fax:+420.222745112
 -------------------------------------------