Subject: Re: [dane] New Version Notification for draft-hoffman-dane-smime-03.txt

From: Paul Hoffman <[email-masked]>
Date: Fri, 9 Mar 2012 10:53:06 -0800

We have updated the S/MIME draft based on some new interest from a few folks. We cleaned up one technical detail (look for "Base32"), and added a privacy-related security consideration.

We'll work on this more after the TLSA document is finished, but if others are also interested, please get in touch with Jakob and I.

--Paul Hoffman

On Mar 9, 2012, at 10:44 AM, [email-masked] wrote:

> A new version of I-D, draft-hoffman-dane-smime-03.txt has been successfully submitted by Paul Hoffman and posted to the IETF repository.
> 
> Filename:	 draft-hoffman-dane-smime
> Revision:	 03
> Title:		 Using Secure DNS to Associate Certificates with Domain Names For S/MIME
> Creation date:	 2012-03-09
> WG ID:		 Individual Submission
> Number of pages: 6
> 
> Abstract:
>   S/MIME uses certificates for authenticating and encrypting messages.
>   Users want their mail user agents to securely associate a certificate
>   with the sender of an encrypted and/or signed message.  DNSSEC
>   provides a mechanism for a zone operator to sign DNS information
>   directly.  This way, bindings of certificates to users within a
>   domain are asserted not by external entities, but by the entities
>   that operate the DNS.  This document describes how to use secure DNS
>   to associate an S/MIME user&#39;s certificate with the intended domain
>   name.

---

From: James Cloos <[email-masked]>
Date: Fri, 09 Mar 2012 16:50:17 -0500

My local cache hasn't got -03 yet, but from a quick look at 02,
there should be some text on how to deal with non-ascii username
strings (even if only to say that they are encoded just like any
other non-ascii dns name).  <[email-masked]> might make a
good example.  ☺

-JimC
-- 
James Cloos <[email-masked]>         OpenPGP: 1024D/ED7DAEA6

---

From: Paul Hoffman <[email-masked]>
Date: Fri, 9 Mar 2012 14:24:12 -0800

> other non-ascii dns name).  <[email-masked]> might make a

Already covered in -03. When you read the draft, if you think we need to add more text about this, let us know.

--Paul Hoffman