Subject: [dc] Service Orchestration Protocol

From: "Ashish Dalela (adalela)" <[email-masked]>
Date: Thu, 16 Feb 2012 22:36:10 +0530

Folks,

This may not be completely relevant to the DC topic, but thought that
some of you might be interested in it.

We have a few drafts posted on a "Service Orchestration Protocol", with
the intent to enable cloud interoperability.

http://tools.ietf.org/html/draft-dalela-orchestration-00 - talks about
why we need a protocol, a.k.a. requirements

http://tools.ietf.org/html/draft-dalela-sop-architecture-00 - describes
the use-cases and network deployments with the protocol

http://tools.ietf.org/html/draft-dalela-sop-00 - describes the
protocol's messages

http://tools.ietf.org/html/draft-dalela-sdf-00 - describes scheme for
service naming, workflows, etc.

http://tools.ietf.org/html/draft-dalela-sop-flows-00 - describes some
message flows

A discussion alias https://www.ietf.org/mailman/listinfo/sop is setup
for you to participate in case you find it interesting.

Thanks and look forward to discussing there.

-Ashish

---

From: Bhumip Khasnabish <[email-masked]>
Date: Thu, 16 Feb 2012 15:57:25 -0500

Hello Ashish,

There is also a Cloud Service Broker draft

http://tools.ietf.org/id/draft-shao-opsawg-cloud-service-broker-02.txt
Thanks.

Best.

Bhumip

On Thu, Feb 16, 2012 at 12:06 PM, Ashish Dalela (adalela) <[email-masked]
> wrote:

>  Folks,****
>
> ** **
>
> This may not be completely relevant to the DC topic, but thought that some
> of you might be interested in it.****
>
> ** **
>
> We have a few drafts posted on a “Service Orchestration Protocol”, with
> the intent to enable cloud interoperability.****
>
> ** **
>
> why we need a protocol, a.k.a. requirements****
>
> the use-cases and network deployments with the protocol****
>
> http://tools.ietf.org/html/draft-dalela-sop-00 - describes the protocol’s
> messages****
>
> service naming, workflows, etc.****
>
> message flows****
> ** **
> A discussion alias https://www.ietf.org/mailman/listinfo/sop is setup for
> you to participate in case you find it interesting.****
>
> ** **
>
> Thanks and look forward to discussing there.****
>
> ** **
>
> -Ashish****
>
> ** **
>
> _______________________________________________
> dc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dc
>
>

---

From: "Ashish Dalela (adalela)" <[email-masked]>
Date: Fri, 17 Feb 2012 08:02:22 +0530

Bhumip,

Thanks, I'm aware of this draft. We should discuss it on the SOP alias
as not to clutter everyone's email with a topic that may not be of
interest. I'm cross posting this to SOP alias for now.

One of things that the first draft describes is limitations of HTTP (and
by implication web-services) for doing cloud - HTTP does not have
constructs to do service discovery, pub-sub, commit-cancel, transaction
forking, interactive prompts, etc. These capabilities are
service-independent (applicable to all services) and very important to
build complex, multi-tiered, or cross-domain services. 

So, we did not want to add just a new content-type to HTTP, and layer
basic capability into the controller application. The idea here is that
if there are service independent capabilities, they should be part of a
basic protocol scheme, which can be used by every type of service. But
we preserved the text-based nature of well-known L7 protocols - SIP,
HTTP, SMTP, etc. 

To the specific issue of broker, you might want to refer to the
architecture draft, where we described different types of brokers (we
call them proxies). The functionality in the broker differs depending on
where you place the broker - in the service edge, customer edge,
provider edge, etc. We expect that different domains (compute, storage,
network ..) will have different domain controllers. You still need to
find an interoperable scheme to stitch these domain controllers.

Thanks, Ashish

From: Bhumip Khasnabish [mailto:[email-masked]] 
Sent: Friday, February 17, 2012 2:27 AM
To: Ashish Dalela (adalela)
Cc: [email-masked]
Subject: Re: [dc] Service Orchestration Protocol

Hello Ashish,

Thanks.

Best.

Bhumip

On Thu, Feb 16, 2012 at 12:06 PM, Ashish Dalela (adalela)
<[email-masked]> wrote:

Folks,

-Ashish

---

From: Bhumip Khasnabish <[email-masked]>
Date: Thu, 16 Feb 2012 21:45:19 -0500

Thanks for your quick comments Ashish. I am cc:ing my co-authors for
reviewing your comments and suggestions, and the SOP drafts for further
discussion.

Best.

Bhumip

On Thu, Feb 16, 2012 at 9:32 PM, Ashish Dalela (adalela)
<[email-masked]>wrote:

>  Bhumip,****
>
> ** **
>
> Thanks, I’m aware of this draft. We should discuss it on the SOP alias as
> not to clutter everyone’s email with a topic that may not be of interest.
> I’m cross posting this to SOP alias for now.****
>
> ** **
>
> by implication web-services) for doing cloud – HTTP does not have
> build complex, multi-tiered, or cross-domain services. ****
>
> ** **
>
> basic capability into the controller application. The idea here is that if
> there are service independent capabilities, they should be part of a basic
> protocol scheme, which can be used by every type of service. But we
> preserved the text-based nature of well-known L7 protocols – SIP, HTTP,
> SMTP, etc. ****
>
> ** **
>
> architecture draft, where we described different types of brokers (we call
> them proxies). The functionality in the broker differs depending on where
> you place the broker – in the service edge, customer edge, provider edge,
> etc. We expect that different domains (compute, storage, network ..) will
> have different domain controllers. You still need to find an interoperable
> scheme to stitch these domain controllers.****
>
> ** **
>
> Thanks, Ashish****
>
> ** **
>
> *From:* Bhumip Khasnabish [mailto:[email-masked]]
> *Sent:* Friday, February 17, 2012 2:27 AM
> *To:* Ashish Dalela (adalela)
> *Cc:* [email-masked]
> *Subject:* Re: [dc] Service Orchestration Protocol****
>
> ** **
>
> Hello Ashish,****
>
>  ****
>
> There is also a Cloud Service Broker draft****
>
>  ****
>
> http://tools.ietf.org/id/draft-shao-opsawg-cloud-service-broker-02.txt ***
> *
>
> Thanks.****
>
>  ****
>
> Best.****
>
>  ****
>
> Bhumip****
>
>
>  ****
>
> On Thu, Feb 16, 2012 at 12:06 PM, Ashish Dalela (adalela) <
> [email-masked]> wrote:****
>
> Folks,****
>
>  ****
>
>  ****
>  ****
>  ****
>  ****
>  ****
>  ****
> https://www.ietf.org/mailman/listinfo/dc****
>
>
>
>
>   ****
>