Subject: I-D ACTION:draft-ietf-dhc-nextserver-00.txt

From: Ralph Droms <[email-masked]>
Date: Thu, 20 Jan 2000 08:38:15 -0500

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Dynamic Host Configuration Working Group 
of the IETF.

	Title		: DHCP Next Server Option
	Author(s)	: J. Privat, M. Borella
	Filename	: draft-ietf-dhc-nextserver-00.txt
	Pages		: 6
	Date		: 19-Jan-00
	
This proposal allows host configuration to be split between two
different address servers, potentially under different
administration.
This ability may be useful to satisfy specific regulatory,
operational or business model requirements, as well as to
provide support for secondary address servers.  This draft
proposes a new DHCP option called the DHCP Next Server option.
A DHCP server can use this option to redirect clients to a
secondary server.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-dhc-nextserver-00.txt

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
	"get draft-ietf-dhc-nextserver-00.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-ietf-dhc-nextserver-00.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

--NextPart
Content-Type: Multipart/Alternative; Boundary="OtherAccess"

--OtherAccess
Content-Type: Message/External-body;
	access-type="mail-server";
	server="[email-masked]"

Content-Type: text/plain
Content-ID:	<[email-masked]>

ENCODING mime
FILE /internet-drafts/draft-ietf-dhc-nextserver-00.txt

--OtherAccess
Content-Type: Message/External-body;
	name="draft-ietf-dhc-nextserver-00.txt";
	site="ftp.ietf.org";
	access-type="anon-ftp";
	directory="internet-drafts"

Content-Type: text/plain
Content-ID:	<[email-masked]>

--OtherAccess--

--NextPart--

---

From: [email-masked]
Date: Thu, 20 Jan 2000 16:58:01 -0000

This new proposed option is pretty straightforward
and can be used by a DHCP server to redirect a
client to a secondary configuration server.

If you have comments on the draft, please send them
to the list.

Thanks,
Jerome Privat,
BT

-----Original Message-----
From: Ralph Droms [mailto:[email-masked]]
Sent: 20 January 2000 13:38
To: dhcp-v4
Subject: I-D ACTION:draft-ietf-dhc-nextserver-00.txt

A New Internet-Draft is available from the on-line Internet-Drafts
directories.
This draft is a work item of the Dynamic Host Configuration Working Group 
of the IETF.

Send a message to:
	[email-masked].
In the body type:

--NextPart

--OtherAccess

Content-Type: text/plain

ENCODING mime

--OtherAccess

Content-Type: text/plain

--OtherAccess--

--NextPart--

---

From: "Henry, Mike" <[email-masked]>
Date: Fri, 21 Jan 2000 10:55:42 -0800

It seems to me that that the draft has a number of weaknesses. It relies os
an explicit IP address, and only one address.  That is, there is no
provision for more than one secondary config server of a particular type. At
a minimum, the ability to provide a list of IP addresses for the client to
try would provide some robustness to address the case where the one and only
secondary config server is down.  Also, there is the question of config
server types.... how does one define a third or fourth  type beyond DHCP and
RSIP-FRAME? Perhaps it would make sense to propose an IANA administered list
so vendors with new config server types could simply register the type?

Finally, it really seems to me that this is just the sort of thing that SLP
(Service Location Protocol) was designed to address. Rather than an ad hoc
option to address this particular case, why not discover the secondary
config server via SLP? This gets the DHCP admin out of the business of
tracking yet another special server type as being of interest to his/her
community, and gets the admin out of the business of tracking down and
maintaining the server's IP address in this context.

Mike H.  
Intel

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Thursday, January 20, 2000 8:58 AM
To: [email-masked]
Subject: RE: I-D ACTION:draft-ietf-dhc-nextserver-00.txt

Thanks,
Jerome Privat,
BT

-----Original Message-----
From: Ralph Droms [mailto:[email-masked]]
Sent: 20 January 2000 13:38
To: dhcp-v4
Subject: I-D ACTION:draft-ietf-dhc-nextserver-00.txt

	

Send a message to:
	[email-masked].
In the body type:

--NextPart

--OtherAccess

Content-Type: text/plain

ENCODING mime

--OtherAccess

Content-Type: text/plain

--OtherAccess--

--NextPart--

---

From: "Mike Borella" <[email-masked]>
Date: Mon, 24 Jan 2000 08:05:49 -0600

The first two points are easily addressed.

SLP is an option and I believe that some people are
currently writing a draft.  However, RSIP will be deployed
on legacy networks that don't necessarily support SLP.
Having an emerging technology rely on another emerging
technology is not a robust solution, especially given that
DHCP solves the problem in a very elegant fashion.

-Mike

[email-masked] on 01/21/2000 10:59:21 PM

Sent by:  [email-masked]

To:   [email-masked]
cc:    (Mike Borella/MW/US/3Com)
Subject:  DHCP-V4 digest 13

                   DHCP-V4 Digest 13

Topics covered in this issue include:

  1) RE: I-D ACTION:draft-ietf-dhc-nextserver-00.txt
     by "Henry, Mike" <[email-masked]>

Message-ID: <[email-masked]>
From: "Henry, Mike" <[email-masked]>
To:  <[email-masked]>
Subject: RE: I-D ACTION:draft-ietf-dhc-nextserver-00.txt
Date: Fri, 21 Jan 2000 10:55:42 -0800
MIME-Version: 1.0
Content-Type: text/plain;     charset="windows-1252"

Mike H.
Intel

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Thursday, January 20, 2000 8:58 AM
To: [email-masked]
Subject: RE: I-D ACTION:draft-ietf-dhc-nextserver-00.txt

Thanks,
Jerome Privat,
BT

-----Original Message-----
From: Ralph Droms [mailto:[email-masked]]
Sent: 20 January 2000 13:38
To: dhcp-v4
Subject: I-D ACTION:draft-ietf-dhc-nextserver-00.txt

Send a message to:
     [email-masked].
In the body type:

--NextPart

--OtherAccess

Content-Type: text/plain

ENCODING mime

--OtherAccess

Content-Type: text/plain

--OtherAccess--

--NextPart--