Subject: RE: Help! Static route option

From: Eric Michelsen <[email-masked]>
Date: Mon, 24 Jan 2000 07:17:57 -0800

I'm all for deprecating it when the route-with-mask option is available.
Even so, it will take a while before all the DHCP servers support it, so it
may still be reasonable to clarify its use until a better option is
available.
-------------------------------------------
Eric L. Michelsen, Copper Mountain Networks 

> -----Original Message-----
> From: Ted Lemon [mailto:[email-masked]]
> Sent: Monday, January 24, 2000 6:27
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: Help! Static route option 
> 
> 
> 
> > I believe this option is currently mandatory for 
> configuring the default
> > route in a host
> 
> Actually, you can use the routers option to configure the default
> route.  That's what, e.g., Windows 95 does.   I don't *think* Win95
> will even take the default route from the static routes option,
> although I could be mistaken.
> 
> > Though somewhat confusing, perhaps a reasonable 
> interpretation of the static
> > routes option is this: if the class-ful interpretation of 
> the route has host
> > bits set, it's a host route.  Otherwise, it's a network 
> route with the
> > class-ful mask.
> 
> The protocol specification doesn't say this, so I think it would be a
> mistake to assume it.   This option is simply not useful anymore, and
> hasn't been for several years.   The right thing to do is deprecate
> it.
> 
> 			       _MelloN_
>

---

From: Ted Lemon <[email-masked]>
Date: Mon, 24 Jan 2000 10:24:18 -0500

> may still be reasonable to clarify its use until a better option is

Clarifying it doesn't make sense when talking about existing
implementations - they are already doing whatever they're going to do,
which normally will be to not request the option and to ignore it if
it's received.   We don't _want_ future implementations, so
clarification doesn't help there either.

The current option _doesn't work_, so there is simply no point in
anybody ever implementing it, clarification or no.   I will try to
have a draft out today for a classless static routes option, and then
we can stop arguing about this.

			       _MelloN_