Subject: no subnet declaration

From: Rod Wrege <[email-masked]>
Date: Thu, 17 Feb 2000 12:55:13 -0600

I installed dhcp-2.0 from isc.org onto a Calder Linux system with 2.2
kernel.  When I execute dhcpd I get the following message:
no subnet declaration for eth0 (209.18.254.222)
dhcpd: exiting

my dhcpd.conf file contains the following:

subnet 209.18.254.192 netmask 255.255.255.224 {
  range 209.18.254.194 209.18.254.206;
  option broadcast-address 209.18.254.223;
  option routers 209.18.254.193;
}

Any suggestions?
--
Rod Wrege, Director
Southwest Telecommunications Cooperative
507.831.6950
fax: 507.831.6944
[email-masked]

---

From: "HIBBS, BARR (SBCSI)" <[email-masked]>
Date: Thu, 17 Feb 2000 14:16:28 -0800

> From: 	Rod Wrege[SMTP:[email-masked]]
> Sent: 	Thursday, February 17, 2000 10:55 AM
> 
...mmmmm.... that's curious!  Given a 27-bit subnet mask, addresses 192-223
are valid for the subnet.  Your range excludes 192, 193, and 207-223, and
your other uses seem appropriate.  I see no obvious typos, either.

The message normally means that dhcpd.conf does not have a valid subnet
declaration that includes the server interface, but that can't be the case
here.

As an experiment, change the subnet mask to 255.255.255.0 and try to start
the server.  If the server starts with that declaration, then you've found
an interesting bug!  I'll also try to recreate the problem to see what I
find....

--Barr