Subject: Comments on draft-ietf-dhc-userclass-05.txt

From: Steve Gonczi <[email-masked]>
Date: Fri, 3 Mar 2000 14:51:28 -0500

Hello,

I believe the N and Ln fields should be 2 byte fields. 
It is quite possible, that the individual class values end up longer than
255
esp. if the values are generated by some ticket issuing authority /
self-registration server. (In practice, these class values may end up being 
certificates, or some simpler authenticated tickets).

Also, it would be quite useful to include start and end time subfields for
each class 
value. (Something like time_t formatted UTC values... 32 bit NBO etc..
etc..)
The obvious use of the end time is to provide a ttl for the ticket (a.k.a
class x )
and the start time could be used for reserving resources for a specific time
slot.
E.g.: to schedule a video conference ahead of time.

/Steve Gonczi
Process Software Corporation

---

From: "Privat,J,Jerome,NZD3 PRIVATJ R" <[email-masked]>
Date: Fri, 10 Mar 2000 11:48:44 -0000

Thanks for your comments.

I agree with having 2-bytes fields for N and Ln.
I will change it in the next version of the draft.

I have no problem with adding a start and end time
subfield for each user class value. But I would like
to know if other people implementing this option
think is a good idea?
Can people implementing the User Class option
(Ted and others) say if they agree on the list?
If we have consensus, I will make the addition in
the next version of the draft.

Thanks,
Jerome 

-----Original Message-----
From: Steve Gonczi [mailto:[email-masked]]
Sent: 03 March 2000 19:51
To: DHCPv4 discussion list
Subject: Comments on draft-ietf-dhc-userclass-05.txt

Hello,

/Steve Gonczi