Subject: User Class draft

From: [email-masked]
Date: Wed, 3 May 2000 14:56:56 +0100

<draft-ietf-dhc-userclass-06.txt> includes the last changes agreed on this
list. It has been out for a couple of weeks now without further comments.

Could we go to WG Last Call for this draft?

Jerome Privat,
BT

---

From: [email-masked]
Date: Thu, 4 May 2000 09:59:47 +0100

Thanks all for your comments.
See my answers below.

1- Length of the option
I will modify the text to say:
" Let n be the number of User Classes carried in the
option.
The length of the option as specified in Len must be the sum
of the lengths of each of the class names plus n:
Len= Len1 + Len2 + ...+ Lenn + n."

2- Multiple User classes
I will add Kim's comment:
"Servers may interpret the meanings of multiple class
specifications in an implementation dependent or
configuration dependent manner, and so the use of multiple
classes by a DHCP client should be based on the specific server
implementation and configuration which will be used to process
that User class option".

3- Security section
I will add to the end of the security section:
"This lack of authentication mechanism means that a DHCP server
cannot check if a given client or user is authorised to use a
given User Class."

4- Name of the option
I would prefer not to add anything here.
The User Class option neither identifies a user or a client.
Several clients can use the same User Class.
For me the term "User" refers to the fact that a user should
be able to configure this option.

I will add all these modifications into version -07 of the
draft if there are no further objections.

Jerome Privat
BT

---

From: [email-masked]
Date: Tue, 30 May 2000 09:28:14 +0100

I agree with Ted on all the points.
>From Ted's and Barr's emails and from previous discussion on
this list, I think there is WG consensus NOT to add
an optional expiration field to the individual classes.

Jerome

-----Original Message-----
From: Ted Lemon [mailto:[email-masked]]
Sent: 26 May 2000 19:20
To: DHCPv4 discussion list
Cc: DHCPv4 discussion list
Subject: Re: User Class draft 

> How do y'all feel about adding an optional expiration field to the
> individual classes?

No.   The draft is in last call.   Please don't try to change it.

> After all, these are credentials of sorts..

No.   These are not credentials.  They are a voluntary description,
provided by the client.   The DHCP authentication draft talks about
credentials.   The user class has nothing to do with credentials.

> Keep in mind that  an user class may be used for a specific, short-term
> purpose ( e.g.: to grant extra bandwith for a video conference).

This is not what the user class option is for.

> Also, do not take it for granted that this will work sort of like a
> password.
> (i.e. the user enters it somehow on the host..)
> It is perfectly conceivable, that in real life, a CMTS will tag it on,
> similarly
> to the relay agent option.

This is not what the draft says.   The draft says that the option is
provided by the client, and that the DHCP client should have a
mechanism for letting the *user* specify the class.

> I understand the desire to make this simple, but there is also a need to
> make it
> useful.

You want a different option that does something different.   Please
propose that option, rather than trying to piggyback your needs onto
an existing option that does something else.

			       _MelloN_