Subject: RE: Quick Poll - RE: draft-ietf-dhc-csr-02.txt - Allow router to be 0 .0.0.0?

From: [email-masked]
Date: Thu, 22 Jun 2000 14:48:38 -0700

I don't think it's a bad idea at all, but I share the reservations about
putting
it into this draft. It feels like a substantial blurring of the DHCP
protocol
boundary, and I think it might well delay the acceptance of the draft.
For that reason, I'd vote for leaving it out and trying in a separate effort
to institute this.

Regards,
Richard Jones
Check Point Software, Inc.

	-----Original Message-----
	From:	Bernie Volz [SMTP:[email-masked]]
	Sent:	Thursday, June 22, 2000 2:02 PM
	To:	DHCPv4 discussion list
	Subject:	Quick Poll - RE: draft-ietf-dhc-csr-02.txt - Allow
router to be 0 .0.0.0?

	Folks:

	I have suggested to Ted that he consider adding text to Classless
Static
	Routing (CSR) draft to allow the router IP address to be 0.0.0.0 for
some
	routes. If the router IP address is 0.0.0.0, the client (if it
supports it)
	should install a route such that the destination is directly
reachable on
	the interface being configured.

	The concept behind this is that it easily allows for probably one of
the
	most useful proposes of routing information to be given to clients
in the
	first place. That of supporting multiple subnets on the same
physical wire.
	This is often a difficult issue since there is no standard (at least
to my
	knowledge) for ICMP Redirects to communicate this.

	If a client does not support the concept of such routes, it would
ignore
	that particular route.

	Ted is somewhat cautious about adding this text as there is no
precedent for
	it anywhere else yet and he (as I) would like to see the CSR draft
go to the
	IESG as soon as possible.

	So, how do people feel about this?
	- Do you feel it is worth adding it?
	- Do you fear it would delay the draft?
	- Do you think it is a bad idea in the first place?

	Thanks for your prompt attention.

	- Bernie Volz
	  IPWorks, Inc.

---

From: Bernie Volz <[email-masked]>
Date: Mon, 26 Jun 2000 21:05:12 -0400

Ralph:

To save option space, having a separate option (IMHO) is not a good idea. It
is routing information - plain and simple.

I don't really know why it would slow down the draft.

- Bernie Volz
  IPWorks, Inc.

-----Original Message-----
From: Ralph Droms [mailto:[email-masked]]
Sent: Monday, June 26, 2000 8:52 PM
To: [email-masked]; DHCPv4 discussion list
Subject: Re: Quick Poll - RE: draft-ietf-dhc-csr-02.txt - Allow router
to be 0 .0.0.0?

I would be inclined to specify the list of networks local to the
interface as a separate option.  It's different information
(and should be carried in a different option), there's no need
to carry the 4 bytes of zeroes with every entry and it would slow
down draft-ietf-dhc-csr-02.txt.

- Ralph

At 05:02 PM 6/22/00 -0400, Bernie Volz wrote:
>I have suggested to Ted that he consider adding text to Classless Static
>Routing (CSR) draft to allow the router IP address to be 0.0.0.0 for some
>routes. If the router IP address is 0.0.0.0, the client (if it supports it)
>should install a route such that the destination is directly reachable on

---

From: Ralph Droms <[email-masked]>
Date: Mon, 26 Jun 2000 21:17:57 -0400

>is routing information - plain and simple.

It would save option space to combine the local subnets
information into the static routes option.  In my opinion,
we have option codes for both options and I think the
two kinds of routing information are different.

>I don't really know why it would slow down the draft.

I think it already has (although not much!) - if we
hadn't had this discussion, draft-ietf-dhc-csr-02.txt
would have been ready to go for PS.

- Ralph

---

From: Eric Michelsen <[email-masked]>
Date: Tue, 27 Jun 2000 01:44:04 -0700

> From: Bernie Volz [mailto:[email-masked]]
> Sent: Thursday, June 22, 2000 14:02
> router to be
> 0 .0.0.0?
...
> - Do you think it is a bad idea in the first place?

I don't think it's worth adding, just because I don't see much value to it.
I think there's a risk of slowing down the draft, because it's not standard,
and will require frequent re-explanation.  But I don't see any major problem
with it, though.