Subject: RE: I-D ACTION:draft-ietf-dhc-agent-options-11.txt

From: "Kostur, Andre" <[email-masked]>
Date: Thu, 27 Jul 2000 11:57:01 -0700

Question about the content of the suboptions:

Is the data within the suboptions necessarily printable? (IE: 7-bit ASCII?)

The ambiguity (for me) arises in sections 3.1 and 3.2 where it mentions:

"The Circuit ID SHOULD be considered an opaque value, with policies based on
exact string match only,..."

Now if the options aren't necessarily printable, shouldn't the wording
reflect that you're not doing an exact string match, but an exact binary
data match?  Or am I reading to much into the meaning of the word "string" ?

--------------------------------------
Andre Kostur
Incognito Software Inc.
Ph: (604)688-4332   Fax: (604)688-4339
http://www.incognito.com

---

From: Ted Lemon <[email-masked]>
Date: Thu, 27 Jul 2000 13:59:48 -0700

> data match?  Or am I reading to much into the meaning of the word "string" ?

You are reading too much into it, but this is a fairly common thing -
many people at Microsoft have misread other portions of the
specification in this way.   So I think your proposed change in
wording is good, although it's a bit late in the game to be changing
the document...   :'}

			       _MelloN_