Subject: Any C++ Client Source Code?

From: Bob Evans <[email-masked]>
Date: Fri, 18 Aug 2000 09:14:35 -0500

I am integrating ISC's C source into our C++ environment (Solaris).  This is
proving to be a tedious exercise.  Are there any C++/Unix sources available
for DHCP clients?  We need to develop a customized client for our
application.

Thanks, Bob.
-
============================
Bob Evans, Principal Engineer
Distributed Processing Environment Team
Network Systems Lab
Samsung Telecommunications America
1130 E. Arapaho Road
Richardson, TX  75081

---

From: Ted Lemon <[email-masked]>
Date: Fri, 18 Aug 2000 11:28:40 -0400

> proving to be a tedious exercise.

It seems like it would be about a day's work, right?

> Are there any C++/Unix sources available

There is a Java DHCP library that might help you, but of course that
would require rototilling as well.  Can't you just slap 'extern "C" {}'
around the dhclient declarations?

			       _MelloN_