Subject: Re: how to simulate multiple DHCP clients ?

From: Fabrice Kah <[email-masked]>
Date: Thu, 10 Aug 2000 10:20:33 +0200 (CEST)

How do I pretend to be a DHCP forwarding agent? 
Is it possible to do this on a windows NT workstation?

I managed to make a DHCP forwarding agent using a
Cisco router, but this doesn't help.

thank you for your help.

Fabrice KAH
[email-masked]
+33 (0) 4 92 11 41 04

--- C J Considine <[email-masked]> a écrit : >
Just pretend to be a DHCP forwarding agent.  Then
> you can script
> as many clients as you want without messing with
> multiple MAC
> addresses. All you really lose is client pingability
> and server
> ARP table overhead.  It is also possible to hack the
> DHCP client
> to run multiple interfaces with funny MAC addresses,
> but what
> does it gain?  We built a database of test packets
> and responses,
> with 10 second lease times it tests quickly.
> 
> Fabrice Kah wrote:
> > 
> > hello,
> > 
> > In order to test a DHCP server, I need to simulate
> > multiple DHCP clients (50 to 500 at the same
> time). I
> > would like to know if it is possible to do this
> using
> > only a few workstations, with a few network cards.
> > I tried to do this using a windowsNT workstation,
> by
> > changing the value
> >
>
HKEY_LOCAL_MACHINE/System/CurrentControlSet/Services/IBMTRP1/Parameters/Tcpip/DhcpClientIdentifier
> > in the registery, but this doesn't seem to work
> for
> > more than 3 clients. Can anyone help me or tell me
> if
> > there is a way to do this on Solaris or on Linux ?
> > ___________________________
> > Fabrice KAH
> > [email-masked]
> > +33 (0) 4 92 11 41 04
> > 
> >
>
___________________________________________________________
> > Do You Yahoo!?
> > Achetez, vendez! À votre prix! Sur
> http://encheres.yahoo.fr
> 

=====
____________________________________________
Fabrice Kah
355, Chemin des Serens
06610 La Gaude - FRANCE

tel.  (0033)4.93.24.82.97
port. (0033)6.63.06.99.04

___________________________________________________________
Do You Yahoo!?
Achetez, vendez! À votre prix! Sur http://encheres.yahoo.fr

---

From: Ralph Droms <[email-masked]>
Date: Thu, 10 Aug 2000 06:53:29 -0400

>Is it possible to do this on a windows NT workstation?

I don't know if it's possible to configure NT to act as a forwarding agents 
and as multiple clients.  You may need a special application that generates 
and receives DHCP client messages.  A student of mine wrote such a tool - 
jDHCP - but he graduated and it's not available on line this AM.  I expect 
to move the code and make it publicly accessible again later today.  I'll 
post a note with the new location for the code later today...

- Ralph Droms

---

From: Ted Lemon <[email-masked]>
Date: Thu, 10 Aug 2000 11:48:56 -0400

> Is it possible to do this on a windows NT workstation?

You're going to have to write some code.   I'd suggest doing it on
Linux or BSD rather than NT, because if you do that there is
freely-available code from which you can start - for example, the ISC
DHCP distribution.

			       _MelloN_