Subject: Re: DHCP server startup announcement

From: "Mark Hinckley" <[email-masked]>
Date: Mon, 25 Sep 2000 16:49:23 -0600

>> However, this could become complicated by many implementations that attach
>> the relay agent to the physical interfaces of a network instead of the
>> virtual in an HSRP or VRRP environment.  In an environment where more than a
>> simple pairing of HSRP or VRRP exists, we could introduce some serious
>> instabilities.  
>
> In this case, the server has to know that this is going on.
> Obviously it only needs to send to one of the router addresses on a
> given physical network.
>
>> Wouldn't this announcement have to be periodic to do any good anyway?
>
> Nope.   If the server is up when the client comes up, the client will
> discover it.  It's only if the server _isn't_ up when the client
> starts that the client needs to get this message.
>
>                   _MelloN_

This is true in a perfectly connected world.  But if the server is up, and then a client comes up,
but the router between them is down temporarily, when will the discovery be done without
a periodic broadcast?   That is not to say there aren't other problems with periodic broadcasts.

---

From: Ted Lemon <[email-masked]>
Date: Mon, 25 Sep 2000 17:13:26 -0700

> This is true in a perfectly connected world.  But if the server is up, and =
> then a client comes up,
> but the router between them is down temporarily, when will the discovery =
> be done without
> a periodic broadcast?   That is not to say there aren't other problems =
> with periodic broadcasts.

You can't win.   You can only increase the reliability level.   Router
outages are (I suspect) uncommon compared to DHCP server outages, at
least in situations where DHCP service is being provided across the
router.   The likelihood that both would happen at the same time is
small - normally servers take longer to recover after a power failure
than routers - so I really don't think this is a big problem,
certainly not one that would justify broadcasts to the entire set of
networks a DHCP server supports more frequently than a client would
retry.

			       _MelloN_