Subject: AW: [Dime] RE: Diameter MIPv6

From: "Tschofenig, Hannes" <[email-masked]>
Date: Wed, 5 Apr 2006 12:19:10 +0200

Gerardo, maybe you also want to change the title of the draft and the
serious formatting problem.
 
Ciao
Hannes

________________________________

	Von: [email-masked] [mailto:[email-masked]] 
	Gesendet: Mittwoch, 5. April 2006 12:17
	An: [email-masked];
[email-masked]; [email-masked]
	Cc: [email-masked]; [email-masked];
[email-masked]; [email-masked]
	Betreff: RE: [Dime] RE: Diameter MIPv6

	Gerardo,

	I think this seems like a reasonable approach.  When you have a
version for review, let me know.
	 
	John

________________________________

		From: ext Giaretta Gerardo
[mailto:[email-masked]] 
		Sent: 05 April, 2006 13:01
		To: Hannes Tschofenig; [email-masked]
		Cc: Demaria Elena; Patil Basavaraj (Nokia-NET/Dallas);
[email-masked]; Guardini Ivano
		Subject: [Dime] RE: Diameter MIPv6

		Hi Hannes and John,
		
		I'm working on a new version of the draft based on
comments I received in Dallas. If you can review the document and have
additional comments, please provide them. I think the draft may be in a
good shape by next IETF if there will be good reviews from MIP6 WG.
		
		As a side note, the draft will encompass all AAA
requirements for MIPv6, both for AAA-HA and AAA-NAS interface, and both
for integrated and split scenario. Therefore I think we may have one
document in DIME WG, since many components of integrated and split
solutions are common.
		
		Regards,
		--Gerardo

		-----Original Message-----
		From: Hannes Tschofenig
[mailto:[email-masked]]
		Sent: Wed 4/5/2006 11:44 AM
		To: [email-masked]; [email-masked];
[email-masked]; Guardini Ivano; Giaretta Gerardo; Demaria
Elena; [email-masked]; [email-masked]
		Subject: Diameter MIPv6
		
		Hi all,
		
		the MIP6 bootstrapping design team has worked on two
solutions for 
		bootstrapping of MIPv6: the integrated and the split
scenario
		
		These two solutions are documented in two separate
drafts:
		
		MIP6-bootstrapping via DHCPv6 for the Integrated
Scenario
	
http://www.ietf.org/internet-drafts/draft-ietf-mip6-bootstrapping-integr
ated-dhc-00.txt
		
		Mobile IPv6 bootstrapping in split scenario
	
http://www.ietf.org/internet-drafts/draft-ietf-mip6-bootstrapping-split-
02.txt
		
		As such, there is the question whether the work in DIME
should also 
		produce two separate documents referring to these two
bootstrapping 
		deployment scenarios or whether it would be useful to
captures both 
		scenarios in a single document.
		
		Thoughts?
		
		Ciao
		Hannes & John
		
		PS: John and myself would also like to know when the
MIP6-AAA Goals draft
	
http://www.ietf.org/internet-drafts/draft-ietf-mip6-aaa-ha-goals-01.txt
		is going to be finalized since the Diameter MIPv6 work
depends on this 
		document.

		

--------------------------------------------------------------------
		CONFIDENTIALITY NOTICE
		This message and its attachments are addressed solely to
the persons
		above and may contain confidential information. If you
have received
		the message in error, be informed that any use of the
content hereof
		is prohibited. Please return it immediately to the
sender and delete
		the message. Should you have any questions, please
contact us by
		replying to [email-masked]
<mailto:[email-masked]> .
		        Thank you
	
www.telecomitalia.it <http://www.telecomitalia.it> 
	
--------------------------------------------------------------------

_______________________________________________
DiME mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dime

---

From: "Gopal Dommety \(gdommety\)" <[email-masked]>
Date: Wed, 5 Apr 2006 11:55:18 -0700

single document makes sense. Unless there is compelling reason to do
otherwise.
 
Thank You,
Gopal
--------------------------------------------------------
       Judgement hinders imagination
----------------------------------------------------------

	From: Basavaraj Patil [mailto:[email-masked]] 
	Sent: Wednesday, April 05, 2006 8:16 AM
	To: Giaretta Gerardo; Hannes Tschofenig; [email-masked]
	Cc: [email-masked]; [email-masked]; Guardini
Ivano; Demaria Elena; Gopal Dommety (gdommety)
	Subject: Re: Diameter MIPv6

	I agree with Gerardo. We need a single document in DIME.
	
	-Raj

	On 4/5/06 5:01 AM, "ext Giaretta Gerardo"
<[email-masked]> wrote:

		Hi Hannes and John,

		
		Regards,
		--Gerardo

		-----Original Message-----
		From: Hannes Tschofenig
		 
		Hi all,

		

	

		Thoughts?
		
		Ciao
		Hannes  John

		

<mailto:[email-masked]> <mailto:[email-masked]>
.
		        Thank you
	
www.telecomitalia.it <http://www.telecomitalia.it>
<http://www.telecomitalia.it>

---

From: "Tschofenig, Hannes" <[email-masked]>
Date: Thu, 6 Apr 2006 14:52:46 +0200

Hi Julien, 

this is my impression was well. Working on the document I got the impression that they are sufficiently different in order to deal with the bootstrapping solutions in a separate document. 

Ciao
Hannes

> -----Ursprüngliche Nachricht-----
> Von: Julien Bournelle [mailto:[email-masked]] 
> Gesendet: Donnerstag, 6. April 2006 14:41
> An: Julien Bournelle
> Cc: [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]
> Betreff: [Dime] Re: Diameter MIPv6
> 
> Hi all,
> 
>  For the Integrated scenario we need to:
>  - define AVPs (HA)
>  - explain where to put it in the Diameter EAP/NASREQ 
> exchanges (between
>    NAS and the AAA)
>  - probably require a Application-ID for that the NAS announces to the
>    AAA that it support the Integrated case.
> 
>  For the split scenario, we need to:
>  - explain how the HA uses Diameter EAP. (HA uses IKEv2 with MN) 
>  - maybe some issues may raised after investigation (do the HA need to
>    tell to the AAA that it is a HA and not a NAS ? this sort 
> of things).
> 
>  So at this point of time, I think it would be better to investigate
>  this separately and see later if it makes sense to merge the 
> documents.
>  I don't really see the advantage of having one document for 
> the moment.
> 
>  Regards,
> 
>  Julien B.
> 
> On Wed, Apr 05, 2006 at 12:42:26PM +0200, Julien Bournelle wrote:
> > Hi all,
> > 
> > On Wed, Apr 05, 2006 at 11:44:37AM +0200, Hannes Tschofenig wrote:
> > > Hi all,
> > > 
> > > bootstrapping of MIPv6: the integrated and the split scenario
> > > 
> > > These two solutions are documented in two separate drafts:
> > > 
> > > MIP6-bootstrapping via DHCPv6 for the Integrated Scenario
> > > 
> http://www.ietf.org/internet-drafts/draft-ietf-mip6-bootstrapp
> ing-integrated-dhc-00.txt
> > > 
> http://www.ietf.org/internet-drafts/draft-ietf-mip6-bootstrapp
> ing-split-02.txt
> > > 
> >  I would prefer two documents. I have two reasons for this:
> > 
> >  1/ In the integrated scenario, the AAA is used between NAS 
> and AAA. The
> >  HA address is delivered from the AAA to the NAS and thus 
> NASREQ or EAP
> >  may be in used.
> > 
> >   In the split scenario, Diameter is used between HA and 
> the AAA. And
> >   the AAA does not deliver the HA to the HA...
> > 
> > 
> >  2/ From an implementation perspective, it would be easier to have a
> >  specific document for each case.
> > 
> >  Julien B.
> > 
> > > 
> > > Ciao
> > > Hannes & John
> > > 
> > -- 
> > julien.bournelle at int-evry.fr
> 
> -- 
> julien.bournelle at int-evry.fr
>