Subject: [Dime] draft-tschofenig-dime-mip6-integrated-00.txt

From: <[email-masked]>
Date: Wed, 5 Apr 2006 00:18:43 +0200

Hi,

In Dallas meeting during the Diameter MIPv6 presentation 
few questions were raised/asked:

  Integrated scenario solution uses Diameter application.
  Questions:
   o Application vs. attributes
   o Interworking with NASREQ and EAP 
   o MIPv4 interaction (dual stacked hosts)

I looks like reusing NASREQ & EAP rather than defining
new commands would be the way to go. However, the question
still remains whether new applications are needed or
would just a set of AVPs be sufficient?

The MIPv4 support for dual stack cases (as worked in
MIP6 WG) would require transporting MIPv4 HA address
along with the MIPv6 stuff. MIP6 WG comment on this
was that "...if you are using DHCP (integrated scenario)
to deliver the IPv4 address of the HA, you would need
some AAA work."

Any thoughts & comments?

Cheers,
	Jouni

> Hi all,
> 
> we should work on a draft update for
> <>. We have discussed
> a number of issues already but we haven't reached a 
> conclusion about the
> application vs. attribute question.
> 
> Another important aspect: I do not want to be the editor nor the main 
> author of the document. It would be great if someone could 
> volunteer to 
> take this position, if the person really has time.
> 
> Ciao
> Hannes
> 
> 

_______________________________________________
DiME mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dime

---

From: Julien Bournelle <[email-masked]>
Date: Wed, 5 Apr 2006 10:54:01 +0200

Hi jouni, all,

 thanks for bringing this up.

> would just a set of AVPs be sufficient?

 Personnally, I tend to think that we don't need new messages and thus
 new Command-Code. Thus, only AVPs are sufficient and explain where to
 put them in the flow of messages for NASREQ/EAP.

 However, if we want that the AAA server knows that the NAS support the
 "mip6-integrated" scenario, the NAS may advertise this (in CER/CEA)
 and thus we also need to request an Application-ID for mip6-integrated.

> to deliver the IPv4 address of the HA, you would need

 I have some doubts about including this at this point. The reason is
 that delivering IPv4 HA address to the MN is not described in the
 Integrated scenario draft. I would prefer that this feature be added in
 this draft (mip6) and then include it in the DiME draft.

 what do you think ?

 Julien B.

-- 
julien.bournelle at int-evry.fr

---

From: <[email-masked]>
Date: Wed, 5 Apr 2006 13:18:36 +0300

Julien,

>> I looks like reusing NASREQ & EAP rather than defining new commands 
>> would be the way to go. However, the question still remains whether 
>> new applications are needed or would just a set of AVPs be 
>sufficient?
>
> Personnally, I tend to think that we don't need new messages 
>and thus  new Command-Code. Thus, only AVPs are sufficient and 
>explain where to  put them in the flow of messages for NASREQ/EAP.
>
> However, if we want that the AAA server knows that the NAS 
>support the  "mip6-integrated" scenario, the NAS may advertise 
>this (in CER/CEA)  and thus we also need to request an 
>Application-ID for mip6-integrated.

I strongly suggest having an application ID for this.

>> MIP6 WG) would require transporting MIPv4 HA address along with the 
>> MIPv6 stuff. MIP6 WG comment on this was that "...if you are using 
>> DHCP (integrated scenario) to deliver the IPv4 address of the HA, you

>> would need some AAA work."
>
> I have some doubts about including this at this point. The 
>reason is  that delivering IPv4 HA address to the MN is not 
>described in the  Integrated scenario draft. I would prefer 
>that this feature be added in  this draft (mip6) and then 
>include it in the DiME draft.
>
> what do you think ?

As a high-level comment, it might be interesting to have a solution that
works with dual-stack MIP, but I'd like to see if others are interested
in it as well.

John