Subject: RE: [Dime] assure proxies can remain in the path of all requests inasession?

From: "Glen Zorn \(gwz\)" <[email-masked]>
Date: Wed, 12 Apr 2006 17:20:49 -0700

zhangtao <mailto:[email-masked]> supposedly scribbled:

> References: <[email-masked]>
>  <[email-masked]>
>  <[email-masked]>
> 
> In my Idea,now Diameter Message routing  base on Destination Realm
> and Destination Host.if one route entry  have two peer entry,it
> cannot assure start session use first Peer,the stop session will use
> first peer also.   
> 
> if one route table  have only one peer entry,then no problem,this
> means all message will route same nodes. 
> 
> I think this will restrict operator contruct his network.also can not
> meet the network reliability requirment. 
> 
> I suggest extend Diameter route policy,maybe  reference sip or IP
> protocol 

Possibly the problem here is that you appear to believe that IP is a circuit-switched protocol.

> 
> ----- Original Message -----
> From: "Tina TSOU" <[email-masked]>
> To: <[email-masked]>
> Sent: Wednesday, April 12, 2006 2:59 PM
> Subject: [Dime] assure proxies can remain in the path of all requests
> in asession? 
> 
> 
>> Hi all,
>> Consider the WLAN 3GPP IP access [23.234]. The WLAN Access Network
>> (WLAN AN) uses EAP over RADIUS/DIAMETER with the 3GPP AAA server (or
>> proxy) for authentication & authorization.  
>> In the roaming case, the WLAN AN is communicating with a 3GPP AAA
>> Proxy in the visited network over the Wa reference point. The 3GPP
>> AAA proxy is connected to the 3GPP Server in the home network over
>> the Wd reference point.  The 3GPP AAA Proxy among its many functions
>> will enforce local policies on access based on agreement with the
>> 3GPP Home Network and with the WLAN operator. It will also send per
>> user charging information for the session to the Offline Charging
>> system. This necessitates the proxy to maintain the session state
>> information and hence remain in-path for the entire session. How to
>> assure proxies can remain in the path of all requests in a session? 
>> 
>> B. R.
>> Tina
>> Messengers:
>> MSN: [email-masked]   Yahoo: tina_tsou    Skype: tinaTSOU   
>>  Jabber: [email-masked]
>> _______________________________________________ 
>>> DiME mailing list
>>> [email-masked]
>>> https://www1.ietf.org/mailman/listinfo/dime
>> 
>> _______________________________________________
>> DiME mailing list
>> [email-masked]
>> https://www1.ietf.org/mailman/listinfo/dime
> 
> _______________________________________________
> DiME mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/dime

Hope this helps,

~gwz

Why is it that most of the world's problems can't be solved by simply
  listening to John Coltrane? -- Henry Gabriel

_______________________________________________
DiME mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dime

---

From: zhangtao <[email-masked]>
Date: Thu, 13 Apr 2006 09:33:47 +0800

if the proxy agent is just relay agent, i agree with you.Because he no need maintain session state,he need credit authorization.he no need bill etc.the visited network is free service,inter-operator no need hide network topology.

In my knowledge,  ipv6 protocol have Routing Header.Sip protocl have Route Header, 
Both use for force route to some hop.Both is Ip-switched protocol.

----- Original Message ----- 
From: "Glen Zorn (gwz)" <[email-masked]>
To: "zhangtao" <[email-masked]>; "Tina TSOU" <[email-masked]>
Cc: <[email-masked]>
Sent: Thursday, April 13, 2006 8:20 AM
Subject: RE: [Dime] assure proxies can remain in the path of all requests inasession?

Hope this helps,

~gwz