Subject: RE: [Dime] assure proxies can remain in the path of all requests inasession?

From: "Glen Zorn \(gwz\)" <[email-masked]>
Date: Wed, 12 Apr 2006 19:25:00 -0700

zhangtao <mailto:[email-masked]> supposedly scribbled:

> if the proxy agent is just relay agent, i agree with you.Because he
> no need maintain session state,he need credit authorization.he no
> need bill etc.the visited network is free service,inter-operator no
> need hide network topology.   
> 
> In my knowledge,  ipv6 protocol have Routing Header.Sip protocl have
> Route Header, Both use for force route to some hop.Both is
> Ip-switched protocol.

So you want to source-route Diameter messages.  Excellent.  Please carry on.  

~gwz

Why is it that most of the world's problems can't be solved by simply
  listening to John Coltrane? -- Henry Gabriel

_______________________________________________
DiME mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dime

---

From: zhangtao <[email-masked]>
Date: Thu, 13 Apr 2006 11:17:03 +0800

First we should  discuss about the requirment,non-first message of session should force routing some proxy agents.
if the requirment is required, non-first message of session  should specify these proxy agents address,othewise use destion-host and destion realm cannot assure routing these proxy agents.

we can reference the sip protocol implement.the first message of session.collect proxy agent address information.
,when send non-first message of session.should give all proxy agent address informaiton also.

----- Original Message ----- 
From: "Glen Zorn (gwz)" <[email-masked]>
To: "zhangtao" <[email-masked]>; "Tina TSOU" <[email-masked]>
Cc: <[email-masked]>
Sent: Thursday, April 13, 2006 10:25 AM
Subject: RE: [Dime] assure proxies can remain in the path of all requests inasession?

~gwz

---

From: Victor Fajardo <[email-masked]>
Date: Wed, 12 Apr 2006 17:54:29 -0400

if you can relay route-record avp (generated in first request) from 
final destination back to the originator in the answer messages, your 
proxies can pick those records and maybe able to determine possible next 
hops for subsequent request ... a poor man's source routing.
regards,
victor

---

From: zhangtao <[email-masked]>
Date: Fri, 14 Apr 2006 14:07:25 +0800

if destination give  route record back,because route record maybe have relay agent information,then should strictly route all same hop,but this path maybe not  reliable,if only have stateful proxy agent information back,it is wonderful.then can select any relay agent.