Subject: RE: [Dime] Re: Diameter MIPv6

From: <[email-masked]>
Date: Thu, 6 Apr 2006 14:58:50 +0200

I would also go for two different documents because of the
differences in solution approaches and for the general
clarity.

Cheers,
	Jouni

> -----Original Message-----
> From: Tschofenig, Hannes [mailto:[email-masked]] 
> Sent: 6. huhtikuuta 2006 15:53
> To: Julien Bournelle
> Cc: [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]
> Subject: AW: [Dime] Re: Diameter MIPv6
> 
> Hi Julien, 
> 
> this is my impression was well. Working on the document I got 
> the impression that they are sufficiently different in order 
> to deal with the bootstrapping solutions in a separate document. 
> 
> Ciao
> Hannes
>  
> 
> > -----Ursprüngliche Nachricht-----
> > Von: Julien Bournelle [mailto:[email-masked]] 
> > Gesendet: Donnerstag, 6. April 2006 14:41
> > An: Julien Bournelle
> > Cc: [email-masked]; [email-masked]; 
> > [email-masked]; [email-masked]; 
> > [email-masked]; [email-masked]
> > Betreff: [Dime] Re: Diameter MIPv6
> > 
> > Hi all,
> > 
> >  For the Integrated scenario we need to:
> >  - define AVPs (HA)
> >  - explain where to put it in the Diameter EAP/NASREQ 
> > exchanges (between
> >    NAS and the AAA)
> >  - probably require a Application-ID for that the NAS 
> announces to the
> >    AAA that it support the Integrated case.
> > 
> >  For the split scenario, we need to:
> >  - explain how the HA uses Diameter EAP. (HA uses IKEv2 with MN) 
> >  - maybe some issues may raised after investigation (do the 
> HA need to
> >    tell to the AAA that it is a HA and not a NAS ? this sort 
> > of things).
> > 
> >  So at this point of time, I think it would be better to investigate
> >  this separately and see later if it makes sense to merge the 
> > documents.
> >  I don't really see the advantage of having one document for 
> > the moment.
> > 
> >  Regards,
> > 
> >  Julien B.
> > 
> > On Wed, Apr 05, 2006 at 12:42:26PM +0200, Julien Bournelle wrote:
> > > Hi all,
> > > 
> > > On Wed, Apr 05, 2006 at 11:44:37AM +0200, Hannes Tschofenig wrote:
> > > > Hi all,
> > > > 
> > > > the MIP6 bootstrapping design team has worked on two 
> > solutions for 
> > > > bootstrapping of MIPv6: the integrated and the split scenario
> > > > 
> > > > These two solutions are documented in two separate drafts:
> > > > 
> > > > MIP6-bootstrapping via DHCPv6 for the Integrated Scenario
> > > > 
> > http://www.ietf.org/internet-drafts/draft-ietf-mip6-bootstrapp
> > ing-integrated-dhc-00.txt
> > > > 
> > > > Mobile IPv6 bootstrapping in split scenario
> > > > 
> > http://www.ietf.org/internet-drafts/draft-ietf-mip6-bootstrapp
> > ing-split-02.txt
> > > > 
> > > > As such, there is the question whether the work in DIME 
> > should also 
> > > > produce two separate documents referring to these two 
> > bootstrapping 
> > > > deployment scenarios or whether it would be useful to 
> > captures both 
> > > > scenarios in a single document.
> > > > 
> > > > Thoughts?
> > > 
> > >  I would prefer two documents. I have two reasons for this:
> > > 
> > >  1/ In the integrated scenario, the AAA is used between NAS 
> > and AAA. The
> > >  HA address is delivered from the AAA to the NAS and thus 
> > NASREQ or EAP
> > >  may be in used.
> > > 
> > >   In the split scenario, Diameter is used between HA and 
> > the AAA. And
> > >   the AAA does not deliver the HA to the HA...
> > > 
> > > 
> > >  2/ From an implementation perspective, it would be 
> easier to have a
> > >  specific document for each case.
> > > 
> > >  Julien B.
> > > 
> > > > 
> > > > Ciao
> > > > Hannes & John
> > > > 
> > > > PS: John and myself would also like to know when the 
> > MIP6-AAA Goals draft
> > > > 
> > http://www.ietf.org/internet-drafts/draft-ietf-mip6-aaa-ha-goa
> > ls-01.txt
> > > > is going to be finalized since the Diameter MIPv6 work 
> > depends on this 
> > > > document.
> > > 
> > > -- 
> > > julien.bournelle at int-evry.fr
> > 
> > -- 
> > julien.bournelle at int-evry.fr
> > 
> > _______________________________________________
> > DiME mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/dime
> > 
> 
> _______________________________________________
> DiME mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/dime
> 

_______________________________________________
DiME mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dime

---

From: "Junghoon Jee" <[email-masked]>
Date: Fri, 7 Apr 2006 08:54:22 +0900

Hi all,

I'd suggest to having _two_ DIME drafts for integrated and split case
because the overall bootstrapping procedures are different in each case.
Please take a look at the current suggested drafts from Hannes,
then might be in the same line with me.   :-)

As a side note: 
Listing up AAA requirements through _single_ document is still valid
as I mentioned in the previous MIP6 WG meeting.

Thanks,
-Junghoon

----- Original Message ----- 
From: <[email-masked]>
To: <[email-masked]>; <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>; <[email-masked]>; <[email-masked]>; <[email-masked]>; <[email-masked]>
Sent: Thursday, April 06, 2006 9:58 PM
Subject: RE: [Dime] Re: Diameter MIPv6

Cheers,
Jouni