Subject: Re: [Dime] assure proxies can remain in the path of all requests in asession?

From: zhangtao <[email-masked]>
Date: Wed, 12 Apr 2006 15:43:07 +0800

References: <[email-masked]>
 <[email-masked]>
 <[email-masked]>

In my Idea,now Diameter Message routing  base on Destination Realm and Destination Host.if one route entry  have two peer entry,it cannot assure start session use first Peer,the stop session will use first peer also.

if one route table  have only one peer entry,then no problem,this means all message will route same nodes.

I think this will restrict operator contruct his network.also can not meet the network reliability requirment.

I suggest extend Diameter route policy,maybe  reference sip or IP protocol  

----- Original Message ----- 
From: "Tina TSOU" <[email-masked]>
To: <[email-masked]>
Sent: Wednesday, April 12, 2006 2:59 PM
Subject: [Dime] assure proxies can remain in the path of all requests in asession?

> Hi all,
> Consider the WLAN 3GPP IP access [23.234]. The WLAN Access Network (WLAN AN) uses EAP over RADIUS/DIAMETER with the 3GPP AAA server (or proxy) for authentication & authorization. 
> In the roaming case, the WLAN AN is communicating with a 3GPP AAA Proxy in the visited network over the Wa reference point. The 3GPP AAA proxy is connected to the 3GPP Server in the home network over the Wd reference point.  The 3GPP AAA Proxy among its many functions will enforce local policies on access based on agreement with the 3GPP Home Network and with the WLAN operator. It will also send per user charging information for the session to the Offline Charging system. This necessitates the proxy to maintain the session state information and hence remain in-path for the entire session. 
> How to assure proxies can remain in the path of all requests in a session?
> 
> B. R.
> Tina
> Messengers: 
> MSN: [email-masked]   Yahoo: tina_tsou    Skype: tinaTSOU    Jabber: [email-masked]
>  _______________________________________________
> > DiME mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/dime
> 
> _______________________________________________
> DiME mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/dime

_______________________________________________
DiME mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dime

---

From: "Tolga Asveren" <[email-masked]>
Date: Wed, 12 Apr 2006 07:58:37 -0400

> In my Idea,now Diameter Message routing  base on Destination
> Realm and Destination Host.if one route entry  have two peer
> entry,it cannot assure start session use first Peer,the stop
> session will use first peer also.
[TOLGA]The behavior you described is achieved by populating Destination-Host
AVP for the non-first messages of a session. this assures that all of them
land on the same node.

---

From: zhangtao <[email-masked]>
Date: Thu, 13 Apr 2006 09:10:07 +0800

Think about below situation:
Client - Relay Agent - Proxy Agent1 - Server
                                -  Proxy Agent2 
client directly connection to realy agent.realy agent connection two proxy agent(Prxoy agent1 and Proxy agent2),both proxy agent can route to server.

Non -First Message is base on Destion-Host,only can assure Go to the same server,but cannot assure route to same prxoy agent(maybe all agent).when client send message ,in peer table cannot find server,then will use Destion Realm,if have two peer entry in the route entry,it can select any one.maybe we can think about client record his first message of a session.then he use same Next Hop.
but if have relay agent,how to do,we cannot requirment,realy agent record any information about session. so the message it can select proxy agent1 or proxy agent2. assume first session message route by proxy agent1. non first session message route by prxoy agent2,then proxy agent1 maintain session state will bring problem.

---

From: "Tolga Asveren" <[email-masked]>
Date: Thu, 13 Apr 2006 08:55:14 -0400

> client directly connection to realy agent.realy agent connection
> two proxy agent(Prxoy agent1 and Proxy agent2),both proxy agent
> can route to server.
>
> Non -First Message is base on Destion-Host,only can assure Go to
> the same server,but cannot assure route to same prxoy agent(maybe
> all agent).when client send message ,in peer table cannot find
> server,then will use Destion Realm,if have two peer entry in the
> route entry,it can select any one.maybe we can think about client
> record his first message of a session.then he use same Next Hop.
> but if have relay agent,how to do,we cannot requirment,realy
> agent record any information about session. so the message it can
> select proxy agent1 or proxy agent2. assume first session message
> route by proxy agent1. non first session message route by prxoy
> agent2,then proxy agent1 maintain session state will bring problem.
[TOLGA}Yes, you are right, but by keeping next-hop per session info, you can
guarantee the delivery to the same Proxy Agent. Now, you can argue, whether
such a node should be called Relay Agent or something else but I believe
naming won't cause interoprability problems.
Alternatively -mentioned by Vishnu already- you can actually proxy the
service you are providing, where Proxy1/Proxy2 populate Origin-Host AVP with
their thir identities for the answer of the first request in the session.
This would require Proxy1/Proxy2 to keep states and modify the content of
the messages but if they are built for that purpose, there probably wouldn't
be a problem.

---

From: zhangtao <[email-masked]>
Date: Fri, 14 Apr 2006 16:59:28 +0800

Please Sess Inline
----- Original Message ----- 
From: "Tolga Asveren" <[email-masked]>
To: <[email-masked]>
Sent: Thursday, April 13, 2006 8:55 PM
Subject: RE: [Dime] assure proxies can remain in the path of allrequestsinasession?

> naming won't cause interoprability problems.

[Zhangtao]It require each  Diameter node maintain session state. this means routing should base on session ID.
every session message should routing same path hop by hop.

> the messages but if they are built for that purpose, there probably wouldn't
[zhangtao]Please See me former mail.

---

From: "Tolga Asveren" <[email-masked]>
Date: Fri, 14 Apr 2006 07:58:44 -0400

Zhangtao,

> [Zhangtao]It require each  Diameter node maintain session state.
> this means routing should base on session ID.
[TOLGA]Yes, but you anyhow will keep some per-session state in those nodes
for certain application specific processing -otherwise you wouldn't require
to visit them for each request of the same session-, so I don't think this
is a showstopper. As said before, whether the functionality of such a node
overlaps exactly with Relay Agent functionality defined in RFC3588 is a
different issue but not an interesting one from interoperability point of
view.

---

From: zhangtao <[email-masked]>
Date: Mon, 17 Apr 2006 14:31:09 +0800

Hi Tolga:
       I agree with you.if each node maintain session state,can solution the problem.
      But some node should  stateless.just message routing,not care about message content(he donnot which command start session or end session).if this node maintian the session state,then should support every Diameter application.so it is bring  interoperability problem,if one node upgrade,maybe should every node upgrade.
       Assume below situation:
       When First Message routing to Home network,The first Access node maybe should qurey HSS,then routing the message to one server.the none-first message no need routing to the Access node again,can directly routing to server.if realize use aforementioned solution,the first access node should maintain session state , all message should routing to him,then routing to server, maybe  not so good.      
       Actual in Diameter base protocol only few comments about Diameter Proxy agent. when i read 3GPP application like:GBA,I-WLAN.not clear how to realize it when routing.       
       Regard!