Subject: [Dime] RE: draft-tschofenig-dime-mip6-integrated-00.txt

From: <[email-masked]>
Date: Wed, 5 Apr 2006 11:27:21 +0200

Hi Julien, 

See my comments inline.

> Hi jouni, all,
> 
>  thanks for bringing this up.
> 
> On Wed, Apr 05, 2006 at 12:18:43AM +0200, 
> [email-masked] wrote:
> > Hi,
> > 
> > In Dallas meeting during the Diameter MIPv6 presentation 
> > few questions were raised/asked:
> > 
> >   Integrated scenario solution uses Diameter application.
> >   Questions:
> >    o Application vs. attributes
> >    o Interworking with NASREQ and EAP 
> >    o MIPv4 interaction (dual stacked hosts)
> > 
> > I looks like reusing NASREQ & EAP rather than defining
> > new commands would be the way to go. However, the question
> > still remains whether new applications are needed or
> > would just a set of AVPs be sufficient?
> 
>  Personnally, I tend to think that we don't need new messages and thus
>  new Command-Code. Thus, only AVPs are sufficient and explain where to
>  put them in the flow of messages for NASREQ/EAP.

I agree that new commands codes should not be needed.

>  However, if we want that the AAA server knows that the NAS 
> support the
>  "mip6-integrated" scenario, the NAS may advertise this (in CER/CEA)
>  and thus we also need to request an Application-ID for 
> mip6-integrated.

I believe that the ability for the AAA server to know whether the NAS
supports integrated scenario is valuable information. Thus requesting
a new Application-ID would be justifiable.

> > The MIPv4 support for dual stack cases (as worked in
> > MIP6 WG) would require transporting MIPv4 HA address
> > along with the MIPv6 stuff. MIP6 WG comment on this
> > was that "...if you are using DHCP (integrated scenario)
> > to deliver the IPv4 address of the HA, you would need
> > some AAA work."
> 
>  I have some doubts about including this at this point. The reason is
>  that delivering IPv4 HA address to the MN is not described in the
>  Integrated scenario draft. I would prefer that this feature 
> be added in
>  this draft (mip6) and then include it in the DiME draft.

Hmmm.. fair enough.. (even though I think reserving one extra
AVP for likely deployment issue does no harm ;)

>  what do you think ?
>  Julien B.

Cheers,
	Jouni

> 
> > 
> > Any thoughts & comments?
> > 
> > Cheers,
> > 	Jouni
> > 
> > 
> > 
> > > Hi all,
> > > 
> > > we should work on a draft update for
> > > <>. We have discussed
> > > a number of issues already but we haven't reached a 
> > > conclusion about the
> > > application vs. attribute question.
> > > 
> > > Another important aspect: I do not want to be the editor 
> nor the main 
> > > author of the document. It would be great if someone could 
> > > volunteer to 
> > > take this position, if the person really has time.
> > > 
> > > Ciao
> > > Hannes
> > > 
> > > 
> 
> -- 
> julien.bournelle at int-evry.fr
> 

_______________________________________________
DiME mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dime

---

From: Hannes Tschofenig <[email-masked]>
Date: Wed, 05 Apr 2006 11:44:37 +0200

Hi all,

the MIP6 bootstrapping design team has worked on two solutions for 
bootstrapping of MIPv6: the integrated and the split scenario

These two solutions are documented in two separate drafts:

MIP6-bootstrapping via DHCPv6 for the Integrated Scenario
http://www.ietf.org/internet-drafts/draft-ietf-mip6-bootstrapping-integrated-dhc-00.txt

Mobile IPv6 bootstrapping in split scenario
http://www.ietf.org/internet-drafts/draft-ietf-mip6-bootstrapping-split-02.txt

As such, there is the question whether the work in DIME should also 
produce two separate documents referring to these two bootstrapping 
deployment scenarios or whether it would be useful to captures both 
scenarios in a single document.

Thoughts?

Ciao
Hannes & John

PS: John and myself would also like to know when the MIP6-AAA Goals draft
http://www.ietf.org/internet-drafts/draft-ietf-mip6-aaa-ha-goals-01.txt
is going to be finalized since the Diameter MIPv6 work depends on this 
document.

---

From: "Giaretta Gerardo" <[email-masked]>
Date: Wed, 5 Apr 2006 12:01:29 +0200

Hi Hannes and John,

I'm working on a new version of the draft based on comments I received in Dallas. If you can review the document and have additional comments, please provide them. I think the draft may be in a good shape by next IETF if there will be good reviews from MIP6 WG.

As a side note, the draft will encompass all AAA requirements for MIPv6, both for AAA-HA and AAA-NAS interface, and both for integrated and split scenario. Therefore I think we may have one document in DIME WG, since many components of integrated and split solutions are common.

Regards,
--Gerardo

-----Original Message-----
From: Hannes Tschofenig [mailto:[email-masked]]
Sent: Wed 4/5/2006 11:44 AM
To: [email-masked]; [email-masked]; [email-masked]; Guardini Ivano; Giaretta Gerardo; Demaria Elena; [email-masked]; [email-masked]
Subject: Diameter MIPv6
 
Hi all,

Thoughts?

Ciao
Hannes & John

--------------------------------------------------------------------

CONFIDENTIALITY NOTICE

This message and its attachments are addressed solely to the persons above and may contain confidential information. If you have received the message in error, be informed that any use of the content hereof is prohibited. Please return it immediately to the sender and delete the message. Should you have any questions, please contact us by replying to [email-masked].

        Thank you

                                        www.telecomitalia.it

--------------------------------------------------------------------

---

From: <[email-masked]>
Date: Wed, 5 Apr 2006 13:16:47 +0300

Gerardo,

I think this seems like a reasonable approach.  When you have a version
for review, let me know.
 
John

________________________________

	From: ext Giaretta Gerardo
[mailto:[email-masked]] 
	Sent: 05 April, 2006 13:01
	To: Hannes Tschofenig; [email-masked]
	Cc: Demaria Elena; Patil Basavaraj (Nokia-NET/Dallas);
[email-masked]; Guardini Ivano
	Subject: [Dime] RE: Diameter MIPv6

	Hi Hannes and John,
	
	I'm working on a new version of the draft based on comments I
received in Dallas. If you can review the document and have additional
comments, please provide them. I think the draft may be in a good shape
by next IETF if there will be good reviews from MIP6 WG.
	
	As a side note, the draft will encompass all AAA requirements
for MIPv6, both for AAA-HA and AAA-NAS interface, and both for
integrated and split scenario. Therefore I think we may have one
document in DIME WG, since many components of integrated and split
solutions are common.
	
	Regards,
	--Gerardo

	-----Original Message-----
	From: Hannes Tschofenig [mailto:[email-masked]]
	Sent: Wed 4/5/2006 11:44 AM
	To: [email-masked]; [email-masked]; [email-masked];
Guardini Ivano; Giaretta Gerardo; Demaria Elena;
[email-masked]; [email-masked]
	Subject: Diameter MIPv6
	
	Hi all,
	
	the MIP6 bootstrapping design team has worked on two solutions
for 
	bootstrapping of MIPv6: the integrated and the split scenario

	
http://www.ietf.org/internet-drafts/draft-ietf-mip6-bootstrapping-integr
ated-dhc-00.txt

http://www.ietf.org/internet-drafts/draft-ietf-mip6-bootstrapping-split-
02.txt
	
	As such, there is the question whether the work in DIME should
also 
	produce two separate documents referring to these two
bootstrapping 
	deployment scenarios or whether it would be useful to captures
both 
	scenarios in a single document.
	
	Thoughts?
	
	Ciao
	Hannes & John
	
	PS: John and myself would also like to know when the MIP6-AAA
Goals draft
	
http://www.ietf.org/internet-drafts/draft-ietf-mip6-aaa-ha-goals-01.txt
	is going to be finalized since the Diameter MIPv6 work depends
on this 
	document.

	

--------------------------------------------------------------------
	CONFIDENTIALITY NOTICE
	This message and its attachments are addressed solely to the
persons
	above and may contain confidential information. If you have
received
	the message in error, be informed that any use of the content
hereof
	is prohibited. Please return it immediately to the sender and
delete
	the message. Should you have any questions, please contact us by
	replying to [email-masked]
<mailto:[email-masked]> .
	        Thank you
	                                        www.telecomitalia.it
<http://www.telecomitalia.it>

---

From: Julien Bournelle <[email-masked]>
Date: Wed, 5 Apr 2006 12:42:26 +0200

Hi all,

> scenarios in a single document.

 I would prefer two documents. I have two reasons for this:

 1/ In the integrated scenario, the AAA is used between NAS and AAA. The
 HA address is delivered from the AAA to the NAS and thus NASREQ or EAP
 may be in used.

  In the split scenario, Diameter is used between HA and the AAA. And
  the AAA does not deliver the HA to the HA...

 2/ From an implementation perspective, it would be easier to have a
 specific document for each case.

 Julien B.

---

From: Basavaraj Patil <[email-masked]>
Date: Wed, 05 Apr 2006 10:16:27 -0500

I agree with Gerardo. We need a single document in DIME.

-Raj

On 4/5/06 5:01 AM, "ext Giaretta Gerardo"
<[email-masked]> wrote:

>  
> Hi Hannes and John,
> 
> I'm working on a new version of the draft based on comments I received in
> Dallas. If you can review the document and have additional comments, please
> provide them. I think the draft may be in a good shape by next IETF if there
> will be good reviews from MIP6 WG.
> 
> As a side note, the draft will encompass all AAA requirements for MIPv6, both
> for AAA-HA and AAA-NAS interface, and both for integrated and split scenario.
> Therefore I think we may have one document in DIME WG, since many components
> of integrated and split solutions are common.
> 
> Regards,
> --Gerardo
> 
> 
> To: [email-masked]; [email-masked]; [email-masked]; Guardini
> Ivano; Giaretta Gerardo; Demaria Elena; [email-masked];
> [email-masked]
> Subject: Diameter MIPv6
>  
> Hi all,
> 
> Hannes  John
> This message and its attachments are addressed solely to the persons
> above and may contain confidential information. If you have received
> the message in error, be informed that any use of the content hereof
> is prohibited. Please return it immediately to the sender and delete
> replying to [email-masked] <mailto:[email-masked]> .
>         Thank you
>                                         www.telecomitalia.it

---

From: Julien Bournelle <[email-masked]>
Date: Thu, 6 Apr 2006 14:41:16 +0200

Hi all,

 For the Integrated scenario we need to:
 - define AVPs (HA)
 - explain where to put it in the Diameter EAP/NASREQ exchanges (between
   NAS and the AAA)
 - probably require a Application-ID for that the NAS announces to the
   AAA that it support the Integrated case.

 For the split scenario, we need to:
 - explain how the HA uses Diameter EAP. (HA uses IKEv2 with MN) 
 - maybe some issues may raised after investigation (do the HA need to
   tell to the AAA that it is a HA and not a NAS ? this sort of things).

 So at this point of time, I think it would be better to investigate
 this separately and see later if it makes sense to merge the documents.
 I don't really see the advantage of having one document for the moment.

 Regards,

 Julien B.