Subject: [Dime] Guidelines for Diameter extensions

From: "Tolga Asveren" <[email-masked]>
Date: Fri, 2 Jun 2006 18:14:59 -0400

I want to get opinion/feedback -especially from WG-chairs + RFC3588 authors-
about quidelines for extensions to Diameter protocol.

In the last couple of months, a few issues have been discussed on the list
and some of them may require enhancements on the existing specification -or
people may want to propose new procedures about other issues- . I believe it
could be useful to have a set of guidelines for such extensions.

For example, how acceptable would the following approaches be, when defining
new procedures:
a) New base protocol messages
b) New error-codes
c) New AVPs for base protocol messages
...

BTW, are we going to have a bis document?

   Thanks,
   Tolga

_______________________________________________
DiME mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dime

---

From: <[email-masked]>
Date: Thu, 8 Jun 2006 16:08:22 +0300

Hi Tolga,

>I want to get opinion/feedback -especially from WG-chairs + 
>RFC3588 authors- about quidelines for extensions to Diameter protocol.
>
>In the last couple of months, a few issues have been discussed 
>on the list and some of them may require enhancements on the 
>existing specification -or people may want to propose new 
>procedures about other issues- . I believe it could be useful 
>to have a set of guidelines for such extensions.

So, we have an item about explaining the role of Diameter Applications,
I think we should should discuss this.

However ...

>For example, how acceptable would the following approaches be, 
>when defining new procedures:

The 3588 IANA considerations should have all of this information,
do you have any questions on what is in there?

>BTW, are we going to have a bis document?

When we have some strong consensus on what should be in there, yes, of
course.
But see my next mail.

John