Subject: [Dime] one doubt about sip application

From: Tony Zhang <[email-masked]>
Date: Mon, 26 Jun 2006 11:32:17 +0800

Hi All:
   In Sip Application SIP-Accounting_Information is like below:
         SIP-Accounting-Information ::= < AVP Header: xx01 >
                                   * [ SIP-Accounting-Server-URI ]
                                   * [ SIP-Credit-Control-Server-URI ]
                                   * [ AVP]

   Actual in Rfc3588 accounting request define is like below:
      <ACR> ::= < Diameter Header: 271, REQ, PXY >
                < Session-Id >
                { Origin-Host }
                { Origin-Realm }
                { Destination-Realm }
                { Accounting-Record-Type }
                { Accounting-Record-Number }
                [ Acct-Application-Id ]
                [ Vendor-Specific-Application-Id ]
                [ User-Name ]
                [ Accounting-Sub-Session-Id ]
                [ Acct-Session-Id ]
                [ Acct-Multi-Session-Id ]
                [ Acct-Interim-Interval ]
                [ Accounting-Realtime-Required ]
                [ Origin-State-Id ]
                [ Event-Timestamp ]
              * [ Proxy-Info ]
              * [ Route-Record ]
              * [ AVP ]
 
this is means,Account Request recommend use Realm not Host.

so if define SIP-Accounting_Information  like below is better or not?
         SIP-Accounting-Information ::= < AVP Header: xx01 >
                                    [ SIP-Accounting-Server-Realm ]
                                    [ SIP-Credit-Control-Server-Ream ]
                                   * [ AVP]
we send account request to account server,then we can Fill SIP-Accounting-Server-Realm  Into Destination-Realm of Account Request.

if not like this,we should fill SIP-Accounting-Server-URI into Destination-Host,the other question is how to contruct Destination-Realm(this avp is mandatory)?

Thanks!
Tony Zhang
_______________________________________________
DiME mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dime

---

From: Miguel Garcia <[email-masked]>
Date: Mon, 26 Jun 2006 09:24:30 +0300

Tony:

The intention of the SIP-Accounting-Information is to outsource Diameter
accounting to a different server, not to a different realm. So, from
that point of view, the idea is to keep the realm constant, but not the
server. I am not sure of any use case where you need to switch realms
within the same application (SIP services), but different hosts
(authorization/authentication vs. accounting).

Additionally, if the Diameter client gets only the realm where to
provide accounting, as you propose, then you need to have a mechanism to
guarantee that you can discover the host out of the realm. So, if this
mechanism is not in place, or the Realm Routing Table is not properly
provisioned, you run into trouble.

Thus, I wouldn't recommend to provide realms for the accounting part of
the Diameter SIP application.

BR,

         Miguel

Tony Zhang wrote:
> we send account request to account server,then we can Fill 
> SIP-Accounting-Server-Realm  Into Destination-Realm of Account Request.
>  
> if not like this,we should fill SIP-Accounting-Server-URI into 
> Destination-Host,the other question is how to contruct 
> Destination-Realm(this avp is mandatory)?
>  
> Thanks!
> Tony Zhang
> 
> 
> ------------------------------------------------------------------------
> 

-- 
Miguel A. Garcia           tel:+358-50-4804586
sip:[email-masked]
Nokia Research Center      Helsinki, Finland

---

From: Tony Zhang <[email-masked]>
Date: Mon, 26 Jun 2006 16:31:40 +0800

Miguel:
    Thanks your reply.
    In my understanding,the Realm have another meaning,like one group of nodes,then it can realize device level reliablity.maybe it will like this all accounting server maybe will use one realm.for example:account.base.com,for call server maybe will use:call.base.com.so i am not assure the sip server will use same realm name with account server.because realm name based on longest-match-from-the-right on the realm rather than requiring an exact match,so maybe both just belong to big realm,but big realm still have some samll realm.
    because almost accounting is very important,so almost have two accounting server,so we should return all server name to sip server,if just return realm,the realm will mangement all accounting server .no need each user data should return two accounting server name,also if server name changed,maybe should update all user data.but use realm,maybe maybe no need update.
   when return realm how to process it,i think return accounting server,also should have some process.base protocol also give some comments how to process the message.
    Regars!
Tony

---

From: Miguel Garcia <[email-masked]>
Date: Mon, 26 Jun 2006 12:49:25 +0300

Hi Tony:

I am sorry, but I still don't get the reasons why someone would like to
do the realm split... you seem to mention something like "device level
reliability", which I don't really understand.

What puzzles me is that the Diameter SIP application has been hanging
around four about 4 years, and we had a requirement from day one to be
able to supply the accounting server, but we never had a requirement to
supply a separate accounting realm. It can be done, it is a simple
extension, but we should understand the requirements and use cases
before starting extending the protocol just because it is possible to do it.

Regards,

         Miguel

---

From: Tony Zhang <[email-masked]>
Date: Tue, 27 Jun 2006 09:45:03 +0800

Hi Miguel:
   actual i am not very good understand realm and host.so i regard  a group server as realm,then when i read RFC3588 or 3GPP Accounting
Application(Ro interface),both  account request donot list Destination Host AVP.so i have doubt how to use the account server URL AVP.so i think it should fill to destinaiton Realm(Destination Host Avp missing in both specification or not?).
   so i just want all application can keep consistent.when have chance please correct it in RFC3588 or Ro interface.
   device level reliability,in my idea.any server an provide service in the realm,so it have more high reliability.
Regards,
   Tony