Subject: RE: [Dime] one doubt about sip application

From: "Glen Zorn \(gwz\)" <[email-masked]>
Date: Mon, 26 Jun 2006 22:58:23 -0700

Miguel Garcia <mailto:[email-masked]> supposedly scribbled:

> Tony:
> 
> The intention of the SIP-Accounting-Information is to outsource
> Diameter accounting to a different server, not to a different realm.
> So, from that point of view, the idea is to keep the realm constant,
> but not the server. I am not sure of any use case where you need to
> switch realms within the same application (SIP services), but
> different hosts (authorization/authentication vs. accounting).     
> 
> Additionally, if the Diameter client gets only the realm where to
> provide accounting, as you propose, then you need to have a mechanism
> to guarantee that you can discover the host out of the realm. So, if
> this mechanism is not in place, or the Realm Routing Table is not
> properly provisioned, you run into trouble.    

What happens if the provided host crashes?  Do you just throw away the accounting message?

> 
> Thus, I wouldn't recommend to provide realms for the accounting part
> of the Diameter SIP application. 
> 
> BR,
> 
>          Miguel
> 
> 
> Tony Zhang wrote:
>> Hi All:
>>    In Sip Application SIP-Accounting_Information is like below:
>>          SIP-Accounting-Information ::= < AVP Header: xx01 >
>>                                    * [ SIP-Accounting-Server-URI ]
>>                                    * [ SIP-Credit-Control-Server-URI
>> ] 
>>                                    * [ AVP]
>> 
>>    Actual in Rfc3588 accounting request define is like below:
>>       <ACR> ::= < Diameter Header: 271, REQ, PXY >
>>                 < Session-Id >
>>                 { Origin-Host }
>>                 { Origin-Realm }
>>                 { Destination-Realm }
>>                 { Accounting-Record-Type }
>>                 { Accounting-Record-Number }
>>                 [ Acct-Application-Id ]
>>                 [ Vendor-Specific-Application-Id ]
>>                 [ User-Name ]
>>                 [ Accounting-Sub-Session-Id ]
>>                 [ Acct-Session-Id ]
>>                 [ Acct-Multi-Session-Id ]
>>                 [ Acct-Interim-Interval ]
>>                 [ Accounting-Realtime-Required ]
>>                 [ Origin-State-Id ]
>>                 [ Event-Timestamp ]
>>               * [ Proxy-Info ]
>>               * [ Route-Record ]
>>               * [ AVP ]
>> 
>> this is means,Account Request recommend use Realm not Host.
>> 
>> so if define SIP-Accounting_Information  like below is better or not?
>>          SIP-Accounting-Information ::= < AVP Header: xx01 >
>>                                     [ SIP-Accounting-Server-Realm ]
>>                                     [ SIP-Credit-Control-Server-Ream
>>                                    ] * [ AVP] we send account
>> request to 
>> account server,then we can Fill SIP-Accounting-Server-Realm  Into
>> Destination-Realm of Account Request.
>> 
>> if not like this,we should fill SIP-Accounting-Server-URI into
>> Destination-Host,the other question is how to contruct
>> Destination-Realm(this avp is mandatory)?
>> 
>> Thanks!
>> Tony Zhang
>> 
>> 
>> ----------------------------------------------------------------------
>> -- 
>> 
>> _______________________________________________
>> DiME mailing list
>> [email-masked]
>> https://www1.ietf.org/mailman/listinfo/dime

Hope this helps,

~gwz

Why is it that most of the world's problems can't be solved by simply
  listening to John Coltrane? -- Henry Gabriel

_______________________________________________
DiME mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dime

---

From: Miguel Garcia <[email-masked]>
Date: Tue, 27 Jun 2006 09:15:01 +0300

Glen Zorn (gwz) wrote:
> What happens if the provided host crashes?  Do you just throw awa the accounting message?

No, you are supposed to install several servers for redundancy purposes,
so there is a backup accounting server. The SIP-Accounting-Information
AVP allows for repetition of the URI of each server, so you can provide
as many as you want:

      SIP-Accounting-Information ::= < AVP Header: xx01 >
                                   * [ SIP-Accounting-Server-URI ]
                                   * [ SIP-Credit-Control-Server-URI ]
                                   * [ AVP]

Additionally, you can also get redundancy through round robin DNS,
although I favor the repetition of the URI AVPs.

/Miguel

-- 
Miguel A. Garcia           tel:+358-50-4804586
sip:[email-masked]
Nokia Research Center      Helsinki, Finland