Subject: [Dime] RE: Diameter base protocol messages used by DCCA

From: "Glen Zorn \(gwz\)" <[email-masked]>
Date: Thu, 15 Jun 2006 10:32:22 -0700

Harri Hakala (TU/LMF) <mailto:[email-masked]> supposedly scribbled:

...

> AA Request/AA Answer are not necessarily equal to AAR/AAA messages in
> NASREQ but they mean in DCCA document a general
> authorization/authentication request/answer in any Diameter
> authorization/authentication application. Bad name example, as it
> seems to collide with the message name in NASREQ.    
> 

This would seem to make it quite difficult to monitor/manage DCCA via SNMP, since presumably one would wish to keep track of all the interrogations & the generic auth message is actually the first interrogation.   This implies that all & any such messages should be allocated a counter in the DCCA MIB, but the membership of this set of messages is not static.  Any suggestions? 
 
...

~gwz

Why is it that most of the world's problems can't be solved by simply
  listening to John Coltrane? -- Henry Gabriel

_______________________________________________
DiME mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dime

---

From: Anders Kristensen <[email-masked]>
Date: Thu, 15 Jun 2006 16:13:10 -0400

> This would seem to make it quite difficult to monitor/manage DCCA via SNMP, since presumably one would wish to keep track of all the interrogations & the generic auth message is actually the first…

Have clients include an Auth-Application-Id AVP in the AAR with the DCC 
app id? It's not clear to me from the specs whether this is the 
intention or not but IMHO there really ought to be a way for the server 
to tell whether the AAR is for a NAS or DCC session - not just for 
management reasons.

Anders

---

From: "Tolga Asveren" <[email-masked]>
Date: Thu, 15 Jun 2006 15:56:47 -0400

RFC4006 5.2.2 states that Credit-Control AVP  MUST be added to AAR to
indicate credit-control capabilities.

> -----Original Message-----
> From: Anders Kristensen [mailto:[email-masked]]
> Sent: Thursday, June 15, 2006 4:13 PM
> To: Glen Zorn (gwz)
> Cc: [email-masked]; [email-masked];
> [email-masked]; [email-masked]; [email-masked]
> Subject: Re: [Dime] RE: Diameter base protocol messages used by DCCA
>
>
>
>
> Glen Zorn (gwz) wrote:
> > This would seem to make it quite difficult to monitor/manage
> DCCA via SNMP, since presumably one would wish to keep track of
> all the interrogations & the generic auth message is actually the
> first interrogation.   This implies that all & any such messages
> should be allocated a counter in the DCCA MIB, but the membership
> of this set of messages is not static.  Any suggestions?
>

---

From: Anders Kristensen <[email-masked]>
Date: Thu, 15 Jun 2006 16:37:42 -0400

OK, so at least there's a way to tell which app the AAR really is for. 
In my view it's a poor solution, though, since the code maintaining peg 
counts could very well belong to a generic Diameter stack which doesn't 
necessarily know about the particulars of DCCA. It's sort of reasonable 
to expect the stack to do something on the basis of Auth-Application-Id 
but not really for DCCA specific AVPs. It makes it unnecessarily 
difficult to layer the server code.

Thanks,
Anders

Tolga Asveren wrote:

>>>Harri Hakala (TU/LMF) <mailto:[email-masked]>
>>
>>supposedly scribbled:
>>
>>>...
>>>
>>>
>>>

---

From: "Tolga Asveren" <[email-masked]>
Date: Thu, 15 Jun 2006 16:21:22 -0400

Actualy, shouldn't ApplicationId in the message header be 4 (ApplicationId
for DCCA) , for such an AAR?

    Tolga

> Sent: Thursday, June 15, 2006 4:38 PM
> To: Tolga Asveren
> Cc: [email-masked]; [email-masked]