Subject: [Dime] Host-IP-Address transport type and port

From: "Ran Arad" <[email-masked]>
Date: Thu, 11 Jan 2007 11:02:37 +0200

Good Day
 
I have a question regarding the Address AVP type: it contains the address type (IP or IP6) and the address itself, without a port or transport type (SCTP, TLS). For instance, if I'm running a server supporting both SCTP and TLS, I cannot advertise both address types; if I'm running two diameter processes on the same machine, they cannot advertise a different port for each.
 
Is there any way to solve this issue apart from vendor specific AVPs?
 
Ran
_______________________________________________
DiME mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dime

---

From: "Tolga Asveren" <[email-masked]>
Date: Thu, 11 Jan 2007 08:31:53 -0500

Hi Ran,

I think Host-IP Address includes addresses used only for the connection, for which CER/CEA is sent. 

I actually wonder what it is used for.

   Thanks,
   Tolga

-----Original Message-----
From: Ran Arad [mailto:[email-masked]]
Sent: Thursday, January 11, 2007 4:03 AM
To: [email-masked]
Subject: [Dime] Host-IP-Address transport type and port

Good Day

Ran