Subject: Re: [Dime] I-D ACTION:draft-ietf-dime-rfc3588bis-01.txt

From: "Gil Shafran" <[email-masked]>
Date: Thu, 1 Feb 2007 08:40:16 +0200

Hi all,

There seem to be a problem with the peer state machine. State
Wait-Conn-Ack/Elect is not reachable to the connection initiator (it is not
a 'next state' of any initiator state), yet initiator events are expected in
this state (I-Rcv-Conn-Ack and I-Rcv-Conn-Nack).
Any idea?

Regards,
Gil Shafran

On 1/31/07, [email-masked] <[email-masked]> wrote:
>
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
> This draft is a work item of the Diameter Maintenance and Extensions
> Working Group of the IETF.
>
>        Title           : Diameter Base Protocol
>        Author(s)       : V. Fajardo, J. Loughney
>        Filename        : draft-ietf-dime-rfc3588bis-01.txt
>        Pages           : 167
>        Date            : 2007-1-31
>
> The Diameter base protocol is intended to provide an Authentication,
>   Authorization and Accounting (AAA) framework for applications such as
>   network access or IP mobility.  Diameter is also intended to work in
>   both local Authentication, Authorization & Accounting and roaming
>   situations.  This document specifies the message format, transport,
>   error reporting, accounting and security services to be used by all
>   Diameter applications.  The Diameter base application needs to be
>   supported by all Diameter implementations.
>
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-ietf-dime-rfc3588bis-01.txt
>
> To remove yourself from the I-D Announcement list, send a message to
> [email-masked] with the word unsubscribe in the body of
> the message.
> You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce
> to change your subscription settings.
>
> Internet-Drafts are also available by anonymous FTP. Login with the
> username "anonymous" and a password of your e-mail address. After
> logging in, type "cd internet-drafts" and then
> "get draft-ietf-dime-rfc3588bis-01.txt".
>
> A list of Internet-Drafts directories can be found in
> http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>
> Internet-Drafts can also be obtained by e-mail.
>
> Send a message to:
>        [email-masked].
> In the body type:
>        "FILE /internet-drafts/draft-ietf-dime-rfc3588bis-01.txt".
>
> NOTE:   The mail server at ietf.org can return the document in
>        MIME-encoded form by using the "mpack" utility.  To use this
>        feature, insert the command "ENCODING mime" before the "FILE"
>        command.  To decode the response(s), you will need "munpack" or
>        a MIME-compliant mail reader.  Different MIME-compliant mail
> readers
>        exhibit different behavior, especially when dealing with
>        "multipart" MIME messages (i.e. documents which have been split
>        up into multiple messages), so check your local documentation on
>        how to manipulate these messages.
>
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
>
>
> _______________________________________________
> DiME mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/dime
>
>
_______________________________________________
DiME mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dime

---

From: Victor Fajardo <[email-masked]>
Date: Thu, 01 Feb 2007 10:27:53 -0500

Hi Gil,
> Wait-Conn-Ack/Elect is not reachable to the connection initiator (it 
> is not a 'next state' of any initiator state), yet initiator events 
> are expected in this state (I-Rcv-Conn-Ack and I-Rcv-Conn-Nack).
> Any idea?

I think because during election, a peer is both an initiator and a 
responder so you have I-Rcv-Conn-Ack and I-Rcv-Conn-Nack while on 
Wait-Conn-Ack/Elect state.

regards,
victor

>  
> Regards,
> Gil Shafran
>
>  
> On 1/31/07, [email-masked] 
> <mailto:[email-masked]>* <[email-masked] 
> <mailto:[email-masked]> > wrote:
>
>     This draft is a work item of the Diameter Maintenance and
>     Extensions Working Group of the IETF.
>
>     [email-masked]
>     <mailto:[email-masked]> with the word unsubscribe
>     in the body of
>     the message.
>            [email-masked] <mailto:[email-masked]>.
>     In the body type:
>            "FILE /internet-drafts/draft- ietf-dime-rfc3588bis-01.txt".
>
>     NOTE:   The mail server at ietf.org <http://ietf.org> can return
>     the document in
>            a MIME-compliant mail reader.  Different MIME-compliant
>     mail readers
>     [email-masked] <mailto:[email-masked]>
> ------------------------------------------------------------------------
>

---

From: [email-masked]
Date: Wed, 31 Jan 2007 15:50:02 -0500

A New Internet-Draft is available from the on-line Internet-Drafts 
directories.
This draft is a work item of the Diameter Maintenance and Extensions Working Group of the IETF.

Send a message to:
	[email-masked].
In the body type:
	
	a MIME-compliant mail reader.  Different MIME-compliant mail readers

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.
_______________________________________________
I-D-Announce mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/i-d-announce
_______________________________________________
DiME mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dime