Subject: [Dime] Question: source of address/port to be used for server responses

From: "Parker, James" <[email-masked]>
Date: Fri, 23 Feb 2007 12:14:09 -0700

I am looking at implementing the Diameter protocol for a server, and I
cannot find a clear statement as to how to create the proper channel to
send responses (answers).  Is the proper method:
 
    - Clone a response channel (e.g., by an accept() system call)?
    - Open the CER Origin-Host/port 3868
    - Open the CER Host-Realm (port 3868 if none specified)
    - Open the CER Host-IP-Address(es)/port 3868
    - Some other method

The first seems the most logical; however that could result in security
issues if a firewall is crossed (since arbitrary ports must be opened).

Thanks in Advance

James Parker
Distinguished Software Development Engineer
Comverse, Inc.

_______________________________________________
DiME mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dime

---

From: "Tolga Asveren" <[email-masked]>
Date: Fri, 23 Feb 2007 14:31:46 -0500

James,

There is always a single Diameter connection between two adjacent entities,
and answers are always sent on the connection from which the corresponding
requests has been received.

    Thanks,
    Tolga

> -----Original Message-----
> From: Parker, James [mailto:[email-masked]]
> Sent: Friday, February 23, 2007 2:14 PM
> To: [email-masked]
> Subject: [Dime] Question: source of address/port to be used for
> serverresponses
>
>