Subject: [Dime] rfc4004 errata - status?

From: "Ulf Wiger \(TN/EAB\)" <[email-masked]>
Date: Thu, 19 Apr 2007 16:18:10 +0200

Apologies, I'm a newcomer on this list.

In the process of developing a Diameter framework, I've 
come across RFC4004. My strategy is to generate code
for encode/decode etc. by copying and pasting from the 
spec into a text document, then parsing it and generating
code. As a result, errors in the spec tend to lead to 
compilation error.

For RFC4004, I stumbled on the AVPs MIP-MN-HA-SPI
and MIP-HA-to-MN-SPI, which are not defined. They are 
mentioned in the grouped AVPs MIP-MN-to-HA-MSA
and MIP-HA-to-MN-MSA respectively.

After some googling, I found that this had been noticed, and 
a post by Peter McCann, 3 Jan 2007*, seemed to suggest 
that I should simply remove them. Is this a correct assumption?

* http://www1.ietf.org/mail-archive/web/dime/current/msg01149.html

BTW, while I'm at it, I might as well contribute another one for the 
upcoming rfc4004 errata:

Session-ID in the ABNF for AA-Mobile-Node-Request should be 
Session-Id. While the names of messages and AVPs are really
of informational nature, they are useful for mapping to structs,
class names, etc., and these will be case-sensitive in many
languages.

BR,
Ulf Wiger
Ericsson AB
_______________________________________________
DiME mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dime

---

From: "McCann Peter-A001034" <[email-masked]>
Date: Thu, 19 Apr 2007 11:10:01 -0400

Hi, Ulf,

It is still my opinion that these SPI AVPs can be left
out of the Diameter messages.  However, I'd like to hear
from someone who is actually deploying a complete system
including RFC 3957.  Anyone?

I can see your point regarding Session-ID vs. Session-Id.
However, as you note this is an internal implementation
matter and won't affect interoperability.  I am not sure
whether it warrants an errata.

-Pete

Ulf Wiger (TN/EAB) wrote:
> In the process of developing a Diameter framework, I've come across
> RFC4004. My strategy is to generate code for encode/decode etc. by
> copying and pasting from the spec into a text document, then parsing
> it and generating code. As a result, errors in the spec tend to lead
> to compilation error.    
> 
> For RFC4004, I stumbled on the AVPs MIP-MN-HA-SPI and
> MIP-HA-to-MN-SPI, which are not defined. They are mentioned in the
> grouped AVPs MIP-MN-to-HA-MSA and MIP-HA-to-MN-MSA respectively.  
> 
> After some googling, I found that this had been noticed, and a post
> by Peter McCann, 3 Jan 2007*, seemed to suggest that I should simply
> remove them. Is this a correct assumption?  
> 
> <http://www1.ietf.org/mail-archive/web/dime/current/msg01149.html> 
> 
> Session-Id. While the names of messages and AVPs are really of
> informational nature, they are useful for mapping to structs, class
> names, etc., and these will be case-sensitive in many languages.   
> 
> BR,
> Ulf Wiger
> Ericsson AB

---

From: "Ulf Wiger \(TN/EAB\)" <[email-masked]>
Date: Thu, 19 Apr 2007 17:10:28 +0200

Hi Hannes,
 
To be fair, I am not aiming at a working implementation either - at
least not now.
 
I'm just incorporating it in order to inherit some attributes into
another specification.
 
These were the things I needed to do to make it compile:
 
;; Source: ftp://ftp.isi.edu/in-notes/rfc4004.txt
;;
;; - Corrected Session-ID to Session-Id in AA-Mobile-Node-Request
;; - Commented out MIP-HA-to-MN-SPI, MIP-MN-FA-SPI & MIP-MN-HA-SPI
;; - Changed MIP-nonce to MIP-Nonce in MIP-MN-to-FA-MSA &
;;   MIP-MN-to-HA-MSA
 
For my purposes, it's perfectly ok to exclude the above AVPs, since I 
don't need them at this point.
 
BR,
Ulf W

________________________________

	From: Tschofenig, Hannes [mailto:[email-masked]] 
	Sent: den 19 april 2007 17:00
	To: Ulf Wiger (TN/EAB); [email-masked]
	Subject: AW: [Dime] rfc4004 errata - status?

	Hi Ulf, 
	 
	so far our efforts have focused on the revision of the Diameter
Base protocol specification. 
	With the past two interop events we did a lot of Base protocol
testing in order to get feedback from implementers.
	 
	We haven't had a lot of feedback regarding RFC 4004. In fact, at
the first interop we had 
	no implementation available to test (if I recall it correctly)
and at the second interop we had 2 companies supporting RFC 4004. 
	 
	Nevertheless, we are interested in collecting bugs for all
Diameter specifications. I will create a roundup issue tracker for this
document as well. 
	 
	Ciao
	Hannes

________________________________

		Von: Ulf Wiger (TN/EAB) [mailto:[email-masked]] 
		Gesendet: Donnerstag, 19. April 2007 16:18
		An: [email-masked]
		Betreff: [Dime] rfc4004 errata - status?

		spec into a text document, then parsing it and
generating 

		After some googling, I found that this had been noticed,
and 
		a post by Peter McCann, 3 Jan 2007*, seemed to suggest 
		that I should simply remove them. Is this a correct
assumption? 

		*
http://www1.ietf.org/mail-archive/web/dime/current/msg01149.html
<http://www1.ietf.org/mail-archive/web/dime/current/msg01149.html>  

		BTW, while I'm at it, I might as well contribute another
one for the 
		upcoming rfc4004 errata: 

		Session-ID in the ABNF for AA-Mobile-Node-Request should
be 
		Session-Id. While the names of messages and AVPs are
really 
		of informational nature, they are useful for mapping to
structs, 
		class names, etc., and these will be case-sensitive in
many 
		languages. 

		BR, 
		Ulf Wiger 
		Ericsson AB

---

From: "Tschofenig, Hannes" <[email-masked]>
Date: Thu, 19 Apr 2007 17:00:14 +0200

Hi Ulf, 
 
so far our efforts have focused on the revision of the Diameter Base
protocol specification. 
With the past two interop events we did a lot of Base protocol testing
in order to get feedback from implementers.
 
We haven't had a lot of feedback regarding RFC 4004. In fact, at the
first interop we had 
no implementation available to test (if I recall it correctly) and at
the second interop we had 2 companies supporting RFC 4004. 
 
Nevertheless, we are interested in collecting bugs for all Diameter
specifications. I will create a roundup issue tracker for this document
as well. 
 
Ciao
Hannes

	

	*

	BTW, while I'm at it, I might as well contribute another one for
the 
	upcoming rfc4004 errata: 

	BR, 
	Ulf Wiger 
	Ericsson AB

---

From: "Ulf Wiger \(TN/EAB\)" <[email-masked]>
Date: Thu, 19 Apr 2007 17:34:28 +0200

> whether it warrants an errata.

Perhaps not, if an errata is published for other reasons,
one may perhaps note such things as well. (:

In fact, generating code from specs is something I would
like to recommend. I can build a dictionary from an 
error-free specification in around 20 minutes. Alas, I 
have yet to find an error-free specification... ;-)

It helps a lot that all Diameter specs from IETF, 3GPP
and TISPAN use the same kind of ABNF for messages and 
grouped AVPs. AVP types listed in tables are not quite
as easy to handle, as I end up with a number of different
variants:

- ASCII tables (partially) delimited by '|', and
  with occasional word wraps in the first column
- PDF tables (empty columns collapsed into a single
  space, when copied into a text document)
- Word tables (tabs between each column)

A tool that parses the specs and reports on 
inconsistencies would be quite useful. I will try to 
keep adding specifications, and will of course pass
on any errors found by my code generator.

It would also be great to have some form of 
recognizable markers surrounding formal descriptions. 
Then, the spec could be parsed directly.  (:

BR,
Ulf W