Subject: RE: [Dime] Clarification on Auth Server state machine

From: "Balamurugan T, TLS-Chennai" <[email-masked]>
Date: Sat, 26 May 2007 10:01:26 +0530

Hi Victor,

The following state table entries should be added in Auth client FSM for RAR support.

=====================================================================
State        Event                          Action     New State
=====================================================================
Idle         RAR Received                   Send RAA       Idle
             for unknown session            with
                                            Result-Code
                                            = UNKNOWN_
                                            SESSION_ID

Open         RAR Received                   Send RAA       Open
             with valid session             with
             parameters.                    Result-Code
                                            = SUCCESS,
                                            
Open         RAR Received                   Send RAA       Open
             with invalid session           with
             parameters.                    Result-Code
                                            = SUCCESS,
======================================================================

 Please add your comments if I missed some points.

Regards,
Bala

-----Original Message-----
From: Victor Fajardo [mailto:[email-masked]]
Sent: Friday, May 25, 2007 4:34 AM
To: Balamurugan T, TLS-Chennai
Cc: [email-masked]
Subject: Re: [Dime] Clarification on Auth Server state machine

It seems ok to me, maybe some folks have comments as well. Also, the 
client side may also need to be defined.

--victor

> Hello! Victor,
>
>     Thanks for the reply. Please suggest if it is correct to add the
>     following additional state table entries to the “SERVER state full
>     AUTH FSM” to add support for sending RAR and any other service
>     specific requests initiation from server.
>
>     Current State
>
>     	
>
>     Event
>
>     	
>
>     Action
>
>     	
>
>     New State
>
>     Open
>
>     	
>
>     Home server wants to confirm authorization of the user
>
>     	
>
>     Send RAR
>
>     	
>
>     Open
>
>     Open
>
>     	
>
>     Received RAA with some failure result code.
>
>     	
>
>     Cleanup
>
>     	
>
>     idle
>
>     Open
>
>     	
>
>     Received RAA with successful result code.
>
>     	
>
>     Update the session
>
>     	
>
>     Open
>
>     Open
>
>     	
>
>     RAR sent failed
>
>     	
>
>     resend RAR
>
>     	
>
>     Open
>
>     Thanks and Regards
>
>     Bala
>
>     -----Original Message-----
>
>     From: Victor Fajardo [mailto:[email-masked]]
>
>     Sent: Wednesday, May 23, 2007 9:44 PM
>
>     To: Balamurugan T, TLS-Chennai
>
>     Cc: [email-masked]
>
>     Subject: Re: [Dime] Clarification on Auth Server state machine
>
>     Hi,
>
>     > As per RFC3588, The diameter server will send the RAR request to
>
>     > diameter client.But, In AUTH SERVER state machine
>
>     > there is no state table entry to send Service specific requests
>
>     > from server. Also Sh,GqGo interfaces send some request
>
>     >
>
>     Maybe we can separate your comments into two(2). First, RARs are not
>
>     depicted in the stateful auth fsms. This should probably be fixed if
>
>     this is the case. Second, I'm not sure that we should not consider
>     RAR
>
>     as "service specific requests". AFAIK, service specific request sent
>
>     from the server is currently not allowed unless the server entity is
>
>     generating a diameter client session. There are ongoing discussions
>
>     about this topic in other threads (Qos).
>
>     regards,
>
>     victor
>
>     > messages from server.
>
>     >
>
>     > Can you please clarify this contradiction in RFC.
>
>     >
>
>     > Regards,
>
>     > Bala
>
>     >
>
>     > ------------------------------------------------------------------------
>
>     >
>
>     > DISCLAIMER:
>
>     > -----------------------------------------------------------------------------------------------------------------------
>
>     >
>
>     > The contents of this e-mail and any attachment(s) are
>     confidential and intended for the named recipient(s) only.
>
>     > It shall not attach any liability on the originator or HCL or its
>     affiliates. Any views or opinions presented in
>
>     > this email are solely those of the author and may not necessarily
>     reflect the opinions of HCL or its affiliates.
>
>     > Any form of reproduction, dissemination, copying, disclosure,
>     modification, distribution and / or publication of
>
>     > this message without the prior written consent of the author of
>     this e-mail is strictly prohibited. If you have
>
>     > received this email in error please delete it and notify the
>     sender immediately. Before opening any mail and
>
>     > attachments please check them for viruses and defect.
>
>     >
>
>     > -----------------------------------------------------------------------------------------------------------------------
>
>     > ------------------------------------------------------------------------
>
>     >
>
>     > _______________________________________________
>
>     > DiME mailing list
>
>     > [email-masked]
>
>     > https://www1.ietf.org/mailman/listinfo/dime
>
>     >
>
>     _______________________________________________
>
>     DiME mailing list
>
>     [email-masked]
>
>     https://www1.ietf.org/mailman/listinfo/dime
>
> ------------------------------------------------------------------------
>
> _______________________________________________
> DiME mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/dime
>   

_______________________________________________
DiME mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dime

---

From: Rajith R <[email-masked]>
Date: Mon, 28 May 2007 15:36:25 +0530

What if client receives an RAR and chooses not to comply?

>From: Balamurugan T, TLS-Chennai [mailto:[email-masked]] 
>Sent: Saturday, May 26, 2007 10:01 AM
>To: Victor Fajardo
>Cc: [email-masked]
>Subject: RE: [Dime] Clarification on Auth Server state machine
>
>Hi Victor,
>
>It seems ok to me, maybe some folks have comments as well. 
>Also, the client side may also need to be defined.
>
>--victor
>
>> Hello! Victor,
>>
>>     following additional state table entries to the "SERVER 
>state full
>>     AUTH FSM" to add support for sending RAR and any other service
>>     depicted in the stateful auth fsms. This should probably 
>be fixed 
>> if
>>
>>     from the server is currently not allowed unless the 
>server entity 
>> is
>>
>----------------------------------------------------------------------
>> -------------------------------------------------
>>
>>     >
>>
>----------------------------------------------------------------------
>> -------------------------------------------------
>>
>>     > 
>>