Subject: [Dime] Doubt regarding RTR message flow.

From: "Balamurugan T, TLS-Chennai" <[email-masked]>
Date: Fri, 4 May 2007 16:49:06 +0530

Hi All,

We need some clarification regarding RTR message flow in CX/Dx application. According to RFC 3588 the Auth server

stateless fsm  receives all service specific requests and responding with answer. No outgoing messages from stateless server.

But Cx/Dx interface specification  3GPP TS 29.228 V7.2.0 says RTR should be sent from HSS to S-CSCF. Here the HSS is

a server component. Also the RTR flows from Auth stateful/stateless server is not available in diameter base RFC.

The doubt here is which component will send RTR first ...Auth server or Auth client?.

If it is from Auth state less server what   are the action functionalities to be done for implementation

of auth server stateless FSM .

Thanks & Regards,

Bala

DISCLAIMER:
-----------------------------------------------------------------------------------------------------------------------

The contents of this e-mail and any attachment(s) are confidential and intended for the named recipient(s) only.
It shall not attach any liability on the originator or HCL or its affiliates. Any views or opinions presented in 
this email are solely those of the author and may not necessarily reflect the opinions of HCL or its affiliates.
Any form of reproduction, dissemination, copying, disclosure, modification, distribution and / or publication of 
this message without the prior written consent of the author of this e-mail is strictly prohibited. If you have 
received this email in error please delete it and notify the sender immediately. Before opening any mail and 
attachments please check them for viruses and defect.

-----------------------------------------------------------------------------------------------------------------------

_______________________________________________
DiME mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dime

---

From: "Asveren, Tolga" <[email-masked]>
Date: Fri, 4 May 2007 08:40:12 -0400

Hi Bala,

I think this is more a 3GPP issue rather than Dime but:
Like you have said, RTR is sent from HSS to S-CSCF. It seems decoupled from UAR/UAA exchange from Diameter sessions point of view (the session for UAR/UAA exchange is over after the answer is sent). So, RTR/RTA exchange will constitute a new Diameter session. In the context of this second session, you can think HSS as the client and S-CSCF as the server. In any case, this is a separate session than the first one, which seems to be inline with the authentication session state machine in RFC3588. AFAICS, there is no equivalent for RTR/RTA session in RFC3588, it simply is something different.

It seems 3GPP wants to use both a stateless approach (from Diameter session perspective) but still wants have the capability to terminate the service from server, hence they have RTR.

Overall, if you stick to descriptions in 3GPP documents, you shouldn't have problems from implementation point of view. They refer to RFCs whenever necessary.

    Thanks,
    Tolga
________________________________________
From: Balamurugan T, TLS-Chennai [mailto:[email-masked]] 
Sent: Friday, May 04, 2007 7:19 AM
To: [email-masked]; [email-masked]
Subject: [Dime] Doubt regarding RTR message flow.

Hi All,