Subject: [Dime] Reg. the Re-Definition of the Command code

From: "Arun Santhanam, TLS-Chennai" <[email-masked]>
Date: Tue, 5 Jun 2007 12:35:30 +0530

Hi Victor,

            I went though the " 3GPP TS 29.209 V6.6.0 (2006-09)" for Gq
interface I'm surprised to see that the Base Command code 

"RAR" and "ASR" has been redefined by the Gq Team. The following is the
example of the Redefinition of the ASR Command code

By the 3GPP Team.      

        { Base Diameter Definition RFC 3588}
 
     <ASR>  ::= < Diameter Header: 274, REQ, PXY >                   
                 < Session-Id >
                 { Origin-Host }
                 { Origin-Realm }
                 { Destination-Realm }
                 { Destination-Host }
                 { Auth-Application-Id }
                 [ User-Name ]
                 [ Origin-State-Id ]

{3GPP TS 29.209 V6.6.0 (2006-09)}

<AS-Request>  ::= < Diameter Header: 274, REQ, PXY > 

                                                  < Session-Id >

                                                 { Origin-Host }

                                                 { Origin-Realm }

                                                 { Destination-Realm }

                                                 { Destination-Host }

                                                 { Auth-Application-Id }

                                                 { Abort-Cause }
{Why this AVP is Mandated Here ?}

                                                 [ Origin-State-Id ]

                                                *[ Proxy-Info ]

                                                *[ Route-Record ]

                                                 [ AVP ]

Is it correct for the Application to redefine the Base Command code?

Thx

-Arun

DISCLAIMER:
-----------------------------------------------------------------------------------------------------------------------

The contents of this e-mail and any attachment(s) are confidential and intended for the named recipient(s) only.
It shall not attach any liability on the originator or HCL or its affiliates. Any views or opinions presented in 
this email are solely those of the author and may not necessarily reflect the opinions of HCL or its affiliates.
Any form of reproduction, dissemination, copying, disclosure, modification, distribution and / or publication of 
this message without the prior written consent of the author of this e-mail is strictly prohibited. If you have
received this email in error please delete it and notify the sender immediately. Before opening any mail and 
attachments please check them for viruses and defect.

-----------------------------------------------------------------------------------------------------------------------

_______________________________________________
DiME mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dime

---

From: "Arun Santhanam, TLS-Chennai" <[email-masked]>
Date: Tue, 5 Jun 2007 14:49:36 +0530

Hi Victor,

            I have one more Query. Can the Application Can remove any
AVP that has been termed as Mandatory in the Base Command code?

            For example in the 3GPP TS 29.209 V6.6.0 (2006-09) I find
that the "Re-Auth-Request-Type" (Which is mandatory AVP in RAR as per
the FRC 3588) has been removed while re-defining the RAR in 3GPP TS
29.209. Is this Approach is Correct?

Thx

-Arun

________________________________

From: Arun Santhanam, TLS-Chennai 
Sent: Tuesday, June 05, 2007 12:36 PM
To: [email-masked]
Subject: [Dime] Reg. the Re-Definition of the Command code

Hi Victor,

By the 3GPP Team.      

                                                  < Session-Id >

                                                 { Origin-Host }

                                                 { Origin-Realm }

                                                 { Destination-Realm }

                                                 { Destination-Host }

                                                 { Auth-Application-Id }

                                                 { Abort-Cause }

                                                 [ Origin-State-Id ]

                                                *[ Proxy-Info ]

                                                *[ Route-Record ]

                                                 [ AVP ]

Thx

-Arun

DISCLAIMER:
------------------------------------------------------------------------
-----------------------------------------------

The contents of this e-mail and any attachment(s) are confidential and
intended for the named recipient(s) only.
It shall not attach any liability on the originator or HCL or its
affiliates. Any views or opinions presented in 
this email are solely those of the author and may not necessarily
reflect the opinions of HCL or its affiliates.
Any form of reproduction, dissemination, copying, disclosure,
modification, distribution and / or publication of 
this message without the prior written consent of the author of this
e-mail is strictly prohibited. If you have
received this email in error please delete it and notify the sender
immediately. Before opening any mail and 
attachments please check them for viruses and defect.

------------------------------------------------------------------------
-----------------------------------------------

---

From: Victor Fajardo <[email-masked]>
Date: Tue, 05 Jun 2007 08:12:10 -0400

Hi Arun,

In general, a command can be re-used and specialized as long as it 
follows diameter extensibility rules. You can read through 
http://www.ietf.org/internet-drafts/draft-ietf-dime-app-design-guide-00.txt 
which hopefully explains this a little clearer. Also, it would be good 
if you can review this document as well and send us comments.

regards,
victor

> Hi Victor,
>
> I have one more Query. Can the Application Can remove any AVP that has 
> been termed as Mandatory in the Base Command code?
>
> For example in the 3GPP TS 29.209 V6.6.0 (2006-09) I find that the 
> “Re-Auth-Request-Type” (Which is mandatory AVP in RAR as per the FRC 
> 3588) has been removed while re-defining the RAR in 3GPP TS 29.209. Is 
> this Approach is Correct?
>
> Thx
>
> -Arun
>
> *From:* Arun Santhanam, TLS-Chennai
> *Sent:* Tuesday, June 05, 2007 12:36 PM
> *To:* [email-masked]
> *Subject:* [Dime] Reg. the Re-Definition of the Command code
>
> Hi Victor,
>
> I went though the “ 3GPP TS 29.209 V6.6.0 (2006-09)” for Gq interface 
> I’m surprised to see that the Base Command code
>
> “RAR” and “ASR” has been redefined by the Gq Team. The following is 
> the example of the Redefinition of the ASR Command code
>
> By the 3GPP Team.
>
>         *{ Base Diameter Definition RFC 3588}*
> * *
> *{**3GPP TS 29.209 V6.6.0 (2006-09)}*
>
> * { Abort-Cause } {Why this AVP is Mandated Here ?}*
>
> [ Origin-State-Id ]**
>
> *[ Proxy-Info ]
>
> *[ Route-Record ]
>
> [ AVP ]
>

---

From: "Glen Zorn \(gwz\)" <[email-masked]>
Date: Tue, 5 Jun 2007 09:35:53 -0700

Hi Victor,

By the 3GPP Team.      

...

 No.  

...

---

From: "Glen Zorn \(gwz\)" <[email-masked]>
Date: Tue, 5 Jun 2007 09:51:39 -0700

Hi Victor,

No.  The mandatory AVPs are, in part, what define a command: adding or
removing them defines a new command.  It is unfortunate that 3GPP
apparently finds the task of appropriately requesting the allocation of
a new command code and documenting it too onerous to complete.  One
might expect that this would be the subject of a liaison from the IETF
to 3GPP...

Thx

-Arun

Hi Victor,

By the 3GPP Team.      

                                                  < Session-Id >

                                                 { Origin-Host }

                                                 { Origin-Realm }

                                                 { Destination-Realm }

                                                 { Destination-Host }

                                                 { Auth-Application-Id }

                                                 { Abort-Cause }

                                                 [ Origin-State-Id ]

                                                *[ Proxy-Info ]

                                                *[ Route-Record ]

                                                 [ AVP ]

Thx

-Arun

DISCLAIMER:

---

From: <[email-masked]>
Date: Tue, 5 Jun 2007 12:07:59 -0500

I'd side with Glen on this.  I think using new command codes is right
thing to do.  Reusing but redefining existing command codes will create
a long term mess, IMO.
 
John

	From: ext Glen Zorn (gwz) [mailto:[email-masked]] 
	Sent: 05 June, 2007 09:52
	To: Arun Santhanam, TLS-Chennai
	Cc: [email-masked]; [email-masked]
	Subject: RE: [Dime] Reg. the Re-Definition of the Command code

	Hi Victor,

	            I have one more Query. Can the Application Can
remove any AVP that has been termed as Mandatory in the Base Command
code?

	            For example in the 3GPP TS 29.209 V6.6.0 (2006-09) I
find that the "Re-Auth-Request-Type" (Which is mandatory AVP in RAR as
per the FRC 3588) has been removed while re-defining the RAR in 3GPP TS
29.209. Is this Approach is Correct? 

	No.  The mandatory AVPs are, in part, what define a command:
adding or removing them defines a new command.  It is unfortunate that
3GPP apparently finds the task of appropriately requesting the
allocation of a new command code and documenting it too onerous to
complete.  One might expect that this would be the subject of a liaison
from the IETF to 3GPP...

	Thx

	-Arun

	Hi Victor,

	            I went though the " 3GPP TS 29.209 V6.6.0 (2006-09)"
for Gq interface I'm surprised to see that the Base Command code 

	"RAR" and "ASR" has been redefined by the Gq Team. The following
is the example of the Redefinition of the ASR Command code

	By the 3GPP Team.      

	                 < Session-Id >
	                 { Origin-Host }
	                 { Origin-Realm }
	                 { Destination-Realm }
	                 { Destination-Host }
	                 { Auth-Application-Id }
	                 [ User-Name ]
	                 [ Origin-State-Id ]

	                                                  < Session-Id >

	                                                 { Origin-Host }

	                                                 { Origin-Realm
}

	                                                 {
Destination-Realm }

	                                                 {
Destination-Host }

	                                                 {
Auth-Application-Id }

	                                                 { Abort-Cause }

	                                                 [
Origin-State-Id ]

	                                                *[ Proxy-Info ]

	                                                *[ Route-Record
]

	                                                 [ AVP ]

	Is it correct for the Application to redefine the Base Command
code?

	Thx

	-Arun

DISCLAIMER:

---

From: Victor Fajardo <[email-masked]>
Date: Tue, 05 Jun 2007 13:24:06 -0400

Ok. Sounds reasonable. We can update the guidelines doc to reflect this.
regards,
victor

>     *From:* ext Glen Zorn (gwz) [mailto:[email-masked]]
>     *Sent:* 05 June, 2007 09:52
>     *To:* Arun Santhanam, TLS-Chennai
>     *Cc:* [email-masked]; [email-masked]
>     *Subject:* RE: [Dime] Reg. the Re-Definition of the Command code
>
>     Hi Victor,
>
>     I have one more Query. Can the Application Can remove any AVP that
>     has been termed as Mandatory in the Base Command code?
>
>     “Re-Auth-Request-Type” (Which is mandatory AVP in RAR as per the
>     FRC 3588) has been removed while re-defining the RAR in 3GPP TS
>     No. The mandatory AVPs are, in part, what define a command: adding
>     or removing them defines a new command. It is unfortunate that
>     complete. One might expect that this would be the subject of a
>     liaison from the IETF to 3GPP...
>
>     Thx
>
>     -Arun
>
>     I went though the “ 3GPP TS 29.209 V6.6.0 (2006-09)” for Gq
>     interface I’m surprised to see that the Base Command code
>
>     “RAR” and “ASR” has been redefined by the Gq Team. The following
>     The contents of this e-mail and any attachment(s) are confidential
>     and intended for the named recipient(s) only.
>     this message without the prior written consent of the author of
>     this e-mail is strictly prohibited. If you have
>     received this email in error please delete it and notify the
>     sender immediately. Before opening any mail and