Subject: [Dime] RE: Pass word in Diameter

From: <[email-masked]>
Date: Mon, 18 Jun 2007 13:51:36 -0500

I have forwarded this to the DiME WG list, this is the proper place to
discuss these issues.
 
John

________________________________

	From: ext Luo, Tong [mailto:[email-masked]] 
	Sent: 11 June, 2007 14:44
	To: [email-masked]; Loughney John (Nokia-NRC/PaloAlto);
[email-masked]; [email-masked]
	Subject: Pass word in Diameter

	Hi, 

	Since unlike Radius, the Diameter protocol defined by RFC 3588
doesn't have an authenticator in the message header anymore. However,
the user access request message defined by Radius could add
User-Password attribute (attribute type 2), which would require to use
authenticator in the Radius header to encrypt the password.  

	So my question is: without authenticator in the Diameter header,
how should the User-Password  attribute be calculated in Diameter?

	Thanks, 
	Tong 

_______________________________________________
DiME mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dime

---

From: "Glen Zorn \(gwz\)" <[email-masked]>
Date: Mon, 18 Jun 2007 12:18:20 -0700

In Diameter, the User-Password attribute is not encrypted separately.
It is covered by the TLS or IPsec security applied to the entire
message.

From: [email-masked] [mailto:[email-masked]] 
Sent: Monday, June 18, 2007 11:52 AM
To: [email-masked]
Cc: [email-masked]; [email-masked];
[email-masked]; [email-masked]
Subject: [Dime] RE: Pass word in Diameter

John

	Hi, 

	Thanks, 
	Tong