Subject: [Dime] group avp length encoding

From: "harish raghuveer" <[email-masked]>
Date: Wed, 20 Jun 2007 12:52:35 +0530

Hello,

I was going thru the draft-ietf-dime-rfc3588bis-04.txt. In the page number
56 the grouped avp seem to have a length of 468. Could someone please
explain how this value is obtained? If we consider the total encoded length
of all the sub-avps (including padding - 19+50+51+223+137+8 padding bytes +
8 bytes header) it comes to 496.  If we exclude the header lengths in the
excluded AVPs from the total encoded length, it should be 496 - (5 * 8) =
456 bytes. What am I missing?

thanks,
Harish
_______________________________________________
DiME mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dime

---

From: Rajith R <[email-masked]>
Date: Wed, 20 Jun 2007 14:12:42 +0530

For the given example of group AVP with the 5 sub AVPs, the length must be
496. The offset of some sub-AVPs must also be changed accordingly.

  _____  

From: harish raghuveer [mailto:[email-masked]] 
Sent: Wednesday, June 20, 2007 12:53 PM
To: [email-masked]
Subject: [Dime] group avp length encoding

Hello,

thanks,
Harish

---

From: "harish raghuveer" <[email-masked]>
Date: Wed, 20 Jun 2007 14:34:59 +0530

Thanks for the clarification, Rajith. The padding seems to be OK in the
example as I can see that they are all 32-bit aligned.

cheers,
Harish

On 6/20/07, Rajith R <[email-masked]> wrote:
>
>  For the given example of group AVP with the 5 sub AVPs, the length must
> be 496. The offset of some sub-AVPs must also be changed accordingly.
>
>
>
>  ------------------------------
> *From:* harish raghuveer [mailto:[email-masked]]
> *Sent:* Wednesday, June 20, 2007 12:53 PM
> *To:* [email-masked]
> *Subject:* [Dime] group avp length encoding
>
> Hello,
>

-- 
Harish R Prabhu
Ph:98457-34737 (M)

---

From: Rajith R <[email-masked]>
Date: Wed, 20 Jun 2007 14:40:23 +0530

the padding is certainly ok, I am talking about the offset, for eg: the 2nd
session Id avp (of length 51) starts at byte offset of '72', actually it
should start at '80' & so on ...

  _____  

From: harish raghuveer [mailto:[email-masked]] 
Sent: Wednesday, June 20, 2007 2:35 PM
To: [email-masked]
Cc: [email-masked]
Subject: Re: [Dime] group avp length encoding

cheers,
Harish

  _____  

Hello,

thanks,
Harish

-- 
Harish R Prabhu
Ph:98457-34737 (M)

---

From: Victor Fajardo <[email-masked]>
Date: Wed, 20 Jun 2007 08:31:13 -0400

Hi,

Thanks for noticing. It should be updated.

regards,
victor

> the padding is certainly ok, I am talking about the offset, for eg: 
> the 2nd session Id avp (of length 51) starts at byte offset of '72', 
> actually it should start at '80' & so on ...
>
>     ------------------------------------------------------------------------
>     *Sent:* Wednesday, June 20, 2007 2:35 PM
>     *To:* [email-masked]
>     *Cc:* [email-masked]
>     *Subject:* Re: [Dime] group avp length encoding
>
>     Thanks for the clarification, Rajith. The padding seems to be OK
>     in the example as I can see that they are all 32-bit aligned.
>
>     cheers,
>     Harish
>
>     On 6/20/07, *Rajith R* <[email-masked]
>     <mailto:[email-masked]>> wrote:
>
>         For the given example of group AVP with the 5 sub AVPs, the
>         length must be 496. The offset of some sub-AVPs must also be
>         changed accordingly.
>          
>          
>
>             ------------------------------------------------------------------------
>             *From:* harish raghuveer [mailto:[email-masked]
>             <mailto:[email-masked]>]
>             *To:* [email-masked] <mailto:[email-masked]>
>             I was going thru the draft-ietf-dime-rfc3588bis-04.txt. In
>             the page number 56 the grouped avp seem to have a length
>             of 468. Could someone please explain how this value is
>             obtained? If we consider the total encoded length of all
>             the sub-avps (including padding - 19+50+51+223+137+8
>             padding bytes + 8 bytes header) it comes to 496.  If we
>             exclude the header lengths in the excluded AVPs from the
>             total encoded length, it should be 496 - (5 * 8) = 456
>             bytes. What am I missing?
>
>             thanks,
>             Harish
>
>
>
>
>     -- 
>     Harish R Prabhu
>     Ph:98457-34737 (M) 
>
> ------------------------------------------------------------------------
>