Subject: [Dime] Clarification regarding the I-PeerDisc event

From: "Balamurugan T, TLS-Chennai" <[email-masked]>
Date: Wed, 25 Jul 2007 21:11:03 +0530

Hi All,

      According to RFC 3588, Peer state machine receives I-PeerDisc
event in wait-returns state. If one 

      peer closes the connection other side peer will receive
(R-PeerDisc).

      Any one, please clarify the scenario in which the I-PeerDisc event
is possible.

Regards,

Bala

DISCLAIMER:
-----------------------------------------------------------------------------------------------------------------------

The contents of this e-mail and any attachment(s) are confidential and intended for the named recipient(s) only.
It shall not attach any liability on the originator or HCL or its affiliates. Any views or opinions presented in 
this email are solely those of the author and may not necessarily reflect the opinions of HCL or its affiliates.
Any form of reproduction, dissemination, copying, disclosure, modification, distribution and / or publication of 
this message without the prior written consent of the author of this e-mail is strictly prohibited. If you have 
received this email in error please delete it and notify the sender immediately. Before opening any mail and 
attachments please check them for viruses and defect.

-----------------------------------------------------------------------------------------------------------------------

_______________________________________________
DiME mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dime

---

From: "Harish R Prabhu" <[email-masked]>
Date: Thu, 26 Jul 2007 11:37:34 +0530

Hi Balamurugan,
My understanding/interpretation of the situation is as follows:
Look at Wait-Returns state from a node (lets say A) that initiates a
transport connection. I-Peer-Disc event would probably mean peer has closed
the transport connection that was initiated from A (due to election win at
the other end perhaps?). In this case the same transport connection has to
be marked closed by A also, that's what I-Disc does in this case. However, I
tend to agree that the state machine description is very terse. Folks,
please feel free to correct any discrepancies in the explanation.
cheers,
Harish

On 7/25/07, Balamurugan T, TLS-Chennai <[email-masked]> wrote:
>
>  Hi All,
>
>
>
>       According to RFC 3588, Peer state machine receives *I-PeerDisc*event in
> *wait-returns* state. If one
>
> The contents of this e-mail and any attachment(s) are confidential and
> intended for the named recipient(s) only.
> It shall not attach any liability on the originator or HCL or its
> affiliates. Any views or opinions presented in
> Any form of reproduction, dissemination, copying, disclosure,
> modification, distribution and / or publication of
> this message without the prior written consent of the author of this
> e-mail is strictly prohibited. If you have