Subject: [Dime] Update on Diameter Auditing

From: "Ulf Bodin" <[email-masked]>
Date: Sun, 29 Jul 2007 10:21:30 +0200

All, 

As requested I'm giving a brief update on the Diameter Auditing work at
the list (basically the update I gave verbally on Friday's WG meeting):

There are two individual drafts on the topic; the Diameter Auditing
requirements draft, AR (draft-bodin-dime-auditing-reqs-02) and the State
recovery draft, SR (draft-asveren-dime-state-recovery-01). AR gives high
level requirements for Diameter auditing and contains previous work done
by Pat Calhoun on defining commads and AVPs for auditing. SR provides an
analyze of what protocol assisted mechanisms can be helfull in
performing state recovery. 

Some mails have been exchanged in June studying which commands and AVPs
either defined in Calhouns original work or that exists in other Dimeter
specificaitons that could be used or enhanced for protocol assisted
state recovery (i.e. auditing). My intention is to proceed that work and
before the next IETF meeting collect what then have been done on the
mailing list into a draft presenting desired extensions to Dimaeter for
protocol assisted state recovery. Based on that work it'd in my view
make sence considering taking on Diameter protocol assisted state
recovery as a WG work item. 

BR Ulf 

_______________________________________________
DiME mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dime

---

From: "Glen Zorn \(gwz\)" <[email-masked]>
Date: Sun, 29 Jul 2007 16:33:02 -0700

Ulf Bodin <mailto:[email-masked]> allegedly scribbled on Sunday,
July 29, 2007 1:22 AM:

> All,
> 
> As requested I'm giving a brief update on the Diameter Auditing work
> at the list (basically the update I gave verbally on Friday's WG
> meeting):  
> 
> 
> requirements draft, AR (draft-bodin-dime-auditing-reqs-02) and the
> State recovery draft, SR (draft-asveren-dime-state-recovery-01). AR
> gives high level requirements for Diameter auditing and contains
> previous work done by Pat Calhoun on defining commads and AVPs for
> auditing. 

This draft is largely indecipherable.  Although there may be
requirements in there, I can't find them and there seems to be no actual
description of the problem it's trying to solve.  My _guess_ is that for
some unknown reason you are trying to use the network as a state
repository so that it can recover state after a failure.  Is that right?
If so, why is this scheme better than, say, NVRAM?

> SR provides an analyze of what protocol assisted mechanisms
> can be helfull in performing state recovery.      
> 
> Some mails have been exchanged in June studying which commands and
> AVPs either defined in Calhouns original work or that exists in other
> Dimeter specificaitons that could be used or enhanced for protocol
> assisted state recovery (i.e. auditing). 

Maybe part of the problem is the (mis)use of the word auditing.
Thinking that I was ignorant I made a rather extensive search of
dictionaries and was unable to find a definition of the word "auditing"
that remotely resembled "protocol assisted (sic) state recovery".

> My intention is to proceed
> that work and before the next IETF meeting collect what then have
> been done on the mailing list into a draft presenting desired
> extensions to Dimaeter for protocol assisted state recovery. Based on
> that work it'd in my view make sence considering taking on Diameter
> protocol assisted state recovery as a WG work item.    

Why?

---

From: Steigerwaldw <[email-masked]>
Date: Tue, 31 Jul 2007 12:37:30 +0200

Hi Glen,

IMHO auditing means not "state recovery". Auditing is more to get the current state of a system or organisation. A good definition I found on Wikipedia.

Wolfgang

T-Systems Enterprise Services GmbH
Systems Integration
Project & Design, Business Unit Telco
Line of Business Products & Services
Goslarer Ufer 35, 10589 Berlin 
Tel.    +49 30 -3497 2058 
Fax     +49 391 53475396 
Mobil   +49 171 5664350 
E-Mail:         [email-masked] 

T-Systems Business Services GmbH
Aufsichtsrat: René Obermann (Vorsitzender)
Executive Committee: Helmut Binder*, Albert Henn*, Olaf Heyden, Katrin Horstmann, Ulrich Kemp*, Axel Knobe, Wilfried Peters*, 
Dr. Herbert Schaaff, Zvezdana Seeger
Handelsregister: Amtsgericht Bonn HRB 6787
Sitz der Gesellschaft: Bonn
WEEE-Reg.-Nr. DE50335567
*Geschäftsführer gem. § 35 GmbHG

Notice: This transmittal and/or attachments may be privileged or confidential. If you are not the intended recipient, you are hereby notified that you have received this transmittal in error; any review, dissemination, or copying is strictly prohibited. If you received this transmittal in error, please notify us immediately by reply and immediately delete this message and all its attachments. Thank you. 

> -----Ursprüngliche Nachricht-----
> Von: Glen Zorn (gwz) [mailto:[email-masked]] 
> Gesendet: Montag, 30. Juli 2007 01:33
> An: Ulf Bodin
> Cc: [email-masked]
> Betreff: RE: [Dime] Update on Diameter Auditing 
> 
> Ulf Bodin <mailto:[email-masked]> allegedly scribbled 
> on Sunday, July 29, 2007 1:22 AM:
> 
> > All,
> > 
> requirements in there, I can't find them and there seems to 
> be no actual description of the problem it's trying to solve. 
>  My _guess_ is that for some unknown reason you are trying to 
> use the network as a state repository so that it can recover 
> state after a failure.  Is that right?
> Thinking that I was ignorant I made a rather extensive search 
> of dictionaries and was unable to find a definition of the 
> word "auditing"
> > that work and before the next IETF meeting collect what 
> then have been 
> > done on the mailing list into a draft presenting desired 
> extensions to 
> > Dimaeter for protocol assisted state recovery. Based on 
> that work it'd 
> > in my view make sence considering taking on Diameter

---

From: Tina TSOU <[email-masked]>
Date: Tue, 31 Jul 2007 19:16:33 +0800

Hi Wolfgang,
I agree with you.

B. R.
Tina
+86-755-28972912 (Office)    +86-13922884380 (Mobile)
Messengers:
MSN: [email-masked]   Yahoo: tina_tsou    Skype: tinaTSOU    Jabber: 
[email-masked]    Google talk: [email-masked]

----- Original Message ----- 
From: "Steigerwaldw" <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>
Sent: Tuesday, July 31, 2007 6:37 PM
Subject: AW: [Dime] Update on Diameter Auditing

Hi Glen,

IMHO auditing means not "state recovery". Auditing is more to get the 
current state of a system or organisation. A good definition I found on 
Wikipedia.

Wolfgang

T-Systems Business Services GmbH
Aufsichtsrat: René Obermann (Vorsitzender)
Executive Committee: Helmut Binder*, Albert Henn*, Olaf Heyden, Katrin 
Horstmann, Ulrich Kemp*, Axel Knobe, Wilfried Peters*,
Dr. Herbert Schaaff, Zvezdana Seeger
Handelsregister: Amtsgericht Bonn HRB 6787
Sitz der Gesellschaft: Bonn
WEEE-Reg.-Nr. DE50335567
*Geschäftsführer gem. § 35 GmbHG

Notice: This transmittal and/or attachments may be privileged or 
confidential. If you are not the intended recipient, you are hereby notified 
that you have received this transmittal in error; any review, dissemination, 
or copying is strictly prohibited. If you received this transmittal in 
error, please notify us immediately by reply and immediately delete this 
message and all its attachments. Thank you.