Subject: [Dime] Question Regarding Failed AVP.

From: Himanshu Bahl <[email-masked]>
Date: Tue, 3 Jul 2007 15:27:10 +0530

Hi all,
In the section 7.5 of draft-ietf-dime-rfc3588bis-04.txt it states that 
" A Diameter message SHOULD contain only one Failed-AVP that corresponds 
to the error indicated by the Result-Code AVP."

The document also states in the same section that 
"For practical purposes, this Failed-AVP would typically refer to the 
first AVP processing error that a Diameter node encounters."

my question is that if the message is supposed to contain only one failed 
AVP then why does the ABNF of messages CEA,DPA and DWA have   *[ 
Failed-AVP ].

Secondly,
if the failed AVP is supposed to contain the first erroneous AVP in it why 
does its ABNF have  1* {AVP} .

Thanks in advance,

Sincerely,
Himanshu Bahl
Software Engineer
 
A R I C E N T
?You can't shake hands with a clenched fist.?

***********************  Aricent-Private   ***********************
"DISCLAIMER: This message is proprietary to Aricent  and is intended solely for the use of 
the individual to whom it is addressed. It may contain privileged or confidential information and should not be 
circulated or used for any purpose other than for what it is intended. If you have received this message in error, 
please notify the originator immediately. If you are not the intended recipient, you are notified that you are strictly
prohibited from using, copying, altering, or disclosing the contents of this message. Aricent accepts no responsibility for 
loss or damage arising from the use of the information transmitted by this email including damage from virus."
_______________________________________________
DiME mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dime

---

From: Rajith R <[email-masked]>
Date: Tue, 03 Jul 2007 15:35:27 +0530

pls see inline

  _____  

From: Himanshu Bahl [mailto:[email-masked]] 
Sent: Tuesday, July 03, 2007 3:27 PM
To: Victor Fajardo
Cc: Amit Kumar PNGN; Preeti Shandilya; [email-masked]
Subject: [Dime] Question Regarding Failed AVP.

Hi all, 
In the section 7.5 of draft-ietf-dime-rfc3588bis-04.txt it states that 
" A Diameter message SHOULD contain only one Failed-AVP that corresponds to
the error indicated by the Result-Code AVP." 

The document also states in the same section that 
"For practical purposes, this Failed-AVP would typically refer to the first
AVP processing error that a Diameter node encounters." 

my question is that if the message is supposed to contain only one failed
AVP then why does the ABNF of messages CEA,DPA and DWA have   *[ Failed-AVP
].  
 
Rajith >>   I think it should be [Failed-AVP]

Secondly, 
 
Rajith>> For eg., in case of CONTRADICTING_AVPS result code, you could add
those avp"s" to this grouped AVP

Thanks in advance, 

Sincerely, 
Himanshu Bahl 

Software Engineer 

A R I C E N T

"You can't shake hands with a clenched fist." 

"DISCLAIMER: This message is proprietary to Aricent  and is intended solely
for the use of 

the individual to whom it is addressed. It may contain privileged or
confidential information and should not be 

circulated or used for any purpose other than for what it is intended. If
you have received this message in error, 

please notify the originator immediately. If you are not the intended
recipient, you are notified that you are strictly

prohibited from using, copying, altering, or disclosing the contents of this
message. Aricent accepts no responsibility for 

loss or damage arising from the use of the information transmitted by this
email including damage from virus."

---

From: Victor Fajardo <[email-masked]>
Date: Tue, 03 Jul 2007 08:22:20 -0400

Hi,

>     In the */section 7.5/* of /draft-ietf-dime-rfc3588bis-04.txt/ it
>     states that
>     " A Diameter message SHOULD contain only one Failed-AVP that
>     corresponds to the error indicated by the Result-Code AVP."
>
>     "For practical purposes, this Failed-AVP would typically refer to
>     the first AVP processing error that a Diameter node encounters."
>
>     my question is that if the message is supposed to contain only one
>     failed AVP then why does the ABNF of messages CEA,DPA and DWA have
>       *[ Failed-AVP ].  
>      

Keeping the *[Failed-AVP] ABNF and using a "SHOULD" instead of a "MUST" 
was based on backward compatibility concerns. I'm not sure if this is 
still a valid concern or not so it maybe best to hear from others as well.

-- victor

---

From: "Thomas Lindgren" <[email-masked]>
Date: Wed, 4 Jul 2007 11:20:48 +0200

> still a valid concern or not so it maybe best to hear from others as well.

Could an error like DIAMETER_CONTRADICTING_AVPS (7.1.5, no 5007) occur? That
one allows returning two or more Failed-AVPs if necessary. It's not
mentioned in 7.5 though.

Best,
Thomas
--
Thomas Lindgren, Millpond Services Ltd
_______________________________________________
DiME mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dime

---

From: Rajith R <[email-masked]>
Date: Wed, 04 Jul 2007 14:54:49 +0530

In this case, you may include those AVPs as the "sub" AVPs of Failed-AVP.
Failed-AVP AVP is a "grouped" AVP.
As I have mentioned earlier, Failed-AVP AVP corresponds to Result Code, and
as long as you have just one result code, it makes sense to have just one
Failed-AVP AVP. This AVP itself might include one or more sub AVPs.

  _____  

From: Thomas Lindgren [mailto:[email-masked]] 
Sent: Wednesday, July 04, 2007 2:51 PM
To: [email-masked]
Subject: Re: [Dime] Question Regarding Failed AVP.

Hi,

Best,
Thomas

---

From: "Thomas Lindgren" <[email-masked]>
Date: Wed, 4 Jul 2007 13:52:17 +0200

On 7/4/07, Rajith R <[email-masked]> wrote:
> As I have mentioned earlier, Failed-AVP AVP corresponds to Result Code,
> and as long as you have just one result code, it makes sense to have just
> one Failed-AVP AVP. This AVP itself might include one or more sub AVPs.
>

Right, though in that case 7.1.5/5007 also needs to be updated since it
explicitly permits more than one Failed-AVP. I'm not sure which is the best
choice -- it's tempting to make things more elegant, but there's something
to be said for nailing down the status quo too. Either way, some
clarification seems useful.

Best,
Thomas

------------------------------
> *From:* Thomas Lindgren [mailto:[email-masked]]
> *Sent:* Wednesday, July 04, 2007 2:51 PM
> *To:* [email-masked]
> *Subject:* Re: [Dime] Question Regarding Failed AVP.
>
>
>
> Could an error like DIAMETER_CONTRADICTING_AVPS (7.1.5, no 5007) occur?
> That one allows returning two or more Failed-AVPs if necessary. It's not
> mentioned in 7.5 though.
>
> Best,
> Thomas
> --

---

From: "harish raghuveer" <[email-masked]>
Date: Wed, 4 Jul 2007 18:04:43 +0530

Hi all,

I also had the thought that a single Failed-AVP corresponds to a single
result code. If the parser implementation can report multiple errors
(consider a case where a request message with multiple unsupported AVPs and
a few enum type AVPs with invalid values), it definitely makes sense to have
multiple Failed-AVPs, each corresponding to a specific type of error. But
that would need the inclusion of "*1 {Result-Code}" in Failed-AVPs  ABNF.
IMHO, the new ABNF definition would also be backward compatible because
there is no requirement on min. number of occurrences of Result-Code AVP.
The receiver of the response with Failed-AVP can either use the common
Result-code in the message or Failed-AVP specific result code to isolate the
cause of error (for debugging purposes).

My $0.02.

thanks,
Harish

On 7/4/07, Thomas Lindgren <[email-masked]> wrote:
> >  In this case, you may include those AVPs as the "sub" AVPs of
> > Failed-AVP. Failed-AVP AVP is a "grouped" AVP.
> > *From:* Thomas Lindgren [mailto: [email-masked]]
> > On 7/3/07, Victor Fajardo < [email-masked]> wrote:
> > >
> > > Hi,
> > >

-- 
Harish R Prabhu
Bangalore, India.

---

From: Victor Fajardo <[email-masked]>
Date: Wed, 04 Jul 2007 20:08:03 -0400

Hi Thomas,
>
> Right, though in that case 7.1.5/5007 also needs to be updated since 
> it explicitly permits more than one Failed-AVP. I'm not sure which is 
> the best choice -- it's tempting to make things more elegant, but 
> there's something to be said for nailing down the status quo too. 
> Either way, some clarification seems useful.

I agree.

regards,
victor

---

From: Victor Fajardo <[email-masked]>
Date: Wed, 04 Jul 2007 20:27:54 -0400

Hi Harish,

Sounds ok to me. BTW, this should also cover STA, ASA, RAA.

regards,
victor
> Hi all,
>
> I also had the thought that a single Failed-AVP corresponds to a 
> single result code. If the parser implementation can report multiple 
> errors (consider a case where a request message with multiple 
> unsupported AVPs and a few enum type AVPs with invalid values), it 
> definitely makes sense to have multiple Failed-AVPs, each 
> corresponding to a specific type of error. But that would need the 
> inclusion of "*1 {Result-Code}" in Failed-AVPs  ABNF.  IMHO, the new 
> ABNF definition would also be backward compatible because there is no 
> requirement on min. number of occurrences of Result-Code AVP. The 
> receiver of the response with Failed-AVP can either use the common 
> Result-code in the message or Failed-AVP specific result code to 
> isolate the cause of error (for debugging purposes).
>
> My $0.02.
>
> thanks,
> Harish
>
> On 7/4/07, *Thomas Lindgren* <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>
>
>     On 7/4/07, * Rajith R* <[email-masked]
>     <mailto:[email-masked]>> wrote:
>
>         As I have mentioned earlier, Failed-AVP AVP corresponds to
>         Result Code, and as long as you have just one result code, it
>         makes sense to have just one Failed-AVP AVP. This AVP itself
>         might include one or more sub AVPs.
>
>
>     Right, though in that case 7.1.5/5007 also needs to be updated
>     since it explicitly permits more than one Failed-AVP. I'm not sure
>     which is the best choice -- it's tempting to make things more
>     elegant, but there's something to be said for nailing down the
>     status quo too. Either way, some clarification seems useful.
>
>     Best,
>     Thomas
>      
>
>             ------------------------------------------------------------------------
>             *From:* Thomas Lindgren [mailto: [send email to
>             [email-masked] via gmail]
>             [email-masked]
>             <mailto:[email-masked]>]
>             *To:* [send email to [email-masked] via gmail]
>             [email-masked] <mailto:[email-masked]>
>             On 7/3/07, *Victor Fajardo* < [send email to
>             [email-masked] via gmail]
>             [email-masked]
>             <mailto:[email-masked]>> wrote:
>
>                 Hi,
>
>             Could an error like DIAMETER_CONTRADICTING_AVPS (7.1.5, no
>             5007) occur? That one allows returning two or more
>             Failed-AVPs if necessary. It's not mentioned in 7.5 though.
>
>             Best,
>             Thomas
>             --
>     [email-masked] <mailto:[email-masked]>
> ------------------------------------------------------------------------
>