Subject: RE: [Dime] 'P' bit in AVP flag

From: "Balamurugan T, TLS-Chennai" <[email-masked]>
Date: Mon, 9 Jul 2007 18:30:50 +0530

Hi All,

    From my understanding P bit means for end to end security. If this bit is no more
    available in diameter RFC, then how can we achieve end-to-end security.

Regards,
Bala

-----Original Message-----
From: Victor Fajardo [mailto:[email-masked]]
Sent: Monday, July 09, 2007 5:35 PM
To: Soji VP
Cc: [email-masked]
Subject: Re: [Dime] 'P' bit in AVP flag

Thanks for catching that. It will be removed in the next rev.

-- victor

> Hi friends,
>
> ‘P’ bit has been removed from AVP header (from 3588bis-03 onwards) but 
> it’s still being referred in the table given in section “4.5 Diameter 
> Base protocol AVPs”. I feel it can be safely removed as it’s no more 
> relevant there.
>
> Thanks & Rgds,
>
> Soj.
>
> ------------------------------------------------------------------------
>
> _______________________________________________
> DiME mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/dime
>   

_______________________________________________
DiME mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dime

DISCLAIMER:
-----------------------------------------------------------------------------------------------------------------------

The contents of this e-mail and any attachment(s) are confidential and intended for the named recipient(s) only.
It shall not attach any liability on the originator or HCL or its affiliates. Any views or opinions presented in 
this email are solely those of the author and may not necessarily reflect the opinions of HCL or its affiliates.
Any form of reproduction, dissemination, copying, disclosure, modification, distribution and / or publication of 
this message without the prior written consent of the author of this e-mail is strictly prohibited. If you have 
received this email in error please delete it and notify the sender immediately. Before opening any mail and 
attachments please check them for viruses and defect.

-----------------------------------------------------------------------------------------------------------------------

_______________________________________________
DiME mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dime

---

From: Hannes Tschofenig <[email-masked]>
Date: Mon, 09 Jul 2007 15:05:26 +0200

The concept of end-to-end security was once described in Diameter CMS 
Security Application, see for example
http://www3.ietf.org/proceedings/02jul/I-D/draft-ietf-aaa-diameter-cms-sec-04.txt

Since the work on that document was stopped we don't have E2E security 
in Diameter anymore (unless someone finds a need for it and continues 
that document).
In this case that document would re-introduce the P bit.

Ciao
Hannes