Subject: Re: [Dime] Diameter QoS Appl.- "PULL/PUSH/Access network related Re: [Dime] Diameter QoS Appl.- "PULL/PUSH/Access network related information"

From: "Christian Esteve" <[email-masked]>
Date: Wed, 11 Jul 2007 16:05:48 -0300

Hi!

My 2 cents:

> But how should the AF know anything about the access network
> characteristics? (unless it is in the access network itself)
[Tina: it is configured by the operator/administrator.]

[Christian: Agree that the configuration of the AF is provided by the
administrative domain. Additionally, the AF may know through application
level user signaling (UE-AF) aboout the access network type for which the
session authorization applies. E.g.the  P-Access- Network-Info [RFC 3455]
used in the IMS SIP signaling relays information about the access technology
that may then be used  to   optimize services (e.g. location-based, bw
optimized) for the UA at the home domain and it could be useful to perform
accurate access network resource authorization requests at the visited
domain.
To my understasnding this information can be used by the AF to choose the
appropriate QoS template.

E.g. P-Access-Network-Info: 3GPP-UTRAN-TDD; utran-cell-id-3gpp=234151D0FCE11
]

Best regards,
Christian

------------------------------

Message: 4
Date: Wed, 11 Jul 2007 19:34:12 +0800
From: Tina TSOU <[email-masked]>
Subject: Re: [Dime] Diameter QoS Appl.- "PULL/PUSH/Access network
       related information"
To: [email-masked], Hannes Tschofenig <[email-masked]>
Message-ID: <[email-masked]>
Content-Type: text/plain; format=flowed; charset=iso-8859-1;
       reply-type=response

----- Original Message -----
From: "Hannes Tschofenig" <[email-masked]>
To: <[email-masked]>; "Tina TSOU" <[email-masked]>
Sent: Wednesday, July 11, 2007 6:46 PM
Subject: Re: [Dime] Diameter QoS Appl.-  "PULL/PUSH/Access network related
information"

> Hi Tina,
>
> who translates high-level QoS information used at the application layer
> into information that is appropriate for a QoS model that is used in a
> particular access network. In your model it seems that the AF is in charge
> of assisting whereas the PDF does the final translation. In any case, it
> is not the NE that does it.
>
> Correct?
[Tina: Correct.]
>
> But how should the AF know anything about the access network
> characteristics?
> (unless it is in the access network itself)
[Tina: it is configured by the operator/administrator.]
> Ciao
> Hannes
_______________________________________________
DiME mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dime

---

From: "Sun, Dong \(Dong\)" <[email-masked]>
Date: Wed, 11 Jul 2007 18:04:02 -0500

Hi Chirstian,
 
I agree, in certain circumstance e.g. IMS AF, it is possible to identify
the access network as you described. 
Maybe, I guess, there is some confusion (to me) on the terminology used
here. If you are saying that AF may determine the service
profile/attributes upon access type, it would be fine in certain case
(but it is out of the scope in this doc). However, not sure if it is
good idea to make the application server involved in network level QoS
selection, even it is worse to make the AS select access specific QoS
profile. 
 
Regards,
Dong

________________________________

	From: Christian Esteve [mailto:[email-masked]] 
	Sent: Wednesday, July 11, 2007 3:06 PM
	To: [email-masked]; Tina TSOU; Hannes Tschofenig
	Subject: Re: [Dime] Diameter QoS Appl.- "PULL/PUSH/Access
network related Re:[Dime] Diameter QoS Appl.- "PULL/PUSH/Access network
relatedinformation"

	Hi!

	
	[Christian: Agree that the configuration of the AF is provided
by the administrative domain. Additionally, the AF may know through
application level user signaling (UE-AF) aboout the access network type
for which the session authorization applies. E.g.the  P-Access-
Network-Info [RFC 3455] used in the IMS SIP signaling relays information
about the access technology that may then be used  to   optimize
services (e.g. location-based, bw optimized) for the UA at the home
domain and it could be useful to perform accurate access network
resource authorization requests at the visited domain. 
	To my understasnding this information can be used by the AF to
choose the appropriate QoS template.
	
	E.g. P-Access-Network-Info: 3GPP-UTRAN-TDD;
utran-cell-id-3gpp=234151D0FCE11
	]
	
	Best regards,
	Christian

	Message: 4
	Date: Wed, 11 Jul 2007 19:34:12 +0800
	From: Tina TSOU < [email-masked] <mailto:[email-masked]> >
	Subject: Re: [Dime] Diameter QoS Appl.- "PULL/PUSH/Access
network
	       related information"
	To: [email-masked], Hannes Tschofenig <[email-masked]>
	Message-ID: < [email-masked]
<mailto:[email-masked]> >
	Content-Type: text/plain; format=flowed; charset=iso-8859-1;
	       reply-type=response

	----- Original Message -----
	From: "Hannes Tschofenig" < [email-masked]>
	To: < [email-masked] <mailto:[email-masked]> >; "Tina TSOU"
<[email-masked]>
	Sent: Wednesday, July 11, 2007 6:46 PM
	Subject: Re: [Dime] Diameter QoS Appl.-  "PULL/PUSH/Access
network related 
	information"

	[Tina: Correct.]

---

From: Tina TSOU <[email-masked]>
Date: Thu, 12 Jul 2007 14:11:16 +0800

Hi Christian,
Actually, the QoS template is not chosen by AF (mapping to Application Server here). It is determined by the policy in SPDF (mapping to Authorizing Entity here) according to related information sent from AF to SPDF. There is no need for AF to see the template information. 

B. R.
Tina
Messengers: 
MSN: [email-masked]   Yahoo: tina_tsou    Skype: tinaTSOU    Jabber: [email-masked]    Google talk: [email-masked]

  ----- Original Message ----- 
  From: Christian Esteve 
  To: [email-masked] ; Tina TSOU ; Hannes Tschofenig 
  Sent: Thursday, July 12, 2007 3:05 AM
  Subject: Re: [Dime] Diameter QoS Appl.- "PULL/PUSH/Access network related Re: [Dime] Diameter QoS Appl.- "PULL/PUSH/Access network related information"

  Hi!

  [Christian: Agree that the configuration of the AF is provided by the administrative domain. Additionally, the AF may know through application level user signaling (UE-AF) aboout the access network type for which the session authorization applies. E.g.the  P-Access- Network-Info [RFC 3455] used in the IMS SIP signaling relays information about the access technology that may then be used  to   optimize services (e.g. location-based, bw optimized) for the UA at the home domain and it could be useful to perform accurate access network resource authorization requests at the visited domain. 
  To my understasnding this information can be used by the AF to choose the appropriate QoS template.

  Best regards,
  Christian

  Message: 4
  Date: Wed, 11 Jul 2007 19:34:12 +0800
  From: Tina TSOU < [email-masked]>
  Subject: Re: [Dime] Diameter QoS Appl.- "PULL/PUSH/Access network
         related information"
  To: [email-masked], Hannes Tschofenig <[email-masked]>
  Message-ID: < [email-masked]>
  Content-Type: text/plain; format=flowed; charset=iso-8859-1;
         reply-type=response

  ----- Original Message -----
  From: "Hannes Tschofenig" < [email-masked]>
  To: < [email-masked]>; "Tina TSOU" <[email-masked]>
  Sent: Wednesday, July 11, 2007 6:46 PM
  Subject: Re: [Dime] Diameter QoS Appl.-  "PULL/PUSH/Access network related 
  information"

  [Tina: Correct.]

---

From: Tina TSOU <[email-masked]>
Date: Thu, 12 Jul 2007 14:39:40 +0800

Hi Christian,
Moreover, 
For mobile terminals, AF can get access network identifier from SIP message header.
For fix terminals, AF can query the access network identifier via e2 interface. The way carried by SIP is not granted by consensus.
 
B. R.
Tina

  ----- Original Message ----- 
  From: Tina TSOU 
  To: Hannes Tschofenig ; [email-masked] ; Christian Esteve 
  Sent: Thursday, July 12, 2007 2:11 PM
  Subject: Re: [Dime] Diameter QoS Appl.-"PULL/PUSH/Access network related Re: [Dime] Diameter QoS Appl.-"PULL/PUSH/Access network related information"

  Hi Christian,

  B. R.
  Tina
  Messengers: 

    ----- Original Message ----- 
    From: Christian Esteve 
    To: [email-masked] ; Tina TSOU ; Hannes Tschofenig 
    Sent: Thursday, July 12, 2007 3:05 AM
    Subject: Re: [Dime] Diameter QoS Appl.- "PULL/PUSH/Access network related Re: [Dime] Diameter QoS Appl.- "PULL/PUSH/Access network related information"

    Hi!

    Best regards,
    Christian

    Message: 4

    ----- Original Message -----
    From: "Hannes Tschofenig" < [email-masked]>
    To: < [email-masked]>; "Tina TSOU" <[email-masked]>
    Sent: Wednesday, July 11, 2007 6:46 PM
    Subject: Re: [Dime] Diameter QoS Appl.-  "PULL/PUSH/Access network related 
    information"

    [Tina: Correct.]
    > Hannes 

------------------------------------------------------------------------------

---

From: Tina TSOU <[email-masked]>
Date: Thu, 12 Jul 2007 15:27:19 +0800

Hi Dong,
Answer for Push/Pull mode: Policy Server needs to know which mode to choose (push or pull) in the converged scenario (similar to the first question from Christian).

Answer for Access network related information: When the interfaces (e.g. Gq', Gq, Rx, Rs) between AS and Policy Server are converged but the procedures are separated as before, Policy Server needs to identify which procedure to perform. Of course, NE can do some identification, but we just propose a more general method for the Policy Server to identify.  So AS will send access network related information to Policy Server. However, if the procedures are also converged in the future, there is no need for the Policy Server to identify. 
 
B. R.
Tina
  ----- Original Message ----- 
  From: Sun, Dong (Dong) 
  To: Christian Esteve ; [email-masked] ; Tina TSOU ; Hannes Tschofenig 
  Sent: Thursday, July 12, 2007 7:04 AM
  Subject: RE: [Dime] Diameter QoS Appl.- "PULL/PUSH/Access network related Re:[Dime] Diameter QoS Appl.- "PULL/PUSH/Access network relatedinformation"

  Hi Chirstian,

  I agree, in certain circumstance e.g. IMS AF, it is possible to identify the access network as you described. 
  Maybe, I guess, there is some confusion (to me) on the terminology used here. If you are saying that AF may determine the service profile/attributes upon access type, it would be fine in certain case (but it is out of the scope in this doc). However, not sure if it is good idea to make the application server involved in network level QoS selection, even it is worse to make the AS select access specific QoS profile. 

  Regards,
  Dong

----------------------------------------------------------------------------
    From: Christian Esteve [mailto:[email-masked]] 
    Sent: Wednesday, July 11, 2007 3:06 PM
    To: [email-masked]; Tina TSOU; Hannes Tschofenig
    Subject: Re: [Dime] Diameter QoS Appl.- "PULL/PUSH/Access network related Re:[Dime] Diameter QoS Appl.- "PULL/PUSH/Access network relatedinformation"

    Hi!

    Best regards,
    Christian

    Message: 4

    ----- Original Message -----
    From: "Hannes Tschofenig" < [email-masked]>
    To: < [email-masked]>; "Tina TSOU" <[email-masked]>
    Sent: Wednesday, July 11, 2007 6:46 PM
    Subject: Re: [Dime] Diameter QoS Appl.-  "PULL/PUSH/Access network related 
    information"

    [Tina: Correct.]