Subject: [Dime] Requirement of transaction maintenance in DIAMETER

From: Arijeet Pal <[email-masked]>
Date: Thu, 5 Jul 2007 01:05:27 -0700 (PDT)

Hello Everyone,
   
  I am new to this group and have just started upon the study of the DIAMETER base protocol. 
   
  I have a very basic question:
   
  Why is the conception of a transaction (and maintaining transaction states) required in DIAMETER agents when this protocol uses only reliable transmission options (e.g. SCTP and/or TCP) for exchanges messages between peers?
   
  Thanks and Regards,
  Arijeet

---------------------------------
Luggage? GPS? Comic books? 
Check out fitting  gifts for grads at Yahoo! Search.

_______________________________________________
DiME mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dime

---

From: "Asveren, Tolga" <[email-masked]>
Date: Thu, 5 Jul 2007 08:09:56 -0400

Arijeet,

SCTP/TCP provides reliable transport between two nodes as long as the nodes are up and running, but when a node fails, messages which are sent via this node and for which no reply has been received yet need to be retransmitted by Diameter base protocol to an alternate next-hop.

  Thanks,
  Tolga

________________________________________
From: Arijeet Pal [mailto:[email-masked]] 
Sent: Thursday, July 05, 2007 4:05 AM
To: [email-masked]
Subject: [Dime] Requirement of transaction maintenance in DIAMETER 

Hello Everyone,

 
 
Thanks and Regards,
Arijeet
  
________________________________________
Luggage? GPS? Comic books? 
Check out fitting gifts for grads at Yahoo! Search.

---

From: Arijeet Pal <[email-masked]>
Date: Thu, 5 Jul 2007 05:13:09 -0700 (PDT)

Understood - thanks a lot Tolga.
   
  Regards,
  Arijeet

"Asveren, Tolga" <[email-masked]> wrote:
  Arijeet,

Thanks,
Tolga

Hello Everyone,

 
 
Thanks and Regards,
Arijeet

       
---------------------------------
Need a vacation? Get great deals to amazing places on Yahoo! Travel.