Subject: [Dime] Reg. the "E" bit for the Protocol Error

From: "Arun Santhanam, TLS-Chennai" <[email-masked]>
Date: Tue, 24 Jul 2007 14:47:41 +0530

Hi Victor,

               I have a Query with respect to "E" bit for protocol
Error's.

               Why "E" bit is set only for the Protocol Errors and not
in general for all Errors Responses?

               As per RFC all 3xxx range errors will be considered as
protocol error, then what is the Significance of the "E" bit?

Thanks & Regards

Arun Santhanam

Lead Engineer- VOIP

HCL Technologies Ltd.

No 8, Mth Road Ambattur Industial estate

Chennai (T.N) 600058

Tel: +91-044-439672000  Extn. (7278)

Direct: +91-044-43967278 

Mob: +91-9841951234

www.hcltech.com

www.hcl.in

DISCLAIMER:
-----------------------------------------------------------------------------------------------------------------------

The contents of this e-mail and any attachment(s) are confidential and intended for the named recipient(s) only.
It shall not attach any liability on the originator or HCL or its affiliates. Any views or opinions presented in 
this email are solely those of the author and may not necessarily reflect the opinions of HCL or its affiliates.
Any form of reproduction, dissemination, copying, disclosure, modification, distribution and / or publication of 
this message without the prior written consent of the author of this e-mail is strictly prohibited. If you have
received this email in error please delete it and notify the sender immediately. Before opening any mail and 
attachments please check them for viruses and defect.

-----------------------------------------------------------------------------------------------------------------------

_______________________________________________
DiME mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dime

---

From: Oviaprasad D <[email-masked]>
Date: Tue, 24 Jul 2007 15:49:29 +0530

Hi Arun
    As per Rfc bellow quote tells the reason why E-bit set only for 
protocol error
<rfc>
      7.  Error Handling

   There are two different types of errors in Diameter; protocol and
   application errors.  A protocol error is one that occurs at the base
   protocol level, and MAY require per hop attention (e.g., message
   routing error).  Application errors, on the other hand, generally
   occur due to a problem with a function specified in a Diameter
   application (e.g., user authentication, Missing AVP).
</rfc>
    Also I will suggest you to see the same section and Figure 8 
provides an example
for Application errors not sets E-bit.

regards
Oviya

Arun Santhanam, TLS-Chennai wrote:
> *Thanks & Regards*
> *Arun Santhanam*
> *HCL Technologies Ltd*.
> *www.hcl.in*
> The contents of this e-mail and any attachment(s) are confidential and 
> intended for the named recipient(s) only.
> It shall not attach any liability on the originator or HCL or its 
> affiliates. Any views or opinions presented in
> this email are solely those of the author and may not necessarily 
> reflect the opinions of HCL or its affiliates.
> Any form of reproduction, dissemination, copying, disclosure, 
> modification, distribution and / or publication of
> this message without the prior written consent of the author of this 
> e-mail is strictly prohibited. If you have
> ------------------------------------------------------------------------
>

EMAIL DISCLAIMER : This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed. Any unauthorised distribution or copying is strictly prohibited. If you receive this transmission in error, please notify the sender by reply email and then destroy the message. Opinions, conclusions and other information in this message that do not relate to official business of Mascon shall be understood to be neither given nor endorsed by Mascon. Any information contained in this email, when addressed to Mascon clients is subject to the terms and conditions in governing client contract.

Whilst Mascon takes steps to prevent the transmission of viruses via e-mail, we can not guarantee that any email or attachment is free from computer viruses and you are strongly advised to undertake your own anti-virus precautions. Mascon grants no warranties regarding performance, use or quality of any e-mail or attachment and undertakes no liability for loss or damage, howsoever caused.

---

From: Victor Fajardo <[email-masked]>
Date: Tue, 24 Jul 2007 11:14:58 -0400

If you guys would like to review the revised Sec 7. of rfc3588bis-05, 
then that would be useful as well ...

> Also I will suggest you to see the same section and Figure 8 provides 
> an example
>> I have a Query with respect to “E” bit for protocol Error’s.
>>
>> Why “E” bit is set only for the Protocol Errors and not in general 
>> for all Errors Responses?
>>
>> As per RFC all 3xxx range errors will be considered as protocol 
>> error, then what is the Significance of the “E” bit?
>>
>> *Thanks & Regards*
>>
>> *Arun Santhanam*
>>
>> Lead Engineer- VOIP
>>
>> *HCL Technologies Ltd*.
>>
>> The contents of this e-mail and any attachment(s) are confidential 
>> and intended for the named recipient(s) only.
> EMAIL DISCLAIMER : This email and any files transmitted with it are 
> confidential and intended solely for the use of the individual or 
> entity to whom they are addressed. Any unauthorised distribution or 
> copying is strictly prohibited. If you receive this transmission in 
> error, please notify the sender by reply email and then destroy the 
> message. Opinions, conclusions and other information in this message 
> that do not relate to official business of Mascon shall be understood 
> to be neither given nor endorsed by Mascon. Any information contained 
> in this email, when addressed to Mascon clients is subject to the 
> terms and conditions in governing client contract.
>
> Whilst Mascon takes steps to prevent the transmission of viruses via 
> e-mail, we can not guarantee that any email or attachment is free from 
> computer viruses and you are strongly advised to undertake your own 
> anti-virus precautions. Mascon grants no warranties regarding 
> performance, use or quality of any e-mail or attachment and undertakes 
> no liability for loss or damage, howsoever caused.
>