Subject: [Dime] STUN relay with push mode QoS reservation

From: "Asveren, Tolga" <[email-masked]>
Date: Thu, 5 Jul 2007 12:07:52 -0400

Let me ping about this first in the friendly neighborhood WG (actually I
guess this topic may be more relevant to SIPPING and/or BEHAVE WGs):

Consider the following configuration (QoS reservation for access network
with push model):

  +----+      +-----+                     +------+
  |    |      |     |                     |      |
  | UA +------+ NAT +---------------------+  AF  |
  |    |xxxxxx|     |                     |      |
  +----+      +-----+                     +---"--+
                 x(IP1)                       "
                 x        +--------+          "      +----+
                 x        |  STUN  |          "      |    |
                 x        |  Relay |xxxxxxxxxxxxxxxxx| UA |
                 x        |        |(IP3)     " (IP4)|    |
                 x        +--------+          "      +----+
                 x          x(IP2)            "
              +-----+       x             +---"--+
              |     |xxxxxxxx             |      |
              | PEF |                     | PDF  |
              |     """""""""""""""""""""""      |
              +-----+                     +------+

      --- Call Signaling (SIP)

      """ QoS Signaling (Diameter QoS application)

      xxx Media

UA would use IP3 as its media address in the SDP, so AF would know only
IP3 and IP4 from the far end UA. What PEF needs is IP2 and IP1.

One solution is probably PEF consulting STUN Relay to learn the actual
IP addresses (STUN Relay has the binding between IP1-IP2/IP3-IP4). 

Another approach could be to signal IP1/IP2 in some newly defined SDP
fields.

Any ideas? 

   Thanks,
   Tolga

_______________________________________________
DiME mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dime

---

From: Hannes Tschofenig <[email-masked]>
Date: Fri, 06 Jul 2007 08:42:20 +0200

Hi Tolga,

you need to explain where you want to install what type of QoS reservation.

In essence, you might consider two scenarios:

* QoS reservation only in the access
* QoS reservation along the path of the media traffic (with a couple of 
routers)

In the former case that's the plan of most SDOs.

For the later case you seem to be describing the interworking between 
Diameter QoS,  STUN to trigger  a proxy RSVP/NSIS scenario.
See
http://www.ietf.org/internet-drafts/draft-ietf-tsvwg-rsvp-proxy-approaches-00.txt
http://www.ietf.org/internet-drafts/draft-ietf-tsvwg-rsvp-proxy-proto-01.txt

For NSIS the functionality is built into the main specification:
http://www.ietf.org/internet-drafts/draft-ietf-nsis-qos-nslp-14.txt

Ciao
Hannes

---

From: "Asveren, Tolga" <[email-masked]>
Date: Fri, 6 Jul 2007 08:00:28 -0400

Hi Hannes,

I was considering the scenario where QoS reservation is done only for
the access.

   Thanks,
   Tolga

> -----Original Message-----
> From: Hannes Tschofenig [mailto:[email-masked]]
> Sent: Friday, July 06, 2007 2:42 AM
> To: Asveren, Tolga
> Cc: [email-masked]
> Subject: Re: [Dime] STUN relay with push mode QoS reservation
> 
> Hi Tolga,
>