Subject: [Dime] Diameter QoS Appl.

From: Tina TSOU <[email-masked]>
Date: Mon, 09 Jul 2007 17:27:38 +0800

Hi all,
I suggest that some texts could be added in the beginning of 3.3 to smooth
with the texts in 3.3.1 and 3.3.2.

[snipped]
3.3.  Authorization schemes

   Three basic authorization models for QoS reservations exist: one two
   -party and two three party models.  In the three party QoS model
   (Figure 3), the authorization entity may be composed of two separate
   functional entities - Application Server which interacts with the QoS
   requesting entity and Authorizing Entity.  The Application Server MAY
   indicate the access network related information in a service request
   to Authorizing Entity which can be used by the Authorizing Entity to
   select the appropriate resource admission and control policies.  The
   service request from Application Server to Authorizing Entity MAY
   also indicate the admission control mode (i.e., "pull" or "push"
   model) in terms of which Authorizing Entity performs QoS
   authorization and then sends the policy decisions to the NE which
   performs QoS reservation. Authorization schemes for both pull
   and push mode will be described below in detail.

3.3.1.  Authorization schemes for pull mode
[snipped]

B. R.
Tina
_______________________________________________
DiME mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dime

---

From: Tina TSOU <[email-masked]>
Date: Wed, 11 Jul 2007 18:08:51 +0800

Hi Guys,
After discussion with Hannes and Dong, I think it might be better to modify like this. It is the recovering of the texts about 
"PULL/PUSH/Access network related information" deleted by mistake or misunderstanding

3    Framework
[snipped]
<t>In some deployment scenarios, QoS aware network elements may request

      authorization through the AAA cloud based on an incoming QoS reservation

      request. The network element will route the request to a designated

      authorizing entity. The authorizing entity will return the result of the

      authorization decision. In other deployment scenarios, the authorization

      will be initiated upon dynamic application state, so that the request

      must be authenticated and authorized based on information from one or

      more application servers. /*start of added*/In terms of the resource request sent from 

      the application server to Authorizing Entity, the Authorizing Entity 

      could identify the access network related information and select appropriate 

      resource admission and control policies. The Push or pull mode also can be 

      dynamically triggered based on the information in the request from application

   server, or statically configured according to operator's demand./*end of added*/</t>

[snipped]

B. R.

Tina

  ----- Original Message ----- 
  From: Tina TSOU 
  To: [email-masked] 
  Sent: Monday, July 09, 2007 5:27 PM
  Subject: [Dime] Diameter QoS Appl.

  Hi all,

  [snipped]

  B. R.
  Tina

------------------------------------------------------------------------------

---

From: "Asveren, Tolga" <[email-masked]>
Date: Wed, 11 Jul 2007 14:49:17 -0400

Hi Tina,

One question about the proposed addition:
What type of scenarios would require pull-mode of operation, if authorizing entity receives a request from an application server?

   Thanks,
   Tolga

________________________________________
From: Tina TSOU [mailto:[email-masked]] 
Sent: Wednesday, July 11, 2007 6:09 AM
To: [email-masked]; Tina TSOU
Subject: Re: [Dime] Diameter QoS Appl. -"PULL/PUSH/Access network related information"

Hi Guys,
 
3    Framework
[snipped]
 
B. R.
Tina
----- Original Message ----- 
From: Tina TSOU 
To: [email-masked] 
Sent: Monday, July 09, 2007 5:27 PM
Subject: [Dime] Diameter QoS Appl.

Hi all,
 
[snipped]

3.3.1.  Authorization schemes for pull mode
[snipped]
B. R.
Tina
________________________________________
_______________________________________________
DiME mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dime

---

From: "Sun, Dong \(Dong\)" <[email-masked]>
Date: Wed, 11 Jul 2007 17:51:24 -0500

Hi Tina,
 
It's ok to me to add the last sentence marked in red. but I am not sure
about the first sentence in red. 
It seems to me that the authorizing entity (i.e. policy server) is
better to map the service attribute (from application server) into a set
of generic network layer QoS parameters rather than translating into
specific access technologies QoS. The mapping from generic QoS into
access specific QoS is more appropriate to be executed in NE, IMO.
 
Moreover, as you stated, they are two irrelevant issues - the trigger of
push/pull and access specific QoS mapping. It would be better to discuss
them separately, i.e., make two separate proposals.
 
Regards,
Dong

________________________________

	From: Tina TSOU [mailto:[email-masked]] 
	Sent: Wednesday, July 11, 2007 6:09 AM
	To: [email-masked]; Tina TSOU
	Subject: Re: [Dime] Diameter QoS Appl. -"PULL/PUSH/Access
network related information"

	Hi Guys,
	After discussion with Hannes and Dong, I think it might be
better to modify like this. It is the recovering of the texts about 
	"PULL/PUSH/Access network related information" deleted by
mistake or misunderstanding
	 
	3    Framework
	[snipped]

	<t>In some deployment scenarios, QoS aware network elements may
request

	      authorization through the AAA cloud based on an incoming
QoS reservation

	      request. The network element will route the request to a
designated

	      authorizing entity. The authorizing entity will return the
result of the

	      authorization decision. In other deployment scenarios, the
authorization

	      will be initiated upon dynamic application state, so that
the request

	      must be authenticated and authorized based on information
from one or

	      more application servers. /*start of added*/In terms of
the resource request sent from 

	      the application server to Authorizing Entity, the
Authorizing Entity 

	      could identify the access network related information and
select appropriate 

	      resource admission and control policies. The Push or pull
mode also can be 

	      dynamically triggered based on the information in the
request from application

	   server, or statically configured according to operator's
demand./*end of added*/</t>

	[snipped]

	B. R.

	Tina

		----- Original Message ----- 
		From: Tina TSOU <mailto:[email-masked]>  
		To: [email-masked] 
		Sent: Monday, July 09, 2007 5:27 PM
		Subject: [Dime] Diameter QoS Appl.

		Hi all,
		I suggest that some texts could be added in the
beginning of 3.3 to smooth
		with the texts in 3.3.1 and 3.3.2.
		 
		[snipped]
		
		   Three basic authorization models for QoS reservations
exist: one two
		   -party and two three party models.  In the three
party QoS model
		   (Figure 3), the authorization entity may be composed
of two separate
		   functional entities - Application Server which
interacts with the QoS
		   requesting entity and Authorizing Entity.  The
Application Server MAY
		   indicate the access network related information in a
service request
		   to Authorizing Entity which can be used by the
Authorizing Entity to
		   select the appropriate resource admission and control
policies.  The
		   service request from Application Server to
Authorizing Entity MAY
		   also indicate the admission control mode (i.e.,
"pull" or "push"
		   model) in terms of which Authorizing Entity performs
QoS
		   authorization and then sends the policy decisions to
the NE which
		   performs QoS reservation. Authorization schemes for
both pull
		   and push mode will be described below in detail.

		B. R.
		Tina

________________________________

---

From: Tina TSOU <[email-masked]>
Date: Thu, 12 Jul 2007 13:59:08 +0800

Hi Tolga,
Pull mode is needed in the mobile network scenario and push mode is needed 
in the fixed network scenario. When the interfaces are converged, we have to 
distinguish which mode to use. ]

B. R.
Tina

----- Original Message ----- 
From: "Asveren, Tolga" <[email-masked]>
To: <[email-masked]>
Sent: Thursday, July 12, 2007 2:49 AM
Subject: RE: [Dime] Diameter QoS Appl. -"PULL/PUSH/Access network related 
information"

Hi Tina,

One question about the proposed addition:
What type of scenarios would require pull-mode of operation, if authorizing 
entity receives a request from an application server?

   Thanks,
   Tolga

Subject: Re: [Dime] Diameter QoS Appl. -"PULL/PUSH/Access network related 
information"

Hi Guys,
After discussion with Hannes and Dong, I think it might be better to modify 
like this. It is the recovering of the texts about
"PULL/PUSH/Access network related information" deleted by mistake or 
misunderstanding

3 Framework
[snipped]
<t>In some deployment scenarios, QoS aware network elements may request
      authorization through the AAA cloud based on an incoming QoS 
reservation
      request. The network element will route the request to a designated
      authorizing entity. The authorizing entity will return the result of 
the
      authorization decision. In other deployment scenarios, the 
authorization
      will be initiated upon dynamic application state, so that the request
      must be authenticated and authorized based on information from one or
      more application servers. /*start of added*/In terms of the resource 
request sent from
      the application server to Authorizing Entity, the Authorizing Entity
      could identify the access network related information and select 
appropriate
      resource admission and control policies. The Push or pull mode also 
can be
      dynamically triggered based on the information in the request from 
application
   server, or statically configured according to operator's demand./*end of 
added*/</t>
[snipped]

B. R.
Tina
----- Original Message ----- 
From: Tina TSOU
To: [email-masked]
Sent: Monday, July 09, 2007 5:27 PM
Subject: [Dime] Diameter QoS Appl.

Hi all,

[snipped]

---

From: Tina TSOU <[email-masked]>
Date: Thu, 12 Jul 2007 14:42:14 +0800

Hi again:)
In addition, PULL mode can be also used in Fix network; the precondition is
that the terminal is QoS aware, therefore the mobile terminals for mobile
network use PULL mode more frequently.

I drew a picture but it exceeds 40 KB, so it is not able to be sent through 
the ML, so I will send it to you personally;-)

B. R.
Tina

----- Original Message ----- 
From: "Tina TSOU" <[email-masked]>
To: <[email-masked]>; "Asveren, Tolga" <[email-masked]>
Sent: Thursday, July 12, 2007 1:59 PM
Subject: Re: [Dime] Diameter QoS Appl. -"PULL/PUSH/Access network related
information"

> in the fixed network scenario. When the interfaces are converged, we have
> to distinguish which mode to use.
> B. R.
> Tina
>
> What type of scenarios would require pull-mode of operation, if
> authorizing entity receives a request from an application server?
>
>   Thanks,
>   Tolga
>
> After discussion with Hannes and Dong, I think it might be better to
> modify like this. It is the recovering of the texts about

---

From: Tina TSOU <[email-masked]>
Date: Thu, 12 Jul 2007 19:20:50 +0800

The picture of the scenario is in
http://www.tschofenig.priv.at/TEMP/pull.jpg
now.
Thanks a lot for Hannes uploading it:)

B. R.
Tina

----- Original Message ----- 
From: "Tina TSOU" <[email-masked]>
To: "Asveren, Tolga" <[email-masked]>; <[email-masked]>; "Tina TSOU" 
<[email-masked]>
Sent: Thursday, July 12, 2007 2:42 PM
Subject: Re: [Dime] Diameter QoS Appl. -"PULL/PUSH/Access network related 
information"

> I drew a picture but it exceeds 40 KB, so it is not able to be sent 
> through the ML, so I will send it to you personally;-)
>
> B. R.
> Tina
>

---

From: "Asveren, Tolga" <[email-masked]>
Date: Thu, 12 Jul 2007 11:44:25 -0400

Hi Tina,

What I was wondering was not the need for push/pull mode but whether we foresee any scenario where application server would initiate a session to authorizing entity for pull-mode (seems unlikely to me, probably it will be the other way around)?

   Thanks,
   Tolga

-----Original Message-----
From: Tina TSOU [mailto:[email-masked]]
Sent: Thu 7/12/2007 2:42 AM
To: Asveren, Tolga; [email-masked]; Tina TSOU
Subject: Re: [Dime] Diameter QoS Appl. -"PULL/PUSH/Access network related	information"
 
Hi again:)

B. R.
Tina

----- Original Message ----- 
From: "Tina TSOU" <[email-masked]>
To: <[email-masked]>; "Asveren, Tolga" <[email-masked]>
Sent: Thursday, July 12, 2007 1:59 PM
Subject: Re: [Dime] Diameter QoS Appl. -"PULL/PUSH/Access network related
information"