Subject: [Dime] Re: DiME Digest, Vol 19, Issue 1

From: "naveen sarma" <[email-masked]>
Date: Wed, 4 Jul 2007 10:58:40 +0530

Hi Victor,

I have a question, for backward compatilibity means, is it related to the
dictionary configuration of the base protocol?  It seems to be more logical
to have [Failed-AVP] instead of *[Failed-AVP], which i have already
mentioned in the Jun27 mail with subject *"**Reg the Failed-AVP in CEA, DWA
and DPA".*
**
Regards,
Naveen

Date: Tue, 03 Jul 2007 08:22:20 -0400
> From: Victor Fajardo <[email-masked]>
> Subject: Re: [Dime] Question Regarding Failed AVP.
> To: [email-masked]
> Cc: [email-masked], 'Amit Kumar PNGN' <[email-masked]>,
>        'Preeti Shandilya' <[email-masked]>
> Message-ID: <[email-masked]>
> Content-Type: text/plain; charset=ISO-8859-1; format=flowed
>
> Hi,
>
> >     In the */section 7.5/* of /draft-ietf-dime-rfc3588bis-04.txt/ it
> >     states that
> >     " A Diameter message SHOULD contain only one Failed-AVP that
> >     corresponds to the error indicated by the Result-Code AVP."
> >
> >     The document also states in the same section that
> >     "For practical purposes, this Failed-AVP would typically refer to
> >     the first AVP processing error that a Diameter node encounters."
> >
> >     my question is that if the message is supposed to contain only one
> >     failed AVP then why does the ABNF of messages CEA,DPA and DWA have
> >       *[ Failed-AVP ].
> >
> >     Rajith >>   I think it should be [Failed-AVP]
> >
>
> Keeping the *[Failed-AVP] ABNF and using a "SHOULD" instead of a "MUST"
> was based on backward compatibility concerns. I'm not sure if this is
> still a valid concern or not so it maybe best to hear from others as well.
>
> -- victor
>
>
>
> ------------------------------
>
> _______________________________________________
> DiME mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/dime
>
>
> End of DiME Digest, Vol 19, Issue 1
> ***********************************
_______________________________________________
DiME mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dime

---

From: Victor Fajardo <[email-masked]>
Date: Wed, 04 Jul 2007 20:33:37 -0400

Pls. see the current thread on this issue. A rough consensus is to 
update the ABNF to [Failed-AVP].
regards,
victor

> Hi Victor,
>  
> I have a question, for backward compatilibity means, is it related to 
> the dictionary configuration of the base protocol?  It seems to be 
> more logical to have [Failed-AVP] instead of *[Failed-AVP], which i 
> have already mentioned in the Jun27 mail with subject *"**Reg the 
> Failed-AVP in CEA, DWA and DPA".*
> ** 
> Regards,
> Naveen
>
>     From: Victor Fajardo < [email-masked]
>     <mailto:[email-masked]>>
>     To: [email-masked] <mailto:[email-masked]>
>     Cc: [email-masked] <mailto:[email-masked]>, 'Amit Kumar PNGN' <
>     [email-masked] <mailto:[email-masked]>>,
>            'Preeti Shandilya' <[email-masked]
>     <mailto:[email-masked]>>
>     Message-ID: < [email-masked]
>     <mailto:[email-masked]>>
>     [email-masked] <mailto:[email-masked]>
>     <https://www1.ietf.org/mailman/listinfo/dime>
>
>
> ------------------------------------------------------------------------
>