Subject: [Dime] One scenario related to QoS Appl.

From: Tina TSOU <[email-masked]>
Date: Thu, 02 Aug 2007 11:16:05 +0800

Hi all,
One scenario to be discussed is as below.

One user is going to make a call with his friend. He estimates it will take about 20 minutes to complete the call. Prices for calls at different QoS levels are different, good quality calls will cost more than low quality ones do. So he gotta know the QoS level at which his account balance can provide 20 minutes quotas or more for him.

Is it supported by the current QoS Appl.?

B. R.
Tina
+86-755-28972912 (Office)    +86-13922884380 (Mobile)
Messengers: 
MSN: [email-masked]   Yahoo: tina_tsou    Skype: tinaTSOU    Jabber: [email-masked]    Google talk: [email-masked]

_______________________________________________
DiME mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dime

---

From: "Asveren, Tolga" <[email-masked]>
Date: Thu, 2 Aug 2007 08:31:09 -0400

Hi Tina,

IMHO, this could be classified as a different "service". For example right now people check a website or a paper document (or sometimes they listen to an announcement) where prices are listed (maybe not for different QoS levels but for different destinations, but conceptually it is similar).

   Thanks,
   Tolga

________________________________________
From: Tina TSOU [mailto:[email-masked]] 
Sent: Wednesday, August 01, 2007 11:16 PM
To: [email-masked]
Subject: [Dime] One scenario related to QoS Appl.

Hi all,

---

From: "McCann Peter-A001034" <[email-masked]>
Date: Thu, 2 Aug 2007 11:16:49 -0400

I agree with Tolga.  The user must consult with his home
provider for the per-minute charges.  The price paid by
the home provider for all the NEs along the path will be
the wholesale price, and the home provider likely has a
contract with the end user for a different price.  The
Diameter QoS application only deals with the wholesale
price.

-Pete

Asveren, Tolga wrote:
> Hi Tina,
> 
> IMHO, this could be classified as a different "service". For example
> right now people check a website or a paper document (or sometimes
> they listen to an announcement) where prices are listed (maybe not
> for different QoS levels but for different destinations, but
> conceptually it is similar).    
> 
>    Thanks,
>    Tolga
> 
> One user is going to make a call with his friend. He estimates it
> will take about 20 minutes to complete the call. Prices for calls at
> different QoS levels are different, good quality calls will cost more
> than low quality ones do. So he gotta know the QoS level at which his
> account balance can provide 20 minutes quotas or more for him.    
> 
> MSN: [email-masked]   Yahoo: tina_tsou    Skype: tinaTSOU   
> Jabber: [email-masked]    Google talk: [email-masked] 
> 
>

---

From: "Sun, Dong \(Dong\)" <[email-masked]>
Date: Thu, 2 Aug 2007 11:10:07 -0500

Hi Pete,
I agree the wholesale model should be supported for sure, but it might be possible to have another model, in the roaming scenario, the visited network, based on the agreement (or negotiate) with home network on Price/QoS for a particular service, may perform QoS handling on individual session/request basis. Maybe I misunderstood the wholesale price/model you refer to.

Regards,
Dong  

-----Original Message-----
From: McCann Peter-A001034 [mailto:[email-masked]] 
Sent: Thursday, August 02, 2007 11:17 AM
To: Asveren, Tolga; Tina TSOU; [email-masked]
Subject: RE: [Dime] One scenario related to QoS Appl.

I agree with Tolga.  The user must consult with his home provider for the per-minute charges.  The price paid by the home provider for all the NEs along the path will be the wholesale price, and the home provider likely has a contract with the end user for a different price.  The Diameter QoS application only deals with the wholesale price.

-Pete

Asveren, Tolga wrote:
> they listen to an announcement) where prices are listed (maybe not for 
> different QoS levels but for different destinations, but
> One user is going to make a call with his friend. He estimates it will 
> take about 20 minutes to complete the call. Prices for calls at

---

From: "McCann Peter-A001034" <[email-masked]>
Date: Thu, 2 Aug 2007 12:18:30 -0400

Hi, Dong,

I don't quite understand the new model you are proposing - I
think you are saying that individual Network Elements might
have a negotiated price with the home network.  I think that's
fine and can be accommodated; the QAR message should contain
the price that the NE is going to charge for its service.  The
NE might take into account contracts that may exist with the
home network, since we assume that the NE knows the Destination
Realm.

-Pete

Sun, Dong (Dong) wrote:
> Hi Pete,
> I agree the wholesale model should be supported for sure, but it
> might be possible to have another model, in the roaming scenario, the
> visited network, based on the agreement (or negotiate) with home
> network on Price/QoS for a particular service, may perform QoS
> handling on individual session/request basis. Maybe I misunderstood
> the wholesale price/model you refer to.     
> 
> Regards,
> Dong
> 
> I agree with Tolga.  The user must consult with his home provider for
> the per-minute charges.  The price paid by the home provider for all
> the NEs along the path will be the wholesale price, and the home
> provider likely has a contract with the end user for a different
> price.  The Diameter QoS application only deals with the wholesale
> price.     
> 
> -Pete
> 
> Asveren, Tolga wrote:
>> Hi Tina,
>>

---

From: "Sun, Dong \(Dong\)" <[email-masked]>
Date: Thu, 2 Aug 2007 11:27:18 -0500

I also think the QoS application should be able to support this new model, may be named as retail scenario.

It seems to me there might be more common in practice to have one local PDF (authorizing entity) residing in the visited network domain to talk to the authorizing entity in the home network rather than asking each NE for this kind of negotiation/decision.

Dong

-----Original Message-----
From: McCann Peter-A001034 [mailto:[email-masked]] 
Sent: Thursday, August 02, 2007 12:19 PM
To: Sun, Dong (Dong); Asveren, Tolga; Tina TSOU; [email-masked]
Subject: RE: [Dime] One scenario related to QoS Appl.

Hi, Dong,

I don't quite understand the new model you are proposing - I think you are saying that individual Network Elements might have a negotiated price with the home network.  I think that's fine and can be accommodated; the QAR message should contain the price that the NE is going to charge for its service.  The NE might take into account contracts that may exist with the home network, since we assume that the NE knows the Destination Realm.

-Pete

Sun, Dong (Dong) wrote:
> Hi Pete,
> I agree the wholesale model should be supported for sure, but it might 
> be possible to have another model, in the roaming scenario, the

---

From: "McCann Peter-A001034" <[email-masked]>
Date: Thu, 2 Aug 2007 12:43:01 -0400

> model, may be named as retail scenario. 

Can you give a more detailed description of the scenario you
have in mind?  Is it the same as Tina's?

> It seems to me there might be more common in practice to have one
> local PDF (authorizing entity) residing in the visited network domain
> to talk to the authorizing entity in the home network rather than
> asking each NE for this kind of negotiation/decision.   

Sure, I think we should allow a PDF to add the price information to
a QAR that is on its way toward the home network.

-Pete

> I don't quite understand the new model you are proposing - I think
> you are saying that individual Network Elements might have a
> negotiated price with the home network.  I think that's fine and can
> be accommodated; the QAR message should contain the price that the NE
> is going to charge for its service.  The NE might take into account
> contracts that may exist with the home network, since we assume that
> the NE knows the Destination Realm.      
> 
> -Pete
> 
> Sun, Dong (Dong) wrote:
>> Hi Pete,
>>> different QoS levels are different, good quality calls will cost
>>> more than low quality ones do. So he gotta know the QoS level at
>>> which his account balance can provide 20 minutes quotas or more for
>>> him. 
>>>

---

From: "Sun, Dong \(Dong\)" <[email-masked]>
Date: Thu, 2 Aug 2007 11:57:10 -0500

The retail scenario in my mind is:
When UE is roaming in visited network and requests a service, the home network will determine the price/QoS based on subscription and resource availability (if multiple price/QoS options are allowed), and the agreement with that visited network, it is also possible that home network and visited network talk to each other on the fly to identify the right price/QoS based on real resource status when the request occurs (either push or pull mode can be used for the interaction depending on the network/UE capability). 

Dong

-----Original Message-----
From: McCann Peter-A001034 [mailto:[email-masked]] 
Sent: Thursday, August 02, 2007 12:43 PM
To: Sun, Dong (Dong); Asveren, Tolga; Tina TSOU; [email-masked]
Subject: RE: [Dime] One scenario related to QoS Appl.

> model, may be named as retail scenario.

Can you give a more detailed description of the scenario you have in mind?  Is it the same as Tina's?

> asking each NE for this kind of negotiation/decision.   

Sure, I think we should allow a PDF to add the price information to a QAR that is on its way toward the home network.

-Pete

> I don't quite understand the new model you are proposing - I think you 
> are saying that individual Network Elements might have a negotiated 
> price with the home network.  I think that's fine and can be 
> accommodated; the QAR message should contain the price that the NE is 
> going to charge for its service.  The NE might take into account

---

From: "Asveren, Tolga" <[email-masked]>
Date: Thu, 2 Aug 2007 16:33:31 -0400

That organizations can dynamically negotiate the price for QoS is interesting but a bit too complex as a first step IMHO. I think, it is better to address it in an extension document.

   Thanks,
   Tolga

> From: Sun, Dong (Dong) [mailto:[email-masked]]
> Sent: Thursday, August 02, 2007 12:57 PM
> To: McCann Peter-A001034; Asveren, Tolga; Tina TSOU; [email-masked]
> When UE is roaming in visited network and requests a service, the home
> network will determine the price/QoS based on subscription and resource
> availability (if multiple price/QoS options are allowed), and the
> agreement with that visited network, it is also possible that home network
> and visited network talk to each other on the fly to identify the right
> price/QoS based on real resource status when the request occurs (either
> push or pull mode can be used for the interaction depending on the
> network/UE capability).
> 
> Dong
> 
> Sure, I think we should allow a PDF to add the price information to a QAR
> that is on its way toward the home network.
> 
> -Pete
> 
> > Dong
> >

---

From: "Sun, Dong \(Dong\)" <[email-masked]>
Date: Thu, 2 Aug 2007 15:44:50 -0500

The basic retail could be dynamically negotiate the QoS and decide the proper price based on static SLA (or vice versa). I thought it can be supported by current QAR, QIR with some add-on parameters (if those parameters have not yet defined). 

The negotiation of SLA on the fly might be a bit complex if that is what you are concerned, which I can see.

-----Original Message-----
From: Asveren, Tolga [mailto:[email-masked]] 
Sent: Thursday, August 02, 2007 4:34 PM
To: Sun, Dong (Dong); McCann Peter-A001034; Tina TSOU; [email-masked]
Subject: RE: [Dime] One scenario related to QoS Appl.

   Thanks,
   Tolga

> network will determine the price/QoS based on subscription and 
> resource availability (if multiple price/QoS options are allowed), and 
> the agreement with that visited network, it is also possible that home 
> network and visited network talk to each other on the fly to identify 
> the right price/QoS based on real resource status when the request 
> occurs (either push or pull mode can be used for the interaction 
> depending on the network/UE capability).
> 
> Dong
> 
> > local PDF (authorizing entity) residing in the visited network 
> > domain to talk to the authorizing entity in the home network rather 
> > than asking each NE for this kind of negotiation/decision.
> 
> Sure, I think we should allow a PDF to add the price information to a 
> QAR that is on its way toward the home network.
> 
> -Pete
> 
> > Dong
> >
> > be accommodated; the QAR message should contain the price that the 
> > NE is going to charge for its service.  The NE might take into 
> > account contracts that may exist with the home network, since we 
> > assume that the NE knows the Destination Realm.
> >
> > -Pete
> >
> > Sun, Dong (Dong) wrote:
> >> Hi Pete,
> >> might be possible to have another model, in the roaming scenario, 
> >> the visited network, based on the agreement (or negotiate) with 
> >> home network on Price/QoS for a particular service, may perform QoS 
> >> I agree with Tolga.  The user must consult with his home provider 
> >> for the per-minute charges.  The price paid by the home provider 
> >> for all the NEs along the path will be the wholesale price, and the 
> >> home provider likely has a contract with the end user for a 
> >> different price.  The Diameter QoS application only deals with the 
> >> wholesale price.
> >>
> >> -Pete
> >>
> >> Asveren, Tolga wrote:
> >>> Hi Tina,
> >>>
> >>> IMHO, this could be classified as a different "service". For 
> >>> example right now people check a website or a paper document (or 
> >>> sometimes they listen to an announcement) where prices are listed 
> >>> (maybe not for different QoS levels but for different 
> >>> destinations, but conceptually it is similar).
> >>>
> >>>    Thanks,
> >>>    Tolga
> >>>
> >>> will take about 20 minutes to complete the call. Prices for calls 
> >>> at different QoS levels are different, good quality calls will 
> >>> cost more than low quality ones do. So he gotta know the QoS level 
> >>> at which his account balance can provide 20 minutes quotas or more 
> >>> for him.
> >>>

---

From: "Asveren, Tolga" <[email-masked]>
Date: Thu, 2 Aug 2007 17:09:17 -0400

Hi Dong,

> Sent: Thursday, August 02, 2007 4:45 PM
> To: Asveren, Tolga; McCann Peter-A001034; Tina TSOU; [email-masked]
> The basic retail could be dynamically negotiate the QoS and decide the
> proper price based on static SLA (or vice versa). I thought it can be
> supported by current QAR, QIR with some add-on parameters (if those
> parameters have not yet defined).
[TOLGA]It may/may not be doable purely from technical perspective. IMHO it is not an immediate need in practice though. Just to make sure that I understood this model correctly:
I have a device/phone/softclient etc... to make voice/video calls. I can select the quality of this communication by pressing/selecting a button. I put the destination address/number, push the dial-button (or whatever is its equivalent) and see some price-tag for different levels of quality. Then I select a quality level.

IMHO, use of resources associated with QoS could be dynamic enough to make this model impractical. For example, it is not guaranteed that during the time between the network issued the price info and hit the button to select a service level, overall resource allocation in the network stays the same.

My understanding of Tina's message was that she is asking to convey some information about static pricing.
> That organizations can dynamically negotiate the price for QoS is
> interesting but a bit too complex as a first step IMHO. I think, it is
> better to address it in an extension document.
> 
>    Thanks,
>    Tolga
> 
> > Can you give a more detailed description of the scenario you have in
> mind?
> > Is it the same as Tina's?
> >

---

From: "Sun, Dong \(Dong\)" <[email-masked]>
Date: Thu, 2 Aug 2007 16:35:21 -0500

Hi Tolga,

The model you described is not exact as I am thinking. The key point in the retail model is that visited network could provide some QoS info on per call level to facilitate the decision in addition to home network policy (against the pure wholesale model). This interaction might be transparent to end user totally. 

If the carrier likes to offer the different options of QoS/price to end user directly, the mechanism should be helpful. I don't see real issue from a purely technical perspective :-) although this scenario is not what I am concerned and addressed sofar. In your example, when UE selects a price/qos plan, it would send a message e.g. SIP to request the authorization from its home SP, before getting back the confirmation to UE, the SP will check and allocate the resources along the path.

Certainly, the options of the price on the list would be very limited typically, may not be more than what you can see in the gas station, I guess :-). 

Regards,
Dong 

-----Original Message-----
From: Asveren, Tolga [mailto:[email-masked]] 
Sent: Thursday, August 02, 2007 5:09 PM
To: Sun, Dong (Dong); McCann Peter-A001034; Tina TSOU; [email-masked]
Subject: RE: [Dime] One scenario related to QoS Appl.

Hi Dong,

> > When UE is roaming in visited network and requests a service, the 
> > home network will determine the price/QoS based on subscription and 
> > resource availability (if multiple price/QoS options are allowed), 
> > and the agreement with that visited network, it is also possible 
> > that home network and visited network talk to each other on the fly 
> > to identify the right price/QoS based on real resource status when 
> > the request occurs (either push or pull mode can be used for the 
> > interaction depending on the network/UE capability).
> >
> > Dong
> >
> > > I also think the QoS application should be able to support this 
> > > new model, may be named as retail scenario.
> >
> > > domain to talk to the authorizing entity in the home network 
> > > rather than asking each NE for this kind of negotiation/decision.
> >
> > > negotiated price with the home network.  I think that's fine and 
> > > can be accommodated; the QAR message should contain the price that 
> > > the NE is going to charge for its service.  The NE might take into 
> > >> home network on Price/QoS for a particular service, may perform 
> > >> QoS handling on individual session/request basis. Maybe I 
> > >> misunderstood the wholesale price/model you refer to.
> > >>
> > >> Regards,
> > >> Dong
> > >>
> > >> for all the NEs along the path will be the wholesale price, and 
> > >> the home provider likely has a contract with the end user for a 
> > >> different price.  The Diameter QoS application only deals with 
> > >> the wholesale price.
> > >>
> > >> -Pete
> > >>
> > >> Asveren, Tolga wrote:
> > >>> Hi Tina,
> > >>>
> > >>> sometimes they listen to an announcement) where prices are 
> > >>> listed (maybe not for different QoS levels but for different 
> > >>> One user is going to make a call with his friend. He estimates 
> > >>> it will take about 20 minutes to complete the call. Prices for 
> > >>> calls at different QoS levels are different, good quality calls 
> > >>> will cost more than low quality ones do. So he gotta know the 
> > >>> QoS level at which his account balance can provide 20 minutes 
> > >>> quotas or more for him.
> > >>>

---

From: "Hannes Tschofenig" <[email-masked]>
Date: Thu, 02 Aug 2007 23:45:07 +0200

Folks, 

I am on vacation and (almost) out of email reach until August 13th.
If you need something really urgent then put "URGENT" into the subject header of your mail to [email-masked]. 

Ciao
Hannes

---

From: Tina TSOU <[email-masked]>
Date: Fri, 03 Aug 2007 16:12:18 +0800

Hi all,
Tks for all your reply. I did not sleep well yesterday night, due to the jet 
lag, or I knew you guys were posting a lot during my sleep;-)

I think Tolga understood my original meaning more precisely.

The detailed scenario is below.
The user has a device/phone/soft client etc... to make voice/video calls. He 
(I would say she :) can select multiple QoS levels of this communication by 
pressing/selecting a button.
Then he puts the destination address/number, the quota he needs (for 
example, 20 minutes), push the dial-button.

(1)One is: The Authorizing Entity calculates different quotas according to 
the user's account balance and different QoS levels, and then returns the 
result to user's device。
The user selects a quality level whose matching quota is equal to the 
required quota or more than it. Maybe the user will select the best quality 
meeting his need on quota.

(2)The other is: The Authorizing Entity calculates different quotas 
according to the account balance and different QoS levels, and then selects 
the best quality level meeting the user's need on quota on its own. Then the 
Authorizing Entity returns the best quality level to network elements in 
order to reserve resources.

B. R.
Tina

----- Original Message ----- 
From: "Sun, Dong (Dong)" <[email-masked]>
To: "Asveren, Tolga" <[email-masked]>; "McCann Peter-A001034" 
<[email-masked]>; "Tina TSOU" <[email-masked]>; <[email-masked]>
Sent: Friday, August 03, 2007 5:35 AM
Subject: RE: [Dime] One scenario related to QoS Appl.

Hi Tolga,

The model you described is not exact as I am thinking. The key point in the 
retail model is that visited network could provide some QoS info on per call 
level to facilitate the decision in addition to home network policy (against 
the pure wholesale model). This interaction might be transparent to end user 
totally.

If the carrier likes to offer the different options of QoS/price to end user 
directly, the mechanism should be helpful. I don't see real issue from a 
purely technical perspective :-) although this scenario is not what I am 
concerned and addressed sofar. In your example, when UE selects a price/qos 
plan, it would send a message e.g. SIP to request the authorization from its 
home SP, before getting back the confirmation to UE, the SP will check and 
allocate the resources along the path.

Certainly, the options of the price on the list would be very limited 
typically, may not be more than what you can see in the gas station, I guess 
:-).

Regards,
Dong

-----Original Message-----
From: Asveren, Tolga [mailto:[email-masked]]
Sent: Thursday, August 02, 2007 5:09 PM
To: Sun, Dong (Dong); McCann Peter-A001034; Tina TSOU; [email-masked]
Subject: RE: [Dime] One scenario related to QoS Appl.

Hi Dong,

> parameters have not yet defined).
[TOLGA]It may/may not be doable purely from technical perspective. IMHO it 
is not an immediate need in practice though. Just to make sure that I 
understood this model correctly:
I have a device/phone/softclient etc... to make voice/video calls. I can 
select the quality of this communication by pressing/selecting a button. I 
put the destination address/number, push the dial-button (or whatever is its 
equivalent) and see some price-tag for different levels of quality. Then I 
select a quality level.

IMHO, use of resources associated with QoS could be dynamic enough to make 
this model impractical. For example, it is not guaranteed that during the 
time between the network issued the price info and hit the button to select 
a service level, overall resource allocation in the network stays the same.

My understanding of Tina's message was that she is asking to convey some 
information about static pricing.